Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: "onvoldoende rechten"  (gelezen 4455 keer)

Resistance

  • Gast
"onvoldoende rechten"
« Gepost op: 2007/06/05, 14:26:19 »
Hallo,

Ik heb gisteren een externe harde schijf geinstalleerd (een LaCie 250Gb) Ubuntu herkent die zonder problemen en ik heb toegang tot de inhoud ervan, maar ik kan er niets naartoe copieren.

Ik heb een geripte CD op mijn desktop staan, wel, die kan ik dus niet verplaatsen naar die externe drive wegens "insufficient rights".

Hoe kan ik mijzelf die rechten toekennen?

Bedankt!

Offline raggar

  • Lid
    • fietsen naar Tibet
  • Steunpunt: Ja
"onvoldoende rechten"
« Reactie #1 Gepost op: 2007/06/05, 14:30:32 »
Hoe is de schijf geformateerd. Gebruikt je Fat als bestandsysteem of ntfs (windows). Ntfs wordt namelijk slecht ondersteund in Linux.

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #2 Gepost op: 2007/06/05, 14:31:54 »
Hoe is de schijf geformateerd?
Als het een NTFS-schijf is, kan je 2 dingen doen.
Je formateert ze naar ext3 (of eventueel FAT32).
Ofwel installeer je via synaptic ntfs-3g, waarmee je ntfs kan schrijven in linux.


edit:
Je wil trouwens ook weten dat de maximum bestandsgrootte op een FAT32-schijf 4Gb is.

Resistance

  • Gast
"onvoldoende rechten"
« Reactie #3 Gepost op: 2007/06/05, 14:43:43 »
De schijf is FAT en het bestand dat ik wil overzetten is veel kleiner dan 4Gb, ik schat 60Mb of zo.

Offline vanadium

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #4 Gepost op: 2007/06/05, 15:55:01 »
Hoe heb je die schijf "geinstalleerd"? Als het een USB schijf is, dan verwondert het mij dat je niet kan schrjven. USB schijven worden standaard bij het inpluggen in /media gemount met volle rechten voor de actuele gebruiker. Als je de schijf daarentegen zelf hebt gemount met het mount commando of via fstab, dan moeten de rechten ingesteld worden met opties.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #5 Gepost op: 2007/06/05, 16:07:49 »
Citaat van: Resistance
Hallo,

Ik heb gisteren een externe harde schijf geinstalleerd (een LaCie 250Gb) Ubuntu herkent die zonder problemen en ik heb toegang tot de inhoud ervan, maar ik kan er niets naartoe copieren.

Ik heb een geripte CD op mijn desktop staan, wel, die kan ik dus niet verplaatsen naar die externe drive wegens "insufficient rights".

Hoe kan ik mijzelf die rechten toekennen?

Bedankt!
gksudo nautilus
daarna rechtermuisknop op de schijf, eigenschappen:rechten aanpassen.
nautilus sluiten.

edenguy17

  • Gast
"onvoldoende rechten"
« Reactie #6 Gepost op: 2007/07/11, 21:33:47 »
Citaat van: leoquant
gksudo nautilus
daarna rechtermuisknop op de schijf, eigenschappen:rechten aanpassen.
nautilus sluiten.
Ik heb hetzelfde probleem met dezelfde harde schijf, helaas is hij in ntfs (het is dan ook in 4 partities opgedeeld). Ik heb dus de bovenstaande instructies gevolgd, maar wanneer ik de eigenaar probeer te veranderen van root naar mezelf krijg ik de melding dat dit onmogelijk is omdat het een 'alleen lezen-schijf' is. Wel, in Windows lukt het anders wel om bestanden te kopieren enz, dus wat is het probleem O_o ??

Offline vanadium

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #7 Gepost op: 2007/07/11, 22:05:15 »
Lees nog een paar postjes terug: om in Linux ntfs schijven te kunnen beschrijven, moet je ntfs-3g installeren. Inderdaad, ntfs is een proprietair formaat van Microsoft. Pas nu kan open source ook (betrouwbaar) naar ntfs schrijven, zo betrouwbaar dat schrijfsupport voor ntfs standaard in de volgende Ubuntu zal zitten.

edenguy17

  • Gast
"onvoldoende rechten"
« Reactie #8 Gepost op: 2007/07/14, 22:18:56 »
wel, ik heb dus zoals gezegd de ntfs-3g geinstalleerd, maar helaas wanneer ik de rechten probeer te veranderen lukt dit nog steeds niet (en natuurlijk dus ook niet om bestanden van of naar de schijf te kopiëren)
Moet ik de ntfs-3g configureren ofzo, ik zou echt niet wete wat ik moet doen.

neo

  • Gast
"onvoldoende rechten"
« Reactie #9 Gepost op: 2007/07/15, 00:08:36 »
heb je ook al met terimal(shell/console hoe je het wilt noemen) al chmod geprobeerd??

Offline vanadium

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #10 Gepost op: 2007/07/15, 12:40:23 »
Mogelijk blijft je schijf voor het ogenblik op de gewone manier (read only) gemount. Zelf heb ik met nfts-3g nog geen ervaring, maar het kriebelt om het heel binnenkort toch eens te proberen. Ik heb mijn Lacie Silverscreen na mijn overstap op Ubuntu omgezet naar FAT32, maar nu kan ik uiteraard geen DVD images meer erop zetten om te laten spelen. ik stel namelijk vast dat mijn DVD speler nogal vaak blijft hangen op zelfgebrande DVD's. Eens ntfs-3g howto opzoeken (durf bijna niet meer zeggen "googelen") levert onder andere

http://ubuntuforums.org/showthread.php?t=217009

Als je ook ntfs-config installeert, dan kan je grafisch configureren. Uit die howto kan ik niet opmaken of een externe ntfs  schijf automatisch en transparant door ntfs-3g gemount wordt bij het inpluggen. Als je minder avontuurlijk aangelegd bent, herformateer dan de schijf naar ext3, of naat fat32, of wacht op de volgende Ubuntu, die ntfs schrijfondersteuning ingebouwd zal hebben. Als je een dual boot hebt, weet dan dat er drivers voor Windows voor ext3 bestaan.

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #11 Gepost op: 2007/07/15, 18:10:07 »
Ik heb ook zo een schijf, maar deze hangt wel aan de router, een NAS schijf dus. In de instellingen moest ik eerst "Shares" aanmaken, moet je dat ook niet doen, of heb je dat gedaan? Ik heb ze eigenlijk nog nooit met USB verbonden, dus ik kan je niet zodadelijk verder helpen...

Grtjs,
Kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
· Mijn persoonlijke Linux blog

Offline vanadium

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #12 Gepost op: 2007/07/15, 18:44:25 »
Een NAS schijf is anders: die benader je via een netwerk. Normaal wordt een USB schijf in Ubuntu standaard lees/schrijf voor de gebruiker gemount in /media. Je krijgt een icoontje op de desktop. Als het een ntfs schijf is, dan is het enkel lezen, standaard.

edenguy17

  • Gast
"onvoldoende rechten"
« Reactie #13 Gepost op: 2007/07/16, 00:42:57 »
Dus ik moet me ermee verzoenen dat ik ermee opgescheept zit tot het standaard uitkomt op de volgende ubuntu en alles in orde zal zijn?
Ik heb het met de ntfs-config geprobeerd, het ondersteunen van ntfs is aangevinkt, maar ik kan nog altijd niks overzetten of de rechten veranderen :-/
Formatteren is geen optie, naar fat32 enz. overgaan ook niet, het is een gedeelde schijf en als ik er iets verander dan is er ruzie.

Offline vanadium

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #14 Gepost op: 2007/07/16, 16:36:10 »
Zal subiet eens mijn Lacie Silverscreen terug omzetten naar ntfs en ik zal mijn wedervaren hier vermelden als het lukt.

Offline vanadium

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #15 Gepost op: 2007/07/16, 20:07:24 »
Formateren van een ntfs duurt een beetje langer dan fat32: fat32 was in een halve seconde geklaard, ntfs formateren duurde zowat anderhalf uur, omdat eerst het medium "geblankt" werd:

vanadium@vanadium:~$ mkntfs -L "Silverscreen" /dev/sdb1
Cluster size has been automatically set to 4096 bytes.
Initializing device with zeroes: 100% - Done.
Creating NTFS volume structures.
mkntfs completed successfully. Have a nice day.
Inderdaad, met de -L optie geef je meteen een label mee. Daarna heb ik m'n schijf uitgeplugd, (was uiteraard geunmount voor het formatteren) en terug ingeplugd.
Daarna was het een kwestie van NTFS configurator tool te openen (Applications - NTFS Configuration tool) en te checken "Enable write support for external drives".

Nu doet Nautilus raar met de root directory: ik kan er geen nieuwe bestanden of directories creeëren, (m.a.w. read only gedrag), maar ik kon wel nieuwgecreëerde directories van elders naar toe draggen (eigenaardig...). Eens binnen in die directories: geen probleem: lezen en schrijven. Voor het ogenblik is rsync all m'n muziekbestanden aan het terugzetten onder /media/Silverscreen/

Ik stel vast dat de owner van /media/jupiter ikzelf ben, maar van /media/Silverscreen is dat de root. Wellicht moet ik dus de permissies veranderen van het mountpoint, of de eigenaar/groep. Het mountpoint wordt evenwel automatisch gecreëerd/gewist, maar het is mogelijk dat Ubuntu 'onthoudt' wat de permissies zijn. Zal dat later nog eens testen.

* De tools die toelaten ntfs volumes te creëren, te formateren, en er ook naar te schrijven (jawel, maar dat verloopt dan niet binnen het gewone bestandssysteem, maar eerder zoals je secure copy't of ftp't naar een andere server) haal je binnen met het pakket ntfsprogs

sudo apt-get ntfsprogsof via Synaptic

* ntfs-3g is dan de driver die toelaat ntfs volumes net als andere volumes binnen je filesysteem te benaderen

sudo apt-get ntfs-configinstalleert de grafische configuratietool en de eigenlijke driver, libntfs-3g0 en ntfs-3g.

Met die twee installaties ben je volledig geïnstalleerd om met ntfs te werken onder Linux.

edenguy17, je moet wel degelijk ook NTSF Config tool installeren en ermee zeggen dat je schrijven wil "enablen". Dit is maar één enkele checkbox, en zegt aan je systeem dat het ntfs-3g moet gebruiken om ntfs'en te mounten. Ik vermoed dat je dat nog niet gedaan hebt. Veel configureren is er niet aan, veel missen dus ook niet: één keer klikken.

Op https://help.ubuntu.com/community/MountingWindowsPartitions/ThirdPartyNTFS3G staat ook hoe het op de handmatige "ouderwetse" manier kan: sudo mount, umount, fstab enz. maar je hebt dat niet nodig.

Offline anko

  • Lid
  • Steunpunt: Nee
"onvoldoende rechten"
« Reactie #16 Gepost op: 2007/07/16, 20:14:57 »
Citaat van: edenguy17
wel, ik heb dus zoals gezegd de ntfs-3g geinstalleerd, maar helaas wanneer ik de rechten probeer te veranderen lukt dit nog steeds niet (en natuurlijk dus ook niet om bestanden van of naar de schijf te kopiëren)
Moet ik de ntfs-3g configureren ofzo, ik zou echt niet wete wat ik moet doen.
Je moet bij het mounten niet 'ntfs' als type opgeven, maar 'ntfs-3g'.
Ik heb dit als regel in mijn fstab staan:
Citaat
/dev/sda1   /media/windows   ntfs-3g   defaults,user   0   0
Succes
Als je denkt te weten dat de weg recht is, mis je de bocht.
lidnummer 3487(?)