Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Update manager loopt vast  (gelezen 4126 keer)

Bernhard

  • Gast
Update manager loopt vast
« Gepost op: 2007/06/03, 15:00:58 »
Sinds een paar dagen werk ik met Ubuntu. De update functie werkte eerst prima maar nu niet meer. Ik krijg een scherm met:

Er is een fout opgetreden

De volgende details zijn beschikbaar:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

Het lukt mij niet om de dpkg --configure -a te starten. Wat is er mis gegaan en wat moet ik doen?

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Update manager loopt vast
« Reactie #1 Gepost op: 2007/06/03, 15:05:45 »
Citaat van: Bernhard
Het lukt mij niet om de dpkg --configure -a te starten. Wat is er mis gegaan en wat moet ik doen?
Wat geeft "dpkg --configure -a"?

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #2 Gepost op: 2007/06/03, 15:21:27 »
beetje een foute sectie om dit in de posten, 'Software en Configuratie' was beter geweest... modje?

Bernhard

  • Gast
Update manager loopt vast
« Reactie #3 Gepost op: 2007/06/03, 15:35:02 »
[Markba schreef:

Wat geeft "dpkg --configure -a"?

Dan krijg ik dit:

-desktop:/$ sudo --configure -a
sudo: please use single character options
usage: sudo -K | -L | -V | -h | -k | -l | -v
usage: sudo [-HPSb] [-p prompt] [-u username|#uid]
            { -e file [...] | -i | -s | }

Bernhard

  • Gast
Update manager loopt vast
« Reactie #4 Gepost op: 2007/06/03, 15:36:23 »
Citaat van: blackdrive
beetje een foute sectie om dit in de posten, 'Software en Configuratie' was beter geweest... modje?
Sorry hoor, ik ben maar een beginner.

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Update manager loopt vast
« Reactie #5 Gepost op: 2007/06/04, 09:19:04 »
Citaat van: Bernhard
[Markba schreef:
Wat geeft "dpkg --configure -a"?
Dan krijg ik dit:
-desktop:/$ sudo --configure -a
Wat je zou moeten ingeven: sudo dpkg --configure -a
Wat jij hebt ingetikt: sudo --configure -a
Je mist de 'dpkg'.

Bernhard

  • Gast
Update manager loopt vast
« Reactie #6 Gepost op: 2007/06/04, 11:15:26 »
Citaat van: markba
Citaat van: Bernhard
[Markba schreef:
Wat geeft "dpkg --configure -a"?
Dan krijg ik dit:
-desktop:/$ sudo --configure -a
Wat je zou moeten ingeven: sudo dpkg --configure -a
Wat jij hebt ingetikt: sudo --configure -a
Je mist de 'dpkg'.
Bedankt voor je reactie! Je hebt gelijk maar mijn probleem is nog niet opgelost want ik krijg nu:

desktop:/$ sudo dpkg --configure -a
dpkg: statusdatabasegebied is vergrendeld door een ander proces

Kennelijk moet ik een ander proces killen, maar hoe?

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #7 Gepost op: 2007/06/04, 11:32:30 »
Kijk eens in je System Monitor of synaptic (gecrashed) nog draait ofzo.

Bernhard

  • Gast
Update manager loopt vast
« Reactie #8 Gepost op: 2007/06/04, 19:12:38 »
Citaat van: blackdrive
Kijk eens in je System Monitor of synaptic (gecrashed) nog draait ofzo.
In de systeemmonitor slapen alle processen behalve de monitor zelf natuurlijk.

Synaptic zie ik niet eens staan.

Wel krijg ik deze melding:  Bezig met configureren van googleearth

Kennelijk heb ik geprobeerd Google Earth te installeren maar dat proces is ergens vastgelopen. Ik heb nog niet gevonden waar dat zit en hoe ik dat kan verwijderen.

Kan iemand mij weer een stapje verder helpen? Bedankt alvast!

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #9 Gepost op: 2007/06/05, 08:02:16 »
Citaat van: Bernhard
Citaat van: blackdrive
Kijk eens in je System Monitor of synaptic (gecrashed) nog draait ofzo.
In de systeemmonitor slapen alle processen behalve de monitor zelf natuurlijk.

Synaptic zie ik niet eens staan.

Wel krijg ik deze melding:  Bezig met configureren van googleearth

Kennelijk heb ik geprobeerd Google Earth te installeren maar dat proces is ergens vastgelopen. Ik heb nog niet gevonden waar dat zit en hoe ik dat kan verwijderen.

Kan iemand mij weer een stapje verder helpen? Bedankt alvast!
synapticproblemen met sun java en googleearth hebben volgens mij allemaal te maken met het niet ondertekenen van de "licensie". deze programma's blijven dan eindeloos hangen en worden feitelijk niet geinstalleerd.
ook is het belangrijk te weten dat je de terminal kunt "uitklappen" bij de installatie door op het kleine driehoekje te klikken. dan kun je met enter en de tabtoets en "licensie" ondertekenen.

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #10 Gepost op: 2007/06/05, 08:26:01 »
Citaat van: leoquant
ook is het belangrijk te weten dat je de terminal kunt "uitklappen" bij de installatie door op het kleine driehoekje te klikken. dan kun je met enter en de tabtoets en "licensie" ondertekenen.
Ja, das is soms irritant. Dan denk je 'is dat nu nog niet geïnstalleerd', het lijkt wel of de installatie vasthangt. Dan klap je ze open en zie je dat je gewoon even moet accepteren... Daar mag nog wel iets aan gedaan worden.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #11 Gepost op: 2007/06/05, 08:29:36 »
Citaat van: blackdrive
Citaat van: leoquant
ook is het belangrijk te weten dat je de terminal kunt "uitklappen" bij de installatie door op het kleine driehoekje te klikken. dan kun je met enter en de tabtoets en "licensie" ondertekenen.
Ja, das is soms irritant. Dan denk je 'is dat nu nog niet geïnstalleerd', het lijkt wel of de installatie vasthangt. Dan klap je ze open en zie je dat je gewoon even moet accepteren... Daar mag nog wel iets aan gedaan worden.
laten we er gewoon op wijzen, het zo zonde van de problemen die ontstaan.
het hoeft niet. maar iemand die nieuw is weet dit vaak gewoon niet.
ik zou hier graag via een opvallend bericht op forum, op willen wijzen, weet alleen hoe ik dat het beste oplos....

Offline Blackdrive

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #12 Gepost op: 2007/06/05, 08:43:15 »
Is er nergens een 'Tips voor beginners' stickie (of wikipagina)?
Anders is het misschien een idee om er eentje te maken.

Dit kan ook een goeie zijn voor in de tips-sectie van het magazine :)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #13 Gepost op: 2007/06/05, 09:02:15 »
Citaat van: blackdrive
Is er nergens een 'Tips voor beginners' stickie (of wikipagina)?
Anders is het misschien een idee om er eentje te maken.

Dit kan ook een goeie zijn voor in de tips-sectie van het magazine :)
idd. dat is een goede plek.;)

Bernhard

  • Gast
Update manager loopt vast
« Reactie #14 Gepost op: 2007/06/05, 11:54:03 »
Citaat van: blackdrive
Citaat van: leoquant
ook is het belangrijk te weten dat je de terminal kunt "uitklappen" bij de installatie door op het kleine driehoekje te klikken. dan kun je met enter en de tabtoets en "licensie" ondertekenen.
Ja, das is soms irritant. Dan denk je 'is dat nu nog niet geïnstalleerd', het lijkt wel of de installatie vasthangt. Dan klap je ze open en zie je dat je gewoon even moet accepteren... Daar mag nog wel iets aan gedaan worden.
leoquant en blackdrive bedankt voor het meedenken!

Mijn probleem is inderdaad het niet ondertekend zijn van de licensie. Maar hoe moet dat nu?
Ik gebruik het standaard terminalvenster maar ik zie geen driehoekje om iets uit te klappen! En het installeren van andere terminals of pakketten lukt ook niet meer door het vastlopen.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #15 Gepost op: 2007/06/05, 12:04:12 »
googleearth installeren via de website van google. plaats het bestand op je buroblad. (bin bestand)

Citaat
cd ~/Desktop

Het bestand is waarschijnlijk ook nog niet uitvoerbaar dus eerst:

chmod a+x GoogleEarthLinux.bin

en daarna

./GoogleEarthLinux.bin

Bernhard

  • Gast
Update manager loopt vast
« Reactie #16 Gepost op: 2007/06/08, 12:17:20 »
Wow, het is me gelukt GoogleEarth op deze manier te installeren. En het werkt! Bedankt voor de hulp.

Alleen .... ik loop wel weer vast bij het installeren van andere pakketten met dezelfde melding als eerst:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

Het systeem blijft kennelijk nog hangen omdat er een niet geaccepteerde eerdere license in het systeem zit. Heeft iemand nog een suggestie voor me?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #17 Gepost op: 2007/06/08, 12:22:29 »
probeer nu: sudo dpkg --configure -a
(dat heb je eerder gedaan, maar misschien lukt het nu wel...)

of:
Citaat
sudo dpkg --configure -a && sudo apt-get -f install
of het bestand:  gedit /var/lib/dpkg/status  openen en kijken naar gebroken pakketten. eventuele pakketten verwijderen kan met : sudo gedit /var/lib/dpkg/status  en de gebroken pakketten verwijderen.
omdat dat een zoektocht is: zoek vooral  bij googleearth en java of de pakketten juist zijn geinstalleerd.....

Bernhard

  • Gast
Update manager loopt vast
« Reactie #18 Gepost op: 2007/06/08, 15:14:19 »
desktop:~$ sudo dpkg --configure -a  had ik al geprobeerd maar lost niets op

desktop:~$ sudo dpkg --configure -a && sudo apt-get -f install geeft als resultaat:
dpkg: statusdatabasegebied is vergrendeld door een ander proces

gedit /var/lib/dpkg/status geeft dit:

Package: googleearth
Status: install ok half-configured
Priority: optional
Section: non-free/net
Installed-Size: 40844
Maintainer: The Medibuntu Team
Architecture: i386
Version: 4.0.2735.0-0medibuntu4
Depends: libc6 (>= 2.5-0ubuntu1), libfontconfig1, libfreetype6, libgl1-mesa-glx | libgl1, libice6, libsm6, libx11-6, libxcursor1, libxext6, libxft2, libxrender1, ttf-dejavu | ttf-bitstream-vera, googleearth-data (= 4.0.2735.0-0medibuntu4)
Pre-Depends: debconf (>= 0.5) | debconf-2.0
Package: googleearth
Status: install ok half-configured
Priority: optional
Section: non-free/net
Installed-Size: 40844
Maintainer: The Medibuntu Team
Architecture: i386
Version: 4.0.2735.0-0medibuntu4
Depends: libc6 (>= 2.5-0ubuntu1), libfontconfig1, libfreetype6, libgl1-mesa-glx | libgl1, libice6, libsm6, libx11-6, libxcursor1, libxext6, libxft2, libxrender1, ttf-dejavu | ttf-bitstream-vera, googleearth-data (= 4.0.2735.0-0medibuntu4)
Pre-Depends: debconf (>= 0.5) | debconf-2.0

en  desktop:~$ sudo gedit /var/lib/dpkg/status geeft:

(yelp:13842): Yelp-WARNING **: Cannot find dbus bus

Unmatched element: citerefentry
Unmatched element: refentrytitle

** (yelp:13842): WARNING **: AT_SPI_REGISTRY was not started at session startup.

** (yelp:13842): WARNING **: IOR not set.

** (yelp:13842): WARNING **: Could not locate registry
Unmatched element: citerefentry
Unmatched element: refentrytitle

Dit is voor mij abracadabra. Kan jij er wat van maken?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Update manager loopt vast
« Reactie #19 Gepost op: 2007/06/08, 15:22:30 »
gedit /var/lib/dpkg/status
ik denk dat googleearth ok is, geen idee of half-configured  het probleem is.
via
Citaat
gksudo nautilus
navigeer je naar het bestand:
Citaat
/var/lib/dpkg/status
en verwijder de googleearth install.
nautilus afsluiten.
daarna sudo apt-get update
            sudo apt-get upgrade

je weet zeker dat er geen gebroken pakketten in het bestand genoemd werden?
het gaat eigenlijk om die pakketten. maar omdat  na de googleearth install de problemen ontstonden doen we het zo.

Bernhard

  • Gast
Update manager loopt vast
« Reactie #20 Gepost op: 2007/06/10, 16:02:38 »
Citaat van: leoquant
gedit /var/lib/dpkg/status
ik denk dat googleearth ok is, geen idee of half-configured  het probleem is.
via
Citaat
gksudo nautilus
navigeer je naar het bestand:
Citaat
/var/lib/dpkg/status
en verwijder de googleearth install.
nautilus afsluiten.
daarna sudo apt-get update
            sudo apt-get upgrade

je weet zeker dat er geen gebroken pakketten in het bestand genoemd werden?
het gaat eigenlijk om die pakketten. maar omdat  na de googleearth install de problemen ontstonden doen we het zo.
Ik heb nog wat moeten stoeien maar ik ben er uit! Bedankt voor de hulp.

Na gksudo nautilus ben ik naar het bestand (de bestanden) genavigeerd. Maar niet via var/lib/dpkg/status maar via var/lib/dpkg/info en heb daar alle bestanden die begonnen met googleearth verwijderd. Daarna sudo dpkg --configure -a en daarna sudo apt-get update en sudo apt-get upgrade. Na de herstart deed alles het weer zonder problemen!
En ook Googleearth staat nog op mijn systeem en draait goed.

Updates en nieuwe pakketten geinstalleerd zonder problemen.

Vriendelijke groet en dank.