Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Laptop sluit niet af  (gelezen 4271 keer)

langezwieper

  • Gast
Laptop sluit niet af
« Gepost op: 2007/06/01, 14:07:08 »
Ik heb een vreemd probleem,
wanneer ik nl op afsluiten klikken zie ik het ubuntu balkje leeg lopen maar nadat het leeg is gebeurd er niets en moet ik dus handmatig mijn laptop uitzetten door de powerknop 5 sec ingedrukt tehouden.

Wat kan ik hier aandoen?

Verder is het met hibernate zo dat wanneer ik opnieuw start ik enkel maar een klein wazig vierkantje blokje in het midden van men scherm krijg, de rest is zwart...

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
Laptop sluit niet af
« Reactie #1 Gepost op: 2007/06/01, 14:18:26 »
Doe eens in je terminal:
sudo shutdown -h now

sluit ie nu normaal af?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

langezwieper

  • Gast
Laptop sluit niet af
« Reactie #2 Gepost op: 2007/06/01, 14:21:49 »
nee helaas het zelfde krijg eerst een lijstje a la

blabla [ok]
blabla [ok]
blabla [ok]
blabla [ok]

vervolgens die balk... en dat was het

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #3 Gepost op: 2007/06/01, 14:53:57 »
Dit is waarschijnlijk de bug:
https://launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/43961

Het heeft te maken met de ACPI-implementatie van je hardware en je software, Ubuntu dus.
Ondanks het feit dat hij staat op 'Fix released', ook voor Feisty, lijkt het probleem not te bestaan.

langezwieper

  • Gast
Laptop sluit niet af
« Reactie #4 Gepost op: 2007/06/01, 14:58:36 »
Gewoon maar afwachten dus

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #5 Gepost op: 2007/06/01, 15:17:52 »
Wat soms wil helpen (volgens een Engels Forum) is achtrer de regel in grub de tekst
Citaat
acpi=force
zetten.
Probeer het, het kost niets .......
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

langezwieper

  • Gast
Laptop sluit niet af
« Reactie #6 Gepost op: 2007/06/02, 16:29:42 »
Zou u de precieze link kunnen geven, want ik ben vrij nieuw en heb niet echt een idee waar ik dit nu moet toevoegen, en hoe

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #7 Gepost op: 2007/06/02, 17:16:03 »
Open een terminal (Toepassingen > Hulpmiddelen > Terminalvenster)
Type daar
Citaat
sudo gedit /boot/grub/menu.lst
Wanneer je doorbladerd zie een regel die eindigd op
Citaat
splash
, maak hiervan
Citaat
spalsh acpi=force
Zodra je het systeem weer hebt opgestart, zou het moeten werken .........

Succes en laat het weten,
Ron
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

langezwieper

  • Gast
Laptop sluit niet af
« Reactie #8 Gepost op: 2007/06/03, 20:04:37 »
ik zie er 2 achter alle 2 plakken dan?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #9 Gepost op: 2007/06/03, 21:18:27 »
Ja, gewoon doen ;)
Elke kernel heeft zo'n regel, jij hebt dan waarschijnlijk nog een oude kernel in je lijst staan.
Op mijn Celeron was dit de oplossing van het probleem .......
Het schijnt te maken te hebben met afwijkende en/of oudere hardware :lol:

Laat je het weten ?
Ron
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

langezwieper

  • Gast
Laptop sluit niet af
« Reactie #10 Gepost op: 2007/06/03, 22:35:09 »
Helaas maakt het niets uit, ik krijg precies hetzelfde... :(

overigens heb ik wel splash gebruikt ipv uw

spalsh acpi=force

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #11 Gepost op: 2007/06/04, 09:42:57 »
Citaat van: langezwieper
Helaas maakt het niets uit, ik krijg precies hetzelfde... :(

overigens heb ik wel splash gebruikt ipv uw

spalsh acpi=force
Uit het bug-commentaar:
https://launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/43961/comments/103

"I tried acpi=force, then switched to a i386 kernel. Both didn't help.

Then I found out that for some reason, the apm kernel module gets always loaded, no matter whether I use ACPI or not. The apm module is even loaded when I start the kernel with the option apm=no and with an additional line 'blacklist apm' in /etc/modprobe.d/blacklist. (Why is this?)

De-installing apmd is no option, because ubuntu-desktop depends on it ... (Why?)

OK, as I couldn't get rid of APM, I tried to get rid of ACPI.

Then I also tried acpi=off, because I thought, apm and acpi might somehow disturb each other. Bingo!"

Het lijkt er op dat de combinatie van blacklisten van apm en de optie acpi=off in ieder geval voor deze gebruiker de oplossing is. Mogelijk dat daardoor de toepassing van alleen acpi=off niet voldoende is, dit wordt ook gemeld door vele bug-commentatoren. Een aantal meldt juist wel succes. Blijkbaar heeft het te maken met de acpi-implementatie van de hardware die niet volgens de specificatie is, Ubuntu moet dit dus 'volgen'.

Het aantal oplossingen varieert enorm:
- andere kernel
- BIOS-update
- acpi=force
- apm uitzetten
- etc.

Een beetje een chaos dus die al blijkbaar vanaf Dapper loopt. Ik zou zeggen, probeer bovenstaande oplossing en misschien een andere die genoemd is in de bug, maar er is een kans dat niets helpt, behalve afwachten. Je zou je eigen ervaring ook als commentaar bij de bug kunnen opnemen; wel even een launchpad-account aanmaken.

Offline Mescaline

  • Lid
  • Steunpunt: Nee
Laptop sluit niet af
« Reactie #12 Gepost op: 2007/06/04, 10:59:45 »
Heb het zelfde probleem hier tot nu toe niks geholpen..
Hopen dat het in 7.10 eruit is..
Ben geen computer-nerd.. weet niet super veel van pcs.
Maar ben er graag mee bezig :)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #13 Gepost op: 2007/06/04, 18:44:22 »
Jammer ......
Bij mij was het de oplossing (op de test-PC),
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline Mescaline

  • Lid
  • Steunpunt: Nee
Laptop sluit niet af
« Reactie #14 Gepost op: 2007/06/04, 22:32:32 »
Tjah niks aantedoen ik wacht wel af ik heb er geen slapenloze nachten van zegmaar haha.
Ben geen computer-nerd.. weet niet super veel van pcs.
Maar ben er graag mee bezig :)

mordicus

  • Gast
Laptop sluit niet af
« Reactie #15 Gepost op: 2007/06/05, 20:19:03 »
Citaat van: r0n.
Open een terminal (Toepassingen > Hulpmiddelen > Terminalvenster)
Type daar
Citaat
sudo gedit /boot/grub/menu.lst
Wanneer je doorbladerd zie een regel die eindigd op
Citaat
splash
, maak hiervan
Citaat
spalsh acpi=force
Zodra je het systeem weer hebt opgestart, zou het moeten werken .........

Succes en laat het weten,
Ron
er staat helemaal niks in dat venster ...
gewoon splash acpi=force intypen dan?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #16 Gepost op: 2007/06/05, 21:14:52 »
Nee, bedoel je dat je geen /boot/grub/menu.lst file hebt ?
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

mordicus

  • Gast
Laptop sluit niet af
« Reactie #17 Gepost op: 2007/06/06, 00:17:06 »
wel, der opent zich daadwerkelijk een nieuw scherm
en kan eruit opmaken dat die file dus bestaat ...

maar daar staat niks in ... gewoon een leeg en wit

langezwieper

  • Gast
Laptop sluit niet af
« Reactie #18 Gepost op: 2007/06/06, 08:03:32 »
Update ivm met mijn laptop, hij sluit af!!!
Niets meer veranderd gewoon 2 dagen na het proberen van die acpi=force dit verwijderd en nu sluit hij af???

snap er niets van, maar ben er blij mee :)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Laptop sluit niet af
« Reactie #19 Gepost op: 2007/06/06, 12:52:53 »
Citaat van: mordicus
wel, der opent zich daadwerkelijk een nieuw scherm
en kan eruit opmaken dat die file dus bestaat ...

maar daar staat niks in ... gewoon een leeg en wit
Dan kan je PC helemaal niet opstarten :lol:
Zoek eens met nautilus of die bestaat en zo ja, of deze inderdaad leeg is !

Hier snap ik niets van :lol:
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

mordicus

  • Gast
Laptop sluit niet af
« Reactie #20 Gepost op: 2007/06/06, 17:08:07 »
euhm ... volgens nautilus (bij 'zoeken' neem ik aan ...) bestaat het niet ...

maareuh ... mijn pc start wel degelijk en alles werkt (aangezien ik nu met ubuntu op dees forum zit ...)

snap het ff ook niet meer, Help!

mordicus

  • Gast
Laptop sluit niet af
« Reactie #21 Gepost op: 2007/06/06, 17:10:04 »
euhm ... dit zal vreemd klinken ... nu bestaat het plots wel !?

enfin, eens kijken of die oplossing werkt

mordicus

  • Gast
Laptop sluit niet af
« Reactie #22 Gepost op: 2007/06/06, 17:22:30 »
het werkt! pak van mijn hart :D

snap echt nie hoe het nu in elkaar zat met die file ... ik zweer het u, ze bestond niet
had het al gekopieerd, zelf ingetypt.... nikske
ook al gans de handel herinstalleert omdat ik dacht: 'mss is er iets mis gelopen', waarbij ik dus ook de life cd eens ongelooflijk traag gebrand heb
na die herinstallatie gezocht in nautilus: niks

en net opt moment dat ik een print screen wou nemen van dat leeg wit scherm ... bleek het plots vol tekst te staan, o wee de ironie

enfin, heel erg bedankt! nu nog mijn printer aan de praat krijgen, da blijkt een ander paar mouwen te zijn :(

Offline bulldozer

  • Lid
    • http://bulldozer.cjb.net
  • Steunpunt: Nee
Laptop sluit niet af
« Reactie #23 Gepost op: 2007/06/24, 22:57:19 »
Citaat van: mordicus
Citaat van: r0n.
Open een terminal (Toepassingen > Hulpmiddelen > Terminalvenster)
Type daar
Citaat
sudo gedit /boot/grub/menu.lst
Wanneer je doorbladerd zie een regel die eindigd op
Citaat
splash
, maak hiervan
Citaat
spalsh acpi=force
Zodra je het systeem weer hebt opgestart, zou het moeten werken .........

Succes en laat het weten,
Ron
er staat helemaal niks in dat venster ...
gewoon splash acpi=force intypen dan?
bij mij heeft het gewerkt:)