Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: nvidia drivers alweeer =(  (gelezen 1641 keer)

Nizzle

  • Gast
nvidia drivers alweeer =(
« Gepost op: 2007/05/30, 20:48:58 »
na teveel gezeik met nvidia drivers op feisty ben ik maar weer terug gegaan naar edgy..
drivers geinstalleerd.. xorg.conf aangepast dat ik nvidia driver gebruik

en BLAM weer kan X niet starten.. dit keer omdat de nvidia kernel module niet wil starten.. klinkt makkelijker om te fixen maar hoe? :P

Offline Mario

  • Lid
  • Steunpunt: Nee
nvidia drivers alweeer =(
« Reactie #1 Gepost op: 2007/05/30, 21:00:57 »
je doet iets verkeerd denk ik
zo installeer ik mijn drivers
na installatie eerst sources list aanpassen met sorgen (vind je hier op het forum "bedankt kiwinote fantastisch dingetje")
dan via synaptic nieuwste drivers installeren (update xorg.conf gebeurt automatisch)
daarna nvidia-settings opstarten in terminal
settings NIET opslaan
preview van bekijken en daarmee xorg.conf aanpassen
            >overnemen van vermelde optie metamodes en modes
NIETS veranderen in de sectie device
PC:Intel dual core 6600 2.4Ghz-Abit AB9-nvidia GeForce 9600 GT-
dual-boot : Debian Lenny - Windows 7
Alle beschrijvingen van de werkelijkheid zijn tijdelijke veronderstellingen

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
nvidia drivers alweeer =(
« Reactie #2 Gepost op: 2007/05/30, 21:08:59 »
@nizzle
probeer aan het eind van de install eens:

sudo nvidia-glx-config enable

Offline Mario

  • Lid
  • Steunpunt: Nee
nvidia drivers alweeer =(
« Reactie #3 Gepost op: 2007/05/30, 21:14:12 »
was ik vergeten
PC:Intel dual core 6600 2.4Ghz-Abit AB9-nvidia GeForce 9600 GT-
dual-boot : Debian Lenny - Windows 7
Alle beschrijvingen van de werkelijkheid zijn tijdelijke veronderstellingen

Nizzle

  • Gast
nvidia drivers alweeer =(
« Reactie #4 Gepost op: 2007/05/30, 21:48:05 »
ok volges mij zitten we aan verkeerde dingen te denken nu :P

ik heb drivers geinstalleerd.. en xorg.conf aangepast zodat nvidia drivers gebruikt worden ipv nv maar zodra ik dan restart krijg ik de crash van X vanwege nvidia kernel module waar X blijkbaar moeite mee heeft

bij nvidia-settings kan ik geen fuck instellen dus geen idee waar dat over gaat..

en sudo nvidia-glx-config enable deed volgens mij ook niets :(

toen ik drivers aanklikte om te installeren is er trouwens wel een kernel module ding geinstalleerd voor me..
en met nv drivers ipv nvidia drivers werkt beryl niet toch?


*EDIT*
zie net wat in mijn terminal staan.. misschien zegt dat iets..

nizzle@Nizzle-ubuntuu:~$ nvidia-settings

ERROR: NV-CONTROL extension not found on this Display.


ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.


ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.

Offline Mario

  • Lid
  • Steunpunt: Nee
nvidia drivers alweeer =(
« Reactie #5 Gepost op: 2007/05/30, 21:59:16 »
indien een hulp dit is mijn xorg.conf werkt perfect
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "v4l"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
        Option          "Emulate3Buttons" "true"
        Option          "Buttons" "7"
        Option          "ButtonMapping" "1 2 3 6 7 8 9 10"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "NVIDIA GeForce 7600GS"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
        Option          "TripleBuffer"          "true"

EndSection

Section "Monitor"
#        HorizSync source: edid, VertRefresh source: edid
Identifier "Philips 190X"
Option "DPMS"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 76.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA GeForce 7600GS"
Monitor "Philips 190X"
        Option          "AddARGBGLXVisuals"     "true"
        Option          "UseEdidFreqs"          "FALSE"
        Option          "NoLogo"                "true"
DefaultDepth 24
        Option         "metamodes" "1280x1024_75 +0+0; 1280x1024 +0+0; 1024x768 +0+0; 800x600 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice     "stylus" "SendCoreEvents"
InputDevice     "cursor" "SendCoreEvents"
InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection
PC:Intel dual core 6600 2.4Ghz-Abit AB9-nvidia GeForce 9600 GT-
dual-boot : Debian Lenny - Windows 7
Alle beschrijvingen van de werkelijkheid zijn tijdelijke veronderstellingen

Nizzle

  • Gast
nvidia drivers alweeer =(
« Reactie #6 Gepost op: 2007/05/30, 22:49:59 »
ok en wat doen deze dingen?

Option        "UseFBDev"        "true"
Option          "TripleBuffer"          "true"
Option          "UseEdidFreqs"          "FALSE"

Offline Mario

  • Lid
  • Steunpunt: Nee
nvidia drivers alweeer =(
« Reactie #7 Gepost op: 2007/05/30, 23:11:34 »
triplebuffer werd automitisch toegevoegd bij installatie van beryl
useFBdev toegevoegd kreeg bij opstarten x waarschuwing dat deze niet ingeschakeld was
UseEdidfreq in feite niet meer nodig was een tip om het probleem op te lossen dat de ververversingsfrequentie bij gnome-instellingen niet juist gedetecteerd wordt
als ik de optie metamode overneem uit mijn nvidia-instellingen blijft de verversingsfrequentie goed (gnome detecteert ze volgens mij niet juist)
PC:Intel dual core 6600 2.4Ghz-Abit AB9-nvidia GeForce 9600 GT-
dual-boot : Debian Lenny - Windows 7
Alle beschrijvingen van de werkelijkheid zijn tijdelijke veronderstellingen

Nizzle

  • Gast
nvidia drivers alweeer =(
« Reactie #8 Gepost op: 2007/05/31, 11:53:08 »
ok dus daar heb ik dus eigenlijk ook niets aan :(

kzal nvidia drivers wel weer ff laden en de foutmelding hier geven

Nizzle

  • Gast
nvidia drivers alweeer =(
« Reactie #9 Gepost op: 2007/05/31, 11:57:38 »
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Offline Scormen

  • Lid
    • LinuxOntdekt.Be
  • Steunpunt: Nee
nvidia drivers alweeer =(
« Reactie #10 Gepost op: 2007/05/31, 23:00:33 »
Welke kaart heb je?

Ik heb hier de nVidia Go 7600 in een laptop, geen probleem mee.

Citaat
Toen dit klaar was rechtstreeks gegaan naar Systeem - Beheer - Beperkt ondersteunde stuurprogramma's. Hier kon ik mijn grafische kaart, een nVidia Gforce Go 7600, eenvoudig installeren. Opgelet: start niet dadelijk opnieuw op!

We moeten de grafische kaart eerst nog activeren. Allereerst maken we er een gewoonte van om een backup te maken. Voeg het volgende commando uit in de terminal: sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup.

Vervolgens activeren we de kaart daadwerkelijk via de terminal: sudo nvidia-xconfig --add-argb-glx-visuals
grtz,
kris
Ubuntu gebruiker #18341 | Linux gebruiker #456955
ยท Mijn persoonlijke Linux blog

Nizzle

  • Gast
nvidia drivers alweeer =(
« Reactie #11 Gepost op: 2007/06/01, 00:01:46 »
XFX GeForce 6800 LE

draai weer edgy omdat het bij feisty totaal niet lekker werkte bij mij ;)

heb inmiddels dat kernel module ding gefixt maar nu krijg ik overal strepen over mijn scherm als ik nvidia drivers aanzet :(
heb op nvidia forums ook een topicje lopen maar daar weten ze volgens mij ook niets :(
kheb ook erges een nvidia log bestand als jullie dat wat zegt :P