Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel  (gelezen 1694 keer)

ubuntuwebbie

  • Gast
Beste Ubuntusers,

Ik heb op mijn webserver Ubuntu 7.04 Samba geïnstalleerd.

gebruikers aangemaakt  met de zelfde namen als op de windows pc

de mappen hebben ik gedeeld, dus rechten gegeven,

Deze staan ook in de smb.conf file. Hierin ook aangegeven welke ip adres van de windows pc is toegestaan.

Met testparm de smb.conf laten controleren, deze gaf ok

Op de windows pc is de Samba server wel te zien, maar niet toegankelijk om bestanden te zien en te wijzigen.

Ik heb ook Swat geïnstalleerd of de services samba wel draaiden.

Ik heb zelfs ook NFS geïnstalleerd, maar tot nu toe geen resultaat.

De firewall Firestarter even uitgeschakeld om te testen of ik samba poorten moest instellen.

Niks hielp

Ubuntusers graag hulp gevraagd.

Bij voorbaat dank.

Offline woteb

  • Lid
  • Steunpunt: Nee
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #1 Gepost op: 2007/05/29, 07:27:50 »
Heb je voor dezelfde gebruikers ook smbpasswd gebruikt?

sudo smbpasswd -a
2x het passwd

Voorbeeld:

smbpasswd -a pietjepuk
pietje
pietje

Waarbij pietjepuk de gebruiker is en pietje het wachtwoord.
Natuurlijk zijn de gebruikers op zowel de server als op jouw XP bakkies identiek met exact dezelfde wachtwoorden.

Succes!!
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

ubuntuwebbie

  • Gast
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #2 Gepost op: 2007/05/29, 22:49:06 »
Hallo woteb,

bedankt voor het reageren, dit had ik al gedaan.

Krijg nog steeds de zelfde melding.

Ubuntusers

graag hulp gevraagd.

Offline woteb

  • Lid
  • Steunpunt: Nee
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #3 Gepost op: 2007/05/29, 22:58:04 »
Heb je op de gedeelde directories al chmod -R 0755 uitgevoerd?

Voorbeeld: chmod -R 0755 /files/foto

Linux is nogal kieskeurig op dit punt.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

ubuntuwebbie

  • Gast
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #4 Gepost op: 2007/05/29, 22:58:29 »
Hallo Ubuntusers,

heb dit probleem naar Software en configuratie verplaatst.

Sorry voor het verkeerd plaatsen.

ubuntuwebbie

  • Gast
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #5 Gepost op: 2007/05/30, 21:06:24 »
Hallo woteb,

heb chmod -R 0755 /home/mijnusername gedaan,

maar krijg nog steeds dezelfde melding

bedankt vor het reageren

Offline woteb

  • Lid
  • Steunpunt: Nee
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #6 Gepost op: 2007/05/30, 21:25:18 »
Probeer het volgende eens:

In smb.conf moet je in een share het volgende toevoegen (even mijn situatie als vooreeld):

[Spinakker]
Comment = Spinakker bestanden
browsable = yes
path = /home/spinakker
public = yes
writable = yes
create mode = 0777
create mask = 0777

Create mode en create mask zorgen ervoor dat de hoofddirectory en de onderliggende directories de juiste rechte hebben.

Browsable zorgt ervoor of de share wel/niet zichtbaar is
Public spreekt voor zichzelf.

Als je de inhoud van een CD wilt delen kun je ook nog

read only = yes

toevoegen.

Wanneer je de aanpassingen hebt doorgevoerd ALTIJD Samba opnieuw starten. dat doe je in een terminal met:

/etc/init.d/samba restart

Let op de PUNT achter init, die moet je echt typen.

Succes!
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

ubuntuwebbie

  • Gast
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #7 Gepost op: 2007/05/30, 21:50:16 »
Hallo woteb,

krijg nog steeds de melding

moet workgroup ook  ingesteld worden.

Hierbij de smb.conf

Bij voorbaat dank

# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2007/05/29 00:49:45

[global]
   null passwords = Yes
   passdb backend = tdbsam
   username map = /etc/samba/smbusers
   syslog only = Yes
   announce version = 5.0
   name resolve order = hosts wins bcast
   socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
   printcap name = CUPS
   wins support = no
   printing = cups
   print command =
   lpq command = %p
   lprm command =

workgroup = WORKGROUP
[print$]
   path = /var/lib/samba/printers
   write list = root
   create mask = 0664
   directory mask = 0775
   guest ok = Yes

[printers]
   path = /tmp
   guest ok = Yes
   printable = Yes
   browseable = No



[edgar]
Comment = edgar bestanden
browsable = yes
path = /home/edgar
public = yes
writable = yes
create mode = 0777
create mask = 0777

[samba]
path = /home/samba
available = yes
browsable = yes
public = yes
writable = no

Offline woteb

  • Lid
  • Steunpunt: Nee
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #8 Gepost op: 2007/05/30, 22:05:08 »
Hier is mijn smb.conf:

#======================= Global Settings =======================
[global]
   log file = /var/log/samba/log.%m
   server string = Spinakker
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
   socket options = TCP_NODELAY
   obey pam restrictions = yes
   domain master = no
   encrypt passwords = true
   passdb backend = tdbsam guest
   passwd program = /usr/bin/passwd %u
   dns proxy = no
   netbios name = Server
   invalid users = root
   workgroup = home
   os level = 64
   security = user
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   max log size = 1000

[homes]
   comment = Home Directories
   browseable = no

# hier staan o.a. de thunderbird mail directories in opgeslagen

[home]
   writeable = yes
   path = /home/homedirs
   comment = Gebruikers persoonlijke bestanden
   create mode = 0777
   create mask = 0777
   browsable = yes
   directory mode = 0777

# Een rommel share

[tijdelijk]
    comment = Tijdelijke opslag van bestanden
    browsable = yes
    path = /files/temp
    public = yes
    writable = yes
    create mode = 0777

# De gemeenschappelijke bestanden van de gebruikers, documenten, foto's e.d.

[spinakker]
    comment = Spinakker bestanden
    browsable = yes
    path = /home/spinakker
    public = yes
    writable = yes
    create mode = 0777
    create mask = 0777

Ik heb hier drie voorbeelden van shares er in laten zitten.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline woteb

  • Lid
  • Steunpunt: Nee
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #9 Gepost op: 2007/05/30, 22:25:20 »
Even alles op een rijtje:

1. Gebruikersnamen en wachtwoorden op de Linux en Windows systemen moeten identiek zijn. Op de Linux systemen tevens met smbpasswd herhalen. Dus op de Windows systemen gebruikersnaam + wachtwoord, op de Linuxsystemen met passwd en smbpasswd.

2. Op de server (ik ga dus uit van een Linuxserver) moet de share bestaan. Hierop moeten de juiste rechten zijn toegekend.

3. In smb.conf moeten dezelfde rechten bestaan. Leesrechten op de directory en lees/schrijfrechten in smb.conf gaat niet werken. Met andere woorden: writable = yes in smb.conf en fysiek r-- zal niet werken.

4. In smb.cond met create mode en create mask ook de juiste rechten toepassen.

5. Niet vergeten na een aanpassing in bijv. smb.conf Samba te herstarten met:
/etc/init.d/samba restart
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

ubuntuwebbie

  • Gast
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #10 Gepost op: 2007/05/30, 23:21:08 »
Hallo woteb,

bedankt voor de reacties.

Het probleem is opgelost.

heb winserver = yes in smb.conf

daarna in

system> beheer > share mappen > eigenschappen > wins ingesteld

kan nu vanuit ubuntu en windows xp en omgekeerd lezen en schrijven.

goede nachtrust.

Offline woteb

  • Lid
  • Steunpunt: Nee
Samba server Ubuntu 7.04 op Windows XP wel te zien maar niet toegankel
« Reactie #11 Gepost op: 2007/05/30, 23:23:43 »
Vergeet niet de vlag binnen te halen, want je hebt wat te vieren :)
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)