Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: download .deb gelukt........ maar dan ?  (gelezen 1258 keer)

Gast

  • Gast
download .deb gelukt........ maar dan ?
« Gepost op: 2006/03/31, 22:27:13 »
Heb als debutant, na het installeren van Ubuntu, een .deb file kunnen downloaden. Staat op m'n desktop.

Als ik hierop dubbelklik (oude gewoonte van een ander OS....) krijg ik de boodschap "Archive type not supported".

Help ???

Jommeke

lennart

  • Gast
download .deb gelukt........ maar dan ?
« Reactie #1 Gepost op: 2006/03/31, 22:37:57 »
Open een terminal(toepassingen - hulpmiddelen - terminalvenster)
type: cd /demap/waarin/de.deb/file/zit
type: sudo dpkg -i naamvandedebfile.deb

Veel .deb files staan ook in synaptic, dus zoek daar eerst voordat je een .deb download

dysan100

  • Gast
download .deb gelukt........ maar dan ?
« Reactie #2 Gepost op: 2006/03/31, 22:40:32 »
Hallo Jommeke,
Is dit een programma dat je wil installeren?
Wellicht is het dan handig om te weten dat je software met Synaptic kunt installeren via Systeem, Beheer, Synaptic pakketbeheer.
Maar goed, om dit debje te installeren:
open een terminal (soort DOS prompt) via Toepassinge, Hulpmiddelen, Terminalvenster
Geef commando
cd Desktop
geef commando:
sudo dpkg -i [naam].deb
NB het sudo commado zal om je wachtwoord vragen. Het commando sudo zorgt ervoor dat je de daarna volgende opdracht als beheerder uitvoert. In Linux termen: als root
Succes

Gast

  • Gast
download .deb gelukt........ maar dan ?
« Reactie #3 Gepost op: 2006/03/31, 23:24:59 »
Bedankt voor de snelle reactie.

Bij het installeren van de  package blijkt deze nog andere dingen nodig te hebben (dependencies?)

Wanneer ik echter dit probleem probeer op te lossen krijg ik dit :

root@ubuntu:/tmp/downloads# sudo dpkg -i libdb4.0++c102_4.0.14-2_i386.deb
Selecting previously deselected package libdb4.0++c102.
(Reading database ... 61623 files and directories currently installed.)
Unpacking libdb4.0++c102 (from libdb4.0++c102_4.0.14-2_i386.deb) ...
Setting up libdb4.0++c102 (4.0.14-2) ...

root@ubuntu:/tmp/downloads# sudo dpkg -i postman_2.0-7_i386.deb
(Reading database ... 61627 files and directories currently installed.)
Preparing to replace postman 2.0-7 (using postman_2.0-7_i386.deb) ...
Unpacking replacement postman ...
dpkg: dependency problems prevent configuration of postman:
 postman depends on libdb4.0; however:
  Package libdb4.0 is not installed.
dpkg: error processing postman (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 postman
root@ubuntu:/tmp/downloads#


Gebruik ik de verkeerde libdb4.0 ??

Jommeke

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
download .deb gelukt........ maar dan ?
« Reactie #4 Gepost op: 2006/04/01, 10:28:23 »
Dependency betekent afhankelijkheid. In open source-wereld bouwen programeuurs verder op wat reeds bestaat. synaptic en apt-get in een terminal zorgen voor een naadloze installatie, dependencies incluis. Maar hier moet je dus eerst libdb4.0 installeren.

treg58

  • Gast
download .deb gelukt........ maar dan ?
« Reactie #5 Gepost op: 2006/04/01, 23:49:26 »
Dames/Heren, ik heb een wat vreemde grafische kaart (ATI RADEON 3000). Ik heb inmiddels de driver gedownload voor Linux. Dat is een prachtige .rpm file. Dus wil ik die met apm-get installeren.... Nou ben ik nog een Linux digibeet.. dus je snapt het al. Hoe los ik dit op?

cvcaelen

  • Gast
download .deb gelukt........ maar dan ?
« Reactie #6 Gepost op: 2006/04/02, 09:43:05 »
@ treg58:

een rpm-file zal je eerst moeten omzetten naar .deb
en wel met: sudo apt-get install alien   (dit is een "conversie of vertaal programma om .rpm naar .deb om te zetten)

vervolgens doe je :sudo alien -i pakketnaam.rpm
(vertaald wil dit zeggen : alien, installeer het pakket met extentie .rpm)

laat je weten of het werkt?

Christiaan

lennart

  • Gast
download .deb gelukt........ maar dan ?
« Reactie #7 Gepost op: 2006/04/03, 20:12:31 »
Citaat van: Jommeke
Gebruik ik de verkeerde libdb4.0 ??
Zou goed kunnen. Volgensmij probeer je een variant of plugin van libd4.0 te installeren die is gebasseerd op libdb4.0. Als het goed is zou je hem ook via synaptic kunnen installeren, alleen misschien moet je dan eerst wat meer "repositories" aanzetten. Kijk daarvoor hier: https://wiki.ubuntu.com/AddingRepositoriesHowto