Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Installeren van wireless adapter (Asus WL-138G, pci)  (gelezen 3552 keer)

tim2005

  • Gast
Installeren van wireless adapter (Asus WL-138G, pci)
« Gepost op: 2007/05/25, 18:30:47 »
Ik heb een asus WL-138G in mijn pc zitten (pci) en ik wil er drivers voor installeren zodat ik hem kan gebruiken. Linux zelf ziet de hardware wel, maar niet bij de internet connecties oid.

Naam Fabrikant: Asus
Product: WL-138G
Chipset: Marvell
Bus: PCI 1.0 / PCI 2.2

Ik las op het forum iets over iwconfig, ik dat ingetikt in de commandline/terminal:
lo      no wireless extensions.
sit0   no wireless extensions.

Ik kom mischien onduidelijk over, maar ik ben nog nieuw met linux en ubuntu. Ik gebruik de LTS versie van Ubuntu.
Ik heb dus nog weinig ervaring met ubuntu.

Ik zou dus graag willen weten (A) waar ik de correcte driver vandaan haal en (B) hoe ik die installeer. Na de drivers moet ik natuurlijk de adaptor configureren, dat hoef ik nog niet te weten, want toen ik hier op het forum de zoek functie al gebruikte zag ik daar al een heleboel topics over.

Met vriendelijke groeten en bij voorbaat dank,
Tim

Edit:
Ben langs de asus site geweest, deze keer met een beetje resultaat...
Er was geen linux driver voor de WL-138g, maar wel voor de WL-138g v2 :)
http://support.asus.com/download/download.aspx?modelname=WL-138g%20v2&SLanguage=en-us

Offline Menno_

  • Lid
  • Steunpunt: Nee
Installeren van wireless adapter (Asus WL-138G, pci)
« Reactie #1 Gepost op: 2007/05/27, 12:39:18 »
Ik zit min of meer met hetzelfde probleem, ik heb een wl-138g v2 en heb op de aangewezen link in het vorige bericht de bestanden gedownload. Daarin staat een readme met een instructie. Die instructie volgend moet je zelf een module "make"n. Ik ben nogal nieuw op dat vlak (ben pas sinds een week of 8 met linux bezig (0,0 unix-ervaring), maar tot zover kom ik nog wel mee.
Naar de directory met de source wandelen, daar staat een makefile en dan het commando "make" uit laten voeren. Dat gaat fout want hij vindt het eea niet en daar haak ik dus af, wat moet ik doen om het goed te laten lopen.. hieronder de uitvoer van de console na het invoeren van "make":

~/src/linuxsta/src/wl/linux$ make
Linux Directory is /lib/modules/2.6.20-15-generic/build
Linux Kernel Versions is 2.6.20-15-generic
make -C /lib/modules/2.6.20-15-generic/build CROSS_COMPILE= M=/home/menno/src/linuxsta/src/wl/linux modules
make[1]: Map '/usr/src/linux-headers-2.6.20-15-generic' wordt binnengegaan
  CC [M]  /home/menno/src/linuxsta/src/wl/linux/wlc_led.o
In file included from /home/menno/src/linuxsta/src/wl/linux/wlc_led.c:17:
/home/menno/src/linuxsta/src/wl/linux/../../include/typedefs.h:166: fout: conflicting types for ‘bool’
include/linux/types.h:36: fout: previous declaration of ‘bool’ was here
In bestand ingevoegd door /home/menno/src/linuxsta/src/wl/linux/../../include/linux_osl.h:21,
                 door /home/menno/src/linuxsta/src/wl/linux/../../include/osl.h:24,
                 door /home/menno/src/linuxsta/src/wl/linux/wlc_led.c:19:
/home/menno/src/linuxsta/src/wl/linux/../../include/linuxver.h:19:26: fout: linux/config.h: Bestand of map bestaat niet
make[2]: *** [/home/menno/src/linuxsta/src/wl/linux/wlc_led.o] Fout 1
make[1]: *** [_module_/home/menno/src/linuxsta/src/wl/linux] Fout 2
make[1]: Map '/usr/src/linux-headers-2.6.20-15-generic' wordt verlaten
make: *** [default] Fout 2

In de directory met de Makefile komen dan een heleboel bestanden te staan waar ik niet mee weet wat te doen (behalve weggooien met "make clean". Ik heb eerst als gewone gebruiker geprbeerd en daarna als root... het enige verschil dat dat oplevert is dat ik de bestandjes die in de directory terecht komen alleen maar als root weer kan opruimen, de foutmeldingen zoals hierboven zijn verder identiek.. Ik mis dus het eea aan informatie/bestanden, maar wat ik precies mis en waar ik het vandaan moet halen is me niet duidelijk.

De instructie in de readme mbt tot make is:
2. Build the Driver
   cd src/linuxsta/src/wl/linux
   in the makefile make sure to set the variables
   CROSS_COMPILE=, if the the gcc is not already in the $PATH or if a different compiler needs to be used, and
   GCC-REV=  dictates the path of the prebuild regulatory binaries, to use while building the driver.(values it takes now are 3.4.2 or 4.0.2),
   if the kernel version is 2.6.14.3 the driver expects that iee80211_crypto.ko module be loaded, prior to loading this driver.

waar ik mijn $PATH moet vinden en of daar GCC-REV is ingesteld en hoe ik moet checken of de iee80211_crypto.ko module is gelanden weet ik (nog) niet.

Alvast hartelijk dank voor jullie inbreng en met vriendelijke groeten,

Menno
6x Ubuntu 10.04 server op VM-Ware // Ubuntu 8.04 server op Dell SC1425

Offline Menno_

  • Lid
  • Steunpunt: Nee
Installeren van wireless adapter (Asus WL-138G, pci)
« Reactie #2 Gepost op: 2007/05/27, 14:19:26 »
Nog even ter aanvulling op mijn bovenstaande post:
Ik heb ndiswrapper ook geïnstalleerd gehad en vervolgens de windowsdriver geïnstalleerd (komt terecht in /etc/ndiswrapper) De panel van ndiswrapper (Windows WiFi Drivers) zegt dan dat er geen hardware is. Aangezien dit hele verhaal een soort emulatie is waarop je dan een niet native-driver installeerd beschouw ik dat maar als een doodgeboren kindje (in mijn geval dan) en probeer met make ed verder te komen.

mvg Menno
6x Ubuntu 10.04 server op VM-Ware // Ubuntu 8.04 server op Dell SC1425

tim2005

  • Gast
Installeren van wireless adapter (Asus WL-138G, pci)
« Reactie #3 Gepost op: 2007/05/27, 14:26:16 »
Bedankt voor je post, ik ben nog ontzettend nieuw met ubuntu/linux (1 week), ik heb nu geen internet op me ubuntu, dus had die driver gedownload.... dat make snap ik dus nog niet, ik zal nogmaals ff de readme lezen en eventueel nog ff wat info zoeken over 'make'.

Ndiswrapper, daar heb ik ook vaker van gehoord.... ik heb wel de originele drivers nog, ik zal eens kijken of ik daar ook iets mee kan....

Gr, Tim

Offline Menno_

  • Lid
  • Steunpunt: Nee
Installeren van wireless adapter (Asus WL-138G, pci)
« Reactie #4 Gepost op: 2007/05/27, 17:38:22 »
Ik heb nog verder gezocht op ubuntu.org en heb de link: http://ubuntuforums.org/showthread.php?t=197102 gevonden. Daarin staat een howto en een installer die je kunt downloaden. Vergeet niet ndiswrapper en nog een tool waarvan ik de naam weer ben vergeten volledig te de-installeren. Op de PC van mijn vriendin draait de netwerkkaart nu prima. Ow ja de kaart is dus een broadcom en geen asus. Checken kan je dat met lspci in de commandprompt, dan zul je waarschijnlijk zien dat de wireless kaart die je hebt gemonteerd een broadcom kaart is :-)

groeten succes, Menno
6x Ubuntu 10.04 server op VM-Ware // Ubuntu 8.04 server op Dell SC1425

tim2005

  • Gast
Installeren van wireless adapter (Asus WL-138G, pci)
« Reactie #5 Gepost op: 2007/05/27, 17:52:37 »
Bedankt voor het (mee) zoeken!

Ik heb versie 1 en jij versie 2, voor versie 2 zijn wel officiele linux drivers uitgegeven, maar voor v1 dus niet.... dat is momenteel dus het grootste probleem.....

gr, Tim