Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04  (gelezen 458 keer)

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Gepost op: 2021/05/04, 17:10:56 »
Hoi Allemaal. Ofschoon onderstaand probleem wellicht te maken heeft met andere problemen waar ik mee zit,zoals bevriezingen, wilde ik dit toch maar in een eigen item plaatsten. Ik kom er niet uit. Ik heb 16.04 en 18.04 en die werken prima. Het is juist daarom ook zo onbegrijpelijk. Maar de nieuw 20-04 gaat me steeds meer problemen geven. Ik kan doen en laten wat ik wil in de 20.04 grub en die exact correct invullen,maar er wordt toch ergens in de opstart gekozen voor iets fouts..?? Mijn Radeon-videokaart wordt normaal keurig gezien en de driver uitgezet om zo de Xubuntu-driver te activeren. ( Ik zeg het maar even op z'n boerenfluitje)  Maar in 20.04 ,die het 2 weken prima heeft gedaan met het beeldscherm, wordt nu ineens voor een instelling gekozen die zoals ik het "zie" juist wel de Radeon-driver ziet en waar geen ondersteuning voor is,..en dus wordt er dan voor een soort basis-standaard driver gekozen die mij alleen maar 3 optionele resoluties geeft waar eigenlijk niet mee te werken is. De beste is dan iets van 1400x1050 in de ( bij starten; videoinfo=)  en in de beeldscherm-instelling op buroblad de hoogste van iets van 700 x 400 ( kan het nu even niet zien) Mijn scherm kan alles aan en staat normaal op 1600x1200 in 20.04. Maar ik heb dus geen enkele greep op mijn grub. Met of zonder nomodeset enz.Ook xandr en anderen laten zien dat ze dus niet dat scherm verder kunnen herkennen. Terwijl in mijn 16 en 18 daar geen enkel probleem is.
Ik wordt nu na weer daaaaaagen er mee bezig zijn, zo langzamerhand gek van. Voor de volledigheid hier enige tekst en ik hoop dat iemand me weer op de goede weg kan helpen.Dank
Graphics:
  Device-1: AMD Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]
  vendor: Pegatron driver: N/A bus ID: 02:00.0
  Display: x11 server: X.Org 1.20.9 driver: ati,vesa
  unloaded: fbdev,modesetting,radeon resolution: 720x480~N/A
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 128 bits) v: 4.5 Mesa 20.2.6
  direct render: Yes   

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #1 Gepost op: 2021/05/04, 19:42:47 »
Beetje interpunctie zou al veel helpen.
mvg,  Peter
Desktop: xubuntu 18.04.5
"No windows in the house but somehow there's more light..."
The future ain’t what it used to be.

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #2 Gepost op: 2021/05/05, 11:42:39 »
Okay pederoco..! Doe ik de volgende keer beter. Voor nu dan de vraag zo simpel mogelijk;  waarom reageert xubuntu 20.04 grub in het geheel niet op enige verandering die ik in /etc/default/grub maak ??

Offline Ronaldus

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #3 Gepost op: 2021/05/05, 12:44:12 »
Na het aanpassen:
sudo update-grub

in de terminal uitvoeren + herstart.
6 pc's in 'actieve dienst'. Daarop draaiend:
** Xubuntu 20.04 (gezins pc/hoofd pc) ** W10 (thuiswerk-pc) ** Xubuntu 20.04 (laptop 1) ** Mint Cinnamon 20 (laptop 2) ** Mint XFCE 20 (laptop 3) ** W10 (laptop 4) **
Voor veel 'tips & tricks', zie: https://makkelijkelinuxtips.blogspot.com/p/1.html

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #4 Gepost op: 2021/05/05, 16:03:10 »
Ja..,Ronaldus, dat updaten doe ik altijd direct na enige aanpassing. Dát is dus ook zo frustrerend. Het heeft geen effect op mijn probleem. Het vreemde is dat ik dezelfde handelingen enige tijd geleden wel gewoon kon doen. Nu dus ineens niet meer. Het achterliggende probleem is dus dat als ik geen nomodeset gebruik, het scherm of zwart gaat of vol met vegen. Hetgeen aangeeft dat de resolutie fout is. Maar om dan ergens in mijn grub-file te kunnen komen,moet ik wel eerst nomodeset gebruiken die me dan alleen die maximale zetting geeft van 720x480. Dan moet ik sudo thunar gebruiken om rechten te krijgen om in etc de grub aan te passen . Daar had ik dan ook het # weggehaald bij de resoluties om zo mijn geschikte 1600x1200 in te vullen.
Maar na het herstarten......noppes! Weer gewoon terug in de 3 vaste zettings met 720x480. Ook nadat ik eens de nomodeset heb verwijderd. Dus érgens wordt de keuze gemaakt vanaf een "ander"soort grub waar ik niet van weet of begrijp hoe dat kan / werkt.

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #5 Gepost op: 2021/05/05, 17:38:14 »
Hallo, resoluties aanpassen doe je volgens mij niet in grub.
Als je gewoon Xubuntu 20.04 opstart, hoe ziet je Bureaublad er dan uit? Lage resolutie? Kun je bij Instellingen - Extra stuurprogramma's komen? Zo ja, welke driver wordt daar gebruikt? De nouveau of een andere?

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #6 Gepost op: 2021/05/05, 18:07:10 »
Hoi Paulk, vanwege het probleem heb ik maximaal 720x480 met een goed beeld maar veel te groot en niet bruikbaar. Ik heb op de extra stuurprogramma's dus helemaal niets staan. Ook niet na lang wachten. Ben nu inmiddels al weer zeker 4 volle werkdagen bezig om alleen maar mijn beeldscherm bruikbaar te krijgen, OMG!
Net nog maar weer een ander wanhoops poging gedaan en iets van een pakker openchrome binnengehaal maar dat heeft ook niets gedaan. Wordt er gek van....!

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #7 Gepost op: 2021/05/05, 21:29:20 »
Radeon HD 6450/7450/8450 / R5 230 OEM
The Radeon R5 230 OEM was a graphics card by AMD, launched in December 2013
Deze is niet meer ondersteund in de huidige Linux-en.
Na veel zoeken nog steeds geen succesverhaal gevonden.
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #8 Gepost op: 2021/05/06, 12:03:23 »
Ik heb zelf de beschikking over een videokaart uit dezelfde HD 6000 reeks.

jolo@testpc:~$ inxi -G
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Cayman PRO [Radeon HD 6950] driver: radeon v: kernel
           Display: x11 server: X.Org 1.20.9 driver: ati,radeon unloaded: fbdev,modesetting,vesa
           resolution: 1280x1024~60Hz
           OpenGL: renderer: AMD CAYMAN (DRM 2.50.0 / 5.8.0-50-generic LLVM 11.0.0) v: 4.3 Mesa 20.2.6

Hier wordt dus wel de radeon driver gebruikt in Xubuntu 20.04
jolo@testpc:~/Documenten$ inxi -S
System:    Host: testpc Kernel: 5.8.0-50-generic x86_64 bits: 64 Desktop: Xfce 4.14.2
           Distro: Ubuntu 20.04.2 LTS (Focal Fossa)

De getoonde resolutie hoort inderdaad bij de aangesloten 19 inch LCD monitor. (Iiyama ProLite E481S) Ook heb ik de Glmark2 GPU test kunnen uitvoeren, zonder foutmeldingen.

jolo@testpc:~$ glmark2
=======================================================
    glmark2 2014.03+git20150611.fa71af2d
=======================================================
    OpenGL Information
    GL_VENDOR:     X.Org
    GL_RENDERER:   AMD CAYMAN (DRM 2.50.0 / 5.8.0-50-generic, LLVM 11.0.0)
    GL_VERSION:    3.1 Mesa 20.2.6
=======================================================
[build] use-vbo=false: FPS: 5143 FrameTime: 0.194 ms
[build] use-vbo=true: FPS: 8229 FrameTime: 0.122 ms
[texture] texture-filter=nearest: FPS: 8352 FrameTime: 0.120 ms
[texture] texture-filter=linear: FPS: 8318 FrameTime: 0.120 ms
[texture] texture-filter=mipmap: FPS: 8489 FrameTime: 0.118 ms
[shading] shading=gouraud: FPS: 7307 FrameTime: 0.137 ms
[shading] shading=blinn-phong-inf: FPS: 7307 FrameTime: 0.137 ms
[shading] shading=phong: FPS: 7155 FrameTime: 0.140 ms
[shading] shading=cel: FPS: 7099 FrameTime: 0.141 ms
[bump] bump-render=high-poly: FPS: 5175 FrameTime: 0.193 ms
[bump] bump-render=normals: FPS: 8554 FrameTime: 0.117 ms
[bump] bump-render=height: FPS: 8466 FrameTime: 0.118 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 8264 FrameTime: 0.121 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 5612 FrameTime: 0.178 ms
[pulsar] light=false:quads=5:texture=false: FPS: 7448 FrameTime: 0.134 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 3261 FrameTime: 0.307 ms
[desktop] effect=shadow:windows=4: FPS: 4263 FrameTime: 0.235 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 986 FrameTime: 1.014 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 1203 FrameTime: 0.831 ms
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 1075 FrameTime: 0.930 ms
[ideas] speed=duration: FPS: 1950 FrameTime: 0.513 ms
[jellyfish] <default>: FPS: 6036 FrameTime: 0.166 ms
[terrain] <default>: FPS: 630 FrameTime: 1.587 ms
[shadow] <default>: FPS: 3061 FrameTime: 0.327 ms
[refract] <default>: FPS: 1089 FrameTime: 0.918 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 8489 FrameTime: 0.118 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 8484 FrameTime: 0.118 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 8498 FrameTime: 0.118 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 8489 FrameTime: 0.118 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 8344 FrameTime: 0.120 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5: FPS: 8482 FrameTime: 0.118 ms
[loop] fragment-steps=5:fragment-uniform=false:vertex-steps=5: FPS: 8486 FrameTime: 0.118 ms
[loop] fragment-steps=5:fragment-uniform=true:vertex-steps=5: FPS: 6404 FrameTime: 0.156 ms
=======================================================
                                  glmark2 Score: 6065
=======================================================
jolo@testpc:~$


Die Radeon HD 6450 van de TS wordt in ieder geval genoemd in https://help.ubuntu.com/community/RadeonDriver Alleen staat er onderaan "RadeonDriver (laatst bewerkt op 2017-08-21 10:07:52 door vipri-alessandro)"

In principe zou de radeon driver "out of the box" behoren te draaien. Tenminste zolang de GRUB_CMDLINE_LINUX_DEFAULT of GRUB_CMDLINE_LINUX regels in /etc/default/grub niet zijn aangepast, met bijvoorbeeld nomodeset. De nomodeset boot optie zorgt er namelijk voor dat de vesa of fbdev driver wordt gebruikt. Met als gevolg daarvan een lage schermresolutie. 
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Xubuntu 18.04.3
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 20.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #9 Gepost op: 2021/05/07, 10:40:57 »
Hé jolo, even off-topic. Ik heb dezelfde Xubuntu en dezelfde Xfce, maar mijn kernel is uit de 5.4.0-reeks terwijl jij een 5.8.0 hebt. Hoe doe je dat?

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #10 Gepost op: 2021/05/07, 11:02:11 »
Hé jolo, even off-topic. Ik heb dezelfde Xubuntu en dezelfde Xfce, maar mijn kernel is uit de 5.4.0-reeks terwijl jij een 5.8.0 hebt. Hoe doe je dat?

Is de officiële HWE-systeemkern van Ubuntu 20.04.x. Zo kun je die makkelijk installeren:
https://forum.ubuntu-nl.org/index.php?topic=109063.0

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #11 Gepost op: 2021/05/07, 11:24:23 »
Is de officiële HWE-systeemkern van Ubuntu 20.04.x.
Ok, maar ik snap denk ik iets niet. Hier https://ubuntu.com/kernel/lifecycle lees ik het volgende:

Citaat
The Ubuntu LTS enablement, or Hardware Enablement (HWE), stacks provide the newer kernel and X support for existing Ubuntu LTS releases. These stacks can be installed manually, but are also installed with an Ubuntu LTS point release.

Ik heb hier een Xubuntu point release draaien ($ inxi -S geeft Distro: Ubuntu 20.04.2 LTS (Focal Fossa)). Waarom is die 5.8 dan niet geïnstalleerd?

Zo kun je die makkelijk installeren:
https://forum.ubuntu-nl.org/index.php?topic=109063.0

Zal daar eens naar kijken, hoewel ik me altijd verre hou van gedoe/geknoei met kernels...

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #12 Gepost op: 2021/05/07, 12:02:06 »
Is de officiële HWE-systeemkern van Ubuntu 20.04.x.
Ok, maar ik snap denk ik iets niet. Hier https://ubuntu.com/kernel/lifecycle lees ik het volgende:

Citaat
The Ubuntu LTS enablement, or Hardware Enablement (HWE), stacks provide the newer kernel and X support for existing Ubuntu LTS releases. These stacks can be installed manually, but are also installed with an Ubuntu LTS point release.

Omdat je nooit gedwongen zult worden om over te stappen van een LTS-systeemkern naar een HWE-systeemkern. Zie:
https://makkelijkelinuxtips.blogspot.com/p/vragen-4.html#ID6
(punt 6)

Overigens kan zo'n overstap ooit nuttig zijn: ik heb een paar vrij nieuwe machines, die simpelweg beter draaien op de 5.8.x-systeemkern dan op de 5.4.x. Kwestie van nieuwere stuurprogramma's. Bij oudere apparatuur is zo'n overstap meestal zinloos.
« Laatst bewerkt op: 2021/05/07, 12:06:18 door Pjotr »

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #13 Gepost op: 2021/05/07, 16:45:55 »
Overigens kan zo'n overstap ooit nuttig zijn: ik heb een paar vrij nieuwe machines, die simpelweg beter draaien op de 5.8.x-systeemkern dan op de 5.4.x. Kwestie van nieuwere stuurprogramma's. Bij oudere apparatuur is zo'n overstap meestal zinloos.
Ik heb hier alleen maar oud spul draaien, m'n werk-pc heb ik in 2014 van een nieuw moederbord voorzien en sindsdien draait dat ding als een zonnetje! Ik zal je tip onthouden overigens.

/off-topic, nu gauw weer terug naar de vraag van Goese Duikertje!

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #14 Gepost op: 2021/05/08, 12:11:31 »
Hoi Allemaal! Was even met wat ziekte bezig en had ook al weer eens mijn hele pc uit elkaar gehaald zonder veel resultaat. Kreeg in 20.04 steeds meer ineens geen beeld meer en keyboard en muis afgesloten. Dacht dat het wellicht met een slecht ingestoken video-kaart te maken had o.i.d. ,kan er geen touw aan vastknopen. Ook dat ik steeds vaker na zo'n harde restart de berichten zie dat er weer enkele orphant inodes moesten worden verwijderd enz. Begrijp nog altijd niet waarom dergelijke, niet meer gebruikte en overbodige bestanden mijn pc moeten slopen. Of waar ze vandaan komen. Ik blijf nu maar even bij mijn 18.04 , want daar heb ik weing problemen mee. Bijgaand heb 2 pdf's gedaan. De één is van 18.04 de ander de 20.04. Het zijn de systeem-verslagen van het programma system profiler and benchmark. Mogelijk zien iemand dáár iets van een duidelijke oorzaak? Het enige dat ik zie is het verschil met die video-driver. Maar ik sta open voor alle tips.Dank.

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #15 Gepost op: 2021/05/08, 15:24:06 »
Kleine aanvulling omdat ik zag dat ik de 20.04 pdf 2x had ingevuld. Hier is de 18.04

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Beeld-instellingen niet meer bruikbaar in xubuntu 20.04
« Reactie #16 Gepost op: Gisteren om 16:04:56 »
Nou, het wil niet lekker lukken allemaal. Ben nu in 20.04 zover weer terug dat ik via nomodeset in mijn etc/default/grub kan komen als ik sudo thunar gebruik. De situatie is nu zó;
 Als in de grub de resolutie aan zet , dus zonder #, en die op 1400x1050 of zelfs op 1920x1440 , met daarboven alleen quite splash doe in de regel en eindig met sudo update-grub, dan start hij prima op met een keurig nog blanco maar vlijm-scherpe desk-foto-achtergrond.......totdat ik op het scherm mijn password heb ingetypt en dan enter doe. Er zijn dan 2 situaties.
1. Als rechtsboven het keuze-knop-meneutje op xfgl staat dan na het enter verspringt het hele bureaublad . Ik na wel de muis erover heen bewegen,maar niets doet het. Ook niet na lang wachten.Ook heb ik dus verschillende resoluties uitgeprobeerd.
2. Als het rechtsboven meneutje op Xubuntu staat, dan na het enteren heb ik alleen een vlijmscherpe bureaublad-foto maar verder gebeurd er dus helemaal niets. Ook hier kan ik de muis bewegen maar heb geen interactie meer. Wel kan ik in beide gevallen via het toetsenbord ctrl-alt-backspace doen en een halve herstart maken. Maar ook het dan kiezen voor de xfg of xubuntu maakt dan niets uit. Geen interactie meer.
Ik heb sterk het idee dat xubuntu iets kiest van ilvmpipecllvm als driver terwijl ik altijd iets heb van mesa of vga ? Ik heb hier geen grip op. Anybody ???Thanks