Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: nvidia drivers geactiveerd met GLX.. HOE!?  (gelezen 954 keer)

Nizzle

  • Gast
nvidia drivers geactiveerd met GLX.. HOE!?
« Gepost op: 2007/05/22, 23:04:00 »
maar ff een eigen onderwerp aanmaken want vragen in 3 verschillende schiet niet op :P

luister het zit zo.. kheb ruzie met die drivers en snap er niets meer van
nvidia-glx en nvidia-glx-legacy werken zoiezo niet dan start X niet eens
met nvidia-glx-new dan start X wel maar dan staan er overal gekleurde strepen door en crasht het na enkele seconden

ik heb een XFX GeForce 6800 LE videokaart en dus de nvidia-glx-new drivers

dit is mijn xorg.conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "Nvidia GeForce 6800LE"
Driver "nv"
BusID "PCI:1:0:0"
Option          "AddARGBVisuals"        "True"
Option          "AddARGBGLXVisuals"     "True"
Option          "NoLogo"        "True"
Option          "UseEvents"     "False"
Option          "AllowGLXWithComposite" "True"
Option          "RenderAccel"   "True"
EndSection

Section "Monitor"
Identifier "Generieke beeldscherm"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Nvidia GeForce 6800LE"
Monitor "Generieke beeldscherm"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
        Option          "Composite"     "Enable"
EndSection
als ik "nv" verander in "nvidia" dan krijg ik dus die prachtige gekleurde strepen en de crash..

oh en GLX staat met "nv" dus blijkbaar niet aan.. :(
nizzle@nizzle-desktop:~$ glxinfo |grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
snap er niets meer van :(
HELP :(

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
nvidia drivers geactiveerd met GLX.. HOE!?
« Reactie #1 Gepost op: 2007/05/23, 09:06:25 »
probeer eens: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia
via de ouderwetse methode in edgy. ik neem aan de restr.drivers manager faalt.(?)
de kaart zou het uitstekende moeten doen.....
legacy moet eraf! glx/ glx-new zou het moeten doen in combinatie met de restricted modules. niet glx en glx-new beiden installeren.......(per ongeluk, zie de synaptic wat er allemaal geinstalleerd is.)

komt hier op neer:
restricted modules: sudo apt-get install linux-restricted-modules-`uname -r`
( uname-r in de terminal geeft je kernel aan)

sudo apt-get install nvidia-glx
daarna:
sudo nvidia-xconfig
en herstarten./rebooten!

Nizzle

  • Gast
nvidia drivers geactiveerd met GLX.. HOE!?
« Reactie #2 Gepost op: 2007/05/23, 14:38:08 »
hmm die sudo nvidia-xonfig nog niet geprobeerd..
hopelijk maakt dat verschil.. :P

heb alleen de glx-new geinstalleerd en de restricted module is al goeie versie

zal die xconfig ff checke.. heb toch een backup van de xorg.conf nu :P

Nizzle

  • Gast
nvidia drivers geactiveerd met GLX.. HOE!?
« Reactie #3 Gepost op: 2007/05/23, 14:51:49 »
zwaar deprimerend :(
dat ding veranderd de "nv" weer in "nvidia" en voor de rest verplaatst het alleen een paar dingen..

kreeg dus weer de prachtige strepen overal enzo
heb "nvidia" terug veranderd in "nv" en heb nu weer beeld maar nog steeds geen GLX toestand :(

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
nvidia drivers geactiveerd met GLX.. HOE!?
« Reactie #4 Gepost op: 2007/05/23, 15:06:36 »
"nv" is dan ook de open source driver.
GLX is dan niet mogelijk volgens mij.

Heb je trouwens al een keer geprobeerd om de drivers van de nvidia site te downloaden?
Als dat eerder fout ging, is het mogelijk dat die drivers en die van Ubuntu elkaar in de weg zitten.

Geen idee of je er iets aan hebt, maar hier is mijn xorg.conf
Ik heb een XFX Geforce 6600 GT, en die werkt zonder problemen met de nvidia-glx-new drivers.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Nov  1 19:47:17 PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
#   InputDevice    "stylus" "SendCoreEvents"
#   InputDevice    "cursor" "SendCoreEvents"
#   InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
    FontPath        "/usr/share/X11/fonts/misc"
    FontPath        "/usr/share/X11/fonts/cyrillic"
    FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/X11/fonts/Type1"
    FontPath        "/usr/share/X11/fonts/100dpi"
    FontPath        "/usr/share/X11/fonts/75dpi"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "i2c"
    Load           "bitmap"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "type1"
    Load           "vbe"
    Load   "dbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
    Option         "XkbVariant" "intl"
    Option         "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option   "Buttons" "7"
    Option         "ButtonMapping" "1 2 3 6 7"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "true"
EndSection

#Section "InputDevice"
#
#                                                      # /dev/input/event
#                                                      # for USB
#    Identifier     "stylus"
#    Driver         "wacom"
#    Option         "Device" "/dev/wacom"          # Change to
#    Option         "Type" "stylus"
#    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
#EndSection

#Section "InputDevice"
#
#                                                      # /dev/input/event
#                                                      # for USB
#    Identifier     "eraser"
#    Driver         "wacom"
#    Option         "Device" "/dev/wacom"          # Change to
#    Option         "Type" "eraser"
#    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
#EndSection

#Section "InputDevice"
#
#                                                      # /dev/input/event
#                                                      # for USB
#    Identifier     "cursor"
#    Driver         "wacom"
#    Option         "Device" "/dev/wacom"          # Change to
#    Option         "Type" "cursor"
#    Option         "ForceDevice" "ISDV4"               # Tablet PC ONLY
#EndSection

Section "Monitor"
    Identifier     "B101920"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "NVIDIA Corporation NV43 [GeForce 6600 GT]"
    Driver         "nvidia"
    Option         "NoLogo"
    Option   "Coolbits"   "1"  ### enables complete nvidia-settings
    Option         "TripleBuffer" "true"
    Option   "DPI" "96 x 96"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV43 [GeForce 6600 GT]"
    Monitor        "B101920"
    DefaultDepth    24
    Option         "AddARGBVisuals" "True"
    Option         "AddARGBGLXVisuals" "True"
##    Option         "DynamicTwinView" "FALSE" ## http://forum.ubuntu-nl.org/topic/9792  ## disabled vanwege errors in nvidia-settings

    SubSection     "Display"
        Depth       1
        Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

Nizzle

  • Gast
nvidia drivers geactiveerd met GLX.. HOE!?
« Reactie #5 Gepost op: 2007/05/23, 15:09:44 »
heb wel iets in je config gezien wat ik niet heb.. maar weer ff proberen dan
als dit ook niet werkt ga ik zoeken naar die nvidia site denk ik :(

Nizzle

  • Gast
nvidia drivers geactiveerd met GLX.. HOE!?
« Reactie #6 Gepost op: 2007/05/23, 16:03:57 »
en dat werkte dus ook al niet :(
word moe van drivers :(

Nizzle

  • Gast
nvidia drivers geactiveerd met GLX.. HOE!?
« Reactie #7 Gepost op: 2007/05/23, 16:51:18 »
http://www.nvnews.net/vbulletin/showthread.php?t=92011

beetje slecht engels in de titel maar nu is ff kijken of er daar een nerd is die mijn held kan zijn :P