Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Windows 10 niet in Grub  (gelezen 263 keer)

Offline h2o

  • Lid
  • Steunpunt: Nee
Windows 10 niet in Grub
« Gepost op: 2020/11/14, 21:01:21 »
Op een van mijn Debian laptops heb ik een wat ingewikkeld probleem.
Ik heb twee SSD schijven.
SSD 1 (Sandisk), moet GPT ingeschakeld om Debian werkend te krijgen. Vier partities waarvan de eerste FAT32 gekoppeld aan /boot/efi. Daarin staat een Debian directory. Deze FAT32 heeft de volgende vlaggen: Boot, esp en legacy_boot
SSD 2 (Kingston) MSDOS ingeschakeld met twee partities, de tweede is NTFS en hierop staat Windows 10.

Zowel Debian als Windows 10 werken uitstekend en geen problemen. Het probleem is eigenlijk alleen dat Windows 10 alleen kan worden opgestart als ik de [F9] toets indruk bij het opstarten en dan de Kingston SSD activeer om op te starten. Met het commando sudo update-grub krijg ik Windows er niet bij.

Citaat
sudo update-grub
Aanmaken van GRUB-configuratiebestand...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Linux-image gevonden: /boot/vmlinuz-4.19.0-12-amd64
Initiële RAM-schijf-image gevonden: /boot/initrd.img-4.19.0-12-amd64
Linux-image gevonden: /boot/vmlinuz-4.19.0-11-amd64
Initiële RAM-schijf-image gevonden: /boot/initrd.img-4.19.0-11-amd64
Adding boot menu entry for EFI firmware configuration
voltooid

Met het installeren van Windows 10 kreeg ik op de Sandisk SSD de melding dat dit niet op een GPT ingeschakelde schijf kon worden geïnstalleerd, vandaar dat Windows 10 op de Kingston SSD staat.

Nadere informatie: Ik heb ik het BIOS legacy modus aangezet. Dan nog zie ik daar de UEFI staan waarbij alleen de Sandisk SSD staat vermeld, bij het Legacy deel staan beide SSD vermeld.

Het zou erg handig zijn dat in Grub ook Windows 10 erbij zou staan. Wie kan mij hierbij helpen?
« Laatst bewerkt op: 2020/11/14, 21:10:35 door h2o »
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Windows 10 niet in Grub
« Reactie #1 Gepost op: 2020/11/16, 10:36:14 »
Niemand? Heeft het soms te maken met een niet-bestaande ingang in /boot/efi?
Zo ja, hoe maak je dat aan voor Windows 10?
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Windows 10 niet in Grub
« Reactie #2 Gepost op: 2020/11/16, 12:39:08 »
Volgens mij was hier laatst op het forum ook zoiets. Meen dat er toen in de BIOS iets tijdelijks was aangepast zodat grub de windows kon vinden ...  AHCI ?

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Windows 10 niet in Grub
« Reactie #3 Gepost op: 2020/11/16, 15:17:09 »
Die AHCI optie kan ik in mijn BIOS niet vinden. Wat ik wel kan vinden bij UEFI bootorder is dat daar Debian (Sandisk xxx) staat. Iets zegt mij dat dus die EFI (FAT32) partitie wordt uitgelezen/gebruikt? Daar staat Debian namelijk in en Windows niet.
Lecacy geeft beide SSD te zien en daar kan ik de Kingston SSD selecteren en opstarten.
Voor mij is EFI/UEFI allemaal nog onbekend gebied.

Toevoeging, ik heb Windows 10 er later op gezet, Debian was al een anderhalf jaar werkzaam.
« Laatst bewerkt op: 2020/11/16, 15:18:41 door h2o »
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable