Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: aan/uit knop voor draadloos laten werken onder ubuntu  (gelezen 13346 keer)

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Gepost op: 2007/05/21, 22:21:44 »
Even aansluiten bij een lange rij draadloos-netwerk-problemen...

Ik ben een absolute leek, op basis van andere vragen heb ik dit al eens ingevoerd (maar begrijp weinig van wat ik hier nu ook mee ben):

LSPCI

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

IFCONFIG

eth0      Link encap:Ethernet  HWaddr 00:0A:E4:B9:C0:29  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18

eth1      Link encap:Ethernet  HWaddr 00:16:6F:AB:26:18  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:19 Base address:0xc000 Memory:b8000000-b8000fff

eth0:avah Link encap:Ethernet  HWaddr 00:0A:E4:B9:C0:29  
          inet addr:169.254.7.203  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:18

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:82 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6276 (6.1 KiB)  TX bytes:6276 (6.1 KiB)

IWCONFIG

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      radio off  ESSID:""  
          Mode:Managed  Channel:0  Access Point: Not-Associated  
          Bit Rate:0 kb/s   Tx-Power=off   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Als ik het goed begrijp, heb ik een intel draadloze kaart en zou ik dus geen problemen mogen hebben, maar het wil toch niet lukken:
* met het icoon in de taakbalk zie ik geen draadloze netwerken
* network manager lukt ook niet (noch in roaming mode, noch door specifieke naam en zo te geven)
* verbinding lukt ook niet als ik de beveiliging van het netwerk uitzet (mét de kabel lukt het wel, en in windows ook draadloos).
* Ik zie ook geen andere draadloze netwerken, terwijl ik in windows meestal een drietal netwerken van buren zie.
* vanavond nog alle updates geïnstalleerd omdat iemand hier ergens beweerde dat de draadloos-problemen opgelost zouden moeten zijn, maar ook dat hielp niet...

Ziet iemand licht in de duisternis?
alvast bedankt,
Jos

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #1 Gepost op: 2007/05/22, 21:54:27 »
Na nog een hoop zoeken en lezen, vermoed ik dat het onder andere te maken heeft met de knop die ik heb om draadloos netwerk aan en uit te zetten (medion laptop): blijkbaar wijst die "radio off" erop dat die knop uit staat. In windows staat die sinds een paar weken uit als ik opstart (moet dus altijd manueel aanzetten), misschien is dit in linux ook zo?
Probleem is dat er op de laptop geen lichtje gaat branden als er een verbinding is, in windows krijg ik op het scherm een mededeling "wireless button status", maar onder ubuntu zie ik niet of de boel aan of uit staat

Hier
http://forum.ubuntu-nl.org/topic/2255
heeft iemand een gelijkaardig probleem, ook met medion, en hier
http://forum.ubuntu-nl.org/topic/1537
geeft iemand een oplossing, maar de website waarnaar hij verwijst, bestaat niet langer. Het komt er blijkbaar op neer de acerhk drivers te vinden, maar waar vind ik die nu weer...?

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #2 Gepost op: 2007/05/25, 15:53:55 »
Ok, dat zal ik eens proberen, bedankt!

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #3 Gepost op: 2007/05/25, 15:55:52 »
Oei, ik vergis mij; ik dacht even dat iemand iets zei tegen mij :) :P

Offline Rulus

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #4 Gepost op: 2007/05/25, 16:08:56 »
Probeer eens in je /etc/modprobe.d/options een optie mee te geven aan de driver voor je draadloze kaart. Ik heb de mijne ook zo werkend gekregen, wat meer info in deze blogpost.

Offline vanadium

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #5 Gepost op: 2007/05/25, 18:37:51 »
Voor mij is draadloos (met WEP) nooit een probleem geweest, integendeel, het gaat stukken beter en stabieler dan met Windows. Wellicht is het ook een Intel:

"03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)"

Heb je al geprobeerd om in /etc/network/interfaces enkel auto lo te laten staan? Mijn ziet er als volgt uit

auto lo
iface lo inet loopback
Dan heropstarten, en dan is het volledig aan de network manager. Gisteren heb ik nog al wachten in een auto in de stad op een netwerk van een vriendelijke buur zitten surfen.

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #6 Gepost op: 2007/05/27, 22:44:41 »
Rulus,
ik heb intussen gemerkt dat het lampje voor draadloze verbinding wél brandt als ik de computer in ubuntu opstart, dus daar zal het probleem niet zitten.

Vanadium,
Bedoel je dat je in dat bestand alles wist wat na de code komt  die je in je bericht zette (een lijn of vijf)? Dat heb ik daarnet geprobeerd, maar nog steeds geen draadloze verbinding...

Bedankt voor de tips alleszins, maar hulp blijft dus welkom!

Jos

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #7 Gepost op: 2007/06/01, 16:47:25 »
Zelfs nu nog! (die hulp die welkom blijft)

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #8 Gepost op: 2007/06/15, 11:24:43 »
Aaaaaaaaaaaaaaaaaaaaaaaaaaaarrgggggggggggggghhhhhhhh!!!!!!

Echt niemand die kan helpen? Zonder die draadloos internet heb ik weinig (niks) aan ubuntu en blijft het windows...

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #9 Gepost op: 2007/06/15, 12:30:10 »
Citaat van: oemoeta
Aaaaaaaaaaaaaaaaaaaaaaaaaaaarrgggggggggggggghhhhhhhh!!!!!!

Echt niemand die kan helpen? Zonder die draadloos internet heb ik weinig (niks) aan ubuntu en blijft het windows...
Blijkbaar is er geen oplossing of kan die (nu) niet gevonden worden, dan is de enige mogelijkheid acceptatie en berusting.

Voordat je naar Windows teruggaat, zou je misschien zou je eens een los pcmcia-kaartje kunnen uitproberen.

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #10 Gepost op: 2007/06/15, 12:47:46 »
Citaat van: vanadium
Dan heropstarten, en dan is het volledig aan de network manager. Gisteren heb ik nog al wachten in een auto in de stad op een netwerk van een vriendelijke buur zitten surfen.
Daarvoor kan je gearresteerd worden blijkbaar. Stond onlangs in de krant :P

Je hebt, eerst en vooral, precies dezelfde kaart als ik, oemoeta. Die werkt out of the box bij mij zonder dat ik iets moest doen.
Het is vreemd dat jouw lampje wel gaat branden, terwijl dat van mij het niet doet onder Linux. De kaart werkt echter wel gewoon, ook al geeft het lampje aan dat de netwerkkaart uitgeschakeld is.
Dat is geen probleem waar jij je zorgen over dient te maken, echter, dat is gewoon een verschil in de architectuur van onze laptops.

Ik neem trouwens al aan dat jij Ubuntu 7.04 Feisty Fawn gebruikt? Die is in elk geval het vriendelijkst voor draadloze netwerken.

Wat je allemaal kan doen:
Geef het volgende in een terminal in:
sudo iwlist eth1 scanDat zou een lijst moeten geven van alle draadloze netwerken in de buurt.
Zo niet, dan staat je kaart inderdaad niet aan, of ze werkt niet.
Ik denk dat ze wel zal werken, aangezien ze in Windows blijkbaar toch ook naar behoren werkt?
Als ze niet aanstaat, druk dan op die knop (of verschuif die schakelaar, wat voor type het ook is) en probeer het nogmaals.
Je zei dat het lichtje brandde als je Ubuntu opstartte, maar het is altijd het proberen waard. (gaat het lampje trouwens uit als je drukt terwijl het brand?)
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #11 Gepost op: 2007/06/16, 21:31:10 »
Citaat van: markba
Blijkbaar is er geen oplossing of kan die (nu) niet gevonden worden, dan is de enige mogelijkheid acceptatie en berusting.
Bedankt voor de tip, maar ik probeer het voorlopig op een iets minder boeddhistische manier op te lossen...

Bail hope,

Ik gebruik idd feisty fawn

"sudo iwlist eth1 scan" geeft als resultaat 'no scanning results'. Lichtje van draadloze netwerkkaart brandt eerst en gaat uit als ik de knop indruk, maar gaat dan niet meer aan als ik opnieuw druk. Alleszins, lichtje brandend of niet, ik krijg twee keer 'no scanning results'. In windows vind ik altijd minstens drie netwerken, dus de kaart werkt duidelijk niet.

Maar wat nu? Ik heb al eens geprobeerd ndiswrapper te gebruiken, maar 't is mij niet duidelijk waar ik de driver voor de netwerkkaart moet vinden...

belg

  • Gast
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #12 Gepost op: 2007/06/19, 23:45:08 »
http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,list_g-l/

In deze lijst staat je chipset vermeld: de intel 2200bg...hij is te draaien met ndiswrapper.

Is best een klus voor een nieuwe ubuntu-gebruiker, maar kijk ook eens op www.ubuntuforums.org. Er zijn nogal wat howto's te vinden daar.

Offline Wasda

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #13 Gepost op: 2007/06/20, 00:16:31 »
Citaat van: oemoeta
IWCONFIG

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      radio off  ESSID:""  
          Mode:Managed  Channel:0  Access Point: Not-Associated  
          Bit Rate:0 kb/s   Tx-Power=off   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Bij eth1 staat radio off.
Is het mogelijk om daar on van te maken?
Ik ben ook maar net begonnen met ubuntu en ik heb de zelfde wireless.
Hier werkt deze out off the box

david@dell-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
david@dell-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11g  ESSID:"xxxxxxx"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: xx:xx:xx:xx:xx:xx  
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=76/100  Signal level=-53 dBm  Noise level=-88 dBm
          Rx invalid nwid:0  Rx invalid crypt:16  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:6

david@dell-laptop:~$

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #14 Gepost op: 2007/06/21, 16:00:30 »
Citaat van: belg
http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,list_g-l/

In deze lijst staat je chipset vermeld: de intel 2200bg...hij is te draaien met ndiswrapper.

Is best een klus voor een nieuwe ubuntu-gebruiker, maar kijk ook eens op www.ubuntuforums.org. Er zijn nogal wat howto's te vinden daar.
Misschien een stomme vraag, maar wat moet ik doen met die lijst? Als ik de link onder de juiste kaart aanklik, krijg ik bericht "wachttijd voor de verbinding is verstreken". Als ik de link rechtstreeks probeer te downloaden(koppeling opslaan als), krijg ik wel een opgeslagen exe-bestand (in het download-overzicht), maar dat kan ik niet openen en vind ik het met verkenner ook niet terug waar het zou moeten staan...

Wasda,
"radio off" is niks aan te veranderen, led aan of uit, alle tips die hierboven staan ook al eens geprobeerd.

Raar dat ik blijkbaar een kaart heb die bij anderen zonder probleem lijkt te werken... Zou het helpen om heel de boel gewoon eens opnieuw te installeren? Of zijn er buiten de netwerkkaart nog onderdelen die ervoor kunnen zorgen dat de boel niet lukt? Ik lees hier in een andere vraag dat vlerknozem, ook met een medion, ook met dit probleem zit...

Offline Wasda

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #15 Gepost op: 2007/06/21, 22:56:18 »
Ik vond deze link via google.

http://www.univ-orleans.fr/mapmo/membres/garet/linux/medion/Debian_GNU_Linux-MD95345.html

misschien dat je hier wat aan hebt?

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #16 Gepost op: 2007/06/24, 22:34:08 »
Wasda,
je zet me alleszins op het goede spoor, maar de combinatie van weinig kennis van informatica, van Engels en van linux zorgt ervoor dat ik er echt niet wijs uit raak.

Wat ik gevonden heb:
er is een linux-driver voor mijn netwerkkaart, via  http://ipw2200.sourceforge.net/firmware.php & http://www.intel.com/support/wireless/wlan/sb/cs-010623.htm vind ik in totaal drie bestanden die ik nodig heb

ieee80211-1.2.17.tar.gz
ipw2200-1.2.0.tgz
ipw2200-fw-3.0.tgz

Ik heb begrepen dat dit gecomprimeerde bestanden zijn, die ik dan kan uitpakken,maar dan...


Het readme-bestand bij de download van de driver zegt dit:

Installing/updating Intel(R) PRO/Wireless driver for Linux
- Extract the archive file: tar xzvf ipw2200_linux_1_2_0.tgz
- To install the driver the following is needed:
1. Linux with a 2.6.8+ kernel. See README.ipw2200 for information on
specific options required to be enabled in the kernel.
2. Wireless Extensions (v16) and Tools (v27-pre23) if not included in
your distribution
3. The driver (ipw2200-1.2.0.tgz)
4. The binary firmware image (ipw2200-fw-3.0.tgz)
5. For instructions on how to build and use the driver, please see
the INSTALL document in the ./intel_ipw2200_120/ directory.

Waar moet ik die bestanden uitpakken? Die opdracht "tar xzvf ipw2200_linux_1_2_0.tgz" lukt niet (wat betekent die xzvf trouwens?)
En die wireless extensions and tools waarvan ze spreken, mag ik ervan uitgaan dat die standaard geïnstalleerd zijn, of moet ik die ook gaan zoeken?

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #17 Gepost op: 2007/06/25, 22:17:44 »
Hij doet het, hij doet het! Eerste bericht via draadloze verbinding onder ubuntu, hoera!
Morgen wat uitleg over hoe het gelukt is...

Offline oemoeta

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #18 Gepost op: 2007/06/26, 15:21:24 »
Ok, probleem was dus niet de netwerkkaart (intel pro/wireless 2200BG) want die werkt, zoals verschillende anderen mij al vertelden, out of the box, maar wel de knop waarmee ik de verbinding aan en uit kan zetten, die onder linux niet werkt (medion laptop, aka een laptop van "den aldi")

De redding is er gekomen dankzij deze handleiding:
http://www.student.dtu.dk/~s971652/ipw2200.shtml

Ik heb alles gedaan zoals gezegd in de handleiding, en wonder boven wonder: alles lukte!
Hier nog een beetje extra uitleg (nummering stemt overeen met die van de handleiding, dit is mijn commentaar en ervaring dus natuurlijk kan dit verschillen bij een andere pc):

1. je krijgt enkele mededelingen, onder andere dat dit extra ruimte inneemt op je pc: altijd ja antwoorden

2. ik kreeg enkele foutmeldingen (bestanden die niet gevonden of geïnstalleerd werden) maar heb die genegeerd

3. de verwijzing naar de driver klopt niet (zoals de meeste links die ik hiervoor gevonden heb), een link die wel nog klopt is deze hier:
http://gentoo-portage.com/app-laptop/acerhk
De versie die je dan hebt eindigt op 35 ipv 22, dus moet je dat natuurlijk overal aanpassen

4. ik ben niet zeker, maar ik dacht dat het uitpakken van de driver via dit commando mislukte, maar ik heb het bestand gewoon onder desktop gezet, daar uitgepakt door rechtsklikken en "extract here", en dan lukte het (dit alles komt dus in de plaats van de eerste opdracht, de volgende lijnen lukken weer wel

8. eth1 stond bij mij niet bij de interfaces; het wireless-tools bestand was dan ook eerst leeg. Ik heb dan het interfaces-bestand geopen, bij mij zag dat bestand er anders uit, maar ik heb gewoon de laatste twee lijnen overgetypt en het bestand zo opgeslaan. Dan teruggegaan naar wireless-tools en daar het commando toegevoegd, en voil� .

Ik hoop dat ik hiermee anderen ook wat vooruit kan helpen.

Bedankt aan al wie mee gezocht heeft naar een oplossing, ik kan eindelijk de rest van ubuntu ontdekken!

ikkeson

  • Gast
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #19 Gepost op: 2008/02/15, 22:23:46 »
Citaat van: oemoeta
Ok, probleem was dus niet de netwerkkaart (intel pro/wireless 2200BG) want die werkt, zoals verschillende anderen mij al vertelden, out of the box, maar wel de knop waarmee ik de verbinding aan en uit kan zetten, die onder linux niet werkt (medion laptop, aka een laptop van "den aldi")

De redding is er gekomen dankzij deze handleiding:
http://www.student.dtu.dk/~s971652/ipw2200.shtml

Ik heb alles gedaan zoals gezegd in de handleiding, en wonder boven wonder: alles lukte!
Hier nog een beetje extra uitleg (nummering stemt overeen met die van de handleiding, dit is mijn commentaar en ervaring dus natuurlijk kan dit verschillen bij een andere pc):

1. je krijgt enkele mededelingen, onder andere dat dit extra ruimte inneemt op je pc: altijd ja antwoorden

2. ik kreeg enkele foutmeldingen (bestanden die niet gevonden of geïnstalleerd werden) maar heb die genegeerd

3. de verwijzing naar de driver klopt niet (zoals de meeste links die ik hiervoor gevonden heb), een link die wel nog klopt is deze hier:
http://gentoo-portage.com/app-laptop/acerhk
De versie die je dan hebt eindigt op 35 ipv 22, dus moet je dat natuurlijk overal aanpassen

4. ik ben niet zeker, maar ik dacht dat het uitpakken van de driver via dit commando mislukte, maar ik heb het bestand gewoon onder desktop gezet, daar uitgepakt door rechtsklikken en "extract here", en dan lukte het (dit alles komt dus in de plaats van de eerste opdracht, de volgende lijnen lukken weer wel

8. eth1 stond bij mij niet bij de interfaces; het wireless-tools bestand was dan ook eerst leeg. Ik heb dan het interfaces-bestand geopen, bij mij zag dat bestand er anders uit, maar ik heb gewoon de laatste twee lijnen overgetypt en het bestand zo opgeslaan. Dan teruggegaan naar wireless-tools en daar het commando toegevoegd, en voil� .

Ik hoop dat ik hiermee anderen ook wat vooruit kan helpen.

Bedankt aan al wie mee gezocht heeft naar een oplossing, ik kan eindelijk de rest van ubuntu ontdekken!
Weet iemand waar ik die link met de manual kan vinden. De link in dit bericht is namelijk dood http://www.student.dtu.dk/~s971652/ipw2200.shtml

Offline Dirk Tas

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #20 Gepost op: 2008/02/17, 14:48:25 »
Citaat van: ikkeson
Weet iemand waar ik die link met de manual kan vinden. De link in dit bericht is namelijk dood http://www.student.dtu.dk/~s971652/ipw2200.shtml
bij het openen van de link kreeg ik het volgende voorgeschoteld, ik vermoed dat dit een archief webpagina is
http://web.archive.org/web/19960101-re_/http://www.student.dtu.dk/~s971652/ipw2200.shtml
Ubuntu User #14670

ikkeson

  • Gast
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #21 Gepost op: 2008/02/18, 11:09:18 »
Citaat van: Maddy67
Citaat van: ikkeson
Weet iemand waar ik die link met de manual kan vinden. De link in dit bericht is namelijk dood http://www.student.dtu.dk/~s971652/ipw2200.shtml
bij het openen van de link kreeg ik het volgende voorgeschoteld, ik vermoed dat dit een archief webpagina is
http://web.archive.org/web/19960101-re_/http://www.student.dtu.dk/~s971652/ipw2200.shtml
Bedankt

Ga deze avond weer eens aan de slag om het werkende te krijgen

Ik hou iedereen hier op de hoogte en als het werkt, maak ik wel even een manual voor deze website als dat gewenst is.

Kleine update:

Het werkt niet. Tot aan punt 5 lukt het maar dan gaat er iets mis volgens mij.

For users of version 0.5.22 or newer:
$ sudo modprobe acerhk
$ echo 1 > /proc/driver/acerhk/wirelessled
For users of an older version of acerhk:
$ sudo modprobe acerhk usedritek=1 autowlan=1 force_series=290
$ echo 1 > /proc/driver/acerhk/wirelessled

wat doet deze modprobe eigenlijk? En wat bedoelen ze eigenlijk met die echo?

ikkeson

  • Gast
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #22 Gepost op: 2008/02/21, 14:58:35 »
Heb ondertussen wel een tijdelijke oplossing in de vorm van een pcmcia kaartje van cisco. Wat een luxe!!! Insteken en het werkt!!! Geen vraag naar drivers maar onmiddelijk vraag naar welk netwerk de verbinding moest gaan. Maar als iemand een oplossing heeft voor mijn intern Wlan probleem hoor ik het graag.

samurijder

  • Gast
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #23 Gepost op: 2008/05/06, 17:29:40 »
Helaas geeft ook mijn laptop 'niet thuis'  als ik op de draadloos aan knop klik. Bij het installeren van de driver voor de knop zoals hier boven beschreven krijg de volgende melding:

Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd        
Reading state information... Klaar
Pakket linux-headers-2.6.22-14-generic is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket linux-headers-2.6.22-14-generic heeft geen installeerbare kandidaat

Als ik het -generic deel weglaat krijg ik de zelfde melding, maar dan zonder -generic.

Het gaat hier om een HP DV5000. Zoals al in andere threads is opgemerkt.. Onder de gutsy gibbon deed 'ie het wel, maar na de update naar de ruige reiger niet meer.

Heeft er nog iemand tips?

Offline DivinGGoD

  • Lid
  • Steunpunt: Nee
aan/uit knop voor draadloos laten werken onder ubuntu
« Reactie #24 Gepost op: 2008/05/06, 18:24:00 »
volg gewoon de volgende handleiding:
http://znote4200.linux.dk/

hiermee moet het bijna wel lukken om hem aan de praat te krijgen,
fout is vaak (zelf ook gehad) dat je bij de link in de handleiding niet acerhk 5.22 maar 5.35 krijgt,
dit moet je dus ook aanpassen in je manual,
ik moet echter nog wel elke keer de code ingeven maar dat is net zoveel werk als de knop indrukken om wlan te activeren