Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opstarten vertragen  (gelezen 1046 keer)

Opstarten vertragen
« Gepost op: 2020/07/03, 12:07:39 »
Hallo iedereen,

Bij het aanzetten van mijn tv via een stekkerblok met master/slaves bediening,start mijn raspberry Pi4 4gb met Ubuntu Mate mee op.
De Pi4 is al opgestart vooraleer de tv de hdmi aansluiting ziet, tot gevolg dat de Pi niet zichtbaar is in een externe ingang.
Met de Debian versie was dat niet het geval, blijkbaar start de Ubuntu sneller op.
Hoe kan ik het booten van  Ubuntu vertragen zodat mijn tv de externe aansluiting ziet?
Alvast bedankt.

Bart

Joshua Orbit

  • Gast
Re: Opstarten vertragen
« Reactie #1 Gepost op: 2020/07/03, 12:16:37 »
Ik zou in dit geval GRUB een langere time-out geven . De boot zelf van Ubuntu is nu eenmaal supersnel.

Aanpak:
sudo nano /etc/default/grub

navigeer met de pijltjestoetsen naar grub time out en zet deze op een waarde naar wens (5 kan al goed uitpakken, maar misschien is ook 10 of meer noodzakelijk in je project).

ctrl + o (niet nul maar oh)  (opslaan + enter ) / ctrl + x (afsluiten) en dan in de terminal sudo update-grub geven . Na de bewerking sudo reboot en check even of dat goed voor je uitpakt. Telkens je de waarde aanpast moet je update-grub ook doen (dubbele actie dus)

Bij opstart vertraagt nu Ubuntu met je opgegeven waarde (seconden) Grub, en start dan automatisch door.
« Laatst bewerkt op: 2020/07/03, 12:19:17 door Joshua Orbit »

Re: Opstarten vertragen
« Reactie #2 Gepost op: 2020/07/03, 21:35:24 »
Dag Joshua,

Bedankt voor het snelle antwoord.
Als ik het commando invoer in de terminal, is  GNU nano 4.8   /etc/default/grub leeg...
In location /etc/default  vind ik flash_kernel,gdomap,hddtemp en im-config, maar geen grub.
Ik ben een beginner, maar heb ervaring met de terminal.
Wat is er verkeerd in mijn aanpak?

Bart
« Laatst bewerkt op: 2020/07/03, 22:05:41 door bartcrimson »

Joshua Orbit

  • Gast
Re: Opstarten vertragen
« Reactie #3 Gepost op: 2020/07/04, 07:03:02 »
Helaas heb ik zelf geen ervaring met een rasp Pi ..... Misschien dat iemand anders er meer van kent ... Ik zou echt niet weten waarom er geen Grub is op je installatie.

Ik dacht dat Grub overal op installeerde maar blijkbaar ben ik dan mis.

Joshua Orbit

  • Gast
Re: Opstarten vertragen
« Reactie #4 Gepost op: 2020/07/05, 13:19:03 »
https://raspberrypi.stackexchange.com/questions/99473/why-is-grub-incompatible-with-the-raspberry-pi-answer-its-not

Je zou wel degelijk GRUB2 kunnen installeren  op de Rasp . In de link is een antwoord met een doorlinken naar de howto.
Je dient enkel met Gparted de EFI bootloader te wissen die Grub mee installeert.

Eenmaal Grub op je Rasp kan je met de bovenstaande truc GRUB een 5 a xxx seconden laten wachten alvorens door te booten.

Wat misschien nóg eenvoudiger is, is een schakelklok (zo een digitaal spul met stopcontact) gebruiken op je power supply van je Rasp en die een delay laten veroorzaken wanneer je 'aan ' klikt . Klinkt ingewikkelder dan het is hoor, maar dat zou de gemakkelijkste oplossing misschien wel zijn om je Rasp te vertragen met de boot van Ubuntu Mate.

Ik zie aan de GRUB install wel een donker kantje hangen ...... iets zegt me dat het niet zo makkelijk is als beschreven. Enfin, het proberen waard natuurlijk als de schakelklok geen optie is .


Offline hkevers

  • Lid
  • Steunpunt: Nee
Re: Opstarten vertragen
« Reactie #6 Gepost op: 2020/07/10, 17:04:30 »
Dit kwam ik toevallig tegen in de Linux tips.

https://makkelijkelinuxtips.blogspot.com/p/windows-eerst.html#ID2


Re: Opstarten vertragen
« Reactie #7 Gepost op: 2020/07/10, 19:47:17 »
Het installeren van grub2 is geen probleem,wel het verwijderen van de EFI flag,het ziet er allemaal nogal complex uit.
Met Gparted is het verwijderen van de flag niet mogelijk,daar in de bootsector geen specifieke onderdelen zoals efi bootloader staan.
Ik had gehoopt op een gemakkelijkere manier, om eventueel in een configuratie een bepaalde stoptijd in te voegen....
 

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Opstarten vertragen
« Reactie #8 Gepost op: 2020/07/11, 18:08:12 »
Volgens mij is het volgende wat je zoekt
https://blog.mivia.dk/solved-hdmi-working-raspberry-pi/
Ik denk dat je de optie force hdmi hotplug moet activeren.

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Opstarten vertragen
« Reactie #9 Gepost op: 2020/07/11, 20:46:17 »
Volgens mij is het volgende wat je zoekt
https://blog.mivia.dk/solved-hdmi-working-raspberry-pi/
Ik denk dat je de optie force hdmi hotplug moet activeren.
Op dit forum zie ik regelmatig opstartproblemen met een hdmi poort langskomen. Is dit voor alle distributies met  hdmi opstartproblemen van toepassing, of alleen voor een Raspberry pi?
« Laatst bewerkt op: 2020/07/11, 21:38:23 door h2o »
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable

Re: Opstarten vertragen
« Reactie #10 Gepost op: 2020/08/02, 18:38:25 »
Een Raspberry die met Ubuntu Mate 20.04 draait, is blijkbaar geen gewone Ubuntu.
-Heeft geen grub.
-Heeft geen config.text zoals gebruikelijk.
Wel een config met 9401 regels met allemaal conf ............
Met Debian heb je dit probleem niet, maar ik ben zo gehecht aan die Ubuntu Mate versie ^-^
Mischien heeft er toch nog iemand een oplossing.

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Opstarten vertragen
« Reactie #11 Gepost op: 2020/08/04, 17:32:35 »
Misschien toch eens de link lezen die ik jouw hebt gestuurd, het beschrijft exact het probleem dat je ondervind volgens mij.

Re: Opstarten vertragen
« Reactie #12 Gepost op: 2020/08/09, 11:30:27 »
Dag Siegi

Ik heb wel degelijk de link gelezen, maar het valt mij op dat u mijn vorig antwoord niet volledig hebt gelezen....
Er bestaat geen config.txt in mijn boot map, dus kan ik uw voorstel niet toepassen.
Mischien hebben wij elkaar niet goed begrepen.
In mijn bijlage zie je de boot folder, waarin er nergens een config.txt staat.
Iemand die een oplossing weet?

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Opstarten vertragen
« Reactie #13 Gepost op: 2020/08/09, 18:01:03 »
Sorry, maar dit was voor mij niet duidelijk je praat over twee dingen tegelijk grub en de file die ik aanhaal.

Blijkbaar is die file in ubuntu mate ergens anders verstopt. https://www.raspberrypi.org/forums/viewtopic.php?t=261726
 /boot/firmware/usercfg.txt

Wat 30 sec google niet allemaal kan doen :)

Re: Opstarten vertragen
« Reactie #14 Gepost op: 2020/08/10, 18:22:24 »
Dag Siegi,

Het werkt.....
Heb de configuratie in usercfg.txt bij gevoegd.
Mijn tv ziet nu inderdaad de Raspberry Pi4 opstarten, maar de resolutie is 640x480 in plaats van 1824x984
Ik kan deze niet aanpassen in "Monitor Preferences"
Hoe kan ik de resolutie in usercfg.txt aanpassen?
Graag uw mening en alvast bedankt.

Joshua Orbit

  • Gast
Re: Opstarten vertragen //// Monitor aanpassing
« Reactie #15 Gepost op: 2020/08/12, 09:29:53 »
Open terug die file en voeg daar de volgende regel aan toe:

disable_overscan = 1

opslaan en reboot .

*Normaal gesproken* moet de resolutie nu goed staan van meet af aan.  (Bron ....... veel te veel sites om nog te herinneren waar ik het vandaan heb gehaald in het verleden EDIT: hier is de site met de broninformatie ook gebaseerd op MATE )

Indien het niet het gewenste resultaat weergeeft, vergeet dan niet die regel te verwijderen uit je usercfg.txt  file.

« Laatst bewerkt op: 2020/08/12, 09:35:22 door Joshua Orbit »

Re: Opstarten vertragen
« Reactie #16 Gepost op: 2020/08/13, 14:11:28 »
Dag Joshua,

Heb de link doorgenomen, en uw voorstel toegepast...
Spijtig genoeg val ik terug in de zelfde resolutie 640x480.
Het is geen overscan waarbij je een zwarte rand krijgt, maar een scherm gezien door een uilenbril.
Bestaat er geen commando zoals HDMI_resolutie_1824x984 of zoiets?
Alvast bedankt

Joshua Orbit

  • Gast
Re: Opstarten vertragen
« Reactie #17 Gepost op: 2020/08/13, 14:44:45 »
hoi Bart,

het was het proberen waard.

AskUbuntu kreeg een identieke vraag en blijkbaar is het 2e antwoord ook meteen de oplossing blijkbaar: de eerste oplossing hadden we al geprobeerd .
Dus de 2e oplossing eens goed lezen ;

https://askubuntu.com/questions/665957/ubuntu-mate-for-rpi2-default-resolution-cant-be-changed

Re: Opstarten vertragen
« Reactie #18 Gepost op: 2020/08/13, 19:40:37 »
Dag Joshua,

Ik veronderstel dat je het commando sudo raspi-config bedoeld.
Er bestaat geen rasp-config in de terminal.
Maar ik heb uw link eens goed doorgenomen, en heb ergens een voorbeeld gevonden van een HDMI scan, waarin er verschillende HDMI groepen en modes worden weergegeven.
Dus, ik dacht wie weet....
Het werkt......

hdmi_force_hotplug=1
hdmi_drive=2
config_hdmi_boost=4
disable_overscan=1
hdmi_group=1
hdmi_mode=16

Bedankt voor de moeite.

Bart