Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Na nieuwe installatie problemen met locales  (gelezen 292 keer)

Offline Simux

  • Lid
Na nieuwe installatie problemen met locales
« Gepost op: 2020/06/24, 10:31:17 »
Hallo ik ben nieuw op dit forum, heb er tot nu toe nooit gebruik van hoeven te maken....echter.

Gisteren heb ik ubuntu 20.04 geinstalleerd, alles verliep perfect, maar als ik een sudo apt-get of  sudo apt  uitvoer krijg ik de melding

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "nl_NL.UTF-8",
        LC_ALL = (unset),
        LC_TIME = "nl_NL.UTF-8",
        LC_MONETARY = "nl_NL.UTF-8",
        LC_ADDRESS = "nl_NL.UTF-8",
        LC_TELEPHONE = "nl_NL.UTF-8",
        LC_NAME = "nl_NL.UTF-8",
        LC_MEASUREMENT = "nl_NL.UTF-8",
        LC_IDENTIFICATION = "nl_NL.UTF-8",
        LC_NUMERIC = "nl_NL.UTF-8",
        LC_PAPER = "nl_NL.UTF-8",
        LANG = "en_NL.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


Normaal gesproken is het dan een kwestie van googlen (het wiel is meestal al uitgevonden)  en het probleem oplossen. Maar tot mijn grote verbazing lossen de oplossingen die er geboden worden mijn probleem NIET op.

in deze link word mooi beschreven hoe je dit probleem moet tackelen https://www.cyberciti.biz/faq/perl-warning-setting-locale-failed-in-debian-ubuntu/

echter werkt dit op 1 of andere manier niet.

mijn configuratie:

-Kubuntu 20.04  op een  i7 Laptop  8GB geheugen  1 Terra SSD    Nvidea Quadro grafische kaart, verder geen bijzonderheden.

Mochten jullie meer info nodig hebben geef dit even aan.

Alvast bedankt voor het meedenken.



Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Na nieuwe installatie problemen met locales
« Reactie #1 Gepost op: 2020/06/24, 14:17:33 »
in deze link word mooi beschreven hoe je dit probleem moet tackelen https://www.cyberciti.biz/faq/perl-warning-setting-locale-failed-in-debian-ubuntu/

echter werkt dit op 1 of andere manier niet.

Hallo, welkom hier. Je oplossing is vast nabij!

Werkt niet zeg je, kun je wat specifieker zijn? Heb je deze ingetypt in een terminal?
$ sudo locale-gen nl_NL.UTF-8 UTF-8
En vervolgens die export-opdrachten gegeven?

Offline Simux

  • Lid
Re: Na nieuwe installatie problemen met locales
« Reactie #2 Gepost op: 2020/06/24, 15:56:07 »
in deze link word mooi beschreven hoe je dit probleem moet tackelen https://www.cyberciti.biz/faq/perl-warning-setting-locale-failed-in-debian-ubuntu/

echter werkt dit op 1 of andere manier niet.

Hallo, welkom hier. Je oplossing is vast nabij!

Werkt niet zeg je, kun je wat specifieker zijn? Heb je deze ingetypt in een terminal?
$ sudo locale-gen nl_NL.UTF-8 UTF-8
En vervolgens die export-opdrachten gegeven?
Bedankt voor de verwelkoming :)

Ja, je kunt er eigenlijk niks fouts aan doen, gewoon precies doen wat die  website  uitlegd, dus stap voor stap heb ik die handelingen verricht echter blijf ik die perl  melding krijgen. 


Als ik met de commando  locale wil zien welke instellingen ik hanteer krijg ik het volgende.


mo@mo-CELSIUS-H700:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_NL.UTF-8
LANGUAGE=nl_NL.UTF-8
LC_CTYPE="en_NL.UTF-8"
LC_NUMERIC=nl_NL.UTF-8
LC_TIME=nl_NL.UTF-8
LC_COLLATE="en_NL.UTF-8"
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES="en_NL.UTF-8"
LC_PAPER=nl_NL.UTF-8
LC_NAME=nl_NL.UTF-8
LC_ADDRESS=nl_NL.UTF-8
LC_TELEPHONE=nl_NL.UTF-8
LC_MEASUREMENT=nl_NL.UTF-8
LC_IDENTIFICATION=nl_NL.UTF-8
LC_ALL=



 

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Na nieuwe installatie problemen met locales
« Reactie #3 Gepost op: 2020/06/24, 16:11:10 »
De laatste waarschuwing lijkt me geen probleem; LC-ALL= is bij mij ook leeg.
Bij de eerste twee zie ik bij jou een mengeling van 'en' en 'NL'.
Bij mijn (goed werkende) systeem is de uitvoer consequent 'nl' en 'NL':
ajjp@ajjp-W9x0LU:~$ locale
LANG=nl_NL.UTF-8
LANGUAGE=nl
LC_CTYPE="nl_NL.UTF-8"
LC_NUMERIC="nl_NL.UTF-8"
LC_TIME="nl_NL.UTF-8"
LC_COLLATE="nl_NL.UTF-8"
LC_MONETARY="nl_NL.UTF-8"
LC_MESSAGES="nl_NL.UTF-8"
LC_PAPER="nl_NL.UTF-8"
LC_NAME="nl_NL.UTF-8"
LC_ADDRESS="nl_NL.UTF-8"
LC_TELEPHONE="nl_NL.UTF-8"
LC_MEASUREMENT="nl_NL.UTF-8"
LC_IDENTIFICATION="nl_NL.UTF-8"
LC_ALL=

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Na nieuwe installatie problemen met locales
« Reactie #4 Gepost op: 2020/06/24, 16:22:03 »
Zelf gebruik ik voor dergelijk klusje localepurge. Hiermee kan je alle overbodige taalbestanden opruimen en op laten ruimen bij het upgraden of installeren van programma's.

Hier een Spaanstalige uitleg. Als je het een paar keer bekijkt kun je het wel volgen en begrijpen. En anders is Google Translate je vriend.
https://www.google.nl/url?sa=t&rct=j&q=&esrc=s&source=video&cd=&ved=2ahUKEwj77vDa0ZrqAhWPlqQKHYNhBTIQtwIwAXoECAQQAQ&url=https%3A%2F%2Flinuxforallsite.wordpress.com%2F2017%2F07%2F30%2Feliminar-archivos-de-idiomas-con-localepurge-en-ubuntu-y-derivadas%2F&usg=AOvVaw3Ks7GWzHq6QVJxnuKP3VxJ

Let erop dat je bij het tweede filmpje bij 40 seconden ziet dat het [Si] aangevinkt staat en zo blijft, dat moet dan [no] worden. Op het eerste filmpje is het goed. Deze filmpjes gaan uit van de Spaanse situatie, in dat van jou is dat dan NL.

Mocht je het toch fout hebben ingesteld, dan kun je dat met het commando
sudo dpkg-reconfigure localepurgeweer rechtzetten.
« Laatst bewerkt op: 2020/06/24, 16:25:03 door h2o »
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable

Offline Simux

  • Lid
Re: Na nieuwe installatie problemen met locales
« Reactie #5 Gepost op: 2020/06/25, 14:55:40 »
De laatste waarschuwing lijkt me geen probleem; LC-ALL= is bij mij ook leeg.
Bij de eerste twee zie ik bij jou een mengeling van 'en' en 'NL'.
Bij mijn (goed werkende) systeem is de uitvoer consequent 'nl' en 'NL':
ajjp@ajjp-W9x0LU:~$ locale
LANG=nl_NL.UTF-8
LANGUAGE=nl
LC_CTYPE="nl_NL.UTF-8"
LC_NUMERIC="nl_NL.UTF-8"
LC_TIME="nl_NL.UTF-8"
LC_COLLATE="nl_NL.UTF-8"
LC_MONETARY="nl_NL.UTF-8"
LC_MESSAGES="nl_NL.UTF-8"
LC_PAPER="nl_NL.UTF-8"
LC_NAME="nl_NL.UTF-8"
LC_ADDRESS="nl_NL.UTF-8"
LC_TELEPHONE="nl_NL.UTF-8"
LC_MEASUREMENT="nl_NL.UTF-8"
LC_IDENTIFICATION="nl_NL.UTF-8"
LC_ALL=

Ja ik zag inderdaad  de combinatie en_NL, maar dit is tijdens de installatie meegekomen kennelijk.  Het enige wat ik gekozen heb is Engelse instructie tijdens installatie,  Nederlandse instellingen zoals datum, tijdsaanduiding etc. en een duitstoetsenbord :) en het systeem heeft dat ervan gemaakt.

Offline Simux

  • Lid
Re: Na nieuwe installatie problemen met locales
« Reactie #6 Gepost op: 2020/06/25, 14:56:36 »
Zelf gebruik ik voor dergelijk klusje localepurge. Hiermee kan je alle overbodige taalbestanden opruimen en op laten ruimen bij het upgraden of installeren van programma's.

Hier een Spaanstalige uitleg. Als je het een paar keer bekijkt kun je het wel volgen en begrijpen. En anders is Google Translate je vriend.
https://www.google.nl/url?sa=t&rct=j&q=&esrc=s&source=video&cd=&ved=2ahUKEwj77vDa0ZrqAhWPlqQKHYNhBTIQtwIwAXoECAQQAQ&url=https%3A%2F%2Flinuxforallsite.wordpress.com%2F2017%2F07%2F30%2Feliminar-archivos-de-idiomas-con-localepurge-en-ubuntu-y-derivadas%2F&usg=AOvVaw3Ks7GWzHq6QVJxnuKP3VxJ

Let erop dat je bij het tweede filmpje bij 40 seconden ziet dat het [Si] aangevinkt staat en zo blijft, dat moet dan [no] worden. Op het eerste filmpje is het goed. Deze filmpjes gaan uit van de Spaanse situatie, in dat van jou is dat dan NL.

Mocht je het toch fout hebben ingesteld, dan kun je dat met het commando
sudo dpkg-reconfigure localepurgeweer rechtzetten.

Ik ga direct  hiermee aan de slag en zal de voortgang hier plaatsen.

Offline Simux

  • Lid
Re: Na nieuwe installatie problemen met locales
« Reactie #7 Gepost op: 2020/06/25, 15:08:07 »
Zelf gebruik ik voor dergelijk klusje localepurge. Hiermee kan je alle overbodige taalbestanden opruimen en op laten ruimen bij het upgraden of installeren van programma's.

Hier een Spaanstalige uitleg. Als je het een paar keer bekijkt kun je het wel volgen en begrijpen. En anders is Google Translate je vriend.
https://www.google.nl/url?sa=t&rct=j&q=&esrc=s&source=video&cd=&ved=2ahUKEwj77vDa0ZrqAhWPlqQKHYNhBTIQtwIwAXoECAQQAQ&url=https%3A%2F%2Flinuxforallsite.wordpress.com%2F2017%2F07%2F30%2Feliminar-archivos-de-idiomas-con-localepurge-en-ubuntu-y-derivadas%2F&usg=AOvVaw3Ks7GWzHq6QVJxnuKP3VxJ

Let erop dat je bij het tweede filmpje bij 40 seconden ziet dat het [Si] aangevinkt staat en zo blijft, dat moet dan [no] worden. Op het eerste filmpje is het goed. Deze filmpjes gaan uit van de Spaanse situatie, in dat van jou is dat dan NL.

Mocht je het toch fout hebben ingesteld, dan kun je dat met het commando
sudo dpkg-reconfigure localepurgeweer rechtzetten.

Mijn probleem is met bovenstaande stappen opgelost (waarvoor mijn dank, trouwens iedereen bedankt die mee heeft gedacht)

1) eerst alle talen  verwijderen die je niet nodig hebt, vervolgens
2) vanuit instellingen --> regionale instellingen de juiste talen kiezen, zorgen dat de belangrijkste taal bovenaan staat.