Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen audio bij Teams-for-Linux  (gelezen 265 keer)

Offline Gerretje

  • Lid
Geen audio bij Teams-for-Linux
« Gepost op: 2020/05/18, 13:50:11 »
Ik heb na een upgrade geen audio bij Teams. Had Teams-for-linux geinstalleerd met Snap, toen deed de camera het eerst niet, geluid en microfoon wel. Ik zat net de post: Topic: Interne microfoon werkt niet bij Microsoft Teams (Lenovo Ideapad) te lezen maar dat is toch weer een ander geval. Als ik naar mijn geluidsinstellingen ga doen namelijk de microfoon en speaker het wel in de test. Ze lijken alleen niet gekoppeld aan Teams.
Na een upgrade waarbij in eerste instantie iets mis ging en er incomplete pakketten waren ( weer gefixed, nu geen foutmeldingen meer) heb ik met deze tip: "https://askubuntu.com/questions/1218761/webcam-not-working-on-microsoft-teams-installed-via-snap"  wel mijn camera kunnen koppelen aan Teams, dus die werkt nu.
Wat ik mij afvraag: zijn er soortgelijke commando' s voor het koppelen van de microfoon en de speakers? Het lijkt of deze na de upgrade "eruit zijn gevallen"
Ik heb een Dell Latitude 3340, maar denk eigenlijk niet dat dat verder ertoe doet. Verder ben ik ook niet heel erg handig met de Konsole commando's , maar dat was misschien al wel duidelijk :-[ .
Ben nu tijdens de Corona toestand voor mijn werk voor vergaderen maar eens Teams gaan installeren, heb het verder niet zo op die Microsoft toestanden maar je moet wat........
En ik ben eens begonnen met het bestuderen van dat Linux commando systeem op : http://linuxcommand.org/index.php.
Dus misschien wordt het nog wat.
Vooralsnog hoop ik op hulp van iemand hier.
groet, en vast bedankt.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Geen audio bij Teams-for-Linux
« Reactie #1 Gepost op: 2020/05/18, 15:35:19 »
Voor snaps kan je ook in Software de permissies controleren en instellen. Voor een geïnstalleerd programma vindt je een knop "Permissions" (naast "Remove"). Het afspelen en opnemen van audio zijn twee afzonderlijke permissies, die beide moeten aan staan.

Staan die aan, controleer dan ook in je geluidsinstellingen of de juiste geluidsuitvoer actief is.

Vind je het niet, probeer dan alternatieve mogelijkheden om Teams te gebruiken op linux:
* De applicatie via de .deb van de Microsoft website
* Via de browsers Chromium of Chrome.

 

Offline Gerretje

  • Lid
Re: Geen audio bij Teams-for-Linux
« Reactie #2 Gepost op: 2020/05/20, 14:32:03 »
Alle toestemmingen voor Teams staan aan. Als ik controleer bij geluidsinstellingen dan doen de speakers het ook met de test, als ik praat zie ik de nivo meter van de microfoon uitslaan dus die reageert ook. Als ik Teams gebruik zie ik mezelf in het kleine kadertje dus de camera doet het ook , alleen niemand hoort mij en ik hoor niemand.

Offline DirkJan

  • Lid
    • dirkjan-dirkjanvanderwal
    • persoonlijk blog
  • Steunpunt: Ja
Re: Geen audio bij Teams-for-Linux
« Reactie #3 Gepost op: 2020/05/22, 10:27:22 »
Zoals je het beschrijft lijkt het er inderdaad op dat je microfoon wel werkt maar dat hij tijdens een meeting niet werkt. Je hebt niet toevallig ingesteld dat je microfoon wordt gemute als je een meeting in gaat? (in de trant van je moet de stekker er in doen ;-) Op zich zou namelijk de microfoon moeten werken in de meeting wanneer in het voorportaal de niveaumeter uitslaat.

Ik kan het hier verder niet reproduceren, gebruik zelf niet de snap versie van teams maar de door vanadium genoemde .deb van de Microsoft website.

Ubuntu fan en OSS enthousiast

Offline Gerretje

  • Lid
Re: Geen audio bij Teams-for-Linux
« Reactie #4 Gepost op: 2020/05/22, 18:04:38 »
Ik wilde juist vermijden om de microsoft versie te downloaden, ik wil toch ook geen windows, dus daarom die Teams-for-Linux .
Als ik de microfoon wil aanzetten geeft ie aan 'geen microfoon gevonden' zoals ik voorheen de melding  'geen camera gevonden' kreeg. Toen deed echter de microfoon het wel en de speaker ook.
Na die upgrade heb ik de camera gekoppeld met het commando : "snap connect teams-for-linux:camera core:camera"
 dus ik dacht dat ik nu misschien ook de microfoon op vergelijkbare wijze opnieuw moet koppelen. Alleen weet ik niet wat dan het commando zou moeten zijn.
Iemand bekend met die commando's? Of moet ik gewoon de installatie met Snap opnieuw doen , zou dat kunnen helpen?

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Geen audio bij Teams-for-Linux
« Reactie #5 Gepost op: 2020/05/22, 18:44:50 »
De snap uitvoering van Microsoft Teams is:
Citaat
Unofficial Microsoft Teams client for Linux using Electron. It uses the Web App and wraps it as a standalone application using Electron.
Wat ik hier van maak is dat je dus net zo goed de web versie (FireFox Chromium of Chrome) kan gebruiken.
De .deb versie die je aangeboden krijgt wanneer je via FF Chromium of Chrome gaat inloggen op teams werkt redelijk op mijn Dell D520 met 2Gb RAM ;)
Stap in deze tijden over drempels en het later verwijderen kan altijd nog  ;)

Edit: Zoals in het volgende bericht van vanadium is aangegeven werkt Teams niet goed als webapplicatie onder FireFox.
« Laatst bewerkt op: 2020/05/23, 10:43:06 door nahjo »
gebruikt Xubuntu op de desktop/notebooks

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Geen audio bij Teams-for-Linux
« Reactie #6 Gepost op: 2020/05/23, 10:08:24 »
De snap uitvoering van Microsoft Teams is:
Citaat
Unofficial Microsoft Teams client for Linux using Electron. It uses the Web App and wraps it as a standalone application using Electron.
Wat ik hier van maak is dat je dus net zo goed de web versie (FireFox Chromium) kan gebruiken.
De .deb versie die je aangeboden krijgt wanneer je via FF of Chromium gaat inloggen op teams werkt redelijk op mijn Dell D520 met 2Gb RAM ;)
Stap in deze tijden over drempels en het later verwijderen kan altijd nog  ;)
Video werkt enkel op Chromium (en Google Chrome) (en hun nieuwere Edge browser die op chromium gebaseerd is).