Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Upgrade Ubuntu 18.04 LTS naar 20.04 LTS - pkgProblemResolver fouten  (gelezen 306 keer)

Offline MarcB

  • Lid
Besten,
wat ik ook doe, ik blijf na de upgrade met de volgende fout meldingen zitten:

****:~$ sudo apt-get install -f
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... mislukt.
De volgende pakketten hebben niet-voldane vereisten:
 backintime-qt4 : Vereisten: backintime-qt maar het is niet geïnstalleerd
 dirmngr : Vereisten: init-system-helpers (>= 1.52) maar 1.51 is geïnstalleerd
 gir1.2-gtk-3.0 : Vereisten: gir1.2-gdkpixbuf-2.0 (>= 2.40.0) maar 2.36.11-2 is geïnstalleerd
                  Vereisten: gir1.2-pango-1.0 (>= 1.41.0) maar 1.40.14-1ubuntu0.1 is geïnstalleerd
                  Vereisten: libgtk-3-0 (>= 3.24.7) maar 3.22.30-1ubuntu4 is geïnstalleerd
 gnupg : Vereisten: gpgv (>= 2.2.19-3ubuntu2)
 gpg-agent : Vereisten: init-system-helpers (>= 1.52) maar 1.51 is geïnstalleerd
 hplip : Vereisten: hplip-data (= 3.20.3+dfsg0-2) maar 3.17.10+repack0-5 is geïnstalleerd
         Vereisten: libhpmud0 (= 3.20.3+dfsg0-2) maar 3.17.10+repack0-5 is geïnstalleerd
         Vereisten: printer-driver-hpcups (= 3.20.3+dfsg0-2) maar 3.17.10+repack0-5 is geïnstalleerd
 libqt4-declarative : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-designer : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-help : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-network : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-script : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-sql : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-sql-mysql : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-svg : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-test : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-xml : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqt4-xmlpatterns : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqtassistantclient4 : Vereisten: libqtcore4 (>= 4:4.8.1) maar het is niet installeerbaar
 libqtdbus4 : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libqtgui4 : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 libsane-hpaio : Vereisten: libhpmud0 (>= 3.20.3+dfsg0) maar 3.17.10+repack0-5 is geïnstalleerd
 libstdc++6:i386 : Vereisten: gcc-10-base:i386 (= 10-20200411-0ubuntu1) maar het is niet geïnstalleerd
                   Vereisten: libc6:i386 (>= 2.18) maar het is niet geïnstalleerd
                   Vereisten: libgcc-s1:i386 (>= 4.2) maar het is niet geïnstalleerd
 python3-apt : Vereisten: libapt-pkg6.0 (>= 1.9.11~) maar het is niet geïnstalleerd
 python3-brlapi : Vereisten: libbrlapi0.7 maar het is niet geïnstalleerd
 python3-dev : Vereisten: libpython3-dev (= 3.8.2-0ubuntu2) maar 3.6.7-1~18.04 is geïnstalleerd
               Vereisten: python3.8-dev (>= 3.8.2-1~) maar het is niet geïnstalleerd
 python3-gi : Vereisten: libgirepository-1.0-1 (>= 1.62.0-4~) maar 1.56.1-1 is geïnstalleerd
 python3-pil : Vereisten: libimagequant0 (>= 2.11.10) maar het is niet geïnstalleerd
 python3-protobuf : Vereisten: libprotobuf17 maar het is niet geïnstalleerd
 python3-uno : Vereisten: libreoffice-core (= 1:6.4.3-0ubuntu0.20.04.1) maar 1:6.0.7-0ubuntu0.18.04.10 is geïnstalleerd of
                          libreoffice-core-nogui (= 1:6.4.3-0ubuntu0.20.04.1) maar het is niet geïnstalleerd
               Vereisten: libuno-cppu3 (>= 4.4.0~alpha) maar het is niet geïnstalleerd
               Vereisten: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) maar het is niet geïnstalleerd
               Vereisten: libuno-sal3 (>= 5.4.0~alpha) maar het is niet geïnstalleerd
               Vereisten: libuno-salhelpergcc3-3 (>= 3.6.0~beta) maar het is niet geïnstalleerd
               Vereisten: uno-libs-private maar het is niet geïnstalleerd
 python3-wxgtk4.0 : Vereisten: libwxgtk3.0-gtk3-0v5 (>= 3.0.4+dfsg-10~) maar 3.0.4+dfsg-3 is geïnstalleerd
 qdbus : Vereisten: libqtcore4 (= 4:4.8.7+dfsg-7ubuntu1) maar het is niet installeerbaar
 qt-at-spi : Vereisten: libqtcore4 (>= 4:4.8~) maar het is niet installeerbaar
 rhythmbox-plugins : Vereisten: librhythmbox-core10 (= 3.4.4-1ubuntu2) maar 3.4.2-4ubuntu1 is geïnstalleerd
                     Vereisten: rhythmbox (= 3.4.4-1ubuntu2) maar 3.4.2-4ubuntu1 is geïnstalleerd
                     Vereisten: gir1.2-rb-3.0 (= 3.4.4-1ubuntu2) maar 3.4.2-4ubuntu1 is geïnstalleerd
E: Fout, pkgProblemResolver::Resolve leverde defecten op. Dit kan veroorzaakt worden door vastgehouden pakketten.
E: Kan vereisten niet corrigeren

Enig advies, alvast bedankt.

Info uname -a: Linux **** 4.15.0-99-generic #100-Ubuntu SMP Wed Apr 22 20:32:56 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
Mem: 5,7 GB - CPU: Intel® Core™ i7-3610QM CPU @ 2.30GHz × 8 - GU: Intel® Ivybridge Mobile - GNOME: 3.36.1 - OS: 64-bit - Type: AMD64

Offline marco1800

  • Lid
  • Steunpunt: Nee
Re: Upgrade Ubuntu 18.04 LTS naar 20.04 LTS - pkgProblemResolver fouten
« Reactie #1 Gepost op: 2020/05/09, 14:53:11 »
Maak het jezelf makkelijk en installeer een nieuwe installatie het duurt een 10-tal minuutjes.

Zorg wel eerst voor een back-up van je home map.
Laptop BTO 16 Gb Ram / Core I5 8265U
120 Gb SSD M.2 / 500 GB SSD
Ubuntu 20.04

Offline marco1800

  • Lid
  • Steunpunt: Nee
« Laatst bewerkt op: 2020/05/09, 15:30:57 door marco1800 »
Laptop BTO 16 Gb Ram / Core I5 8265U
120 Gb SSD M.2 / 500 GB SSD
Ubuntu 20.04

Offline MarcB

  • Lid
Re: Upgrade Ubuntu 18.04 LTS naar 20.04 LTS - pkgProblemResolver fouten
« Reactie #3 Gepost op: 2020/05/09, 15:58:32 »
Bedankt voor het advies.
Je hebt gelijk en ik had eigenlijk beter moeten weten.  :rolleyes:
Ik ga je raad alvast opvolgen!

Offline Vincentlaborant

  • Lid
    • vincentvandenbergh
  • Steunpunt: Nee
Re: Upgrade Ubuntu 18.04 LTS naar 20.04 LTS - pkgProblemResolver fouten
« Reactie #4 Gepost op: 2020/05/09, 22:37:04 »
Maak het jezelf makkelijk en installeer een nieuwe installatie het duurt een 10-tal minuutjes.

Zorg wel eerst voor een back-up van je home map.

Dit is wat iedereen behoort te doen maar je moet nou eenmaal ook koppige mensen hebben zodat wij hier op het forum kunnen hobby'en.

Hoe dan ook, probeer maar

dpkg-reconfigure -a
Dan wouden je bestaande pakketten opnieuw geconfigureerd. Alles wat niet lekker staat gaat naar zijn basis instellingen toe.
openSUSE LEAP KDE
Kubuntu