Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Medion Geforce3  (gelezen 1405 keer)

DekuNuts

  • Gast
Medion Geforce3
« Gepost op: 2007/05/20, 18:42:32 »
Hallo,

Ik ben al een hele tijd bezig met ubuntu en tot voor kort was ik er mij niet van bewust dat er een nederlandstalig forum bestond, daarom poste ik altijd op het engelstalige. Enfin, dat is het probleem niet.

Een tijdje terug heeft mijn x700 het loodje gelegd en aangezien ik niet echt games speel op computer, achtte ik de geforce 6200 een goede vervanger. Nog voor ik er een kon kopen, kreeg ik een geforce 3 aangeboden van een vriend. Deze werkt perfect, op het feit na dat ik er geen opengl acceleratie uit kan krijgen!

Wanneer ik de driver probeer te installeren, krijg ik steeds een foutmelding :

E: /var/cache/apt/archives/nvidia-glx_1%3a1.0.9631+2.6.20.5-15.20_i386.deb: subproces pre-installation script gaf een foutwaarde 2 terug

Ik weet niet wat dit betekent en kan dus niet verder vooraleer ik dat weer.

Het 'rare' ligt hem misschien wel aan het feit dat het een kaart van medion is. Deze wijken altijd wel wat af van de 'echte' kaarten.

merci

Offline siegi

  • Lid
  • Steunpunt: Nee
Medion Geforce3
« Reactie #1 Gepost op: 2007/05/25, 00:34:18 »
Je hebt deze nog nodig voor die oude kaart nvidia-glx-legacy  want de nieuwe driver van nvidia werkt er niet mee.
Sorry dat je zo laat antwoord krijgt, ik heb je vraag ook alleen bij onbeantwoorde berichten zien staan.

DekuNuts

  • Gast
Medion Geforce3
« Reactie #2 Gepost op: 2007/05/25, 08:11:51 »
danku, maar

E: /var/cache/apt/archives/nvidia-glx-legacy_1.0.7184+2.6.20.5-15.20_i386.deb: subproces pre-installation script gaf een foutwaarde 2 terug

dit is de foutmelding bij het installeren van de legacy driver. Hetzelfde dus, ik snap niet wat er mis loopt. Het is ook niet zo dat ik geen idee heb van waar ik mee bezig ben en gewoon klakkeloos overneem wat mij wordt verteld.

ander idee?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
Medion Geforce3
« Reactie #3 Gepost op: 2007/05/25, 08:46:35 »
We hebben meer context informatie nodig. Kopieer eens een aantal extra lijnen voor de foutmelding, daar zou namelijk meer informatie moeten staan over wat er precies is misgelopen.
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Marinus

  • Lid
  • Steunpunt: Nee
Medion Geforce3
« Reactie #4 Gepost op: 2007/05/25, 09:38:51 »
Citaat van: DekuNuts
danku, maar

E: /var/cache/apt/archives/nvidia-glx-legacy_1.0.7184+2.6.20.5-15.20_i386.deb: subproces pre-installation script gaf een foutwaarde 2 terug

dit is de foutmelding bij het installeren van de legacy driver. Hetzelfde dus, ik snap niet wat er mis loopt. Het is ook niet zo dat ik geen idee heb van waar ik mee bezig ben en gewoon klakkeloos overneem wat mij wordt verteld.

ander idee?
Het volgende heeft mij uit de problemen geholpen
https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia
Ubuntu 12.04 Unity

DekuNuts

  • Gast
Medion Geforce3
« Reactie #5 Gepost op: 2007/05/25, 17:20:54 »
Danku Marinus, via daar kan ik een lijst vinden die zegt welke kaart welke driver vereist.

http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/README/appendix-a.html

->ik moet wel 1.0-96xx driver gebruiken en dat is dus nvidia-glx en niet legacy.

En ProfoX dan, de error die ik gaf kwam van het installer venstertje van synaptic, maar wanneer ik via de terminal het pakket installeer, komt er inderdaad meer info (sommige die zelfs niet zichtbaar was in het terminal venster van synaptec).
-----------------------------------------------------------------------------------------
...

Uitpakken van nvidia-glx-legacy (uit .../nvidia-glx-legacy_1.0.7184+2.6.20.5-15.20_i386.deb) ...
dpkg-divert: 'diversion of /usr/lib/libGL.so.1 to /usr/lib/nvidia/libGL.so.1.xlibmesa by nvidia-glx-legacy' conflicteert met 'diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/libGL.so.1.xlibmesa by xorg-driver-fglrx'
dpkg: fout bij afhandelen van /var/cache/apt/archives/nvidia-glx-legacy_1.0.7184+2.6.20.5-15.20_i386.deb (--unpack):
 subproces pre-installation script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/nvidia-glx-legacy_1.0.7184+2.6.20.5-15.20_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
stefan@Athlon:~$
-------------------------------------------------------------------------------------------
Hieruit valt te concluderen dat er een conflict is tussen bestanden waarvan xorg-driver-fglrx de bron is. Volgens synaptix heb ik dat pakket niet geinstalleerd. Mss is het een overblijfsel van ooit zelf de ati driver te compileren.

Ik ga nu dus proberen dit conflict op te lossen en zal later eens terug kijken naar de thread.

EDIT : die info stond wel in het terminal venster van synaptic (logisch), ik heb er gewoon over gekeken.

DekuNuts

  • Gast
Medion Geforce3
« Reactie #6 Gepost op: 2007/05/25, 21:44:06 »
Dus, ik heb alle mesa pakketen geherinstalleerd en alle pakketen van fglrx volledig verwijderd, inclusief config en dan ook de restricted driver tools geherinstalleerd. Toch krijg ik nog steeds dezelfde error ivm de diversion van xorg-driver-fglrx, alhoewel dit en de pakketen die er bij horen niet meer aanwezig zijn. Ik heb geprobeerd deze bestandjes te bekijken, maar gedit kan ze niet openen en zelf weet ik niet wat er in zit.


Ik denk dat ik op een of andere manier via de terminal dat bestand zal moeten aanspreken en de fglrx links verwijderen ofzo, ik weet het niet goed.

Iemand?

Offline Marinus

  • Lid
  • Steunpunt: Nee
Medion Geforce3
« Reactie #7 Gepost op: 2007/05/29, 11:39:38 »
Citaat van: DekuNuts
Dus, ik heb alle mesa pakketen geherinstalleerd en alle pakketen van fglrx volledig verwijderd, inclusief config en dan ook de restricted driver tools geherinstalleerd. Toch krijg ik nog steeds dezelfde error ivm de diversion van xorg-driver-fglrx, alhoewel dit en de pakketen die er bij horen niet meer aanwezig zijn. Ik heb geprobeerd deze bestandjes te bekijken, maar gedit kan ze niet openen en zelf weet ik niet wat er in zit.


Ik denk dat ik op een of andere manier via de terminal dat bestand zal moeten aanspreken en de fglrx links verwijderen ofzo, ik weet het niet goed.

Iemand?
Ik heb een GeForce2 en alles werkt perfect, dus misschien heb je hier iets aan:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   Fontpath   "/usr/share/fonts/X11/misc"
   Fontpath   "/usr/share/fonts/X11/cyrillic"
   Fontpath   "/usr/share/fonts/X11/100dpi/:unscaled"
   Fontpath   "/usr/share/fonts/X11/75dpi/:unscaled"
   Fontpath   "/usr/share/fonts/X11/Type1"
   Fontpath   "/usr/share/fonts/X11/100dpi"
   Fontpath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   Fontpath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load      "i2c"
   Load      "bitmap"
   Load      "ddc"
   Load      "extmod"
   Load      "freetype"
   Load      "glx"
   Load      "int10"
   Load      "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "be"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "stylus"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "eraser"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "cursor"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "nVidia Corporation NV15 [GeForce2 GTS/Pro]"
   Driver      "nvidia"
   Busid      "PCI:1:0:0"
   Option      "NoLogo"   "False"
   Option      "AllowGLXWithComposite"   "True"
EndSection

Section "Monitor"
   Identifier   "CPD-220AS"
   Option      "DPMS"
   Horizsync   30-70
   Vertrefresh   50-120
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation NV15 [GeForce2 GTS/Pro]"
   Monitor      "CPD-220AS"
   Defaultdepth   24
   SubSection "Display"
      Depth   1
      Modes      "1280x1024"   "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"
   EndSubSection
   SubSection "Display"
      Depth   4
      Modes      "1280x1024"   "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"
   EndSubSection
   SubSection "Display"
      Depth   8
      Modes      "1280x1024"   "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"
   EndSubSection
   SubSection "Display"
      Depth   15
      Modes      "1280x1024"   "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"
   EndSubSection
   SubSection "Display"
      Depth   16
      Modes      "1280x1024"   "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"
   EndSubSection
   SubSection "Display"
      Depth   24
      Modes      "1280x1024"   "1024x768"   "832x624"   "800x600"   "720x400"   "640x480"   "640x400"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   Inputdevice   "stylus"   "SendCoreEvents"
   Inputdevice   "cursor"   "SendCoreEvents"
   Inputdevice   "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection
Ubuntu 12.04 Unity

DekuNuts

  • Gast
Medion Geforce3
« Reactie #8 Gepost op: 2007/05/29, 17:48:20 »
Bedankt voor de conf file, maar het probleem bleek veel dieper dan dat te liggen. Intussen heb ik het 'opgelost' door te herinstalleren. De oorzaak was dat een bepaalde link niet meer werkte omdat het doelbestand weg was, maar gezien deze niet aanpasbaar bleek en niemand hier of op de engelse ubuntu fora en op de irc van ubuntu-nl en .org raad wist, naam ik aan dat ik het gewoonweg zelf veroorzaakt heb door de fglrx driver slordig te compileren en een abormale situatie te scheppen.

Mss kan dit topic dan maar beter gesloten worden.