Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hidden Grub toch zichtbaar  (gelezen 798 keer)

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Hidden Grub toch zichtbaar
« Gepost op: 2020/02/20, 18:13:43 »
Het lukt mij niet mijn Grubmenu hidden te krijgen in LM19.3 Mate.

Via deze link:
https://help.ubuntu.com/community/Grub2/Setup
Heb ik met volgende parameters gespeeld, maar of de timeout is 10s (terwijl ik wel 0 of 1s heb ingesteld), of het is gewoon 1s zichtbaar.
GRUB_HIDDEN_TIMEOUT=1
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=1
GRUB_TIMEOUT_STYLE=hidden

In geen geval lukt het om het Grubmenu hidden te maken.
Wat doe ik verkeerd?

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #1 Gepost op: 2020/02/20, 18:42:14 »
Het lijkt me, dat je niet hidden timeout en timeout tegelijk actief kunt hebben.... Misschien veroorzaakt dat een probleem?

Dit staat er overigens mijn /etc/default/grub, wat prima werkt (vijf seconden):
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

En vergeet dit niet, hè:   =D
sudo update-grub

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #2 Gepost op: 2020/02/21, 08:45:53 »
Als je een UEFI boot hebt, volstaat een druk op de Esc knop tijdens de opstart om direct in Grub te zitten, zelfs al staat GRUB helemaal verborgen zonder vertraging. Probeer dat eens. Heb je een MBR boot (het oude systeem), dan moet het met Shift lukken. Bij mij (single boot zonder grub) stat het zo:
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
« Laatst bewerkt op: 2020/02/21, 14:42:05 door vanadium »

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #3 Gepost op: 2020/02/21, 14:34:25 »
Als ik vanadiums Grub overneem krijg ik een menu met 10s wachttijd...
Verander ik de tijd in 1s , dan is het wel 1s.... maar nog steeds is het menu zichtbaar...
Ik snap er niets van.
Overigens heb ik jouw 'i915.enable_psr=0' niet overgenomen, aangezien dat waarschijnlijk voor een flickerend scherm is en hier waarschijnlijk niets mee te maken heeft.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #4 Gepost op: 2020/02/21, 14:41:47 »
Die i915.enable_psr=0, juist, ben ik vergeten aan te passen. Je doet toch wel een "sudo update-grub" na iedere aanpassing van "/etc/default/grub"? Post hier misschien eens je gehele Grub? Misschien staat er nog meer in waardoor het kan verklaard worden dat jij met die instellingen toch 10 s het Grubmenu ziet.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #5 Gepost op: 2020/02/21, 16:01:08 »
GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=1
#GRUB_HIDDEN_TIMEOUT=1
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux "
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Bovenstaande geeft het menu 1s weer.
Maak ik vd 1 een 0, dan krijg ik het menu 10s.

Ik heb al wat geprobeerd met trial & error, maar elke keer opstarten schiet natuurlijk niet op.  >:(
sudo update-grub gebruik ik.  :)

nahjo

  • Gast
Re: Hidden Grub toch zichtbaar
« Reactie #6 Gepost op: 2020/02/21, 16:33:20 »
schakel GRUB_HIDDEN_TIMEOUT_QUIET=true ook eens uit want is ook niet meer nodig.

Er staan in mijn /etc/default/grub veel meer regels met andere uitgeschakelde opdrachten. Volgens mij vraagt vanadium om een totaal overzicht van je /etc/default/grub bestand  ;)

En krijg je met sudo update-grub ook een waarschuwing op het scherm?
« Laatst bewerkt op: 2020/02/21, 16:40:36 door nahjo »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #7 Gepost op: 2020/02/21, 16:44:29 »
nahjo is me net voor!

Hm, ik zie niets abnormaals. Enkel die "GRUB_HIDDEN_TIMEOUT_QUIET=true" mag er uit, want wordt tegenwoordig geregeld met de optie "GRUB_TIMEOUT_STYLE=hidden". Misschien lost dat het probleem op.

En inderdaad: goed idee om goed de uitvoer van "sudo update-grub" op foutmeldingen te checken. Bij mij geen foutmeldingen, en dan ziet het eruit als:
$ sudo update-grub
[sudo] password for vanadium:
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3.0-40-generic
Found initrd image: /boot/initrd.img-5.3.0-40-generic
Found linux image: /boot/vmlinuz-5.3.0-29-generic
Found initrd image: /boot/initrd.img-5.3.0-29-generic
Adding boot menu entry for EFI firmware configuration
done
« Laatst bewerkt op: 2020/02/21, 16:46:57 door vanadium »

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #8 Gepost op: 2020/02/21, 17:18:37 »
Grub:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=1
#GRUB_HIDDEN_TIMEOUT=1
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux "
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"



Meldingen na sudo update-grub:
$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
Sourcing file `/etc/default/grub.d/60_mint-theme.cfg'
Aanmaken van GRUB-configuratiebestand...
Gevonden thema: /boot/grub/themes/linuxmint/theme.txt
Linux-schijfkopie gevonden: /boot/vmlinuz-5.3.0-40-generic
Initrd-schijfkopie gevonden: /boot/initrd.img-5.3.0-40-generic
Linux-schijfkopie gevonden: /boot/vmlinuz-5.0.0-32-generic
Initrd-schijfkopie gevonden: /boot/initrd.img-5.0.0-32-generic
Windows Boot Manager gevonden op /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Opstartmenuregel toevoegen voor instelling van EFI-firmware
voltooid

Die andere 2 files in /grub.d/ bevatten niets raars.

nahjo

  • Gast
Re: Hidden Grub toch zichtbaar
« Reactie #9 Gepost op: 2020/02/21, 17:28:46 »
Citaat
Windows Boot Manager gevonden op /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Bij dualboot moet het Grub menu zichtbaar zijn .....

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #10 Gepost op: 2020/02/21, 18:33:55 »
Bij dualboot moet het Grub menu zichtbaar zijn .....
Met de optie GRUB_TIMEOUT_STYLE=hidden wordt verwacht dat het Grubmenu niet zichtbaar is. Dan kan je binnen de timeout nog Esc drukken om het menu vooralsnog te tonen. Het zou inderdaad moeten zijn dat die opties niet werken als er meerdere besturingssystemen zijn, maar ik heb dat nog nergens gedocumenteerd gezien.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #11 Gepost op: 2020/02/21, 18:41:28 »
Mogelijk heb ik het gevonden: voeg eens
GRUB_DISABLE_OS_PROBER=true
toe.

nahjo

  • Gast
Re: Hidden Grub toch zichtbaar
« Reactie #12 Gepost op: 2020/02/21, 18:48:03 »
Mogelijk heb ik het gevonden: voeg eens
GRUB_DISABLE_OS_PROBER=true
toe.
Ben benieuwd of dat werkt.  ^-^
In mijn dualboot systeem staat GRUB_TIMEOUT_STYLE=hidden maar gelukkig is het menu zichtbaar zodat ik kan kiezen.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #13 Gepost op: 2020/02/22, 10:46:20 »
Citaat
Windows Boot Manager gevonden op /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Bij dualboot moet het Grub menu zichtbaar zijn .....
Bij mijn desktop is het ook hidden.

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #14 Gepost op: 2020/02/22, 10:48:44 »
Mogelijk heb ik het gevonden: voeg eens
GRUB_DISABLE_OS_PROBER=true
toe.
Dit werkt: grubmenu is nu hidden!
Maar....... de Windows entry in het menu is nu ook weg...
Op zich kan ik daar mee leven omdat ik Windows toch alleen gebruik voor het updaten van firmware, bios etc.
Maar mooi is het niet; een oplossing die de Win entry laat staan zou ik prefereren.
« Laatst bewerkt op: 2020/02/22, 10:51:18 door VuurVosje »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Hidden Grub toch zichtbaar
« Reactie #15 Gepost op: 2020/02/22, 12:50:13 »
Het is eigenaardig dat je niet eenvoudig het menu op hidden kan zetten en de keuzes behouden als er meerdere besturingssystemen zijn. Je moet blijkbaar al in de code duiken om dat voor elkaar te krijgen.

nahjo

  • Gast
Re: Hidden Grub toch zichtbaar
« Reactie #16 Gepost op: 2020/02/22, 14:20:29 »
Het is eigenaardig dat je niet eenvoudig het menu op hidden kan zetten en de keuzes behouden als er meerdere besturingssystemen zijn. Je moet blijkbaar al in de code duiken om dat voor elkaar te krijgen.
Het schijnt dat je met grub-customizer het grub menu zo kunt aanpassen. Heb het zelf jaren terug eens gebruikt maar om daarna weer terug te gaan naar het 'gewone' grub menu was een totale herinstallatie noodzakelijk.