Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NVidia driver incompatibel met kernel?  (gelezen 1440 keer)

Patsjoelie

  • Gast
NVidia driver incompatibel met kernel?
« Gepost op: 2007/05/19, 19:52:39 »
Hoi allemaal ...
Sinds de upgrade naar Feisty Fawn haal ik zeer slechte performantie resultaten op mijn vooroorlogse pc (Pentium III, 800Mhz, 512Mb Ram, GeForce 2 GTS/PRO).
Na veel zoeken en lezen zou dit wel eens kunnen teruggebracht worden naar de nieuwe NVidia drivers die meegeleverd worden met Feisty.
Wanneer ik in mijn xorg.conf kijk, zie ik dat de driver "nv" gebruikt wordt. Dit zou "NVidia" moeten zijn.
Wanneer ik via de beperkt ondersteunde stuurprogramma's ga zie ik dat het stuurprogramma voor oudere NVidia kaarten niet in gebruik is. Wanneer ik deze wil activeren wordt een installatie geprobeert, maar dit lukt niet.
Wanneer ik via synaptic probeer om de oudere drivers te installeren, krijg ik steevast een foutmelding, idem via apt-get.
Ik heb dan na enige tijd zoeken de driver op de NVidia website gevonden, wanneer ik deze probeer te installeren (pc opgestart zonder gnome te laden), krijg ik ook foutmelding. Uit deze installatie kan ik wel opmaken dat mijn huidige kernel niet compatibel zou zijn met die drivers.

Foutmelding via apt-get:
sudo apt-get install nvidia-glx
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
Voorgestelde pakketten:
  nvidia-kernel-source
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  nvidia-glx
0 pakketten opgewaardeerd, 1 nieuwe pakketten geïnstalleerd, 0 verwijderen en 2 niet opgewaardeerd.
Er moeten 0B/4492kB aan archieven opgehaald worden.
Na het uitpakken zal er 13,7MB extra schijfruimte gebruikt worden.
(Database inlezen ... 123659 bestanden en mappen geïnstalleerd.)
Uitpakken van nvidia-glx (uit .../nvidia-glx_1%3a1.0.9631+2.6.20.5-15.20_i386.deb) ...
dpkg-divert: 'diversion of /usr/lib/libGL.so.1 to /usr/lib/nvidia/libGL.so.1.xlibmesa by nvidia-glx' conflicteert met 'diversion of /usr/lib/libGL.so.1 to /usr/lib/nvidia/libGL.so.1.xlibmesa by nvidia-glx-new'
dpkg: fout bij afhandelen van /var/cache/apt/archives/nvidia-glx_1%3a1.0.9631+2.6.20.5-15.20_i386.deb (--unpack):
 subproces pre-installation script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/nvidia-glx_1%3a1.0.9631+2.6.20.5-15.20_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

100 keer deze commando's
sudo apt-get -f install
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove
dpkg --configure -a

Het rechtstreeks uitvoeren van:
NVIDIA-Linux-x86-1.0-9631-pkg1.run geeft een hele rits meldingen dat mijn systeem incompatibel zou zijn, met specifieke verwijzingen naar de kernel.

Ik ben door mijn ideeën uit.
Wie kan me helpen om de juiste NVidia driver geïnstalleerd te krijgen zodat ik weer een vlot werkend systeem kan krijgen.
Alvast hartelijk dank op voorhand!

Patsjoelie

  • Gast
NVidia driver incompatibel met kernel?
« Reactie #1 Gepost op: 2007/05/19, 20:01:15 »
Ik lees net in mijn eigen post hierboven over een conflict met:
"nvidia-glx-new".
Maar wanneer ik via Synaptic een kijkje neem, dan is deze "nvidia-glx-new" niet geïnstalleerd??

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
NVidia driver incompatibel met kernel?
« Reactie #2 Gepost op: 2007/05/19, 20:10:39 »
volgens mij moet je zowel de glx als de glx-new door de legacy driver vervangen.
maar ik weet het niet zeker. zal nog ff googlen.

: Ze hebben de Nvidia drivers opgedeeld in 3 groepen:
nvidia-glx heeft driver 9631
nvidia-glx-new heeft de nieuwste 9755
nvidia-glx-legacy heeft de oudste drivers 71xx

Iedereen die dus een Geforce FX of nieuwer heeft, kan dus de nvidia-glx-new drivers installeren.
Voor de Geforce 4 en ouder de gewone nvidia-glx.
De antieke kaarten worden nog ondersteund door de nvidia-glx-legacy drivers.

Hier: http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/README/appendix-a.html kan je kijken welke driver je moet hebben voor jouw kaart.

Als je van driver wisselt, kan het noodzakelijk zijn dat je de restricted modules even opnieuw moet installeren.

draadje johanvd

Offline Marinus

  • Lid
  • Steunpunt: Nee
NVidia driver incompatibel met kernel?
« Reactie #3 Gepost op: 2007/05/25, 09:40:41 »
Citaat van: Patsjoelie
Hoi allemaal ...
Sinds de upgrade naar Feisty Fawn haal ik zeer slechte performantie resultaten op mijn vooroorlogse pc (Pentium III, 800Mhz, 512Mb Ram, GeForce 2 GTS/PRO).
Na veel zoeken en lezen zou dit wel eens kunnen teruggebracht worden naar de nieuwe NVidia drivers die meegeleverd worden met Feisty.
Wanneer ik in mijn xorg.conf kijk, zie ik dat de driver "nv" gebruikt wordt. Dit zou "NVidia" moeten zijn.
Wanneer ik via de beperkt ondersteunde stuurprogramma's ga zie ik dat het stuurprogramma voor oudere NVidia kaarten niet in gebruik is. Wanneer ik deze wil activeren wordt een installatie geprobeert, maar dit lukt niet.
Wanneer ik via synaptic probeer om de oudere drivers te installeren, krijg ik steevast een foutmelding, idem via apt-get.
Ik heb dan na enige tijd zoeken de driver op de NVidia website gevonden, wanneer ik deze probeer te installeren (pc opgestart zonder gnome te laden), krijg ik ook foutmelding. Uit deze installatie kan ik wel opmaken dat mijn huidige kernel niet compatibel zou zijn met die drivers.

Foutmelding via apt-get:
sudo apt-get install nvidia-glx
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
Voorgestelde pakketten:
  nvidia-kernel-source
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  nvidia-glx
0 pakketten opgewaardeerd, 1 nieuwe pakketten geïnstalleerd, 0 verwijderen en 2 niet opgewaardeerd.
Er moeten 0B/4492kB aan archieven opgehaald worden.
Na het uitpakken zal er 13,7MB extra schijfruimte gebruikt worden.
(Database inlezen ... 123659 bestanden en mappen geïnstalleerd.)
Uitpakken van nvidia-glx (uit .../nvidia-glx_1%3a1.0.9631+2.6.20.5-15.20_i386.deb) ...
dpkg-divert: 'diversion of /usr/lib/libGL.so.1 to /usr/lib/nvidia/libGL.so.1.xlibmesa by nvidia-glx' conflicteert met 'diversion of /usr/lib/libGL.so.1 to /usr/lib/nvidia/libGL.so.1.xlibmesa by nvidia-glx-new'
dpkg: fout bij afhandelen van /var/cache/apt/archives/nvidia-glx_1%3a1.0.9631+2.6.20.5-15.20_i386.deb (--unpack):
 subproces pre-installation script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/nvidia-glx_1%3a1.0.9631+2.6.20.5-15.20_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

100 keer deze commando's
sudo apt-get -f install
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove
dpkg --configure -a

Het rechtstreeks uitvoeren van:
NVIDIA-Linux-x86-1.0-9631-pkg1.run geeft een hele rits meldingen dat mijn systeem incompatibel zou zijn, met specifieke verwijzingen naar de kernel.

Ik ben door mijn ideeën uit.
Wie kan me helpen om de juiste NVidia driver geïnstalleerd te krijgen zodat ik weer een vlot werkend systeem kan krijgen.
Alvast hartelijk dank op voorhand!
Het volgende heeft mij uit de problemen geholpen, alles werkt perfect nu
https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia
Ubuntu 12.04 Unity