Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Doomsday engine  (gelezen 671 keer)

Offline maxpower

  • Lid
  • Steunpunt: Nee
Doomsday engine
« Gepost op: 2007/05/19, 19:12:37 »
Ik speel vaak doom.. Dat met doomsday engine. Ik weet dat deze ook op linux te krijgen is.. Deze heb ik gedownload van www.doomsdayhq.com en proberen te compilen.. Eerst ontbrak het aan de nodige libraries bij configure.. deze heb ik allemaal geinstalleerd.. configure ging goed maar toen ging het mis bij make.. Heeft iemand enig idee wat ik hier ooit aan zou kunnen doen? Want ik wil wel HEEEEL graag doom weer spelen via doomsday engine (omdat ik weet dat ik daarmee ook samen met een windows systeem doom kan spelen over het netwerk) en ik zie het niet zitten om daarvoor speciaal iedere keer weer windows op te moeten starten.. dit zijn de fouten:

p_setup.c: In function 'P_LoadVertexes':
p_setup.c:87: error: invalid lvalue in assignment
p_setup.c: In function 'P_LoadSegs':
p_setup.c:135: error: invalid lvalue in assignment
p_setup.c: In function 'P_LoadSegsGL':
p_setup.c:176: error: invalid lvalue in assignment
p_setup.c: In function 'P_LoadSubsectors':
p_setup.c:242: error: invalid lvalue in assignment
p_setup.c: In function 'P_LoadSectors':
p_setup.c:269: error: invalid lvalue in assignment
p_setup.c: In function 'P_LoadNodes':
p_setup.c:304: error: invalid lvalue in assignment
p_setup.c: In function 'P_LoadLineDefs':
p_setup.c:395: error: invalid lvalue in assignment
p_setup.c: In function 'P_LoadSideDefs':
p_setup.c:473: error: invalid lvalue in assignment
make[3]: *** [p_setup.lo] Error 1
make[3]: Leaving directory `/home/maxpower/Desktop/deng-1.8.6/Src/jDoom'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/maxpower/Desktop/deng-1.8.6/Src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/maxpower/Desktop/deng-1.8.6'
make: *** [all] Error 2


 Kan iemand mij vertellen hoe ik doomsday engine aan de praat kan krijgen.. 1.9 of 1.8... dat maakt me helemaal niet uit..
 
alvast bedankt..

ps ik gebruik ubuntu Feisty Fawns en doomsday engine 1.8.6 omdat ik 1.9 helemaaal niet aan de gang kan krijgen..

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Doomsday engine
« Reactie #1 Gepost op: 2007/05/19, 19:45:18 »
Heb je al in de README en COMPILING instructies gekeken die in het bestand staan?
Wat je denk ik moet installeren:
cmake
build-essential
libsdl1.2-dev en aanverwante pakketten (Kijk bij de recommended packages in synaptic)
libopenal-dev

Citaat van: COMPILING
REQUIREMENTS:
-------------

You will need these tools and libraries for building everything:

- Cmake 2.4 or latter ( http://www.cmake.org/HTML/Download.html )
- A C Compiler (GCC on *NIX, OSX. Cygwin, MingGW, Borland or Visual C on Windows)
- GNU Make on *NIX, Cygwin or MinGW
- ncurses on *NIX, OSX
- OpenGL (This can be disabled in cmake for a dedicated build)
- GLU (This can be disabled in cmake for a dedicated build)
- SDL (http://www.libsdl.org/)
- SDL_net
- SDL_mixer (This can be disabled in cmake for a dedicated build)
- OpenAL (This can be disabled in cmake for a dedicated build)
- zip (to create Doomsday.pk3) ( http://www.info-zip.org/ )


IF YOU HAVE A SOURCE TARBALL:
-----------------------------

1. Unpack the source tarball, if you haven't already done so.

2. Cd to the Build directory.  Compiling under the Build directory
   will keep the main source directories clean of any object files.
   It also prevents conflicts in the Src/Common/ directory, which is
   used in a slightly different way by each game.

3. Run "cmake ../"  By default, everything will be installed under
   FIXME.  You might want to use e.g. FIXME.

4. If cmake failed due to missing libraries, install the required
   ones.  Make sure you have the development files for each.

5. On *NIX run "make" and then "su -c 'make install'" or
   "sudo 'make install'" depending on you *NIX distribution.
   This will compile everything and install the executable (doomsday),
   the libraries (games, renderer, sound), data files and definitions
   files under the directory specified by the configured prefix.
Had je trouwens ook al hier gekeken?
http://dengine.net/dew/index.php?title=Main_Page

Hier ook al gekeken?
http://dengine.net/dew/index.php?title=Installation#Linux.2FUnix
Ze geven zelfs de mogelijkheid om het via apt te doen als ik het goed zie :)

Offline maxpower

  • Lid
  • Steunpunt: Nee
Doomsday engine
« Reactie #2 Gepost op: 2007/05/19, 21:39:11 »
Dat wat je zei heb ik allemaal gekeken of het is geïnstalleerd en het is inderdaad geïnstalleerd.. daar ligt het dus niet aan.. Nog steeds komt hij me t de zelfde fouten en nog steeds wil 1.9 helemaaal niet.. Die server om hem te apt-getten is offline :( dus daar kan ik hem ook niet vandaan halen.. Heeft iemand enig idee? :(

Offline maxpower

  • Lid
  • Steunpunt: Nee
Doomsday engine
« Reactie #3 Gepost op: 2007/05/31, 13:31:55 »
oke :) jah ik heb dus nu een oplossing. . die source was niet berijkbaar omdat hij niet meer voor die versie van ubuntu beschikbaar was.. ik heb dus even verder gezocht en daar stond op een franse site een  andere software source.. de site is : http://doc.ubuntu-fr.org/doomsday