Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wine gebruikt verkeerde geluidskaart  (gelezen 1334 keer)

webgnome

  • Gast
Wine gebruikt verkeerde geluidskaart
« Gepost op: 2007/05/19, 16:57:07 »
Ik heb Wine geinstalleerd zoals jullie vast al wel in de gaten hadden . Echter gebruikt hij de verkeerde geluidskaart. Ik heb een Audigy en een Onboard geluidskaart en in games gebruikt hij steevast de onboard. Hoe kan ik het makkelijkste overschakelen naar de andere als er geen optie voor is in het spel/programma zelf?

Offline Kev

  • Lid
  • Steunpunt: Nee
Wine gebruikt verkeerde geluidskaart
« Reactie #1 Gepost op: 2007/05/19, 18:54:30 »
Dit moet je eerst instellen bij Ubuntu zelf, namelijk je kunt zien welke soundsystem op welke kaart zit.
Dan kun je met winecfg op het tabblad audio de juiste driver aanduiden waarmee je soundsystem werkt, dus ALSA als hij ALSA gebruikt en OSS als hij OSS gebruikt en ga zo verder.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

webgnome

  • Gast
Wine gebruikt verkeerde geluidskaart
« Reactie #2 Gepost op: 2007/05/19, 19:58:29 »
Het gekke is dat als ik twee games opstart. De een op de onboard sound afspeelt en het andere game op de audigy. Lijken mij dus dezelfde system te gebruiken. MAar hoe stel ik nu in dat elk spel ALTIJD de audigy gebruikt?

Offline Kev

  • Lid
  • Steunpunt: Nee
Wine gebruikt verkeerde geluidskaart
« Reactie #3 Gepost op: 2007/05/19, 20:59:56 »
Het is zo dat je dan het best in Ubuntu zelf een kunstgreep moet uitvoeren om de onboard chip als secundair geluidssysteem te laten benaderen, ik heb het ooit kunnen fixen, maar ben de geleverde handelingen ervoor vergeten.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

webgnome

  • Gast
Wine gebruikt verkeerde geluidskaart
« Reactie #4 Gepost op: 2007/05/20, 01:08:59 »
Weet iemand anders misschien hoe het moet :)

Speedboy

  • Gast
Wine gebruikt verkeerde geluidskaart
« Reactie #5 Gepost op: 2007/05/20, 12:39:00 »
Citaat van: webgnome
Weet iemand anders misschien hoe het moet :)
Ik heb hetzelfde probleem gehad. Ik heb toen gewoon de onboardkaart uitgezet in de bios. Als je alleen je audigy gebruikt is dat een oplossing.

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Wine gebruikt verkeerde geluidskaart
« Reactie #6 Gepost op: 2007/05/20, 12:42:50 »
Je kunt ook proberen om met winecfg de gewenste geluidskaart te verbinden aan de applicatie. Je kunt namelijk meerdere configuraties opnemen (eigenlijk: programma's) met allemaal verschillende instellingen.

webgnome

  • Gast
Wine gebruikt verkeerde geluidskaart
« Reactie #7 Gepost op: 2007/05/20, 12:48:18 »
Citaat van: Speedboy
Citaat van: webgnome
Weet iemand anders misschien hoe het moet :)
Ik heb hetzelfde probleem gehad. Ik heb toen gewoon de onboardkaart uitgezet in de bios. Als je alleen je audigy gebruikt is dat een oplossing.
helaas kan ik hem vanuit de bios niet uitzetten anders had ik dat al lang gedaan.

Citaat van: markba
Je kunt ook proberen om met winecfg de gewenste geluidskaart te verbinden aan de applicatie. Je kunt namelijk meerdere configuraties opnemen (eigenlijk: programma's) met allemaal verschillende instellingen.
Dat heb ik geprobeert maar het enige wat er komt als ik wow.exe toevoeg is de keuze van een besturingssysteem :S

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Wine gebruikt verkeerde geluidskaart
« Reactie #8 Gepost op: 2007/05/20, 13:03:32 »
Citaat van: webgnome
Dat heb ik geprobeert maar het enige wat er komt als ik wow.exe toevoeg is de keuze van een besturingssysteem :S
Als je 'Add application' hebt gedaan naar wow.exe zijn *alle* instellingen specifiek voor deze applicatie. Je kunt dat ook zien aan de titelbalk, deze zou dan het volgende moeten aangeven 'Wine Configuration for wow.exe'

webgnome

  • Gast
Wine gebruikt verkeerde geluidskaart
« Reactie #9 Gepost op: 2007/05/20, 14:19:10 »
Thanks. Dat was me niet eens opgevallen. Ik heb het eens geprobeerd maar als ik de soundsysteem wil instellen dan geeft hij een popup met een ok knop verder niks. En daar ja.. heb je niet veel aan :P

Offline Kev

  • Lid
  • Steunpunt: Nee
Wine gebruikt verkeerde geluidskaart
« Reactie #10 Gepost op: 2007/05/20, 20:25:14 »
Onder welke versie van ubuntu werk je, want dat audiotab kan soms eens crashen als er bijvoorbeeld arts op staat, maar niet ingeladen is dit komt voor wanneer je KDE programma's draaien hebt op Gnome en je een oudere ubuntuversie gebruikt.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

DekuNuts

  • Gast
Wine gebruikt verkeerde geluidskaart
« Reactie #11 Gepost op: 2007/05/20, 21:10:16 »
Als je dat onboard dingetje nooit nodig zou hebben, kan je het gewoon uitschakelen in de bios en op die manier kan alles dan enkel je pci kaart gebruiken.

Offline Kev

  • Lid
  • Steunpunt: Nee
Wine gebruikt verkeerde geluidskaart
« Reactie #12 Gepost op: 2007/05/20, 21:39:18 »
Citaat van: DekuNuts
Als je dat onboard dingetje nooit nodig zou hebben, kan je het gewoon uitschakelen in de bios en op die manier kan alles dan enkel je pci kaart gebruiken.
Sorry deze optie werkt niet al uitgelegd iets hoger in de topic.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

webgnome

  • Gast
Wine gebruikt verkeerde geluidskaart
« Reactie #13 Gepost op: 2007/05/21, 20:12:29 »
Kev, ik gebruik ubuntu 6.06 LTS.
DekuNuts, ik kan helaas de onboard geluidskaart niet deactiveren of weet jij hoe dat moet op een Asus a6j notebook :P