Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: read only filesteem na instalatie Ubunti 16.04.6  (gelezen 484 keer)

Offline kuifje09

  • Lid
read only filesteem na instalatie Ubunti 16.04.6
« Gepost op: 2019/11/27, 20:35:13 »
Heel vervelend. Na instalatie 16.04.6 is het systeem onbruikbaar geworden doordat het filesysteem readonly is gemount.
Zelfs als root kan je dan niets schrijven.

Hoe kwam ik hier achter ? Omdat na de reboot na instalatie de grafische omgeving wegbleef, omdat het geen lockfile kon aanmaken in /tmp .

Dit is voor mij wel erg lang geleden dat ik dit soort fouten had en ben nu even de draad kwijt.

Als ik het systeem met Mint start is alles beschrijfbaar, na mounten uiteraard... Maar ubuntu wil het niet, ook niet na herhaald opstarten.

Ik zie hier echter nog geen draadje van, wat me vreemd lijkt, maar toch... Iemand raad misschien. Dank u wel.

Offline kuifje09

  • Lid
Re: read only filesteem na instalatie Ubunti 16.04.6
« Reactie #1 Gepost op: 2019/11/27, 21:31:01 »
Als ik na de boot het filesysteem met de hand remount  -o remount,rw , dan kan ik wel schrijven, maar,
er blijkt meer mis. Ik kan b.v. geen apt-get doen. Dat mist een stel libraries ????

Een startx levert een berg fouten op en een missing nvidia-304 o.i.d.

Ergens is iets niet gekontroleerd voor de distributie!  en dit is nog wel de 16.04.6  niet de eerste versie.

Is er iemand die een oplossing weet? want dit is wel erg bedroevend.  Maar als apt-get het al laat afweten...
Een nieuwe update vanaf CD/DVD?  lijkt me niet echt een optie.

Een restart van de upgrade naar 16.04.6? geen idee hoe ik dat doe.

Offline kuifje09

  • Lid
Re: read only filesteem na instalatie Ubunti 16.04.6
« Reactie #2 Gepost op: 2019/11/27, 22:04:40 »
Voor het geval dat dit helpt, de fout van apt en apt-get ( zelfde ) vastgelegd.

apt: relocation error: /usr/lib/i386-linux-gnu/libapt-pkg.so.5.0: symbol _ZNKSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE7compareERKS4_, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

Geen idee wat ik daar nu mee moet.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: read only filesteem na instalatie Ubunti 16.04.6
« Reactie #3 Gepost op: 2019/11/28, 13:16:57 »
Dat ziet er allemaal heel erg verkeerd uit, en zou kunnen wijzen op een sterk beschadigd bestandssysteem. Korte pijn hier: geheel vers installeren, waarbij de betreffende partities geheel gewist en opnieuw geformatteerd worden.

Offline kuifje09

  • Lid
Re: read only filesteem na instalatie Ubunti 16.04.6
« Reactie #4 Gepost op: 2019/11/28, 16:32:00 »
Ja, kan eigenlijk niet, maar kennelijk verslikt ubuntu zich nog regelmatig.
Ik was al begonnen met de restore.

Wel heel vervelend dat ubuntu na al die jaren dit soort fouten maakt.
En altijd gezeur met Nvidia, Zonder Nvidia herkend hij mijn monitor als een oude laptop i/p/v/ moderne breedbeeld.

Maar goed, heeft allemaal geen zin. kennelijk elke tweede of derde upgrade moet het mis gaan.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: read only filesteem na instalatie Ubunti 16.04.6
« Reactie #5 Gepost op: 2019/11/28, 20:44:13 »
Was dit een upgrade? Ja, dat gaat niet altijd goed. "Verse" installatie verdient de voorkeur.

Offline kuifje09

  • Lid
Re: read only filesteem na instalatie Ubunti 16.04.6
« Reactie #6 Gepost op: 2019/11/29, 20:48:23 »
Het was een upgrade, nadat ik juist de laatste updates had gedaan, En.. een backup van het zaakje.

Ik heb meerdere upgrades gedaan zonder problemen, maar het gaat wel eens fout.. Jammer, want het hoort niet.
Dan heeft er iemand steken latenvallen.

Ik zou niet weten hoe ik nu de upgrade moet doen? wellicht Nvidia eerst deleten?
Op dit systeem niet super belangrijk, maar op een tweede wel, die is ook nog 32Bits... dat wordt helemaal grappig.

Overigens heeft Dump / Restore ook een bug.

Wellicht ergens het vermelden waard?

Na een 0 dump en een stel andere en dan een 1 dump kan je voor de restore volstaan met een Resore 0 en een 1.
Helaas gaat Resore over de restore 1 mekkeren, istes in de zin van verkerd volgummer of tijd ? helaas ben ik de echte fout kwijd.

Hoe ik dat opgelost heb?

Een Systeem herstel met restore -r ... {level 0}  en daar na een Filerestore van de level 1 "tapes"

Dus een restore -r .... en daarna een restore -x -X ....  ( wel zorgen dat je op de goede plek staat waarvanaf de restore terecht komt ;)  )
Dan gaat de laatse restore geen systeem recovery doen maar files van de tape terug zetten.
Dat gaat wat langzamer, maar het werkt gelukkig wel.

Mijn systeem werkt weer inclusief Nvidia zoals hij na de laatse update was. Pfffhooeoe.  ( 14-04- )
« Laatst bewerkt op: 2019/11/29, 21:25:59 door kuifje09 »