Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ati Radeon x1600 Mobility driver problemen  (gelezen 792 keer)

webgnome

  • Gast
Ati Radeon x1600 Mobility driver problemen
« Gepost op: 2007/05/19, 00:43:20 »
Hoi best mensen,

Ik heb een tijdje terug een 'driver' update gedaan voor mijn videokaart. Althans zo dacht ik. Voor het installeren van de Ati driver uit de saveas repository  draaide World of Warcraft redelijk tot goed met Wine. Echter op dit moment draait het spel niet meer. Ik krijg als ik het spel opstart de volgende meldingen in de terminal:

fixme:midi:OSS_MidiInit Synthesizer supports MIDI in. Not yet supported.
fixme:advapi:SetSecurityInfo stub
fixme:system:SystemParametersInfoW Unimplemented action: 112 (SPI_GETMOUSESPEED)fixme:win:EnumDisplayDevicesW ((null),0,0x33edd4,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f33c,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f5dc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),0,0x33f5dc,0x00000000), stub!
fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)err:wgl:get_fbconfig_from_visualid No fbconfig found for Wine's main visual (0x26), expect problems!
err:wgl:init_formats Can't get the FBCONFIG_ID for the main visual, expect problems!
err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 0
err:wgl:get_fbconfig_from_visualid No fbconfig found for Wine's main visual (0x26), expect problems!
err:wgl:init_formats Can't get the FBCONFIG_ID for the main visual, expect problems!
err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 1
err:wgl:X11DRV_ChoosePixelFormat Can't find a matching FBCONFIG_ID for VISUAL_ID 0x26!
fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)err:wgl:get_fbconfig_from_visualid No fbconfig found for Wine's main visual (0x26), expect problems!
err:wgl:init_formats Can't get the FBCONFIG_ID for the main visual, expect problems!
err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 1
err:wgl:X11DRV_ChoosePixelFormat Can't find a matching FBCONFIG_ID for VISUAL_ID 0x26!
fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)err:wgl:get_fbconfig_from_visualid No fbconfig found for Wine's main visual (0x26), expect problems!
err:wgl:init_formats Can't get the FBCONFIG_ID for the main visual, expect problems!
err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 1
err:wgl:X11DRV_ChoosePixelFormat Can't find a matching FBCONFIG_ID for VISUAL_ID 0x26!
fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)err:wgl:get_fbconfig_from_visualid No fbconfig found for Wine's main visual (0x26), expect problems!
err:wgl:init_formats Can't get the FBCONFIG_ID for the main visual, expect problems!
err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 1
err:wgl:X11DRV_ChoosePixelFormat Can't find a matching FBCONFIG_ID for VISUAL_ID 0x26!
fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)err:wgl:get_fbconfig_from_visualid No fbconfig found for Wine's main visual (0x26), expect problems!
err:wgl:init_formats Can't get the FBCONFIG_ID for the main visual, expect problems!
err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 1
err:wgl:X11DRV_ChoosePixelFormat Can't find a matching FBCONFIG_ID for VISUAL_ID 0x26!
fixme:system:SystemParametersInfoW Unimplemented action: 113 (SPI_SETMOUSESPEED)err:wgl:get_fbconfig_from_visualid No fbconfig found for Wine's main visual (0x26), expect problems!
err:wgl:init_formats Can't get the FBCONFIG_ID for the main visual, expect problems!
err:wgl:ConvertPixelFormatWGLtoGLX invalid iPixelFormat 1
err:wgl:X11DRV_ChoosePixelFormat Can't find a matching FBCONFIG_ID for VISUAL_ID 0x26!
Hierna komt een ' windows ' popup die mij zegt dat hij 3D acceleration niet kan starten. Om het verhaal volledig te maken.

- Ik draai Ubuntu 6.0.6
Dit is mijn huidige xorg.conf file:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier     "Default Layout"
Screen      0  "aticonfig-Screen[0]" 0 0
InputDevice    "Generic Keyboard"
InputDevice    "Configured Mouse"
InputDevice    "stylus" "SendCoreEvents"
InputDevice    "cursor" "SendCoreEvents"
InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath     "/usr/share/X11/fonts/misc"
FontPath     "/usr/share/X11/fonts/cyrillic"
FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/Type1"
FontPath     "/usr/share/X11/fonts/100dpi"
FontPath     "/usr/share/X11/fonts/75dpi"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load  "i2c"
Load  "bitmap"
Load  "ddc"
Load  "dri"
Load  "extmod"
Load  "freetype"
Load  "glx"
Load  "int10"
Load  "type1"
Load  "vbe"
EndSection

Section "InputDevice"
Identifier  "Generic Keyboard"
Driver      "kbd"
Option    "CoreKeyboard"
Option    "XkbRules" "xorg"
Option    "XkbModel" "pc104"
Option    "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier  "Configured Mouse"
Driver      "mouse"
Option    "CorePointer"
Option    "Device" "/dev/input/mice"
Option    "Protocol" "ExplorerPS/2"
Option    "ZAxisMapping" "4 5"
Option    "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
Identifier  "stylus"
Driver      "wacom"
Option    "Device" "/dev/wacom"          # Change to
Option    "Type" "stylus"
Option    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
Identifier  "eraser"
Driver      "wacom"
Option    "Device" "/dev/wacom"          # Change to
Option    "Type" "eraser"
Option    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
Identifier  "cursor"
Driver      "wacom"
Option    "Device" "/dev/wacom"          # Change to
Option    "Type" "cursor"
Option    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier   "Generic Monitor"
HorizSync    28.0 - 64.0
VertRefresh  43.0 - 60.0
Option    "DPMS"
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]"
Option    "VendorName" "ATI Proprietary Driver"
Option    "ModelName" "Generic Autodetecting Monitor"
Option    "DPMS" "true"
EndSection

Section "Device"
Identifier  "ATI Technologies, Inc. ATI Default Card"
Driver      "vesa"
BusID       "PCI:1:0:0"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]"
Driver      "fglrx"
Option    "VideoOverlay" "on"
Option    "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "Default Screen"
Device     "ATI Technologies, Inc. ATI Default Card"
Monitor    "Generic Monitor"
DefaultDepth     24
SubSection "Display"
Depth     1
Modes    "1280x800"
EndSubSection
SubSection "Display"
Depth     4
Modes    "1280x800"
EndSubSection
SubSection "Display"
Depth     8
Modes    "1280x800"
EndSubSection
SubSection "Display"
Depth     15
Modes    "1280x800"
EndSubSection
SubSection "Display"
Depth     16
Modes    "1280x800"
EndSubSection
SubSection "Display"
Depth     24
Modes    "1280x800"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device     "aticonfig-Device[0]"
Monitor    "aticonfig-Monitor[0]"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "DRI"
Group        0
Mode         0666
EndSection
Kan iemand mij helpen bij het oplossen van dit probleem? Alvast bedankt. Ik kom er zelfstandig namelijk niet echt uit.