Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hoe verander ik "tcp 0.0.0.0:ssh 0.0.0.0:* LISTEN" naar "tcp *.ssh *:* LISTEN"  (gelezen 331 keer)

Offline hansvl

  • Lid
Op een Ubuntu 18 systeem heb ik openssh-server geïnstalleerd.
ssh hans@localhost werkt goed.
Vanaf een ander systeem werkt "ssh hans@<ip-address>" echter niet.
Dit komt (volgens mij) omdat op het Ubuntu 18 het commando "netstat -at | grep ssh" geeft:
tcp        0      0   0.0.0.0:ssh             0.0.0.0:*               LISTEN

Door die "0.0.0.0" luistert de sshd alleen naar de lokale host.

Op een ander systeem geeft het commando  "netstat -at | grep ssh"
tcp        0      0   *:ssh                   *:*                     LISTEN

Hoe verander ik de configuratie dat de sshd luistert naar alle ip-adressen?
Ik zou verwachten metde parameter "ListenAddress" in /etc/ssh/sshd_config maar het lukt me nog niet.
Er staat geen firewall aan.
In /etc/hosts.allow staat sshd: 192.168.0.0/24
In /etc/hosts.deny staat alleen maar commentaar.

Mijn fout. Er bleek tot een externe firewall de ssh connectie tegen te houden.
"0.0.0.0:ssh" en "0:ssh" betekend het zelfde.
 
Opgelost.
« Laatst bewerkt op: 2019/09/12, 14:56:29 door hansvl »