Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Debian 10 en Shutter  (gelezen 941 keer)

Offline EvC

  • Lid
  • Steunpunt: Nee
Debian 10 en Shutter
« Gepost op: 2019/07/10, 20:27:28 »
Debian 10 heb ik nagenoeg hetzelfde ingericht als Ubuntu, echter Shutter ontbreekt nog.
Is een redelijk recente versie nog mogelijk?



Ubuntu 20.04 Cinnamon  +  VMware Player

Offline spievensterke

  • Lid
  • Steunpunt: Nee
« Laatst bewerkt op: 2019/07/10, 23:41:50 door spievensterke »
Maté - Rolling Release 64bit.

Offline EvC

  • Lid
  • Steunpunt: Nee
Re: Debian 10 en Shutter
« Reactie #2 Gepost op: 2019/07/10, 23:54:00 »
Het Stretch package werkt niet in Buster:

Ubuntu 20.04 Cinnamon  +  VMware Player

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Debian 10 en Shutter
« Reactie #3 Gepost op: 2019/07/11, 08:15:53 »
Ik zou het niet echt adviseren om Ubuntu PPA's aan Debian toe te voegen.
Beter kun je de Stretch repositories kunnen toevoegen en dan Shutter 'pinnen' op Stretch. Nu ontbreekt mij even de tijd, maar ik zal het straks wel even uitleggen hoe dat gaat.
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Debian 10 en Shutter
« Reactie #4 Gepost op: 2019/07/11, 09:19:51 »
Op Xubuntu gebruik ik deze ppa, hiermee wordt ook de Bewerken-optie weer actief (pijltjes of cirkels plaatsen in een schermafdruk).

http://ppa.launchpad.net/linuxuprising/shutter/ubuntu

Weet niet of deze ook voor Debian werkt.

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Debian 10 en Shutter
« Reactie #5 Gepost op: 2019/07/11, 09:27:48 »
Ok, even over het 'pinnen' bij Debian. Bij Debian is het gebruikelijk dat je de Stable versie draait. Die wordt normaliter ruim twee jaar ondersteund. Daarna schuift de Stable door naar 'Old Stable'. Die wordt ook nog een jaar normaal ondersteund. Daarna heb je nog twee extra jaar ondersteuning, dat is dan de Extended service. Dat geldt alleen voor de 64 en 32 bits versie van Debian.

In het huidige geval hebben we sinds afgelopen zaterdag Buster als Stable en is Stretch nu in de Old Stable fase.

Bepaalde pakketten zijn bij Buster niet meer in gebruik, maar nog wel bij Stretch of Jessie aanwezig. In principe gebruik je die niet meer, maar je kun bepaalde pakketten nog wel gebruiken onder Buster.

Daarvoor moet je je /etc/apt/sources.list aanpassen. Zo ziet die van mij eruit:

Citaat
deb http://ftp.nl.debian.org/debian/ buster contrib non-free main
deb http://security.debian.org/debian-security/ buster/updates main contrib non-free
deb http://ftp.nl.debian.org/debian/ buster-backports main non-free contrib
# deb http://ftp.nl.debian.org/debian/ unstable main non-free contrib
# deb http://deb.debian.org/debian/ experimental main 
# deb http://ftp.nl.debian.org/debian/ stretch main non-free contrib
# deb http://ftp.nl.debian.org/debian/ jessie main non-free contrib

Je ziet hier Jessie en Stretch aanwezig, maar door het # teken uitgeschakeld. Haal dat teken weg zoals bij Buster en dan zijn de pakketten aanwezig.

Nu de truc. Je zou dan in principe een gemengd systeem krijgen. Dat is dus niet de bedoeling. Hiervoor maken we in de directory /etc/apt een bestandje aan met de naam preferences

Dat ziet er bij mij zo uit:
Citaat
Package:*
Pin: release a=buster
Pin-Priority: 900

Package:*
Pin: release a=unstable
Pin-Priority: 300

Package:*
Pin: release a=experimental
Pin-Priority: 100

Package:*
Pin: release a=stretch
Pin-Priority: 100

#Package:*
#Pin: release a=jessie
#Pin-Priority: 100

Je ziet bij elke versie van Debian een regel beginnend met Pin-Priority: met daarachter een getal. Hoe hoger het getal, hoe hoger de prioriteit. Bij elke update of installatie heeft de versie met de hoogste prioriteit voorrang op de andere.
Je kunt hier dus zien dat Buster voorrang heeft boven Unstable en dat heeft weer voorrang op Stretch enz.

Je kunt ook ipv Package:* alleen een pakketnaam invullen. In jouw geval dus bij Stretch package: shutter. Dan wordt alleen het pakket Shutter met de afhankelijkheden opgehaald en bijgewerkt vanauit Stretch.

Stel dat je ruzie hebt met de nieuwere versie van VLC, dan kun je bij Stretch invullen: Package: shutter vlc

Dit even in het kort. Op het internet kun je veel meer informatie vinden, maar dit is voor jou misschien een nieuwe richting die je kunt beandelen.
« Laatst bewerkt op: 2019/07/11, 09:29:26 door h2o »
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Debian 10 en Shutter
« Reactie #6 Gepost op: 2019/07/11, 15:29:00 »
Je zou met mijn aanwijzingen ook het volgende kunnen doen:
sudo apt install -t stretch shutterDan forceer je een installatie vanuit de Strech pakketten.
Laptops , tablets + werkstations: Debian Buster
Test-laptop: Debian Testing/Unstable

DarkEra

  • Gast
Re: Debian 10 en Shutter
« Reactie #7 Gepost op: 2019/07/11, 15:47:23 »
De reden dat shutter niet meer in Debian zit is niet voor niets:
Google vertaling:
Citaat
De populaire screenshot-tool, die Gtk2 en Perl gebruikt, was een van de weinige pakketten die Debian (en Ubuntu) blokkeerden om het verouderde libgnome2-perl en libgnome2-vfs-perl uit het archief van de repository te verwijderen. Aangezien Shutter niet werkt zonder deze pakketten, is deze verwijderd uit de Debian Unstable en Ubuntu 18.10-repositories.
https://www.linuxuprising.com/2018/10/shutter-removed-from-ubuntu-1810-and.html
« Laatst bewerkt op: 2019/07/11, 15:50:50 door Maik »

Offline EvC

  • Lid
  • Steunpunt: Nee
Re: Debian 10 en Shutter
« Reactie #8 Gepost op: 2019/07/11, 20:08:09 »
Tja, welk compromis is wijs: tweaken met de oplossing van h20 of toch maar Flameshot gebruiken (hoewel het nog geen file editor heeft)?
Er zijn meer applicaties die nog niet geschikt gemaakt zijn voor Debian 10.
De distributie is nog pril.
Ubuntu 20.04 Cinnamon  +  VMware Player

Offline rico70

  • Lid
  • Steunpunt: Nee
Re: Debian 10 en Shutter
« Reactie #9 Gepost op: 2019/07/11, 20:38:28 »
Of Debian 9 blijven gebruiken als daar wel alles inzit wat je nodig hebt / wilt gebruiken.