Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: HPLIP opnieuw installeren  (gelezen 664 keer)

Offline molly w

  • Lid
HPLIP opnieuw installeren
« Gepost op: 2019/05/21, 14:04:39 »
Ik heb wat problemen met mijn printer: HP 2575. De scan-opdrachten vanaf de computer mislukken: communicatiefout. Een testpagina printer gaat probleemloos. ook heb ik de printer verwijderd en opnieuw toegevoegd, dat werkte soms als er printproblemen waren, maar nu maakt dat niet uit. Het ligt niet aan de printer, vanaf een laptop met Windows7 gaat scannen prima.
Het zou te maken kunnen hebben met problemen die ik heb gehad van /dev/sda6 en die ik tot twee keer toe heb moeten verhelpen met fsck. Daarom dacht ik dat ik misschien het stuurprogramma opnieuw moet installeren. Maar hoe doe ik dat?
Voorheen kreeg ik elke keer als er nieuwe versie beschikbaar was, een popup met de optie 'install' en dan kon een kind de was doen. Maar die zie ik na mint 19 installeren niet meer. En ik weet niet meer hoe ik deze hplip geïntalleerd heb. Via de Terminal, dan wel.
Ik heb een map met bestanden van HPLIP 3.19.1 op mijn NAS staan.
« Laatst bewerkt op: 2019/05/21, 14:06:37 door molly w »

Offline peer

  • Lid
  • Steunpunt: Nee
Re: HPLIP opnieuw installeren
« Reactie #1 Gepost op: 2019/05/21, 15:11:45 »
hplip zit, volgens mij,  gewoon in de repo's. Bij mij in Debian 10 zie ik hplip versie 3.18
In de terminal doe je:
sudo apt install hplip
In synaptic is het gewoon een kwestie van opzoeken en aanklikken

Offline molly w

  • Lid
Re: HPLIP opnieuw installeren
« Reactie #2 Gepost op: 2019/05/22, 10:32:57 »
HPLIP opnieuw geïnstalleerd, via programmabeheer. Maar probleem is niet verholpen. Scannen stopt als de "lichtbalk" even heeft bewogen.

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: HPLIP opnieuw installeren
« Reactie #3 Gepost op: 2019/05/22, 11:38:52 »
Probeer eens het volgende:
sudo apt purge hplip*
sudo apt autoremove
sudo apt install hplip-gui
Tien vauten voorbehouden, ik zit even met een tablet.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline molly w

  • Lid
Re: HPLIP opnieuw installeren
« Reactie #4 Gepost op: 2019/05/22, 13:57:40 »
Gedaan.
Terminal meldde:
naam@PC:~$ sudo apt purge hplip*
[sudo] wachtwoord voor Naam:         
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
Let op, 'hplip-data' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-doc' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-gui' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-cups' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-ppds' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Pakket 'hplip-cups' is niet geïnstalleerd, en wordt dus niet verwijderd
Let op, 'hpijs-ppds' wordt geselecteerd in plaats van 'hplip-ppds'
Pakket 'hplip-doc' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'hplip-gui' is niet geïnstalleerd, en wordt dus niet verwijderd
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  cabextract icoutils libopenal-data libopenal1 libwine libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 python-wxgtk3.0 python-wxversion
Gebruik 'sudo apt autoremove' om ze te verwijderen.
De volgende pakketten zullen VERWIJDERD worden:
  hplip* hplip-data*
0 opgewaardeerd, 0 nieuw geïnstalleerd, 2 te verwijderen en 63 niet opgewaardeerd.
Na deze bewerking zal er 11,7 MB schijfruimte vrijkomen.
Wilt u doorgaan? [J/n] J
(Database wordt ingelezen ... 289347 bestanden en mappen momenteel geïnstalleerd.)
hplip (3.17.10+repack0-5) wordt verwijderd ...
hplip-data (3.17.10+repack0-5) wordt verwijderd ...
dpkg: waarschuwing: tijdens verwijderen van hplip-data blijkt map '/usr/share/hplip/data/images/other' niet leeg en wordt dus niet verwijderd
dpkg: waarschuwing: tijdens verwijderen van hplip-data blijkt map '/usr/share/hplip/base' niet leeg en wordt dus niet verwijderd
Bezig met afhandelen van triggers voor man-db (2.8.3-2ubuntu0.1) ...
Bezig met afhandelen van triggers voor dbus (1.12.2-1ubuntu1) ...
(Database wordt ingelezen ... 288732 bestanden en mappen momenteel geïnstalleerd.)
Configuratiebestanden voor hplip (3.17.10+repack0-5) worden gewist ...
Bezig met afhandelen van triggers voor dbus (1.12.2-1ubuntu1) ...
Fout: Tijd is verlopen
Naam@PC:~$ sudo apt purge hplip*
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
Let op, 'hplip-data' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-doc' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-gui' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-cups' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Let op, 'hplip-ppds' wordt geselecteerd omwille van expansie (glob) 'hplip*'
Pakket 'hplip-cups' is niet geïnstalleerd, en wordt dus niet verwijderd
Let op, 'hpijs-ppds' wordt geselecteerd in plaats van 'hplip-ppds'
Pakket 'hplip' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'hplip-data' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'hplip-doc' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'hplip-gui' is niet geïnstalleerd, en wordt dus niet verwijderd
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  cabextract icoutils libopenal-data libopenal1 libwine libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 python-wxgtk3.0 python-wxversion
Gebruik 'sudo apt autoremove' om ze te verwijderen.
0 opgewaardeerd, 0 nieuw geïnstalleerd, 0 te verwijderen en 63 niet opgewaardeerd.
wiegerinck@PCZolder:~$ sudo apt autoremove
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
De volgende pakketten zullen VERWIJDERD worden:
  cabextract icoutils libopenal-data libopenal1 libwine libwxbase3.0-0v5
  libwxgtk3.0-gtk3-0v5 python-wxgtk3.0 python-wxversion
0 opgewaardeerd, 0 nieuw geïnstalleerd, 9 te verwijderen en 63 niet opgewaardeerd.
Na deze bewerking zal er 230 MB schijfruimte vrijkomen.
Wilt u doorgaan? [J/n] J
(Database wordt ingelezen ... 288731 bestanden en mappen momenteel geïnstalleerd.)
cabextract (1.6-1.1) wordt verwijderd ...
icoutils (0.32.3-1) wordt verwijderd ...
libwine:i386 (3.0-1ubuntu1) wordt verwijderd ...
libopenal1:i386 (1:1.18.2-2) wordt verwijderd ...
libopenal-data (1:1.18.2-2) wordt verwijderd ...
python-wxgtk3.0 (3.0.2.0+dfsg-7) wordt verwijderd ...
libwxgtk3.0-gtk3-0v5:i386 (3.0.4+dfsg-3) wordt verwijderd ...
libwxbase3.0-0v5:i386 (3.0.4+dfsg-3) wordt verwijderd ...
python-wxversion (3.0.2.0+dfsg-7) wordt verwijderd ...
Bezig met afhandelen van triggers voor libc-bin (2.27-3ubuntu1) ...
Bezig met afhandelen van triggers voor man-db (2.8.3-2ubuntu0.1) ...
wiegerinck@PCZolder:~$ sudo apt install hplip-gui
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
De volgende extra pakketten zullen geïnstalleerd worden:
  hplip hplip-data libqt5designer5 libqt5help5 libqt5printsupport5 libqt5sql5
  libqt5test5 libqt5xml5 python3-dbus.mainloop.pyqt5 python3-pyqt5 python3-sip
Voorgestelde pakketten:
  hplip-doc python3-notify2 python3-pyqt5-dbg
Aanbevolen pakketten:
  printer-driver-postscript-hp python3-notify2 libqt5sql5-sqlite
  | libqt5sql5-mysql | libqt5sql5-odbc | libqt5sql5-psql | libqt5sql5-tds
  | libqt5sql5-ibase
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  hplip hplip-data hplip-gui libqt5designer5 libqt5help5 libqt5printsupport5
  libqt5sql5 libqt5test5 libqt5xml5 python3-dbus.mainloop.pyqt5 python3-pyqt5
  python3-sip
0 opgewaardeerd, 12 nieuw geïnstalleerd, 0 te verwijderen en 63 niet opgewaardeerd.
Er moeten 12,1 MB/13,1 MB aan archieven opgehaald worden.
Na deze bewerking zal er 36,7 MB extra schijfruimte gebruikt worden.
Wilt u doorgaan? [J/n] J
Ophalen:1 http://archive.ubuntu.com/ubuntu bionic/main i386 hplip-data all 3.17.10+repack0-5 [6392 kB]
Ophalen:2 http://archive.ubuntu.com/ubuntu bionic/universe i386 python3-dbus.mainloop.pyqt5 i386 5.10.1+dfsg-1ubuntu2 [14,0 kB]
Ophalen:3 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libqt5xml5 i386 5.9.5+dfsg-0ubuntu2 [110 kB]
Ophalen:4 http://archive.ubuntu.com/ubuntu bionic/universe i386 libqt5designer5 i386 5.9.5-0ubuntu1 [2881 kB]
Ophalen:5 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libqt5sql5 i386 5.9.5+dfsg-0ubuntu2 [128 kB]
Ophalen:6 http://archive.ubuntu.com/ubuntu bionic/universe i386 libqt5help5 i386 5.9.5-0ubuntu1 [153 kB]
Ophalen:7 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libqt5printsupport5 i386 5.9.5+dfsg-0ubuntu2 [193 kB]
Ophalen:8 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 libqt5test5 i386 5.9.5+dfsg-0ubuntu2 [103 kB]
Ophalen:9 http://archive.ubuntu.com/ubuntu bionic/universe i386 python3-sip i386 4.19.7+dfsg-1 [76,8 kB]
Ophalen:10 http://archive.ubuntu.com/ubuntu bionic/universe i386 python3-pyqt5 i386 5.10.1+dfsg-1ubuntu2 [2027 kB]
Ophalen:11 http://archive.ubuntu.com/ubuntu bionic/universe i386 hplip-gui all 3.17.10+repack0-5 [19,0 kB]
12,1 MB opgehaald in 3s (3832 kB/s)   
Voorheen niet geselecteerd pakket hplip-data wordt geselecteerd.
(Database wordt ingelezen ... 286418 bestanden en mappen momenteel geïnstalleerd.)
Uitpakken van .../00-hplip-data_3.17.10+repack0-5_all.deb wordt voorbereid...
Bezig met uitpakken van hplip-data (3.17.10+repack0-5) ...
Voorheen niet geselecteerd pakket hplip wordt geselecteerd.
Uitpakken van .../01-hplip_3.17.10+repack0-5_i386.deb wordt voorbereid...
Bezig met uitpakken van hplip (3.17.10+repack0-5) ...
Voorheen niet geselecteerd pakket python3-dbus.mainloop.pyqt5 wordt geselecteerd.
Uitpakken van .../02-python3-dbus.mainloop.pyqt5_5.10.1+dfsg-1ubuntu2_i386.deb wordt voorbereid...
Bezig met uitpakken van python3-dbus.mainloop.pyqt5 (5.10.1+dfsg-1ubuntu2) ...
Voorheen niet geselecteerd pakket libqt5xml5:i386 wordt geselecteerd.
Uitpakken van .../03-libqt5xml5_5.9.5+dfsg-0ubuntu2_i386.deb wordt voorbereid...
Bezig met uitpakken van libqt5xml5:i386 (5.9.5+dfsg-0ubuntu2) ...
Voorheen niet geselecteerd pakket libqt5designer5:i386 wordt geselecteerd.
Uitpakken van .../04-libqt5designer5_5.9.5-0ubuntu1_i386.deb wordt voorbereid...
Bezig met uitpakken van libqt5designer5:i386 (5.9.5-0ubuntu1) ...
Voorheen niet geselecteerd pakket libqt5sql5:i386 wordt geselecteerd.
Uitpakken van .../05-libqt5sql5_5.9.5+dfsg-0ubuntu2_i386.deb wordt voorbereid...
Bezig met uitpakken van libqt5sql5:i386 (5.9.5+dfsg-0ubuntu2) ...
Voorheen niet geselecteerd pakket libqt5help5:i386 wordt geselecteerd.
Uitpakken van .../06-libqt5help5_5.9.5-0ubuntu1_i386.deb wordt voorbereid...
Bezig met uitpakken van libqt5help5:i386 (5.9.5-0ubuntu1) ...
Voorheen niet geselecteerd pakket libqt5printsupport5:i386 wordt geselecteerd.
Uitpakken van .../07-libqt5printsupport5_5.9.5+dfsg-0ubuntu2_i386.deb wordt voorbereid...
Bezig met uitpakken van libqt5printsupport5:i386 (5.9.5+dfsg-0ubuntu2) ...
Voorheen niet geselecteerd pakket libqt5test5:i386 wordt geselecteerd.
Uitpakken van .../08-libqt5test5_5.9.5+dfsg-0ubuntu2_i386.deb wordt voorbereid...
Bezig met uitpakken van libqt5test5:i386 (5.9.5+dfsg-0ubuntu2) ...
Voorheen niet geselecteerd pakket python3-sip wordt geselecteerd.
Uitpakken van .../09-python3-sip_4.19.7+dfsg-1_i386.deb wordt voorbereid...
Bezig met uitpakken van python3-sip (4.19.7+dfsg-1) ...
Voorheen niet geselecteerd pakket python3-pyqt5 wordt geselecteerd.
Uitpakken van .../10-python3-pyqt5_5.10.1+dfsg-1ubuntu2_i386.deb wordt voorbereid...
Bezig met uitpakken van python3-pyqt5 (5.10.1+dfsg-1ubuntu2) ...
Voorheen niet geselecteerd pakket hplip-gui wordt geselecteerd.
Uitpakken van .../11-hplip-gui_3.17.10+repack0-5_all.deb wordt voorbereid...
Bezig met uitpakken van hplip-gui (3.17.10+repack0-5) ...
Bezig met afhandelen van triggers voor mime-support (3.60ubuntu1) ...
Bezig met afhandelen van triggers voor desktop-file-utils (0.23+linuxmint5) ...
Instellen van libqt5test5:i386 (5.9.5+dfsg-0ubuntu2) ...
Instellen van hplip-data (3.17.10+repack0-5) ...
Instellen van libqt5printsupport5:i386 (5.9.5+dfsg-0ubuntu2) ...
Bezig met afhandelen van triggers voor libc-bin (2.27-3ubuntu1) ...
Instellen van libqt5xml5:i386 (5.9.5+dfsg-0ubuntu2) ...
Instellen van libqt5sql5:i386 (5.9.5+dfsg-0ubuntu2) ...
Instellen van python3-sip (4.19.7+dfsg-1) ...
Bezig met afhandelen van triggers voor man-db (2.8.3-2ubuntu0.1) ...
Bezig met afhandelen van triggers voor gnome-menus (3.13.3-11ubuntu1.1) ...
Bezig met afhandelen van triggers voor dbus (1.12.2-1ubuntu1) ...
Instellen van libqt5designer5:i386 (5.9.5-0ubuntu1) ...
Instellen van python3-dbus.mainloop.pyqt5 (5.10.1+dfsg-1ubuntu2) ...
Instellen van hplip (3.17.10+repack0-5) ...
Creating/updating hplip user account...
dpkg-statoverride: waarschuwing: --update is opgegeven maar /var/run/hplip bestaat niet
Instellen van libqt5help5:i386 (5.9.5-0ubuntu1) ...
Instellen van python3-pyqt5 (5.10.1+dfsg-1ubuntu2) ...
Instellen van hplip-gui (3.17.10+repack0-5) ...
Bezig met afhandelen van triggers voor libc-bin (2.27-3ubuntu1) ...
Bezig met afhandelen van triggers voor dbus (1.12.2-1ubuntu1) ...
naam@PC:~$

Ik zag dat
  • er drie waarschuwingen in voorkwamen
  • na de eerste ronde 'purge' de tijd om was.
Wat betekent dat?

Bovendien: HP Printing System Control Center start niet

Offline molly w

  • Lid
Re: HPLIP opnieuw installeren
« Reactie #5 Gepost op: 2019/05/23, 13:20:56 »
Nog wat geprobeerd.
Het programmaatje Simple Scan scant wél.
Zou het probleem ook bij Xsane kunnen liggen??