Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: pdf shuffler start niet  (gelezen 627 keer)

Offline molly w

  • Lid
pdf shuffler start niet
« Gepost op: 2019/03/17, 20:05:55 »
Vanmiddag heb ik Pdf-shuffler geïnstalleerd, eerst met een download van sourceforge, later mbv programma beheer. Maar de starter in het menu doet niks. In de opdrachtregel staat alleen "Pdf-shuffler", meer niet.
In menu beheer lees ik over een parserfout: /usr/bin/policytool zou ontbreken in het pad.
Policytool stond inderdaad niet in mijn systeem. Ik heb het geïnstalleerd, maar nu laat programma beheerder zich niet meer zien. De starter in het menu aanklikken, de startmelder draait een tijdje en dan: niets. Wat is er aan de hand?

Offline steef76

  • Lid
  • Steunpunt: Nee
Re: pdf shuffler start niet
« Reactie #1 Gepost op: 2019/03/17, 21:08:26 »
Hoi,

Heb het net even via synaptic geinstalleerd en hier geen problemen. Het progje start gewoon op.

Misschien moet je het via synaptic even volledig verwijderen en met synaptic opnieuw installeren.

groet,

Steven

Offline molly w

  • Lid
Re: pdf shuffler start niet
« Reactie #2 Gepost op: 2019/03/18, 12:01:41 »
Kun je me de code geven waarmee je dat doet. Synaptic, de term zie ik geregeld voorbij komen maar het blijft chinees voor me.
Volledig verwijderen, dan is ook de starter in het menu weg? Die blijft namelijk hardnekkig staan, ook als ik hem met menubeheer dacht verwijderd te hebben.

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: pdf shuffler start niet
« Reactie #3 Gepost op: 2019/03/18, 15:25:40 »
Ik weet niet hoe het bij Ununtu is, maar pdfshuffler kan ik bij Debian gewoon installeren via synaptic. Bij de nieuwe versie van Debian heet het nu pdfarranger. Misschien moet je daar eens op gaan zoeken?
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Testing/Unstable

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: pdf shuffler start niet
« Reactie #4 Gepost op: 2019/03/18, 15:52:47 »
In Ubuntu kan je het ook via Synaptic installeren
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu Gnome 18.04/Xubuntu 18.04; Windows 10 (dualboot) RPI: Ubuntu Mate; Asus 1005PE: Linux Lite 3.8
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: pdf shuffler start niet
« Reactie #5 Gepost op: 2019/03/18, 15:58:34 »
Kun je me de code geven waarmee je dat doet. Synaptic, de term zie ik geregeld voorbij komen maar het blijft chinees voor me.
Volledig verwijderen, dan is ook de starter in het menu weg? Die blijft namelijk hardnekkig staan, ook als ik hem met menubeheer dacht verwijderd te hebben.

Je kan het via de terminal installeren.
Terminal kan je oproepen via <crtl>+<alt>+t

sudo apt install synaptic
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu Gnome 18.04/Xubuntu 18.04; Windows 10 (dualboot) RPI: Ubuntu Mate; Asus 1005PE: Linux Lite 3.8
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: pdf shuffler start niet
« Reactie #6 Gepost op: 2019/03/18, 17:41:50 »
Ik heb het hier zonder probleem eens geïnstalleerd.

  • Probeer het eens te starten via een terminalcommando. Dan komen er mogelijk foutmeldingen die een idee kunnen geven van het probleem. 1) Open de terminal 2) geef het commando pdfshuffler in, gevolgd door een druk op de <enter> toets.
  • Dat jou softwarecentrum niet start, kan wijzen op een probleem met je pakketbeheer. Controleer eens of dat nog goed werkt met het commando sudo apt -f install. Als hier na vier lijntjes iets uitkomt als 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded., dan zit je goed. Heb je foutmeldingen, dan zal je je pakketbeheer moeten repareren (mogelijk is het uitvoeren van dit commando al voldoende voor de reparatie).

Offline molly w

  • Lid
Re: pdf shuffler start niet
« Reactie #7 Gepost op: 2019/03/19, 11:13:33 »
Terminal gaf terug op sudo -f apt installhet volgende:
apt
Usage: apt command [options]
       apt help command [options]

Commands:
  add-repository   - Add entries to apt sources.list
  autoclean        - Erase old downloaded archive files
  autoremove       - Remove automatically all unused packages
  build            - Build binary or source packages from sources
  build-dep        - Configure build-dependencies for source packages
  changelog        - View a package's changelog
  check            - Verify that there are no broken dependencies
  clean            - Erase downloaded archive files
  contains         - List packages containing a file
  content          - List files contained in a package
  deb              - Install a .deb package
  depends          - Show raw dependency information for a package
  dist-upgrade     - Upgrade the system by removing/installing/upgrading packages
  download         - Download the .deb file for a package
  edit-sources     - Edit /etc/apt/sources.list with your preferred text editor
  dselect-upgrade  - Follow dselect selections
  full-upgrade     - Same as 'dist-upgrade'
  held             - List all held packages
  help             - Show help for a command
  hold             - Hold a package
  install          - Install/upgrade packages
  list             - List packages based on package names
  policy           - Show policy settings
  purge            - Remove packages and their configuration files
  recommends       - List missing recommended packages for a particular package
  rdepends         - Show reverse dependency information for a package
  reinstall        - Download and (possibly) reinstall a currently installed package
  remove           - Remove packages
  search           - Search for a package by name and/or expression
  show             - Display detailed information about a package
  showhold         - Same as 'held'
  source           - Download source archives
  sources          - Same as 'edit-sources'
  unhold           - Unhold a package
  update           - Download lists of new/upgradable packages
  upgrade          - Perform a safe upgrade
  version          - Show the installed version of a package

Offline molly w

  • Lid
Re: pdf shuffler start niet
« Reactie #8 Gepost op: 2019/03/19, 11:16:05 »
    Ik heb het hier zonder probleem eens geïnstalleerd.

    • Probeer het eens te starten via een terminalcommando. Dan komen er mogelijk foutmeldingen die een idee kunnen geven van het probleem. 1) Open de terminal 2) geef het commando pdfshuffler in, gevolgd door een druk op de <enter> toets.
    [/li]
    [/list]
    Gedaan. Terminal zegt:
    ~$ pdfshuffler
    Error: Could not import pdfshuffler
    Cause: No module named pyPdf
    Er ontbreekt wat. Ik heb Pdf shuffler geïnstalleerd via programmabeheer (zo heet dat in Linux19)

    Offline vanadium

    • Lid
    • Steunpunt: Nee
    Re: pdf shuffler start niet
    « Reactie #9 Gepost op: 2019/03/19, 13:02:37 »
    Waarom heb je er sudo -f apt install van gemaakt als er stond  sudo apt -f install? Het is altijd een goed idee een terminal opdracht te kopiëren en te plakken - dit verlaagt de kans op fouten.

    Je tweede output geeft aan dat een pythonmodule ontbreekt. Probeer eens een herinstallatie
    sudo apt install --reinstall pdfshuffler

    Als dat niet lukt, post de foutmeldjng dan hier. Dit kan het geval zijn als je pakketsysteem inderdaad niet consistent is.

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #10 Gepost op: 2019/03/19, 15:04:33 »
    Waarom heb je er sudo -f apt install van gemaakt als er stond  sudo apt -f install? Het is altijd een goed idee een terminal opdracht te kopiëren en te plakken - dit verlaagt de kans op fouten.
    Oeps typefout. Maar de uitkomst is hetzelfde. Terminal leest ook ongeschreven bedoelingen :)

    Citaat
    Je tweede output geeft aan dat een pythonmodule ontbreekt. Probeer eens een herinstallatie
    sudo apt install --reinstall pdfshuffler

    Als dat niet lukt, post de foutmeldjng dan hier. Dit kan het geval zijn als je pakketsysteem inderdaad niet consistent is.
    Blijft hetzelfde. Foutmelding:
    ~$ pdfshuffler
    Error: Could not import pdfshuffler
    Cause: No module named pyPdf
    « Laatst bewerkt op: 2019/03/19, 15:07:55 door molly w »

    Offline vanadium

    • Lid
    • Steunpunt: Nee
    Re: pdf shuffler start niet
    « Reactie #11 Gepost op: 2019/03/19, 15:50:09 »
    Blijft hetzelfde. Foutmelding:
    ~$ pdfshuffler
    Error: Could not import pdfshuffler
    Cause: No module named pyPdf
    Dat is niet de uitvoer van sudo apt install --reinstall pdfshuffler. Is de herinstallatie wel goed gegaan in de eerste plaats?

    python-pypdf2 is een afhankelijkheid van pdfshuffler, dus zou automatisch mee geïnstalleerd moeten worden. Nu heb je eerst geinstalleerd via sourceforge, dus ik denk dat daar nog sporen van kunnen aanwezig zijn op je systeem die het probleem veroorzaken. Misschien wordt nog de executable van die eerste installatie aangeroepen.

    Mocht python-pypdf2 nog niet geïnstalleerd zijn bij jou, dan volstaat het misschien dit pakket er nog even bij te installeren.

    Maar opnieuw, ik heb nog steeds geen aanduiding of jou pakketbeheer nu nog in orde is of niet.
    « Laatst bewerkt op: 2019/03/19, 15:59:06 door vanadium »

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #12 Gepost op: 2019/03/20, 11:01:07 »
    pfdshuffler reïnstall uitgevoerd. Terminal geeft terug:
    sudo apt install --reinstall pdfshuffler
    [sudo] wachtwoord voor wiegerinck:
    Pakketlijsten worden ingelezen... Klaar
    Boom van vereisten wordt opgebouwd       
    De statusinformatie wordt gelezen... Klaar
    De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
      cabextract gir1.2-rsvg-2.0 icoutils libcairo-script-interpreter2
      libcairo2-dev libdjvulibre-dev libfontconfig1-dev libgdk-pixbuf2.0-dev
      libgsoap-2.8.60 libilmbase-dev liblqr-1-0-dev libmagick++-6-headers
      libmagick++-6.q16-7 libmagick++-6.q16-dev libmagickcore-6-arch-config
      libmagickcore-6-headers libmagickcore-6.q16-dev libmagickwand-6-headers
      libmagickwand-6.q16-dev libopenal-data libopenal1 libopenexr-dev
      libpixman-1-dev libqt5opengl5 libqt5printsupport5 libqt5x11extras5
      librsvg2-dev libvncserver1 libwine libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5
      libxcb-render0-dev libxcb-shm0-dev libxrender-dev libxt-dev python-wxgtk3.0
      python-wxversion virtualbox virtualbox-dkms
    Gebruik 'sudo apt autoremove' om ze te verwijderen.
    0 opgewaardeerd, 0 nieuw geïnstalleerd, 1 opnieuw geïnstalleerd, 0 te verwijderen en 523 niet opgewaardeerd.
    Er moeten 0 B/31,4 kB aan archieven opgehaald worden.
    Na deze bewerking zal er 0 B extra schijfruimte gebruikt worden.
    (Database wordt ingelezen ... 255189 bestanden en mappen momenteel geïnstalleerd.)
    Uitpakken van .../pdfshuffler_0.6.0-8_all.deb wordt voorbereid...
    Bezig met uitpakken van pdfshuffler (0.6.0-8) over (0.6.0-8) ...
    Bezig met afhandelen van triggers voor mime-support (3.60ubuntu1) ...
    Bezig met afhandelen van triggers voor desktop-file-utils (0.23+linuxmint3) ...
    Instellen van pdfshuffler (0.6.0-8) ...
    Bezig met afhandelen van triggers voor man-db (2.8.3-2) ...
    Bezig met afhandelen van triggers voor gnome-menus (3.13.3-11ubuntu1) ...
    Bezig met afhandelen van triggers voor hicolor-icon-theme (0.17-2) ...

    Hierna poging tot start vanuit hoofdmenu: geen reactie
    Start vanuit terminal: dezelfde foutmeldingen als eerder. Dus gaat nog steeds niet goed.

    Volgens programmabeheer (zo heet pakketbeheer nu in Linux19) is Pdf-shuffler nu geïnstalleerd.
    Als er restanten zijn van vorige installatiepogingen, hoe krijg ik die weg?? Met wortel en tak uitgeroeid. Volgens mij heb ik eerder via programmabeheer Pdfshuffler verwijderd, maar dat zou dan niet radicaal zijn gebeurd.

    Controle gedaan of programmabeheer goed werkt met sudo apt -f install. (had ik al eerder gedaan op jouw aanraden)
    Daar komen geen foutmeldingen uit, ook geen 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded of zoiets.
    Wel een lijst commando's. Is het de bedoeling een van die commando's te gebruiken om na te gaan of programmabeheer in orde is? Ja sorry, ik ben wat dat betreft een nitwit.
    « Laatst bewerkt op: 2019/03/20, 11:33:42 door molly w »

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #13 Gepost op: 2019/03/20, 11:17:44 »
    Zoals je aangaf  python-pypdf2 geïnstalleerd.
    ~$ sudo apt install python-pypdf2
    [sudo] wachtwoord voor wiegerinck:
    Pakketlijsten worden ingelezen... Klaar
    Boom van vereisten wordt opgebouwd       
    De statusinformatie wordt gelezen... Klaar
    python-pypdf2 is reeds de nieuwste versie (1.26.0-2).
    De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
      cabextract gir1.2-rsvg-2.0 icoutils libcairo-script-interpreter2
      libcairo2-dev libdjvulibre-dev libfontconfig1-dev libgdk-pixbuf2.0-dev
      libgsoap-2.8.60 libilmbase-dev liblqr-1-0-dev libmagick++-6-headers
      libmagick++-6.q16-7 libmagick++-6.q16-dev libmagickcore-6-arch-config
      libmagickcore-6-headers libmagickcore-6.q16-dev libmagickwand-6-headers
      libmagickwand-6.q16-dev libopenal-data libopenal1 libopenexr-dev
      libpixman-1-dev libqt5opengl5 libqt5printsupport5 libqt5x11extras5
      librsvg2-dev libvncserver1 libwine libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5
      libxcb-render0-dev libxcb-shm0-dev libxrender-dev libxt-dev python-wxgtk3.0
      python-wxversion virtualbox virtualbox-dkms
    Gebruik 'sudo apt autoremove' om ze te verwijderen.
    0 opgewaardeerd, 0 nieuw geïnstalleerd, 0 te verwijderen en 523 niet opgewaardeerd.
    Daarna start pdfshuffler
    Geen positief resultaat, foutmeldingen blijven hetzelfde.
    Pdfshuffler verwijderen met commando sudo apt remove pdfshuffler ? Of dat is dat niet goede commando?
    En daarna opnieuw installeren sudo apt install pdfshuffler
    « Laatst bewerkt op: 2019/03/20, 11:32:25 door molly w »

    Offline vanadium

    • Lid
    • Steunpunt: Nee
    Re: pdf shuffler start niet
    « Reactie #14 Gepost op: 2019/03/20, 11:20:39 »
    Die installatie lijkt alvast goed te gaan. Ook bij mij versie 0.6.0-8, en dat gaat zonder problemen. Het moet te maken hebben met die vorige installatie via sourceforge. Kan je eens aangeven welke de executable is van pdfshuffler:

    which pdfshuffler
    en post ook eens je PATH
    echo $PATH

    Terzijde: doe jezelf een plezier en ruim overbodige pakketten op met:
    sudo apt autoremove

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #15 Gepost op: 2019/03/20, 14:27:26 »
    Die installatie lijkt alvast goed te gaan. Ook bij mij versie 0.6.0-8, en dat gaat zonder problemen. Het moet te maken hebben met die vorige installatie via sourceforge. Kan je eens aangeven welke de executable is van pdfshuffler:

    which pdfshuffler
    Dit is antwoord: $ which pdfshuffler
    /usr/local/bin/pdfshuffler

    en post ook eens je PATH
    echo $PATH
    Path is $ echo $PATH
    /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
    - usr/local/sbin is leeg.
    - usr/local/bin bevat o.a. pdfshuffler, een python script
    - usr/sbin bevat van alles, maar geen pdf*** noch iets van python
    - usr/bin bevat o.a. pdfshuffler. een python script
    - sbin bevat van alles, maar geen pdf*** noch iets van python
    - bin bevat o.a. pdfshuffler, een python script
    - usr/game bevat 1 bestand maar geen pdfshuffler noch python
    - usr/local games is leeg.
    Dat pdfshuffler in meerdere mappen staat, levert dat geen conflicten op? Of hoort dat bij Linux en zo: dat overal iets staat?

    Terzijde: doe jezelf een plezier en ruim overbodige pakketten op met:
    sudo apt autoremove
    Gedaan.  :) Had ik al wel aan zitten denken, maar toch bang belangrijke, onmisbare bestanden weg te gooien.
    « Laatst bewerkt op: 2019/03/20, 14:42:02 door molly w »

    Offline vanadium

    • Lid
    • Steunpunt: Nee
    Re: pdf shuffler start niet
    « Reactie #16 Gepost op: 2019/03/20, 14:38:48 »
    Zeker toch dat het ook niet lukt als je opstart uit de terminal? Laatste poging: eens grondiger verwijderen en herinstalleren

    sudo apt purge pdfshuffler
    sudo apt remove python-pypdf2
    sudo apt install pdfshuffler

    Test altijd eerst door op te starten via de terminal: dan wordt een mogelijk probleem met de starter omzeilt. Lukt het nog niet, maak dan (tijdelijk) een nieuwe account aan, en start pdfshuffler op vanuit de nieuwe account. dat om uit te sluiten dat het probleem zit in een gebruikersconfiguratie (na zoveel herinstallaties begint het daar op te lijken).

    Je hebt toch geen vreemde PPA's actief waar mogelijk die pdfshuffler vandaan komt?

    Offline steef76

    • Lid
    • Steunpunt: Nee
    Re: pdf shuffler start niet
    « Reactie #17 Gepost op: 2019/03/20, 14:55:20 »
    Citaat
    Je hebt toch geen vreemde PPA's actief waar mogelijk die pdfshuffler vandaan komt?

    Molly heeft het van sourceforge gedownload & geïnstalleerd.
    Misschien is dit een wijze les voor Molly om daar NOOIT meer software te halen.
    Kijk altijd eerst of het gewoon in de repo van Ubuntu staat, zoniet, haal het dan van de website van de softwareschrijver zelf!!!!

    Ik ken wel meer mensen die problemen met hun pc kregen nadat ze spullen van sourceforge hebben gehaald, dus ik loop er met een hele grote boog omheen

    groet,

    Steven

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #18 Gepost op: 2019/03/20, 15:13:39 »
    Zeker toch dat het ook niet lukt als je opstart uit de terminal? Laatste poging: eens grondiger verwijderen en herinstalleren

    sudo apt purge pdfshuffler
    sudo apt remove python-pypdf2
    sudo apt install pdfshuffler

    Test altijd eerst door op te starten via de terminal: dan wordt een mogelijk probleem met de starter omzeilt. Lukt het nog niet, maak dan (tijdelijk) een nieuwe account aan, en start pdfshuffler op vanuit de nieuwe account. dat om uit te sluiten dat het probleem zit in een gebruikersconfiguratie (na zoveel herinstallaties begint het daar op te lijken).

    Je hebt toch geen vreemde PPA's actief waar mogelijk die pdfshuffler vandaan komt?

    Genoemde commando's uitgevoerd.
    Pdf shuffler opnieuw geïnstalleerd.
    Start vanuit terminal.
    Same old story:
    $ pdfshuffler
    Error: Could not import pdfshuffler
    Cause: No module named pyPdf
    Ik heb in mijn home nog de download staan. Het gaat om pdf shuffler 0.6.0, niet 0.6.0-8. Die laatste versie zag ik voorbij komen tijdens grondige reiniging (purge)

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #19 Gepost op: 2019/03/20, 15:17:53 »
    Steven schreef:
    Citaat
    Molly heeft het van sourceforge gedownload & geïnstalleerd.
    Misschien is dit een wijze les voor Molly om daar NOOIT meer software te halen.
    Kijk altijd eerst of het gewoon in de repo van Ubuntu staat, zoniet, haal het dan van de website van de softwareschrijver zelf!!!!

    Ik ben gaan surfen toen ik in programmabeheer telkens bot ving, na allerlei schrijfwijzen van Pdf-shuffler geprobeerd te hebben. Dat steekt blijkbaar irritant nauw, met een deel van de naam kom je er niet. En dan denk je: het staat niet hier, maar misschien wel elders op internet.
    « Laatst bewerkt op: 2019/03/20, 15:28:02 door molly w »

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #20 Gepost op: 2019/03/20, 15:24:30 »
    Test altijd eerst door op te starten via de terminal: dan wordt een mogelijk probleem met de starter omzeilt. Lukt het nog niet, maak dan (tijdelijk) een nieuwe account aan, en start pdfshuffler op vanuit de nieuwe account. dat om uit te sluiten dat het probleem zit in een gebruikersconfiguratie (na zoveel herinstallaties begint het daar op te lijken).?

    Nieuwe gebruiker aangemaakt. Daarin vanuit terminal pdfshuffler gestart.
    Nope. Lukt niet.
    $ pdfshuffler
    Error: Could not import pdfshuffler
    Cause: No module named pyPdf

    Offline vanadium

    • Lid
    • Steunpunt: Nee
    Re: pdf shuffler start niet
    « Reactie #21 Gepost op: 2019/03/20, 16:04:21 »
    Wat geeft
    locate pdfshuffler.py
    bij jou?
    Geef ook eens de uitvoer van
    locate PyPDF2

    Bij een normale installatie zit pdfshuffler.py in /usr/lib/python2.7/dist-packages/pdfshuffler/.

    Bij de versie die ik heb, wordt teruggevallen op pypdf als PyPDF2 er niet is:
    try:
        from PyPDF2 import PdfFileWriter, PdfFileReader
    except ImportError:
        from pyPdf import PdfFileWriter, PdfFileReader
    Op mijn systeem bevindt de folder PyPDF2 zich onder /usr/lib/python2.7/dist-packages/

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #22 Gepost op: 2019/03/20, 16:46:30 »
    Wat geeft
    locate pdfshuffler.py
    bij jou?
    Dit:
    $ locate pdfshuffler.py
    /home/wiegerinck/Downloads/pdfshuffler-0.6.0/pdfshuffler/pdfshuffler.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/local/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/local/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.pyc
    /usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    /usr/local/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    /usr/local/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.pyc

    Citaat
    Geef ook eens de uitvoer van
    locate PyPDF2
    Deze lap tekst:
    $ locate PyPDF2
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2-1.26.0.egg-info
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/__init__.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/__init__.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/_version.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/_version.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/filters.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/filters.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/generic.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/generic.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/merger.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/merger.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pagerange.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pagerange.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pdf.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pdf.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/utils.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/utils.pyc
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/xmp.py
    /timeshift/snapshots/2019-03-16_14-00-01/localhost/usr/lib/python2.7/dist-packages/PyPDF2/xmp.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2-1.26.0.egg-info
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/__init__.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/__init__.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/_version.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/_version.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/filters.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/filters.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/generic.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/generic.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/merger.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/merger.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pagerange.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pagerange.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pdf.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pdf.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/utils.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/utils.pyc
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/xmp.py
    /timeshift/snapshots/2019-03-17_14-00-05/localhost/usr/lib/python2.7/dist-packages/PyPDF2/xmp.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2-1.26.0.egg-info
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/__init__.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/__init__.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/_version.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/_version.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/filters.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/filters.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/generic.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/generic.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/merger.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/merger.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pagerange.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pagerange.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pdf.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/pdf.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/utils.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/utils.pyc
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/xmp.py
    /timeshift/snapshots/2019-03-19_11-00-03/localhost/usr/lib/python2.7/dist-packages/PyPDF2/xmp.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2
    /usr/lib/python2.7/dist-packages/PyPDF2-1.26.0.egg-info
    /usr/lib/python2.7/dist-packages/PyPDF2/__init__.py
    /usr/lib/python2.7/dist-packages/PyPDF2/__init__.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/_version.py
    /usr/lib/python2.7/dist-packages/PyPDF2/_version.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/filters.py
    /usr/lib/python2.7/dist-packages/PyPDF2/filters.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/generic.py
    /usr/lib/python2.7/dist-packages/PyPDF2/generic.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/merger.py
    /usr/lib/python2.7/dist-packages/PyPDF2/merger.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/pagerange.py
    /usr/lib/python2.7/dist-packages/PyPDF2/pagerange.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/pdf.py
    /usr/lib/python2.7/dist-packages/PyPDF2/pdf.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/utils.py
    /usr/lib/python2.7/dist-packages/PyPDF2/utils.pyc
    /usr/lib/python2.7/dist-packages/PyPDF2/xmp.py
    /usr/lib/python2.7/dist-packages/PyPDF2/xmp.pyc

    Citaat
    Bij een normale installatie zit pdfshuffler.py in /usr/lib/python2.7/dist-packages/pdfshuffler/.
    Klopt, bij mij ook.

    Citaat
    Bij de versie die ik heb, wordt teruggevallen op pypdf als PyPDF2 er niet is:
    try:
        from PyPDF2 import PdfFileWriter, PdfFileReader
    except ImportError:
        from pyPdf import PdfFileWriter, PdfFileReader
    Op mijn systeem bevindt de folder PyPDF2 zich onder /usr/lib/python2.7/dist-packages/
    Bij mij is dat ook zo. Hoort daar de vermiste module pyPdf te staan??? Ik zie daarin wel een bestand [pdf.py] staan en een bestand pdf.pyc.
    Een map pyPdf is er niet. Vraagt Pdf-shuffler om juist díe map?? En doet ie niks met PyPDF2??
    De bestanden PdfFileWriter, PdfFileReader staan daar niet in.
    « Laatst bewerkt op: 2019/03/20, 16:51:16 door molly w »

    Offline vanadium

    • Lid
    • Steunpunt: Nee
    Re: pdf shuffler start niet
    « Reactie #23 Gepost op: 2019/03/20, 17:52:34 »
    Diegene die ik heb, is enkel
    /usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    Die heb jij ook, maar je hebt de overeenkomstige gecompileerde versie, pdfshuffler.pyc, niet. Dat doet mij vermoeden dat het bij jou niet die "officiële" versie is, die gestart wordt, maar wel
    /usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    Dat zie ik, omdat die laatste versie wel een overeenkomstige pyc versie heeft. De pyc versie wordt aangemaakt wanneer je het programma de eerste keer opstart.

    Laten we even, in een laatste poging, het scalpel erbij nemen.

    1) Verwijder (opnieuw, zucht) de PPA versie
    sudo apt purge pdfshuffler
    sudo apt remove python-pypdf2
    sudo apt clean ;  sudo apt autoclean;  sudo apt autoremove

    2) Kijk wat er nog steeds bestaat aan pdfshuffler bestanden (we kijken natuurlijk niet naar jou timeshift bestanden onder /timeshift - die tellen niet mee):
    sudo updatedb
    locate pdfshuffler.py
    ik vermoed (maar jij bent het die goed moet verifiëren, dat /usr/local/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py er nog steeds zal zijn. Haal de ganse pdfshuffler folder weg:
    sudo rm -r /usr/local/lib/python2.7/dist-packages/pdfshuffler

    3) Herinstalleer
    sudo apt install pdfshuffler

    Nu zou het moeten goed zijn. Ik vermoed dat die sourceforge versie onder "/urs/local/lib/" die daar nog stond, prioritair aangeroepen wordt vóór de PPA versie onder "/usr/lib". Zalfs door de PPA versie te installeren, bleef dus die sourceforge versie aangeroepen worden. (zeker ben ik dit niet tot jij zegt hoe het is verlopen).
    « Laatst bewerkt op: 2019/03/21, 08:42:55 door vanadium »

    Offline molly w

    • Lid
    Re: pdf shuffler start niet
    « Reactie #24 Gepost op: 2019/03/21, 14:49:36 »
    Diegene die ik heb, is enkel
    /usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    Die heb jij ook, maar je hebt de overeenkomstige gecompileerde versie, pdfshuffler.pyc, niet. Dat doet mij vermoeden dat het bij jou niet die "officiële" versie is, die gestart wordt, maar wel
    /usr/lib/python2.7/dist-packages/pdfshuffler/pdfshuffler.py
    Dat zie ik, omdat die laatste versie wel een overeenkomstige pyc versie heeft. De pyc versie wordt aangemaakt wanneer je het programma de eerste keer opstart.

    Voordat ik jouw instructies opvolg, ging ik even kijken in genoemde folder. Daar zie ik wel degelijk een pyc-versie staan. Ziebijlage
    Stond eerst in /bin/ ook een bestand pdfshuffler (pythonscript), dat is nu weg. Sinds de vorige purge-actie.

    Ik wacht je reactie even af om twee redenen:
    1. Misschien heeft deze constatering invloed op je diagnose en remedie
    2. Ik heb op vanaf dit moment enkele dagen geen tijd om rustig je plan van aanpak uit te voeren en uitgebreid te testen.
    « Laatst bewerkt op: 2019/03/21, 15:08:00 door molly w »