Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Sinds install Linux19 bestanden op NAS kunnen niet gelezen of bewerkt worden  (gelezen 1134 keer)

Offline molly w

  • Lid
Sinds ik Linux19 heb geinstalleerd, kan ik de bestanden op mijn NAS  niet openen via de stationsnamen in bestandsbeheer. Ze staan genoemd in de lijst APPARATEN, maar zijn vaag. Ik kan ze wel benaderen via NETWERK, maar moet ik elke keer inloggen op de NAS. Dat was onder Linux13 nooit nodig, daar had ik gewoon toegang via de lijst zoals ik nu onder APPARATEN zie. (zie bijlage)
Het heeft te maken met rechten, zegt bijlage 2.
Ik heb de locaties wel toegevoegd aan fstab, zoals ik ook gedaan heb bij Linux 13 maar dat helpt niet.
Daar staat zo:
Citaat
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb6 during installation
UUID=55e8dd07-b5d1-4484-b765-5b8cf06764fd /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
//192.168.1.2/media /media/nas_media cifs username=guest,password=,iocharset=utf8,uid=1000   0   0
//192.168.1.2/documenten /media/nas_documenten cifs username=guest,password=,iocharset=utf8,uid=1000   0   0
//192.168.1.2/oblimon /media/nas_oblimon cifs username=guest,password=,iocharset=utf8,umask=000,uid=1000   0   0

NB
De bestanden op de NAS wil ik ook kunnen blijven benaderen vanuit Windows- (laptop) of Android/ios (smartphone, tablet) omgeving.

Wie weet raad???
« Laatst bewerkt op: 2019/03/14, 14:59:22 door molly w »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Voeg eens de optie "users" toe bij elk van die lijnen voor je NAS.

Offline swake

  • Lid
    • Crisisopvang Asse
  • Steunpunt: Ja
Citaat
//192.168.1.2/oblimon /media/nas_oblimon cifs username=guest,password=,iocharset=utf8,umask=000,uid=1000   0   0
Dat is inderdaad een rechtenprobleem . Je benadert nu de NAS als gast .
Ik hoop dat je hier wat aan hebt .https://steunpunt-almere.nl/artikelen/hoe-je-nas-automatisch-mouten/

Offline vanadium

  • Lid
  • Steunpunt: Nee
Het zal inderdaad niet aan die "users" optie liggen dat je NAS niet initieel aangekoppeld is. Met de "users" optie zal je wél nadien via klikken in bestandbeheer de NAS kunnen aankoppelen, maar dit is hier niet de bedoeling, zie ik nu.

Bedoeling is dat de NAS automatisch aangekoppeld wordt tijdens de opstart. Dat dit nu niet gebeurt, zou een gevolg kunnen zijn van het feit dat het netwerk niet klaar is op het ogenblik dat fstab uitgevoerd wordt. Probeer de optie "_netdev". Mocht het nog niet lukken, voed dan ook nog "x-systemd.after=network-online.target" toe. 

Offline molly w

  • Lid
Graag meer toelichting. Waar dienen genoemde opties toegevoegd worden? In welk bestand?

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Graag meer toelichting. Waar dienen genoemde opties toegevoegd worden? In welk bestand?

Moet toegevoegd worden aan bestand fstab en staat  in map etc.
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu Gnome 18.04/Xubuntu 18.04; Windows 10 (dualboot) RPI: Ubuntu Mate; Asus 1005PE: Linux Lite 3.8
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline molly w

  • Lid
Helaas, beide suggesties hebben niet het gewenste resultaat. Het staat er nu z'o (ik zie dat de toetenbordindeling " met dode toetsen"  niet werkt) :
Citaat
//192.168.1.2/media /media/nas_media cifs _netdev,x-systemd.after=network-online.target,username=guest,password=,iocharset=utf8,uid=1000   0   0
Staan de toevoegingen op de verkeerde plaats???

Offline vanadium

  • Lid
  • Steunpunt: Nee
De opties staan op de juiste plaats. Wat geeft de uitvoer van:
sudo mount -a

Als er geen uitvoer is, dan zou dat betekenen dat je NAS schijven nu wel aangekoppeld zijn zonder fout. Indien er wel een foutmelding is, post die dan hier: kan een idee geven over waar de fout nog kan liggen.

Offline swake

  • Lid
    • Crisisopvang Asse
  • Steunpunt: Ja
Bekijk nog eens je afbeelding

Dat betekent dat je geen Root privileges hebt .
https://www.reddit.com/r/linuxquestions/comments/93ab8d/operation_permitted_for_root_only_error_when/

Offline swake

  • Lid
    • Crisisopvang Asse
  • Steunpunt: Ja
Kun je volgen ?
Dat je  terug eerst als root op de NAS zal moeten aanmelden en opnieuw de rechten instellen .


Offline molly w

  • Lid
De opties staan op de juiste plaats. Wat geeft de uitvoer van:
sudo mount -a

Als er geen uitvoer is, dan zou dat betekenen dat je NAS schijven nu wel aangekoppeld zijn zonder fout. Indien er wel een foutmelding is, post die dan hier: kan een idee geven over waar de fout nog kan liggen.
Terminal meldt:
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Ik heb de NAS nog wel wakker geschud door op knopje te drukken, maar dat verandert niets.
Ik begrijp niet waarom de NAS tot vorige week wél automatisch werd aangekoppeld, met dezelfde regels in fstab, maar niet meer sinds de installatie van Mint19.
« Laatst bewerkt op: 2019/03/15, 15:44:25 door molly w »

Offline swake

  • Lid
    • Crisisopvang Asse
  • Steunpunt: Ja
Je hebt toch SAMBA geïnstalleerd ?

Offline molly w

  • Lid
De URL van bestanden begint met smb. Dus ik neem aan van wél. Overigens is mij door het installatie programma van mint19 hieromtrent niets gevraagd.

Offline swake

  • Lid
    • Crisisopvang Asse
  • Steunpunt: Ja
Citaat
//192.168.1.2/media /media/nas_media cifs _netdev,x-systemd.after=network-online.target,username=guest,password=,iocharset=utf8,uid=1000   0   0
Moet zijn

//192.168.1.2/media /media/nas_media cifs _netdev,x-systemd.after=network-online.target,username=root,password=,iocharset=utf8,uid=1000   0   0


Offline vanadium

  • Lid
  • Steunpunt: Nee
Er zijn twee foutmeldingen "server down", en er is één foutmelding "Invalid argument". Het verschil in de derde lijn met de twee vorige is dat je daar de optie umask=000, ook hebt. Is dat geldig voor een cifs mount? Verwijder die optie eens tijdelijk: wat geeft "mount -a" dan?

De "host is down" melding kan een gevolg zijn van het feit dat het protocol waarmee jou Mint tot de server spreekt, niet meer klopt. Ik zou eens de optie "vers=1.0" proberen. Lukt dat niet, probeer dan ook eens "vers=2.0" en "vers=3.0".
« Laatst bewerkt op: 2019/03/15, 18:59:53 door vanadium »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Kan het zijn dat je nas opeens een andere ip nummer heeft gekregen, van de router?

Offline molly w

  • Lid
Kan ik testen in Firefox. Kijken of ik toegang krijgen

Offline swake

  • Lid
    • Crisisopvang Asse
  • Steunpunt: Ja
Citaat
Kan ik testen in Firefox. Kijken of ik toegang krijgen
En dat bedoelde ik met mijn bericht in #9
Via de webinterface inloggen en terug de recchten instellen .

Offline molly w

  • Lid
Het bestaande ip-adres is niet gewijzigd, met de browser kom ik in het inlogscherm. Na inloggen kom ik op <ip>/shares maar dat zegt dat momenteen geen shares toegankelijk zijn. Hier stopt het dus.
Ik wil ook geen rechten van de NAS wijzigen, want de NAS wil ik toegankelijk houden voor de andere apparaten in huis (laptop, smartphone, tablet met windows, android of ios)
« Laatst bewerkt op: 2019/03/16, 11:33:19 door molly w »

Offline molly w

  • Lid
Er zijn twee foutmeldingen "server down", en er is één foutmelding "Invalid argument". Het verschil in de derde lijn met de twee vorige is dat je daar de optie umask=000, ook hebt. Is dat geldig voor een cifs mount? Verwijder die optie eens tijdelijk: wat geeft "mount -a" dan?
Deze optie verwijderd, terminal antwoordt met drie keer "server down". dat klopt dus.

Citaat
De "host is down" melding kan een gevolg zijn van het feit dat het protocol waarmee jou Mint tot de server spreekt, niet meer klopt. Ik zou eens de optie "vers=1.0" proberen. Lukt dat niet, probeer dan ook eens "vers=2.0" en "vers=3.0".
Ik heb een en ander geprobeerd. Terminal zei dat ik eerst smbclient moest installeren. Gedaan.
Daarna jouw suggestie geprobeerd. De terminal gaf terug:
~$ sudo mount -t cifs //192.168.1.2/shares /mnt/media/nas_media -o vers=2.0
Couldn't chdir to /mnt/media/nas_media: No such file or directory
Ik heb eens gekeken in de mappen /media/nas_xxxx. Deze zijn alle leeg. Ook geen verborgen bestanden. Is dat een spoor???


Offline swake

  • Lid
    • Crisisopvang Asse
  • Steunpunt: Ja
Wat voor NAS is dat juist ? Blijkbaar loopt er iets fouts met het SMB protocol .

Een gelijksoortig probleem , klik
« Laatst bewerkt op: 2019/03/16, 11:47:49 door swake »

Offline nahjo

  • Lid
  • Steunpunt: Nee
Het probleem zal waarschijnlijk in de gebruikte samba versies zitten (SMB3.x versus SMB2.x) en dan zou in principe de vers=2.0 optie moeten werken.
Is cifs-utils wel geinstalleerd?
sudo apt install cifs-utils

Offline molly w

  • Lid
Het probleem zal waarschijnlijk in de gebruikte samba versies zitten (SMB3.x versus SMB2.x) en dan zou in principe de vers=2.0 optie moeten werken.
Is cifs-utils wel geinstalleerd?
sudo apt install cifs-utils
Antwoord van terminal:
De statusinformatie wordt gelezen... Klaar
cifs-utils is reeds de nieuwste versie (2:6.8-1).
Dus ... cifs-utils zijn geInstalleerd. Daar zit het probleem dus niet

Offline molly w

  • Lid
In terminal gaf ik het volgende in:
sudo smbclient -L 192.168.1.2 -U admin -m SMB1

Terminal gaf volgende terug:
WARNING: Ignoring invalid value 'SMB1' for parameter 'client max protocol'
WARNING: The "syslog" option is deprecated
Enter WORKGROUP\admin's password:

Sharename       Type      Comment
---------       ----      -------
c               Disk      Volume C
oblimon         Disk      data PCZolder D
media           Disk      Media Server Share
documenten      Disk      documenten PCZolder F
IPC$            IPC       IPC Service (NAS)
Reconnecting with SMB1 for workgroup listing.

Server               Comment
---------            -------

Workgroup            Master
---------            -------
WIEGERINCK           NAS
We komen er in, maar het lijkt hetzelfde als ik in bestandsbeheer NETWERK kies. Ook kan moet ik inloggen en kom ik bij mijn bestanden.
Namen van de stations onder APPARATEN geven nog steeds nul op het request.

Gebruik ik SMB2 ipv SMB1, dan is resultaat hetzelfde

Offline nahjo

  • Lid
  • Steunpunt: Nee
Het verhaal wat ik tegenkwam is:
Citaat
** What can be an issue is if you are running something with a very old version of samba like most NAS devices and there you would have to add an option to your cifs mount statement forcing it back to SMB1:
CODE: SELECT ALL

vers=1.0
En dan zou je FSTAB er ongeveer zo moeten uitzien:
//192.168.1.2/media /media/nas_media cifs vers=1.0,username=guest,password=,iocharset=utf8,uid=1000   0   0