Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.  (gelezen 1019 keer)

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Gepost op: 2019/02/12, 13:52:19 »
Hoi Allemaal.
Onlangs de 18.04 op de pc gezet en in eerste instantie leek alles prima te zijn. Ik heb naast Windows ook nog de oude vertrouwde Xubuntu 16.04  staan en zelfs nog een oude 12.04. Alles werkt normaal en uitstekend. Echter, het probleem waar ik nu niet meer uit kom is dat als ik de als home ingestelde 18.04 ‘s-morgens bij de 1e keer opstart hij NIET dóórstart na de grub? ( Geen muis, toetsenbord en geen beeld. Dus harde herstart!) Wel als ik eerst de 16.04 start die het altijd doet, en dáárna de 18.04. Dan gaat alles wel goed. Kan dan de hele dag heen en weer switsen zonder problemen. En de 18.04 sluit ook keurig af aan het eind van de dag. Dus wat gaat er nou fout in die paar nachtelijke uren dat de pc uit staat ?? Onderstaande info zag ik gevraagd worden ergens op het forum en deed maar eens wat na. Mogelijk kan iemand me even op de goede weg helpen? Alvast dank.

Groet,
Goese Duikertje

Dit was o.a. naar aanleiding van het item “nomodeset” wel of niet aanzetten. Dus in mijn pc gaf dit:
:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.4.0-142-generic root=UUID=c05a30ad-5bfd-453d-a39f-5395a37fe1df ro quiet splash
:~$ 
Enige verschil met mijn nieuw 18.04 is dat die een versie 4.15. generic heeft ipv 4.4. Dus blijkbaar in geen van beiden die nomodeset. Waarom werkt de 16.04 wel vlekkeloos en die 18.04 niet ?

Ik denk dus dat het te maken heeft met het onderstaande item. Het onderste deel geeft volgens mij aan dat de pc gebruik maakt van de Mesa-driver in plaats van de VGA-driver ? En dát deel ontbreekt in de uitdraai in 18.04. In mijn PC heb ik dit :

:~$ cat /var/log/gpu-manager.log
log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /run/u-d-c-nvidia-was-loaded file
can't access /run/u-d-c-fglrx-was-loaded file
Looking for fglrx modules in /lib/modules/4.4.0-142-generic/updates/dkms
Looking for nvidia modules in /lib/modules/4.4.0-142-generic/updates/dkms
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is fglrx loaded? no
Was fglrx unloaded? no
Is fglrx blacklisted? no
Is intel loaded? no
Is radeon loaded? yes
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is nouveau loaded? no
Is nouveau blacklisted? no
Is fglrx kernel module available? no
Is nvidia kernel module available? no
Vendor/Device Id: 1002:6779
BusID "PCI:2@0:0:0"
Is boot vga? yes
Skipping "/dev/dri/card0", driven by "radeon"
Found "/dev/dri/card0", driven by "radeon"
output 0:
card0-DVI-I-1
Number of connected outputs for /dev/dri/card0: 1
Skipping "/dev/dri/card0", driven by "radeon"
Skipping "/dev/dri/card0", driven by "radeon"
Does it require offloading? no
last cards number = 1
Has amd? yes
Has intel? no
Has nvidia? no
How many cards? 1
Has the system changed? No
( Hieronder staat tekst die dus NIET in 18.04 staat.
main_arch_path i386-linux-gnu, other_arch_path x86_64-linux-gnu
Current alternative: /usr/lib/i386-linux-gnu/mesa/ld.so.conf
Current core alternative: (null)
Current egl alternative: /usr/lib/i386-linux-gnu/mesa-egl/ld.so.conf
Is nvidia enabled? no
Is nvidia egl enabled? no
Is fglrx enabled? no
Is mesa enabled? yes
Is mesa egl enabled? yes
Is pxpress enabled? no
Is prime enabled? no
Is prime egl enabled? no
Is nvidia available? no
Is nvidia egl available? no
Is fglrx available? no
Is fglrx-core available? no
Is mesa available? yes
Is mesa egl available? yes
Is pxpress available? no
Is prime available? no
Is prime egl available? no
Single card detected
Kernel Module is not loaded
Nothing to do
No change - nothing to do
 


Nu heb ik wel ergens nog een stukje tekst van het web gevonden ivm het volledig verwijderen van xorg en dat dan weer her-installeren, maar ik heb geen idee óf dit echt dé oplossing is en of het klopt. En zo ja, hoe te doen nú in mijn 18.04 ? Temeer daar het bericht van 2012 is.
videokaart drivers herstellen! « Gepost op: 2012/05/01, 11:00:02 »
het was weer zo ver met met mijn drivers dat mijn beeldscherm alleen nog maar 640x480 resolutie kon draaien, toen vond ik deze kleine tutorial en ik dacht ik post hem hier voor jullie, misschien dat ooit iemand er wat aan heeft.
1. Verwijder je xorg.conf
Citaat
sudo rm /etc/X11/xorg.conf
2. Installeer Xorg helemaal opnieuw
Citaat
sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-
dri:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64
3. configureer Xorg opnieuw
Citaat
sudo dpkg-reconfigure xserver-xorg
4. Herstarten
Citaat
sudo reboot
ik hoop dat iemand hier ooit een keer iets aan zal hebben. ik heb hier namelijk heel veel aan gehad:)
dit zou moeten werken voor alle nvidia / ati videokaarten. en sowieso op 12.04
en ik had mijn ubuntu 12.04 resolutie gesloopt met nvidia drivers. dus moest deze terug zetten  [/code ]

En mbt mijn beeldschermen dit:

[code] :~$ sudo lshw -C display
[sudo] wachtwoord voor :
  *-display               
       description: VGA compatible controller
       product: Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:31 memory:c0000000-cfffffff memory:dfec0000-dfedffff ioport:cc00(size=256) memory:dfea0000-dfebffff


In zowel 16.04 als in 18.04 heb ik mijn beeldscherm gewoon op 1920 x 1080 staan met 60 HZ en werken beiden perfect. Wie kan het zeggen ...?



Online jan11000

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #1 Gepost op: 2019/02/12, 21:30:05 »
als ik de als home ingestelde 18.04 ‘
Wat bedoel je hiermee?

Online jan11000

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #2 Gepost op: 2019/02/12, 21:37:15 »
Je hebt misschien meerdere grub' s?
Als je na installatie dit probleem niet had? Maar bijv wel na update van en van je oudere linux versies, die dan grub wijzigen, waardoor je nieuwe misschien weigert.

Boot je altijd van dezelfde schijf?

Linux boot zo,

bios,
bootable hd, hier wordt de MBR gestart, hier staat een stukje grub in,
dan gaat de bootable hd die in de MBR staat, grub op de hd starten(normaal gesproken de bootable hd).(map grup op de hd).

Misschien veranderd er steeds iets.
Zorg dat je boot vanaf dezelfde schijf.

ik zou dit eerst doen, grub repareren voor de nieuwe versie,
boot naar je nieuwe linux,
dan repareer linux, door os-prober te starten, deze zoekt naar andere os operatings systems en voegt deze toe aan grub, dan grub-update doen, en dan testen of dit werkt.
(google op ubuntu+os-prober om de terminal info die je moet in typen).

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #3 Gepost op: 2019/02/13, 14:45:36 »
Nu heb ik wel ergens nog een stukje tekst van het web gevonden ivm het volledig verwijderen van xorg en dat dan weer her-installeren
Nee, dit moet je echt niet doen, je probleem zit elders.

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #4 Gepost op: 2019/02/13, 14:55:20 »
Canonical meldt 9 februari jl. dat een kernel-upgrade een regressieprobleem heeft geïntroduceerd met onder meer de volgende eigenschappen: "USN-3878-1 fixed vulnerabilities in the Linux kernel. Unfortunately, that update introduced a regression that could prevent systems with certain graphics chipsets from booting."

Misschien dat je probleem hier mee te maken heeft.

link: https://usn.ubuntu.com/3878-3/

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #5 Gepost op: 2019/02/15, 12:11:22 »
Hoi Allemaal. Sorry voor mijn wat late response. Deels door afwezigheid, maar helaas ook door de vele problemen die ik had met dat opstarten van xubuntu 18.04 en alle, al dan niet gegokte, mogelijke aanpassingen en tricks. Heb zowat een halve bibliotheek doorgelezen en ben er nog altijd niet uit. Ik heb dus nog steeds geen idee wat de oorzaak nu écht is. ( Laat staan dé oplossing.)

MBT Paul Matthijsse: ik dacht niet dat dit, USN-3878-1 fixed vulnerabilities, het is. Alhoewel ik er niet heel van begrijp in deze lange teksten. En dat Mesa lijkt het ook niet te zijn.Zie hieronder.
MBT  jan11000: Ik meen maar 1 grub te hebben. Maar ik heb boot-repair gebruikt-advanged instellingen en dan krijg je een keuze in het proces waar dan die grub moet komen. En als je het niet zeker weet is het advies om het overal te zetten. Wel afgeraden omdat het dan met blocklijst oid gaat werken maar het kan dus. Ik meen daar ingesteld te hebben op de hoofdschijf sda én op de partitie sda10( de 18.04). Mogelijk fout?
Ook via recovery laten herstellen van grub en paketten levert geen problemen op. Het blijft me een raadsel.

Hét probleem is dus nog steeds dat als ik ‘s-morgens de 1e opstart doe, die dus begint in de grub op de home partitie met 18.04 erop, dan gaat alles uit. Dus geen muis,geen toetsenbord en zwart inactief scherm. Kan alleen harde herstart doen. Als ik dan i.p.v 18.04 de 16.04 kies in de grub, dan start hij keurig op. Er zijn wel enkele meldingen maar daar kom ik niet goed uit. En als ik hierna dus herstart en gewoon de standaard 18.04 laat starten, gaat ook weer alles goed. Tot de volgende ochtend.

Ik heb inmiddels al weer heel wat uitgeprobeerd maar het is en blijft onzeker. Zo heb ik ook al eens de nomodeset gedaan en dan start de 18.0 ook op. Ook in energiebeheer wat zitten rommelen en met andere items maar ik heb geen idee of het werkt en wat de volgende ochtend gaat gebeuren.

Ik heb nog steeds het idee dat het iets met die Mesa-driver te maken heeft waarvan ik eerst dacht dat die wel in de 16.04 was ingezet en niet in de 18.04. Maar als ik onderstaande doe lijkt het erop dat die ook in de 18.04 staat. Begrijp er niets van.
glxinfo | grep "OpenGL version"

Dus bij mij in 16.04 keurig Mesa.

~$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 18.0.5

Maar dus gek genoeg ook in 18.04 zit er iets:

~$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.1 Mesa 18.2.2
 

Tevens maar eens wat van die log-data kunnen verzamelen maar dat zegt mij niet veel, anderen mogelijk wel ? Deze is van de inmiddels goed werkende opstart met 18.04.

11:44:59 smartd: Device: /dev/sdb [SAT], 1678 Offline uncorrectable sectors
11:44:59 smartd: Device: /dev/sdb [SAT], 1678 Offline uncorrectable sectors
11:44:59 smartd: Device: /dev/sdb [SAT], 1678 Currently unreadable (pending) sectors
11:15:56 pulseaudio: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
11:15:56 pulseaudio: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
11:15:31 pulseaudio: [pulseaudio] pid.c: Daemon already running.
11:15:26 spice-vdagent: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
11:15:12 lightdm: PAM adding faulty module: pam_kwallet.so
11:15:12 lightdm: PAM adding faulty module: pam_kwallet.so
11:15:12 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
11:15:10 colord-sane: io/hpmud/pp.c 627: unable to read device-id ret=-1
11:15:08 lightdm: PAM adding faulty module: pam_kwallet.so
11:15:08 lightdm: PAM adding faulty module: pam_kwallet.so
11:15:08 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
11:14:58 smartd: Device: /dev/sdb [SAT], ATA error count increased from 64769 to 64775
11:14:58 smartd: Device: /dev/sdb [SAT], ATA error count increased from 64769 to 64775
11:14:58 smartd: Device: /dev/sdb [SAT], 1678 Offline uncorrectable sectors
11:14:58 smartd: Device: /dev/sdb [SAT], 1678 Currently unreadable (pending) sectors
11:14:55 kernel: Buffer I/O error on dev sdb6, logical block 107, async page read
11:14:55 kernel: print_req_error: I/O error, dev sdb, sector 484209503
11:14:55 kernel: ata6.00: error: { UNC }
11:14:55 kernel: ata6.00: error: { UNC }
11:14:55 kernel: ata6.00: status: { DRDY ERR }
11:14:55 kernel: ata6.00: cmd 25/00:08:58:73:dc/00:00:1c:00:00/e0 tag 0 dma 4096 in
         res 51/40:00:5f:73:dc/40:00:1c:00:00/e0 Emask 0x9 (media error)
11:14:55 kernel: ata6.00: failed command: READ DMA EXT
11:14:55 kernel: ata6.00: BMDMA stat 0x4
11:14:55 kernel: ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
11:14:53 kernel: print_req_error: I/O error, dev sdb, sector 484209503
11:14:53 kernel: ata6.00: error: { UNC }
11:14:53 kernel: ata6.00: error: { UNC }
11:14:53 kernel: ata6.00: status: { DRDY ERR }
11:14:53 kernel: ata6.00: cmd 25/00:00:00:72:dc/00:02:1c:00:00/e0 tag 0 dma 262144 in
         res 51/40:00:5f:73:dc/40:00:1c:00:00/e0 Emask 0x9 (media error)
11:14:53 kernel: ata6.00: failed command: READ DMA EXT
11:14:53 kernel: ata6.00: BMDMA stat 0x4
11:14:53 kernel: ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
11:14:50 kernel: snd_hda_intel 0000:80:01.0: CORB reset timeout#1, CORBRP = 0
11:14:44 kernel: Buffer I/O error on dev sdb6, logical block 107, async page read
11:14:44 kernel: print_req_error: I/O error, dev sdb, sector 484209503
11:14:44 kernel: ata6.00: error: { UNC }
11:14:44 kernel: ata6.00: error: { UNC }
11:14:44 kernel: ata6.00: status: { DRDY ERR }
11:14:44 kernel: ata6.00: cmd 25/00:08:58:73:dc/00:00:1c:00:00/e0 tag 0 dma 4096 in
         res 51/40:00:5f:73:dc/40:00:1c:00:00/e0 Emask 0x9 (media error)
11:14:44 kernel: ata6.00: failed command: READ DMA EXT
11:14:44 kernel: ata6.00: BMDMA stat 0x4
11:14:44 kernel: ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
11:14:44 kernel: print_req_error: I/O error, dev sdb, sector 484209503
11:14:44 kernel: ata6.00: error: { UNC }
11:14:44 kernel: ata6.00: error: { UNC }
11:14:44 kernel: ata6.00: status: { DRDY ERR }
11:14:44 kernel: ata6.00: cmd 25/00:00:00:72:dc/00:02:1c:00:00/e0 tag 0 dma 262144 in
         res 51/40:00:5f:73:dc/40:00:1c:00:00/e0 Emask 0x9 (media error)
11:14:44 kernel: ata6.00: failed command: READ DMA EXT
11:14:44 kernel: ata6.00: BMDMA stat 0x4
11:14:44 kernel: ata6.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
 

Ik heb ook wel met boot-repair zitten klungelen en mogelijk dat ik dáár nog eens wat moet verbeteren? Belangrijk daarbij is dat ik mijn 2e , oude 250GB schijf waar fouten op staan, alleen maar als data-opslag gebruik en dat werkt altijd prima in 16 én 18. Maar ik twijfel altijd over het feit dat ik ,uiteraard, op de grote standaard-schijf de bootflag heb staan en blijkbaar óók een bootflag heb staan op die oude schijf. Die hier dan als sdb staat. Mogelijk is dát mijn fout? Ik dacht namelijk dat elke eigen schijf ook een boot moest hebben?? Ben huiverig om die zomaar weg te nemen.Zie bijgaande pics van Gparted.

Wie nog wat kan adviseren graag.

Groet,
Goese Duikertje


 



 

Online jan11000

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #6 Gepost op: 2019/02/17, 10:04:18 »
Je defecte schijf natuurlijk even ontkoppelen, en dan zonder deze schijf testen.

De boot zou ik weg halen, deze kun je altijd via je installatie stick weer terug zetten indien nodig.

Start s'morgens eens op via je F12 bootmenu(of welke knop op je pc dit is)(boot menu keuze, zodat je zeker weet dat je vanaf de goede hd start)

En als je nvidia videokaart hebt, kun je via instellingen via een grafische menu, de videokaart driver wijzigen van nvidia naar open source, of andersom.

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #7 Gepost op: 2019/02/17, 12:21:17 »
Hoi jan11000. Dank voor je reactie. Op zich ben ik wat huiverig om in de pc die schijf "los te koppelen". Het gaat bij de 16 altijd goed en dat wil ik graag zo ook in de 18 laten. Ik heb het gevoel dat het maar om een hele kleine, simpele aanpassing moet gaan. Ik zal zeker hierna eens die 2e boor gaan weghalen via de boot-repair en zien of dat het is. Maar laat ik nog eens het "verloop" beschrijven van waar wat mis gaat.

Ik heb een Xubuntu versie 16.04 en een nieuw Xubuntu versie 18.04. Versie 16 was altijd mijn home-partie en dat is nu dus de versie 18 geworden. Versie 16 start altijd keurig op. Versie 18 doet alles precies als 16, TOT ná het grub-menu. Dan stopt deze 18 alles. Dus geen keyboard , geen muis, geen cursor en geen scherm en start dus niet meer dóór. Het bijzondere is nu dat als ik eerst de 16 start , herstart en niets aanpas, dan start de versie 18 home gewoon precies net zo keurig op als 16. Opvallend is hierbij wel dat normaal het grub-menu 10 sec blijft staan en bij die her-start is dat 30 sec...!?

Als ik echter helemaal afsluit / uitzet, en dan bijvoorbeeld een uur later weer wil opstarten via de versie 18 home, dan gaat alles weer op zwart en uit. Kan het zijn dat bij een her-start op de achtergrond nog steeds die met de versie 16 opgestarte driver min of meer “actief” is gebleven? En dat dus na een volledige afsluiting deze niet meer actief is en dan dus bij een nieuwe opstart de “foute” ,eigen driver pakt van versie 18 ?

Ik heb dus een oude Radeon 6450 erin zitten. Maar die is dus blijkbaar altijd standaard uitgeschakeld i.v.m. de opensource vga/ mesa.

Gevoelsmatig zeg ik dat ik hezelfde opstart-protocool van versie 16 zou moeten zien te krijgen in 18. Ik ga nu eerst dus maar weer eens die boot-repair doen.

Groet,
Goese Duikertje

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #8 Gepost op: 2019/02/17, 15:46:33 »
Ik heb een Xubuntu versie 16.04 en een nieuw Xubuntu versie 18.04. Versie 16 was altijd mijn home-partie en dat is nu dus de versie 18 geworden.
Dat betekent volgens mij dat als jouw versie 18 eenmaal is gestart, je een lege thuismap hebt? Of verwijs je door naar de thuismap van v16?

Versie 16 start altijd keurig op. Versie 18 doet alles precies als 16, TOT ná het grub-menu. Dan stopt deze 18 alles. Dus geen keyboard , geen muis, geen cursor en geen scherm en start dus niet meer dóór.
Volgens mij zoekt versie 18 naar een partitie die hij niet kan vinden, vandaar dat-ie opgeeft.

Het bijzondere is nu dat als ik eerst de 16 start , herstart en niets aanpas, dan start de versie 18 home gewoon precies net zo keurig op als 16. Opvallend is hierbij wel dat normaal het grub-menu 10 sec blijft staan en bij die her-start is dat 30 sec...!?
Dit is niet bijzonder, dit is ronduit belachelijk! ;) Je hebt volgens mij twee keer een grub actief, op verschillende partities.

Als ik echter helemaal afsluit / uitzet, en dan bijvoorbeeld een uur later weer wil opstarten via de versie 18 home, dan gaat alles weer op zwart en uit. Kan het zijn dat bij een her-start op de achtergrond nog steeds die met de versie 16 opgestarte driver min of meer “actief” is gebleven?
Volgens mij betekent een herstart dat het systeem opnieuw wordt gestart, dat is: vanaf nul. Er blijven bij mijn weten nooit zaken actief na een herstart.

Leuk probleem heb je daar!
Zou je eens de terminaluitvoer willen geven van de volgende drie commando's?
sudo blkid(die tweede is een L)

en
sudo fdisk -l(opnieuw een L)

en
sudo cat /etc/fstab

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #9 Gepost op: 2019/02/17, 16:57:29 »
Hoi Paul Matthijsse. Ook dank dat je even de tijd hebt. Ben inmiddels weer een dagje zoet geweest zonder resultaat. Met die home bedoel ik dat dit de partitie is waar de grub en  "/ "staat . Het is de partitie die ik graag als eerste wil laten starten. De overige partities kan ik selecteren in dat grub-menu. En zou heel goed kunnen dat mijn fout inderdaad te maken heeft met dat er 2 grubs staan. Want ik heb de laatste keer dat ik de boot-repair gebruikte, opgegeven dat hij de grub moest plaatsten op zowel de sda ( de gehele schijf) als op de sda10 ( de partitie met versie 18.). Er werd hiervoor de keuze gegeven om het overal te zetten als je niet zeker was. Maar werd afgeraden omdat er dan met blocks wordt gewerk?? En ja, het is absoluut zo dat áls ik herstart er geen problemen zijn , maar als ik volledig afsluit en dán opstart wel. Bijgaand de uitslagen. Hopelijk kan je me wat licht aan het einde van het tunneltje laten zien. Alvast dank.

sudo blkid
[sudo] wachtwoord :
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/sda1: UUID="01CF13A1306AC600" TYPE="ntfs" PARTUUID="beb93d40-01"
/dev/sda5: UUID="76da738e-aeb5-4f1d-93a1-89435d17c08e" TYPE="ext4" PARTUUID="beb93d40-05"
/dev/sda6: LABEL="Lokaal oude hd station" UUID="01D147C471458A80" TYPE="ntfs" PARTUUID="beb93d40-06"
/dev/sda7: LABEL="Xubuntu 16 04" UUID="c05a30ad-5bfd-453d-a39f-5395a37fe1df" TYPE="ext4" PTTYPE="dos" PARTUUID="beb93d40-07"
/dev/sda8: UUID="ebcc6c42-db70-4742-bc62-7efbd8fc4fa2" TYPE="swap" PARTUUID="beb93d40-08"
/dev/sda9: LABEL="Don Reserve" UUID="01D146FA7F2ED900" TYPE="ntfs" PARTUUID="beb93d40-09"
/dev/sda10: LABEL="Xubuntu 18 04" UUID="7da6c326-2029-4fe7-9e4d-51661d497494" TYPE="ext4" PARTUUID="beb93d40-0a"
/dev/sdb1: UUID="01D149EF06C46280" TYPE="ntfs" PARTUUID="0007fad8-01"
/dev/sdb5: UUID="76da738e-aeb5-4f1d-93a1-89435d17c08e" TYPE="ext4" PARTUUID="0007fad8-05"
/dev/sdb6: UUID="21754043-1c62-41e6-ae36-e6686cc659a9" TYPE="swap" PARTUUID="0007fad8-06"

dan deze:
sudo fdisk -l
[sudo] wachtwoord
Schijf /dev/loop0: 85,7 MiB, 89825280 bytes, 175440 sectoren
Eenheid: sectoren van 1 * 512 = 512 bytes
Sectorgrootte (logisch/fysiek): 512 bytes / 512 bytes
In-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes


Schijf /dev/loop1: 131,6 MiB, 138006528 bytes, 269544 sectoren
Eenheid: sectoren van 1 * 512 = 512 bytes
Sectorgrootte (logisch/fysiek): 512 bytes / 512 bytes
In-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes


Schijf /dev/loop2: 85,7 MiB, 89821184 bytes, 175432 sectoren
Eenheid: sectoren van 1 * 512 = 512 bytes
Sectorgrootte (logisch/fysiek): 512 bytes / 512 bytes
In-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes 

tenslotte:

sudo cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda10 during installation
UUID=7da6c326-2029-4fe7-9e4d-51661d497494 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda8 during installation
UUID=ebcc6c42-db70-4742-bc62-7efbd8fc4fa2 none            swap    sw              0       0
# swap was on /dev/sdb6 during installation
UUID=21754043-1c62-41e6-ae36-e6686cc659a9 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0 

Groet,
Goese Duikertje



Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #10 Gepost op: 2019/02/18, 11:07:08 »
Hallo, zo te zien (fstab) wordt alleen sda10 aangekoppeld als je de pc start, dus Xubuntu 18.04.
Volgens fdisk -l is er geen enkele partitie actief of aangekoppeld, terwijl blkid wel alle partities weergeeft. Hoe je in Xubuntu 16.04 kunt geraken, is me op dit moment een raadsel.

Ik vermoed/weet bijna zeker dat je probleem in de fstab zit.

Eerst even checken: hoeveel fstab'en heb je op je systeem? Eerst al je schijven aankoppelen.
locate fstab
Graag even de uitvoer melden. De eerste regel zal zijn:
/etc/fstab
Benieuwd wat er daarna nog volgt.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #11 Gepost op: 2019/02/18, 12:26:06 »
Ik vermoed/weet bijna zeker dat je probleem in de fstab zit.
Denk ik helemaal niet. Lijkt mij nog meest waarschijnlijk in de hardware te zitten (de grafische kaart), anders misschien Grub. Het eigenaardige hier is het verschillend gedrag: bij een koude opstart start Ubuntu 18.04 niet door, bij een warme opstart, i.e., na een reboot, wel.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #12 Gepost op: 2019/02/18, 15:02:13 »
Je hebt een AMD kaart. Als je nu niet met nomodeset opstart, pas dan je grub aan om dat wel te doen (zie het tweede antwoord over hoe die instelling permanent in /etc/default/grub op te nemen). Treedt het probleem dan nog op?

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #13 Gepost op: 2019/02/18, 17:41:00 »
Je hebt een AMD kaart. Als je nu niet met nomodeset opstart, pas dan je grub aan om dat wel te doen (zie het tweede antwoord over hoe die instelling permanent in /etc/default/grub op te nemen). Treedt het probleem dan nog op?
Aanvullend:
Notebook AMD Radeon Xubuntu start pas lekker door na splash te hebben verwijderd. Anders kwam het systeem in een soort pauzestand (zwart scherm) welke ik dan kon opheffen met deksel dicht en deksel weer open........
Draai nu een test met Xubuntu 18.04 plus 4.4 kernel en dat gaat ook lekker inclusief splash scherm (zie 16.04 wel startend).

Xubuntu 18.04

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #14 Gepost op: 2019/02/18, 18:01:57 »
... Dan lukt het misschien ook al enkel door de "splash" optie weg te laten.

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #15 Gepost op: 2019/02/19, 10:36:15 »
Hoi Paul Matthijsse. Eerst maar even bij jou beginnen. Ik kan 16 gewoon kiezen uit de grublijst en eenmaal opgestart staan alle schijven / partities op mijn bureaublad. Dubbelklik en ik kan ze verkennen. Echter, als ik echt wil gaan werken in bv 16 terwijl ik in 18 zit, dan doe ik netjes een herstart en kies in grub.

Hier de uitslag:
$ locate fstab
/etc/fstab
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/etc/fstab
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/lib/systemd/system-generators/systemd-fstab-generator
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/sbin/fstab-decode
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/snap/core/6349/etc/fstab
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/snap/core/6349/lib/systemd/system-generators/systemd-fstab-generator
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/snap/core/6349/sbin/fstab-decode
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/include/fstab.h
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/doc/m4/examples/fstab.m4
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/doc/mount/examples/fstab
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/doc/mount/examples/mount.fstab
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/doc/util-linux/examples/fstab
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/doc/util-linux/examples/fstab.example2
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/man/man5/fstab.5.gz
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/man/man8/fstab-decode.8.gz
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/usr/share/man/man8/systemd-fstab-generator.8.gz
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/var/lib/snapd/mount/snap.audacity.fstab
/home/submaster/Backup 18-04 Xubuntu 14-2-19/backintime/Novita/root/1/20190214-152604-188/backup/var/lib/snapd/mount/snap.audacity.user-fstab
/lib/systemd/system-generators/systemd-fstab-generator
/sbin/fstab-decode
/snap/core/6349/etc/fstab
/snap/core/6349/lib/systemd/system-generators/systemd-fstab-generator
/snap/core/6349/sbin/fstab-decode
/snap/core/6408/etc/fstab
/snap/core/6408/lib/systemd/system-generators/systemd-fstab-generator
/snap/core/6408/sbin/fstab-decode
/usr/include/fstab.h
/usr/share/doc/m4/examples/fstab.m4
/usr/share/doc/mount/examples/fstab
/usr/share/doc/mount/examples/mount.fstab
/usr/share/doc/util-linux/examples/fstab
/usr/share/doc/util-linux/examples/fstab.example2
/usr/share/man/man5/fstab.5.gz
/usr/share/man/man8/fstab-decode.8.gz
/usr/share/man/man8/systemd-fstab-generator.8.gz
/var/lib/snapd/mount/snap.audacity.fstab
/var/lib/snapd/mount/snap.audacity.user-fstab 

Dan even naar jou Vanadium. Ik ga dit met splash maar eens proberen zo dadelijk. Die nomodeset lijkt me toch niet echt van invloed want in 16 gaat dat altijd goed en daarna ook in 18...? Het is niet zozeer koud of warm starten maar van het óf herstarten, óf geheel afsluiten en dan opnieuw starten.   Maar ik blijf het wat verwarrend vinden in jou verhaal. Ook daar zegt men eerst die splash weg te moeten halen opdat alles werkt en daarna gewoon weer er terug hebben staan en alles werkt ook prima?? Ik laat zo even weten wat dat zonder die splash doet.
Groet,
Goese Duikertje

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #16 Gepost op: 2019/02/19, 11:26:21 »
Hi Vanadium. Nou dat weghalen van splash werkte helaas niet. Hét wezenlijk verschil in dat opstarten is dus dat beiden versie eerst de grub laten zien, dan gaat bij beiden het toetsenbord uit ( goed te zien door het num lock lampje dat uitgaat.) en het scherm gaat op zwart. Dan in 16 gaat het toetsenbord weer aan na ± 7 a 10 sec, ( Bij 18 stopt het hier dus.) en het scherm wordt weer actief en het welkomstsscherm ontstaat.
Tenzij ik her-start, want dat gaat 18 precies zó opstarten. Meestal wel na ± 30 sec.

Deze spreuk ook ergens gevonden.(   ~$ gedit /boot/grub/grub.cfg  ) . Kan dit mogelijk een indicatie geven? Probleem is echter het meer is dan 2000 tekens en dan werkt het hier niet. Sugesties ?



Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #17 Gepost op: 2019/02/19, 11:56:40 »
Al eens geprobeerd met toevoeging van nomodeset? De procedure om dat permanent in te stellen is die in de *tweede* post: /etc/default/grub openen, "nomodeset" toevoegen aan de lijn GRUB_CMDLINE_LINUX_DEFAULT zodat het eruit ziet in de zin van [/code]GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
 [/code] en, belangrijk, na het opslaan van dat bestand de wijziging effectief doorgeven aan grub met het commando
sudo update-grub

Heb je dit wel correct gedaan? Ik stelde voor verschillende instellingente proberen:

- Eerst eens proberen zonder de "splash" optie: [/code]GRUB_CMDLINE_LINUX_DEFAULT="quiet"
 [/code]: hierdoor wordt geen grafisch logo vertoond tijdens opstart.
- Dan eens proberen na toevoegen van nomodeset: [/code]GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
 [/code]
- Je kan ook eens alle parameters weglaten: dan zie je alle opstartberichten en zie je waar het eventueel stopt/foutloopt.

Telkens hiervoor, terwijl je ingelogd bent in het systeem,  /etc/default/grub aanpassen én de aanpassing doorvoeren: "sudo update-grub"

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #18 Gepost op: 2019/02/19, 13:02:58 »
Hoi Vanadium. Inmiddels nu weer die nomodeset gedaan zoals je beschreef. Dus met update grub. Op zich werkt dit wel, maar de reden waarom ik dat eerder ook niet meer wilde was dat hij dan opstart in een beeldscherm van 1400 x 1050 met 77 hz. Tevens kan je dan niets aanpassen in beeldschermen.
Het beeld valt dan ook net buiten het frame en de muis is sloom en de letters anders. Ik heb normaal : 1920 x 1080 en 60 hz.

In het welkomstscherm waar je je paswoord invult ,is ook iets dat ik nog niet eerder zag. De knop ( beaver) rechtsboven om af te sluiten, heeft op dat moment een heel ander menutje. In de gauwigheid zag ik o.a. 4 keuzes om in verder te gaan. Hij stond standaard op Xubuntu 18. Terwijl erboven iets stond van xfgl. Geen idee wat dit nou inhoudt en of ik straffeloos bijvoorbeeld die xfgl kan kiezen. Wat gebeurd er dan..???
Voorlopig dus maar gewoon op de standaard laten staan. En na de start is de beaver weer het gewone menu.
Groet,
Goes Duikertje
 

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #19 Gepost op: 2019/02/19, 14:20:41 »
Hi Vanadium. Nog een kleine update. Ik heb dat met die xfgl keuze toch maar eens geprobeerd maar maakte niets uit. Inmiddels is me wel het volgende opgevallen. In 16 heb ik volledige beschikking over alle beeldscherm-instellingen. Maar in 18 helemaal niet! Hij staat daar op default van 1400 x 1050 met 77 hz. En kan dus niets aanpassen. Ook niet na de vakje aanvinken mbt "indentificeer beeldscherm".

Ben nu maar weer druk op zoek naar mogelijke oorzaken en oplossingen dáárvan. Of zit ik helemaal fout hier?

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #20 Gepost op: 2019/02/19, 14:42:31 »
Dan zou ik niet verder zoeken met "nomodeset", en dat er uit laten. Wat geeft het als je alle opties tijdelijk eruit haalt?
GRUB_CMDLINE_LINUX_DEFAULT="" (of commentaarteken voór die lijn)

Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #21 Gepost op: 2019/02/19, 15:27:11 »
Hi Vanadium. Inmiddels jouw idee om een commentaarteken vóór de lijn te plaatsten gedaan. Het heeft op zich gewerkt. Krijg na alle meldingen uiteindelijk mijn normale welkomst-scherm te zien. Zo als ook in 16. Maar omdat ik  al weer helemaal verzonken was in allerlei lightdm welkomst instellingen  / xfg enz aan te passen, heb ik mogelijk iets gedaan dat ik niet wilde.  Geen idee wat. Hoe dan ook, kort na ik mijn bureaublad werkend heb komt er nu een kleine pop-up met iets van dat er een systeemfout is ontdekt en of ik dat wil melden. Na ok klikken is het weg. Wat zou het zijn ?? Ook ARandr binnengehaald en daar viel op dat in de "oude"situatie hij alleen maar "default"als scherm heeft staan waar je dus niets mee kunt. Maar nu in de nieuwe situatie staat daar DVI en met alle resoluties die mijn scherm heeft.

Dan maar eens proberen om één voor één die items terug te zetten in die grub-lijn ?
Groet,
Goese Duikertje


Offline Goese Duikertje

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #22 Gepost op: 2019/02/20, 12:47:21 »
Hi Vanadium. Helaas! Ben eerst gisteren nog wat aan het opruimen geweest op die oude 2e schijf en alles leek goed te gaan. Ook die vervelende pop-up van "systeemfout ontdekt"heb ik op 0 kunnen zetten.
Maaaaar..,vanmorgen opstarten en dus ho maar. Het oude probleem. Zwart scherm en verder ook niets meer. Dus in de status met het uitgeschakeld zijn van de linux-lijn. Krijg er de riebels van. Ik ga nu maar eerst eens opnieuw met de boot-repair aan de gang en zien wat die weer kan doen.

Groet,
Goese Duikertje

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Nieuwe Xubuntu 18.04 start Niet dóór na Grub.
« Reactie #23 Gepost op: 2019/02/20, 13:52:39 »
Tja, vervelend. Mogelijk wordt dit verholpen bij een kernelupgrade. Mogelijk doet het probleem zich niet voor bij Ubuntu 18.10 of een andere distributie, wie zal het zeggen? Ik zie niet onmiddellijk meer een mogelijk oplossing.