Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: feisty+nvidia geforce 5200, krijg drivers niet aan de praat.  (gelezen 2233 keer)

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Gepost op: 2007/05/16, 13:50:39 »
Ik draai sinds kort nu dus feisty en hoewel ik wat problemen eerst had, met oa het bevriezen van mijn pc dankzij een CPU softlockup(AMD 1800+ XP.) is dat verholpen sinds  ik niet de generic kernel meer gebruik maar de 386 versie van 2.6.20-15.  
Het enige probleem wat ik nu heb betreft het werkend krijgen van mijn nvidia drivers.
Ik heb het op verscheidene manieren al geprobeerd via envy, de manier via de restricted drivers uit het system menu en zelfs via apt-get en het handmatig wijzigen van mijn config file.
Het rare is dat ik het gewoon niet werkend krijg en iedere keer ik gewoon uit X wordt gegooid totdat ik mijn oude xorg.conf weer terug zet.
Ik had het in Edgy perfect werken. Ik had Beryl uitgeschakeld want dat werkte wel, maar bleef lichtelijk vertragen indien ik UT2k4 aan het spelen was.
Graag zou ik advies willen hoe ik het wel werkend krijg.

lsmod | grep nvidia
levert niets op,
echter modprobe nvidia levert het volgende op.
FATAL: Could not open '/lib/modules/2.6.20-15-386/volatile/nvidia.ko': No such file or directory

Terwijl voor het opnieuw installeren ervan desbetreffende file wel degelijk op zijn plek stond:
/lib/modules/2.6.20-15-386/volatile$ ls
ath_hal.ko fcdslsl.ko fcdslusba.ko fcusb.ko ltmodem.ko
fcdsl2.ko fcdslslusb.ko fcdslusb.ko fglrx.ko ltserial.ko
fcdsl.ko fcdslusb2.ko fcpci.ko fxusb.ko nvidia.ko

Er na is het verdwenen en vervangen door:
ls
ath_hal.ko fcdslsl.ko fcdslusba.ko fcusb.ko ltmodem.ko
fcdsl2.ko fcdslslusb.ko fcdslusb.ko fglrx.ko ltserial.ko
fcdsl.ko fcdslusb2.ko fcpci.ko fxusb.ko nvidia_new.ko

Ik kijk vast ergens over heen, maar ik vind dit al vreemd ten eerste.

Aan mijn xorg.conf ligt het niet er is weinig verschil tussen het oude en het nieuwe
alleen dus het feit dat ik dit heb vervangen:
Section "Device"
   Identifier   "NVIDIA Corporation NV34 [GeForce FX 5200]"
   Driver      "nv"
   BusID      "PCI:1:0:0"

door:
Section "Device"
    Identifier     "NVIDIA Corporation NV34 [GeForce FX 5200]"
    Driver         "nvidia"
    BusID     "PCI:1:0:0"

bij voorbaat dank.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #1 Gepost op: 2007/05/16, 14:11:43 »
Systeem -> beheer -> beperkt ondersteund stuurprogramma

lukt dat ook niet?
Ik vrees helaas dat je met envy je systeem een beetje verziekt hebt. Afblijven van die zooi.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #2 Gepost op: 2007/05/16, 14:49:25 »
Citaat van: bartek
Systeem -> beheer -> beperkt ondersteund stuurprogramma

lukt dat ook niet?
Ik vrees helaas dat je met envy je systeem een beetje verziekt hebt. Afblijven van die zooi.
nope werkt niet, dat had ik al geprobeerd, als een van de eerste manieren. Dat viel overigens ook te lezen.

envy was een van de laatste pogingen, voor zover ik het kon lezen kreeg het niets voor elkaar.
blabla, kon kernel source niet vinden blabla, terwijl die kernel source er wel degelijk is.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #3 Gepost op: 2007/05/16, 14:59:36 »
het is een beetje raden geworden na het installeren van envy.
doe eens: sudo apt-get install linux-restricted-modules-`uname -r`
en een reboot.

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #4 Gepost op: 2007/05/16, 15:06:09 »
Citaat van: leoquant
het is een beetje raden geworden na het installeren van envy.
doe eens: sudo apt-get install linux-restricted-modules-`uname -r`
en een reboot.
sudo apt-get install linux-restricted-modules-`uname -r`
Password:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
linux-restricted-modules-2.6.20-15-386 is already the newest version.

ook al reeds gedaan.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #5 Gepost op: 2007/05/16, 15:07:28 »
doe eens: uname -a in de terminal

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #6 Gepost op: 2007/05/16, 15:10:22 »
Citaat van: leoquant
doe eens: uname -a in de terminal
dat levert dit op:

Linux almaddin 2.6.20-15-386 #2 Sun Apr 15 07:34:00 UTC 2007 i686 GNU/Linux

modprobe nvidia
FATAL: Could not open '/lib/modules/2.6.20-15-386/volatile/nvidia.ko': No such file or directory

terwijl er vlak er voor wederom nog voor de reboot een nvidia.ko file stond.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline hadez

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #7 Gepost op: 2007/05/16, 15:22:09 »
Gooi anders eens je restricted modules er af. Opnieuw opstarten, opnieuw installeren, opnieuw opstarten. En dan pas "nv" vervangen door "nvidia".

nVidia geforce5200 zou wel goed ondersteund moeten worden, want de mijne (een 5200FX) wordt perfect ondersteund :)

heb je ook deze pakketten:

nvidia-glx
nvidia-kernel-common
xserver-xorg-video-nv

Ik weet verder niet wat je processor-architectuur is, maar ik heb een AMD, maar ik draai niet de -386 kernel, maar de -generic en heb ook de k7-headers geinstalleerd, en dat gaf een enorme snelheidsboost.

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #8 Gepost op: 2007/05/16, 15:35:57 »
Citaat van: hadez
Gooi anders eens je restricted modules er af. Opnieuw opstarten, opnieuw installeren, opnieuw opstarten. En dan pas "nv" vervangen door "nvidia".

nVidia geforce5200 zou wel goed ondersteund moeten worden, want de mijne (een 5200FX) wordt perfect ondersteund :)

heb je ook deze pakketten:

nvidia-glx
nvidia-kernel-common
xserver-xorg-video-nv

Ik weet verder niet wat je processor-architectuur is, maar ik heb een AMD, maar ik draai niet de -386 kernel, maar de -generic en heb ook de k7-headers geinstalleerd, en dat gaf een enorme snelheidsboost.
Bij de generic krijg ik een CPU soft lock up. De 386 niet.

Alle genoemde pakketten heb ik.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline Dave

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #9 Gepost op: 2007/05/16, 15:49:59 »
afgelopen weken ook dagelijks een bevriezend systeem gehad en kreeg toch het idee dat het de vidiokaart driver was.
in Edgy kon ik de glx gebruiken maar nu in feisty enkel de legacy en geen 3d meer en wat meer beperkingen en dus dat bevriezende systeem steeds.
nu vanmorgen alles van nvidia verwijderd en de vesa geselecteerd.
ook wel beperkingen maar tgaat wel weer vlot allemaal zoals openen van een fotomap.
bevriezend systeem nog afwachten of dat over is. tot nu gaat het goed.

nvidia geforce2 MX400 en amd thunderbird 1200

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #10 Gepost op: 2007/05/16, 15:54:52 »
Citaat van: Dave
afgelopen weken ook dagelijks een bevriezend systeem gehad en kreeg toch het idee dat het de vidiokaart driver was.
in Edgy kon ik de glx gebruiken maar nu in feisty enkel de legacy en geen 3d meer en wat meer beperkingen en dus dat bevriezende systeem steeds.
nu vanmorgen alles van nvidia verwijderd en de vesa geselecteerd.
ook wel beperkingen maar tgaat wel weer vlot allemaal zoals openen van een fotomap.
bevriezend systeem nog afwachten of dat over is. tot nu gaat het goed.

nvidia geforce2 MX400 en amd thunderbird 1200
De lock up vond plaats zonder nvidia driver. Vaak al tijdens de bootup procedure.
Nu is dat "verholpen". Beter gezegd ik heb er nu geen last van. ik zou geen probleem hebben met een andere driver zoals vesa, ware het niet dat ten alle tijde ik eindig met een heel donker scherm, ook al pas ik de brightness van mijn monitor aan.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #11 Gepost op: 2007/05/16, 16:17:14 »
Heb de restricted modules gedeinstalleerd en geherinstalleerd. gereboot tussendoor.
ik heb nv nog niet verandert in nvidia want als ik na de laatste reboot nogmaals de commando's: lsmod | grep nvidia en modprobe nvidia doe houd ik hetzelfde resultaat
De eerste levert niets op, de tweede blijft me zeggen dat er geen nvidia.ko is.
Wat klopt, aangezien de enige file die er is met de naam nvidia in de desbetreffende directory nvidia_new.ko is.
Update: toch nog even met nvidia in xorg.conf geprobeerd, het werkte niet, x bleef crashen.

Ik twijfel er niet aan dat het hoort te werken, ik heb het allemaal werkend gehad in zowel, edgy als ook een andere linux distributies die ooit heb gedraaid. Van fedora tot red hat waar ik ooit in 2001 mee ben begonnen.(Ik heb al tijden een nvidia kaart zij het in het begin een wat oudere nvidia MX440.)
Ubuntu heeft inmiddels mijn voorkeur, het werkt gewoon makkelijker en het meeste wat ik nodig heb installeert zichzelf en werkt zonder problemen. Dit is een van de weinige problemen waar ik toevallig tegen aan loop zo af en toe.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #12 Gepost op: 2007/05/17, 08:11:19 »
Ik zit te denken aan een complete reinstall aangezien het waarschijnlijk toch "verpest" is door envy en om een of andere reden ik het niet draaiende verder krijg.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline hadez

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #13 Gepost op: 2007/05/17, 12:33:49 »
iS HET proberen van modprobe nvidia_new geen optie? (ik zit nu niet op n ubuntu-bak, ik weet uberhaupt niet of het mogelijk is ... :(  )

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #14 Gepost op: 2007/05/17, 13:25:37 »
Citaat van: hadez
iS HET proberen van modprobe nvidia_new geen optie? (ik zit nu niet op n ubuntu-bak, ik weet uberhaupt niet of het mogelijk is ... :(  )
modprobe nvidia_new
FATAL: Error running install command for nvidia_new

mogelijk... levert wel een probleem op dus.
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline almaddin

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #15 Gepost op: 2007/05/20, 11:54:44 »
Na een zeer uitgebreide reinstall van dapper naar feisty werkt alles wel. Op de meest simpele manier via de restricted drivers manager.
:)
"I may not have ended up where I intended to go, but I think I ended up where I intended to be" Douglas Adams
8834 http://ubuntucounter.geekosophical.net/
Acer Aspire 7116: Ubuntu 10.04+Windows Vista Home Premium
PCs: Fedora 13, Ubuntu 10.10 en Windows 2000 professional(3 pcs)

Offline fred101

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #16 Gepost op: 2007/05/27, 14:31:36 »
Ik heb gisteren de restricted drivers aangezet voor mijn compaq presario r3000 met nvidia geforce 4. Deze resulteerde soms in zwarte schremen onder firefox. Met edgy heb ik nooit een vastloper gehad, feisty wil nu niet meer. Ik heb de restricted drivers dus weer uitgezet en nu kan ik niet meer. Ik heb ingelogd in rescue mode en het een en ander geprobeerd maar nu weet ik het niet meer. Hoe zet ik restricted drivers weer aan. Wil niet herinstalleren want dan ben ik een boel data kwijt.

fred

Offline fred101

  • Lid
  • Steunpunt: Nee
feisty+nvidia geforce 5200, krijg drivers niet aan de praat.
« Reactie #17 Gepost op: 2007/05/28, 19:46:25 »
Ik heb weer beeld maar steeds zwarte schermen, begint XP te lijken met zoveel uit moeten zetten.

Fred