Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: zoneminder installeren. wat problemen.  (gelezen 91 keer)

zoneminder installeren. wat problemen.
« Gepost op: 2018/06/08, 09:54:35 »
Hallo
ik probeer momenteel zoneminder te installeren.
Hiervoor gebruik ik dit youtube filmpje waarin stap voor stap word uitgelegd hoe de installatie werkt.
https://www.youtube.com/watch?v=Spr-JD2bEbc

Nou zijn dit de eerste stappen die tot nu toe probleemloos gaan:
+ sudo apt-get install tasksel
+ sudo tasksel install lamp-server
+ sudo add-apt-repository ppa:iconnor/zoneminder
+ sudo apt-get update
+ sudo apt-get upgrade
+ sudo apt-get dist-upgrade
+ sudo rm /etc/mysql/my.cnf
+ sudo cp /etc/mysql/mysql.conf.d/mysqld.cnf /etc/mysql/my.cnf

Nu kom ik in de problemen:
om het gnu nano bestand te openen tik je: sudo nano /etcmysql/my.cnf
Het gnu nano open zich maar krijg dan de melding:  [ Directory '/etcmysql' does not exist ]

hoe is dit op te lossen?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: zoneminder installeren. wat problemen.
« Reactie #1 Gepost op: 2018/06/08, 10:12:17 »
Het moet zijn: sudo nano /etc/mysql/my.cnf
Er is dus een "/" weggevallen.........
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Re: zoneminder installeren. wat problemen.
« Reactie #2 Gepost op: 2018/06/08, 10:31:11 »
Het moet zijn: sudo nano /etc/mysql/my.cnf
Er is dus een "/" weggevallen.........

thanks, ik zie het nu.
ik heb de installatie nu helemaal voor elkaar.

Dit is wat ik allemaal gedaan hebt:
Citaat
+ sudo apt-get install tasksel
+ sudo tasksel install lamp-server

Update Repos
+ sudo add-apt-repository ppa:iconnor/zoneminder

Update repo and upgrade.
+ sudo apt-get update
+ sudo apt-get upgrade
+ sudo apt-get dist-upgrade

Configure MySQL
+ sudo rm /etc/mysql/my.cnf
+ sudo cp /etc/mysql/mysql.conf.d/mysqld.cnf /etc/mysql/my.cnf
+ sudo nano /etc/mysql/my.cnf
zoek naar: lc-messages-dir   = /usr/share/mysql
skip-external-locking
+ maak een lege regel ertussen en typ daarin: sql_mode = NO_ENGINE_SUBSTITUTION
(het ziet er dus zo uit:
lc-messages-dir   = /usr/share/mysql
NO_ENGINE_SUBSTITUTION
skip-external-locking)
+ save flile en exit.
+ terug naar terminal: systemctl restart mysql

Install ZoneMinder
+ sudo apt-get install zoneminder

Configure the ZoneMinder Database
+ mysql -uroot -p < /usr/share/zoneminder/db/zm_create.sql  (hiermee installeer je wachtwoord?)
+ mysql -uroot -p -e "grant select,insert,update,delete,create,alter,index,lock tables on zm.* to 'zmuser'@localhost identified by 'zmpass';"

Set permissions
+ sudo chmod 740 /etc/zm/zm.conf
+ sudo chown root:www-data /etc/zm/zm.conf
+ sudo chown -R www-data:www-data /usr/share/zoneminder/

Configure Apache correctly:
+ sudo a2enconf zoneminder
+ sudo a2enmod cgi
+ sudo a2enmod rewrite

Enable and start Zoneminder
+ sudo systemctl enable zoneminder
+ sudo systemctl start zoneminder

Edit Timezone in PHP
+ sudo nano /etc/php/7.0/apache2/php.ini
+ zoek naar [date]
+ verander de zin ;date.timezone in date.timezone = europe/amsterdam
+ save file en exit.

Reload Apache service
+ sudo systemctl reload apache2

Making ZoneMinder works
+ open de browser en tik in http://hostname_or_ip/zm

Nou bij het laatste "Making ZoneMinder works" kom ik er niet uit.
Het "hostname_or_ip" moet het ip adres van de camera zijn?
Dus in mijn geval is dat dus: https://192.168.1.100/zm Maar dan krijg ik een "404-not found" melding te zien.
wat  misschien gezien ook wel logisch is want als ik https://192.168.1.100 (zonder zm)in mijn browser tik krijg het inlogscherm van mijn camera te zien. en daar kan zoneminder niet doorheen komen en is dat de reden van "404-not-found" melding?

of hoe moet ik dat zien/waarom krijg ik een 404 melding te zien en hoe los ik dit op?


« Laatst bewerkt op: 2018/06/08, 10:45:11 door ubuntugirl2 »

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: zoneminder installeren. wat problemen.
« Reactie #3 Gepost op: 2018/06/08, 12:23:42 »
Mijn kennis houdt op bij de lamp-server ............
Maar in het voorbeeld gebruik je HTTP en daaronder gebruik je HTTPS ..........
Verder weet ik het ook niet.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.