Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Na installatie Ubuntu ---> no bootable device  (gelezen 353 keer)

Offline evermeiren

  • Lid
  • Steunpunt: Nee
Na installatie Ubuntu ---> no bootable device
« Gepost op: 2018/05/31, 18:57:37 »
Hi,

Ik heb na een mislukte update van windows 10 besloten om ubuntu te installeren op een Acer ES 14. Ik heb ubuntu 16.04, Lubuntu 18.06 en ubuntu 18.06 geprobeerd en hoewel de installatie goed verloopt krijg ik steeds na de reboot een melding NO bootable device.
Ik heb reeds allerlei aangereikte oplossingen  uitgeprobeerd zonder resultaat. Het aanpassen van de bootfiles bootx64.efi en Shimx64.efi en de bootorder in efibootmgr  verdwijnen na een reboot en steeds dezelfde foutmelding "no bootable device".
Ik wil enkel een versie van ubuntu, geen windows voor mij.
Graag enkele tips of mogelijke oplossingen.

Etienne

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #1 Gepost op: 2018/05/31, 20:01:14 »
Heb je -met secure boot ingeschakeld- een "UEFI file as trusted for executing" kunnen kiezen?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #2 Gepost op: 2018/05/31, 20:53:38 »
Heb je de opstart-lader (grub) wel op je HD geinstaleerd en niet op b.v. een ingeplugde USB stick?
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline evermeiren

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #3 Gepost op: 2018/05/31, 23:02:45 »
Ik kan geen Uefi file als trusted kiezen. De keuze is er eenvoudig niet .

Ik heb de installatie  standaard uitgevoerd met een opstart Usb- stick. De installatie verloopt vlekkeloos tot er gereboot moet worden, dan krijg ik de melding "no bootable device".

Wanneer ik dan met  Live sessie opstart zie ik op de harde schijf de 3 partities namelijk Efi, het systeem en de swap

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #4 Gepost op: 2018/06/01, 08:39:29 »
Ik kan geen Uefi file als trusted kiezen. De keuze is er eenvoudig niet .

Ik heb de installatie  standaard uitgevoerd met een opstart Usb- stick. De installatie verloopt vlekkeloos tot er gereboot moet worden, dan krijg ik de melding "no bootable device".

Wanneer ik dan met  Live sessie opstart zie ik op de harde schijf de 3 partities namelijk Efi, het systeem en de swap
In dat geval zou ik Boot-Repair zijn werk laten doen: https://help.ubuntu.com/community/Boot-Repair

Offline evermeiren

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #5 Gepost op: 2018/06/01, 10:23:28 »
Ik heb de boot-repair geprobeerd zonder resultaat. ik heb bootinfo verzameld en deze kan worden bekenen in http://paste.ubuntu.com/p/WHH27q3B3M/

Mischien kan iemand hier iets mee doen.

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #6 Gepost op: 2018/06/01, 12:54:33 »
Ik heb de boot-repair geprobeerd zonder resultaat. ik heb bootinfo verzameld en deze kan worden bekenen in http://paste.ubuntu.com/p/WHH27q3B3M/
Mischien kan iemand hier iets mee doen.
Heb je de voorgestelde repair (regel 528) laten uitvoeren?
En heb je daarna als bootfile ingesteld wat er in regel 534 staat?
Ik heb zelf ooit met een Acer netbook gelijksoortige problemen gehad. Na het draaien van Boot-Repair (en laten repareren) moest ik tot slot ook de bootfile aanpassen, en pas toen was alle leed geleden.

Offline evermeiren

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #7 Gepost op: 2018/06/01, 14:41:01 »
Ik heb de aanpassingen uitgevoerd maar na de reboot is mijn bootfile terug aangepast en de bootorder is niet meer correct.

Zo ziet de bootfile er nu uit:

ubuntu@ubuntu:~$ sudo efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,2002,2003
Boot0000* Unknown Device:    HD(1,GPT,6d2406c4-38b0-4d88-bdc7-a9d10c6078f0,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0001* USB HDD: Generic Flash Disk   PciRoot(0x0)/Pci(0x15,0x0)/USB(3,0)/HD(1,MBR,0x2b192737,0x380acc,0x1240)RC
Boot0002* Unknown Device:    HD(1,GPT,6d2406c4-38b0-4d88-bdc7-a9d10c6078f0,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0004* UEFI hard drive   HD(1,GPT,6d2406c4-38b0-4d88-bdc7-a9d10c6078f0,0x800,0x100000)/File(\EFI\boot\grubx64.efi)
Boot2001* EFI USB Device   RC
Boot2002* EFI DVD/CDROM   RC
Boot2003* EFI Network   RC
ubuntu@ubuntu:~$

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #8 Gepost op: 2018/06/01, 15:42:01 »
Er vallen me twee dingen op:
1 BootOrder: 2001,2002,2003; hierin komt je HDD niet voor.
2 Ik zie nergens de in regel 534 aangegeven file staan. Die zou je in de UEFI in moeten voeren (waarschijnlijk verstopt achter wat andere keuzes).
Helaas kan ik je geen kant-en-klaar antwoord geven. Ik kan je hooguit verwijzen naar de oplossing die destijds voor mij gold: https://forum.ubuntu-nl.org/index.php?topic=87072.25, Reactie # 26. Helaas zijn alle BIOS'en en UEFI's anders.

Offline evermeiren

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #9 Gepost op: 2018/06/01, 17:28:17 »
De wijzigingen zijn uitgevoerd geweest en de bootorder was ook aangepast, maar  na de reboot is de bootorder terug verkeerd.

Ik merk ook op dat de diskidentifier in de bootfile verschillend  is van degene die ik vind via de bootrepair log  namelijk:

1)in bootfile:
 Boot0004* UEFI hard drive   HD(1,GPT,6d2406c4-38b0-4d88-bdc7-a9d10c6078f0,0x800,0x100000)/File(\EFI\boot\grubx64.efi)
Disk identifier: 465C93CF-CF4B-4B59-A855-49DC870191E3
2) in boot repair  log of via fdisk:
Disk identifier: 465C93CF-CF4B-4B59-A855-49DC870191E3
Disk identifier: 465C93CF-CF4B-4B59-A855-49DC870191E3

nochtans gebruik als dev name mmcblk0p1

Offline evermeiren

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #10 Gepost op: 2018/06/11, 11:16:20 »
Probleem is opgelost door on boot-repair advanced options te kiezen en daarin Windows boot repair aan te vinken.
Het systeem probeerde dan te booten maar mankeerde de file grubx64.efi in de Microsoft/Boot directory. Deze file daarin gecopieerd en probleem opgelost.

Aan iedereen die geholpen heeft, toch bedankt.
Etienne

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #11 Gepost op: 2018/06/11, 17:37:45 »
Mooi dat het werkt.
Toch blijf ik -ter lering- met een vraag zitten: had je bij de installatie gekozen voor alles wissen en hele schijf gebruiken of niet?

Offline evermeiren

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #12 Gepost op: 2018/06/11, 18:20:18 »
Ik heb bij de installatie de ganse schijf gebruikt en gewist. Ik heb dit 3 x gedaan, 1 x met ubuntu 16.04, 1x met Lubuntu en de laatste maal met xubuntu 18.04. Het resultaat was telkens hetzelfde no bootable device. Ik verdenk Acer ervan dat ze hardcoded enkel Windows laten booten.

Ik had ook ondersteuning bij Acer gevraagd waarbij men mij dit antwoord hebben doorgestuurd: Dit heeft mij echter niet verder geholpen.

Reactie Door Email (Jasper) (07/06/2018 11:54)
Geachte heer Vermeiren,
 
Bekijkt u de volgende link eens, daarmee zou het moeten lukken Ubuntu werkend te krijgen op de ES1-432:
https://askubuntu.com/questions/886536/how-to-install-ubuntu-on-an-acer-with-preinstalled-windows-10-home
 

Offline ajjp

  • Lid
  • Steunpunt: Nee
Re: Na installatie Ubuntu ---> no bootable device
« Reactie #13 Gepost op: 2018/06/11, 21:24:08 »
Citaat
Ik verdenk Acer ervan dat ze hardcoded enkel Windows laten booten.
Daar lijkt het inderdaad op.
M.b.t. de gegeven link: had die drie-en-een-half jaar geleden maar bestaan. Ik ben toen m.b.v. dit forum (met name Jolo) op hetzelfde uitgekomen, maar wat zou me dat een zweetdruppels hebben bespaard.