Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Folders op externe drive worden niet meer automatisch gemapped.  (gelezen 250 keer)

Offline Sandman

  • Lid
Hi,

Al mijn files staan op mijn nas via gedeelde nfs folders, die ik op ubuntu via symbolic links en de fstab file automatisch liet inladen. Dit werkt echter niet meer.

Ook niet als ik als ik met adminrechten het commando mount -a uitvoer, dan zijn mijn mappen nog altijd leeg, en staat er op het iccontje een slot.

Slechts als ik een map specifiek apart mount, bvb met het commando mount 192.168.1.107:/volume1/homes/Joost/Documenten    /nfs/joost/documenten  ,  dan is alles ter beschikking zoals vanouds..; iemand tips voor deze leek? :)

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Folders op externe drive worden niet meer automatisch gemapped.
« Reactie #1 Gepost op: 2018/05/28, 08:40:48 »
Waarschijnijk is het netwerk nog niet actief als /etc/fstab wordt uitgevoerd.

Mogelijk helpt het om de optie _netdev of x-systemd.after=network-online.target toe te voegen aan /etc/fstab

https://unix.stackexchange.com/questions/349264/fstab-mount-wait-for-network/349278#349278
Klik links bovenin op Documentatie

Offline Sandman

  • Lid
Re: Folders op externe drive worden niet meer automatisch gemapped.
« Reactie #2 Gepost op: 2018/05/28, 22:46:25 »
Hi, ik ben niet zeker of ik het juist heb toegevoegd, maar ik heb de regel in fstab aangepast van 1
92.168.1.107:/volume1/homes/Joost/Documenten    /nfs/joost/documenten      nfs     noauto,  0 0

 naar

192.168.1.107:/volume1/homes/Joost/Documenten    /nfs/joost/documenten      nfs     noauto,_netdev  0 0

Het effect was iig niets, na een reboot, dit commando zou dus het mounten doen wachten tot nadat er effectief een netwerk is, helaas werkt het commando mount -a ook niet als er al effectief een netwerk is, enkel het commando 192.168.1.107:/volume1/homes/Joost/Documenten    /nfs/joost/documenten     uitvoeren in de commandobox na boot en netwerk maakt deze directory beschikbaar. Helaas zijn het een tiental directoriies :)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Folders op externe drive worden niet meer automatisch gemapped.
« Reactie #3 Gepost op: 2018/05/30, 06:25:11 »
Al geprobeerd ook de x-systemd.after=network-online.target optie toe te voegen?

Offline Sandman

  • Lid
Re: Folders op externe drive worden niet meer automatisch gemapped.
« Reactie #4 Gepost op: 2018/05/30, 19:14:21 »
ik heb nu in fstab de regel veranderd naar 192.168.1.107:/volume1/homes/Joost/Documenten    /nfs/joost/documenten      nfs     noauto,_netdev,x-systemd.after=network-online.target  0 0 . Zou dit zo correct moeten zijn? het heeft iig helaas geen effect.

Offline Sandman

  • Lid
Re: Folders op externe drive worden niet meer automatisch gemapped.
« Reactie #5 Gepost op: 2018/05/30, 19:30:09 »
Ik kreeg nog een foutmelding van mijn wifi driver, maar ook op lankabel blijft de pc de netwerkdrives niet automatisch mappen, en werkt ook het commando mount -a niet. enkel alle netwerkdrives manueel koppelen lukt. :)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Folders op externe drive worden niet meer automatisch gemapped.
« Reactie #6 Gepost op: 2018/05/31, 04:44:35 »
Het valt mij nu op dat er tevens "noauto" staat in je opties. Je kan dus voor het ogenblik niet verwachten dat de aankoppeling automatisch gebeurt. Verwijder dus die optie als je wenst dat de aankoppeling automatisch doorgevoerd wordt.

Offline Sandman

  • Lid
Re: Folders op externe drive worden niet meer automatisch gemapped.
« Reactie #7 Gepost op: 2018/05/31, 17:03:07 »
Mja, die optie noauto had ik maar gecopieerd ooit van een manual om die automatische netwerkmapping in orde te brengen, het heeft er wel 2 jaar wel mee gewerkt. Maar goed, ik heb de optie even weggelaten en er is vooruitgang: Na een reboot is
weliswaar nog steeds geen enkele map automatisch gemapped, maar het commando 'mount -a' werkt wel, waardoor alle drives met dit ene korte commando nu wel weer beschikbaar zijn...