Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu en Mint willen alleen starten met " Nouveau.noaccel-1" in Grub  (gelezen 268 keer)

Offline Catweazle

  • Lid
Hallo allemaal,
ik ben al weken aan het stoeien met Ubuntu 16.4 en Mint Cinnamon 18.
Heb jaren probleemloos met Mint gewerkt. Een paar weken geleden is daar een update in binnen gekomen en geïnstalleerd de beeldweergave op mijn monitoren volledig verwoeste.
Ik had alleen maar diagonaal schuin beeld en kom niet meer doen.
Na veel uitproberen was het niet meer mogelijk op welke wijze dan ook toegang tot het systeem te krijgen en heb ik het volledige opnieuw moeten opzetten.
Na installatie en herstart kreeg ik, het al wel bekende, zwarte beeld.
Heb daar toen niets op uit gedaan en op dezelfde computer Ubuntu 16.4 naast Mint Cinnamon 18 geïnstalleerd om uit te vinden of die het zelfde probleem had.
En ja hoor, daar ook na herstart, het bekende zwarte beeld en verder niets.
Beide systemen werken " achter" het zwarte beeld echter wel en reageerde op de CTRL+Alt+Del toetsen.
Door in het Grub-opstart menu de optie, "nouveau.noaccel=1" toe te voegen zijn beide systemen weer zichtbaar geworden op de monitoren en werken ze ook weer met beide monitoren.
Voor de duidelijkheid, een systeem waar twee monitoren op aangesloten zijn via een Nvidia Geforce 7300GT videokaart.
Het gehele systeem is al vrij oud, maar dat maakte in het verleden niet uit en heeft jaren probleemloos gewerkt.

Ik heb ondertussen op het mint systeem al uitgeprobeerd om de Nvidia beeldschermdrivers 304.135 te installeren maar dat was niet bepaald een succes.
Weer zwart scherm en zweetdruppels om het geheel naar Nouveau video terug te zetten.

Nu mijn brandende vraag:
is er een mogelijkheid beide systemen, of in ieder geval Ubuntu, aan de praat te krijgen onder de nouveau video drivers zonder de optie " noaccel=1" in het Grub opstart systeem.
Door die optie is het afspelen van filmpjes en het kijken op youtube en dergelijke namelijk een regelrechte ramp doordar ik niet de beschikking heb over de benodigde video acceleratie die daar voor nodig is om filmpjes en video's vloeiend en schok/stoot vrij te kunnen volgen..

Wie heeft daar de " Goudentip " voor.
Moet wel even van te voren vertellen dat ik heel weinig ervaring met Linux systemen heb en hoe het achter het scherm allemaal werkt.
Mvg. Ruud.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu en Mint willen alleen starten met " Nouveau.noaccel-1" in Grub
« Reactie #1 Gepost op: 2018/03/16, 15:43:20 »
Post hier eens een volledig systeemoverzicht, op de volgende wijze:
https://sites.google.com/site/computertip/inxi

Offline Catweazle

  • Lid
Re: Ubuntu en Mint willen alleen starten met " Nouveau.noaccel-1" in Grub
« Reactie #2 Gepost op: 2018/03/16, 16:17:56 »
Ik heb het inixi programmaatje laten draaien en dit zijn mijn systeem gegevens:

System:    Host: Ububtu-16 Kernel: 4.13.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Unity 7.4.5 (Gtk 3.18.9-1ubuntu3.3) Distro: Ubuntu 16.04 xenial
Machine:   Mobo: Abit model: KN9(NF-MCP55 series) v: 1.x Bios: Phoenix v: 6.00 PG date: 11/19/2007
CPU:       Dual core AMD Athlon 64 X2 4600+ (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm) bmips: 9599
           clock speeds: max: 2400 MHz 1: 2400 MHz 2: 2400 MHz
Graphics:  Card: NVIDIA G73 [GeForce 7300 GT] bus-ID: 06:00.0
           Display Server: X.Org 1.19.5 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: llvmpipe (LLVM 5.0, 128 bits) GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card-1 NVIDIA MCP55 High Definition Audio driver: snd_hda_intel bus-ID: 00:06.1
           Card-2 GEMBIRD driver: USB Audio usb-ID: 001-005
           Sound: Advanced Linux Sound Architecture v: k4.13.0-37-generic
Network:   Card-1: NVIDIA MCP55 Ethernet driver: forcedeth port: b000 bus-ID: 00:08.0
           IF: enp0s8 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: NVIDIA MCP55 Ethernet driver: forcedeth port: ac00 bus-ID: 00:09.0
           IF: enp0s9 state: down mac: <filter>
Drives:    HDD Total Size: 924.3GB (3.5% used) ID-1: /dev/sda model: SAMSUNG_HD400LD size: 400.1GB temp: 39C
           ID-2: /dev/sdb model: HDS722525VLAT80 size: 250.1GB temp: 43C
           ID-3: /dev/sdc model: Maxtor_6Y120M0 size: 122.9GB temp: 50C
           ID-4: /dev/sdd model: SAMSUNG_SP1213C size: 120.1GB temp: 33C
           ID-5: USB /dev/sde model: Media size: 31.1GB temp: 0C
Partition: ID-1: / size: 365G used: 29G (9%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.15GB used: 0.01GB (1%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A gpu: 67.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 186 Uptime: 1:05 Memory: 1565.9/1994.0MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Wat mij bij de gebruikte monitoren wel is opgevallen is dat de 1e monitor in het menu, Systeem/scherm, in Mint wordt weergegeven als VGA en de tweede als DVI.
Beide monitoren zijn echter wel met een DVI kabel rechtstreeks en zonder verloop adapters op de Nvidia videokaart aangesloten.
Kan dit iets met een refresh van de monitoren te maken hebben?
In het verleden hebben beide monitoren op de zelfde aangesloten wijze echter nooit geen problemen gegeven.

Wat mij nu ook te binnen schiet is dat ik tijdens de installatie van Ubuntu ook in het DVD installatie menu al heb extra optie nomodeset heb moeten aanvinken om beeld op de beeldscherm te krijgen.
Naderhand heb ik in het Grubmenu de optie " nouveau.noaccel=1 " moeten toevoegen om beeld op de beeldschermen te krijgen.
Daarna werkte beide systemen met beide beeldschermen onder de resolutie van 1920X1080.

De software op beide systemen is ook nog steeds alleen maar standaard zoals bij de installatie, Dus geen extra' s toegevoegd.
Wel is het pakket restricted-media toegevoegd na de installaties.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Ubuntu en Mint willen alleen starten met " Nouveau.noaccel-1" in Grub
« Reactie #3 Gepost op: 2018/03/16, 16:36:57 »
Beperk het tijdelijk eens tot één beeldscherm, dus trek er eentje los. Installeer daarna de nvidia-304 wederom en herstart daarna niet meteen, maar doe eerst dit:

1. Nomodeset:
https://sites.google.com/site/easylinuxtipsproject/nomodeset

2. Zet Nouveau op de zwarte lijst:
https://sites.google.com/site/easylinuxtipsproject/bugs#TOC-The-closed-non-free-Nvidia-driver-won-t-load
(punt 12, linkerkolom)

3. Herstart je computer.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Ubuntu en Mint willen alleen starten met " Nouveau.noaccel-1" in Grub
« Reactie #4 Gepost op: 2018/03/16, 21:13:02 »
Bij een dergelijke fout,  had je  kunnen proberen op te starten met een oudere kernel, waar je videokaart wel werkt.

Kan zijn dat door de updates tav de veiligheid problemen je problemen hebt.(firmware update die in de kernel zit).

Wat je zou kunnen doen is een install met een oudere versie van je linux, oud bedoel ik de punt versie,
dus 16.04(oudste) of 16.04.1 of 16.04.2 etc.
En dan hier de kernel vast zetten.
Als de updates in je videokaart driver zit, dan zal dit misschien niet helpen, dus je komt te testen.

Offline Catweazle

  • Lid
Re: Ubuntu en Mint willen alleen starten met " Nouveau.noaccel-1" in Grub
« Reactie #5 Gepost op: 2018/03/17, 16:51:47 »
@Pjotr: Ik heb alle drie de punten afgewerkt zoals je beschreven hebt. Dus geen nieuwe opstart meteen na het installeren van Nvidia maar eerst de twee overige punten nog even doorgevoerd.
Daarna de PC pas opnieuw opgestart.
Toen kwam ik met geen mogelijkheid meer in Linux. Het scherm was zwart en bleef zwart.
Ook na de noodingrepen in Grub met de opties: nomodeset, nvidia.nomodeset, nouveau.noaccel=1 ( logisch eigenlijk want nouveau was blacklisted =) )
Dus uithuilen en opnieuw beginnen.
Heb gelukkig nog een versie van Ubuntu die ik wel draaiend heb met de noodingreep nouveau.noaccel=1 in Grub op de zelfde PC.
Maar geef niet op hoor, ga weer een testversie naast de werkende Ubuntu zetten en toch zien het probleem te tackelen.
Voel dat nu gewoon als een uitdaging. =) Te meer daar ik heel weinig van Linux af weet. Dus leer er alleen maar veel door. Hoe het wel en NIET moet =)

@Jan1100: Ik zou nu willen proberen om het systeem op te zetten met een 4.08 kernel. Daarvan weet ik dat ik die ook in het eerder goed lopende systeem had zitten. Maar ook daar moest ik het systeem niet upgraden naar de Nvidia en gewoon nouveau blijven draaien als videodriver. Maar had daar wel de acceleratie van de video kaart werkend en kon normaal video en films kijken als ik dat even wou.
Maar vraagje, hoe zou ik een oudere kernel inhet systeem kunnen zetten.?

Offline Catweazle

  • Lid
Re: Ubuntu en Mint willen alleen starten met " Nouveau.noaccel-1" in Grub
« Reactie #6 Gepost op: 2018/03/22, 11:56:58 »
Was even een beetje stil rond dit onderwerp maar ben intussen druk bezig geweest met uitproberen van diverse mogelijkheden.
De eerste is: Ubuntu 16.4 installeren met de optie "priority=low nouveau.noacccel=1"  tijdens het Grub opstarten.
Dit heeft bij mij als resultaat dat Ubuntu normaal opstart en geen zwart beeld geeft.
Wel is dan het gebruik van Youtube en dergelijke sites bijna niet te doen.
Heel schokkerig en veel foutenmeldingen dat de site het systeem onacceptabel vertraag.
Ubuntu opstarten met de optie "noapic nodmraid" in Grub laten het systeem weer een zwart beeld geven na de opstart.
De optie "nomodeset" laat het systeem wel opstarten maar kan dan geen twee monitoren gebruiken en geven een max. beeld resolutie van 1280X1024.
Ook niet echt optiiemaal dus.

Uiteindelijk heb ik Xubuntu als test systeem geinstalleerd naast Ubuntu.
Tijdens de start word in Grub gebruik gemaakt van de opties "noapic nodmraid" waarna het systeem goed doorstart en alles naar behoren werkt.
Normale youtube weergave tot en met een weergave van 720p. daarboven gaat het afspelen weer stotteren. Maar 720p vind ik voor mij doen zeer acceptabel.
Ook worden beide beeldschermen probleemloos weer gegeven en werken snel en optimaal.
Over de Xubuntu installatie ben ik op zich tevreden.
Een paar kleine dingen ben ik nog niet achter hoe dat op te lossen.
Zo is het bij Ubuntu mogelijk om op beide beeldschermen een startbalk te plaatsen.
In Xubuntu heb ik dat tot nu toe alleen nog maar op het hoofdbeeldscherm.
Bij vensters, bijvoorbeeld een spelletje, waar de achtergrond een kleur heeft is deze achtergrond zeer "korrelig". Het zelfde effect is ook zochtbaar bij de menuknoppen, een heldere tekst en knopafbeelding met een "korrelige/blokkerige" achtergrond.
Ik heb het idee dat dit iets met "doorzichtigheid te maken heeft. Weet alleen nog niet hoe dit op te lossen.

Al met al heb ik het nu dus voor elkaar kunnen krijgen om op het zeer oude systeem van mij toch nog twee installaties van Ubuntu aan het draaien te krijgen. =)
Ubuntu 16.4, niet optimaal maar werkt wel.
Xubuntu 16.4, werkt zo goed, snel en zo goed als optimaal.

Dus zelf voor een nop, zoals ik ben, op Linux gebied, is het met een beetje hulp en uitproberen toch mogelijk een goed werkende Ubuntu op een ruim 10 jaar oude computer te zetten.

Wat ik WEL geleerd heb, is dat ik met de vingers van NIET vrije stuurprogramma's zoals Nvidia driver afblijf.
Elke keer als ik daar een poging toe deed die te installeren liep het grandioos  uit de hand en moest ik zelf een paar keer de gehele installatie opnieuw opzetten.
Voor de zekerheid heb ik momenteel bij de Xubuntu installatie alleen het bijwerken van veiligheidsupdates maar toegestaan en alle overige updates uitgeschakeld.
Hoop dat het systeem daardoor nog een hele tijd foutloos zal draaien.