Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: instellingen toetsenbord verdwijnen  (gelezen 86 keer)

Offline TomP

  • Lid
instellingen toetsenbord verdwijnen
« Gepost op: 2018/03/05, 10:16:26 »
Met de tip van Pjotr heb ik Lxkeymap gebruikt om mijn toetsenbord (laptop BTO)  correct in te stellen (Ubuntu 16.04).
Alleen: als ik afmeld en weer aanmeld zijn deze instellingen verdwenen en moet ik Lxkeymap opnieuw starten.
Hoe los ik dat op?
Tom

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: instellingen toetsenbord verdwijnen
« Reactie #1 Gepost op: 2018/03/05, 15:23:06 »
Ik mag ervan uitgaan dat je Lubuntu gebruikt? Mogelijk deze bug, https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1284635, waarbij sommige toetsenbordlayouts niet werken als ibus actief is. Een workaround is ibus te verwijderen of af te zetten.

Verwijderen: sudo apt-get remove ibus
Afzetten: In Lubuntu just go to "Preferences → Language Suport" and on "Language" tab set "Keyboard input method system" to "none".

ibus is een systeem om allerlei talen te kunnen inputten. In de praktijk ga je geen enkel nadeel ondervinden door het uit te schakelelen.

Een andere oplossing schijnt te zijn lxkeymap telkens bij het inloggen automatisch op te starten:  http://lubuntu-users.narkive.com/PQNdpjvt/lxkeymap-make-changes-defintive
Kan in lubuntu door de lijn "@lxkeymap --autostart" aan ~/.config/lxsession/Lubuntu/autostart toe te voegen.

Offline TomP

  • Lid
Re: instellingen toetsenbord verdwijnen
« Reactie #2 Gepost op: 2018/03/05, 17:22:24 »
Ibus op ´geen´ zetten bood geen oplossing.
Automtisch starten van Lxkeymap voorlopig wel. Minder elegant omdat ik het het programmaatje na opstarten telkens weg moet klikken.
In ieder geval bedankt voor de oplossingsrichting.

Tom

Offline TomP

  • Lid
Re: instellingen toetsenbord verdwijnen
« Reactie #3 Gepost op: 2018/03/05, 17:30:47 »
Het bleek nog simpeler te kunnen. Na afzetten van Ibus moest ik bij instellingen ´tekstivoer´ de priotering van VS toetsenborden juist instellen. De foutieve heb ik verwijderd. Nu blijft hij op de goede combinatie staan.
Opgelost dus.

Tom