Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba wil niet  (gelezen 1475 keer)

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Samba wil niet
« Gepost op: 2018/02/25, 01:28:47 »
Laptop geinstalleerd met Ubuntu 16.04LTS.
Alles lijkt te werken naar behoren (later nog hdmi aansluiten en testen).
Ingericht met benodigde extra (beperkte) gebruikers.
Mappen delen, dus Samba geinstalleerd (terminal).

Maar Samba wil niet. :(
Mappen kwamen moeizaam zichtbaar voor de andere gebruikers. Wel voor de delende administrator.
Eindelijk zichtbasr, zegt Samba "kan map niet vinden".

Wat doe ik fout? Ik deed volgens mij niet andes dan anders (wat wel zo werkte).
Kan het te maken hebben met encrypted gebruikersbestanden tijdens install? Want dat is het enige afwijkende.
Zou toch wel handig zijn als het gaat werken. :|
- I ♥ Linux -

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #1 Gepost op: 2018/02/25, 09:30:29 »
Met de encryptie heeft dit niks te maken.

Firewall tijdelijk uitzetten kan helpen.

Reboot alle hardware, te beginnen bij je router.
Dan herstart alle pc's.

Vaak moet je langer wachten, de verbinding komt soms laat tot verbinding.
Zeker na een reboot.

Zoek op mijn naam in het forum, dan vind je(in eerdere berichten) een handleiding van samba wat je zou kunnen vergelijken, met wat jij gedaan hebt.

Schrijf alle ip nummers op, en vul de ip nummer direct in, werkt het dan beter?

"kan map niet vinden"
Dan heb je toch iets tav beveiliging/gebruikers niet goed staan.
Controller alles nog een keer, vooral tav rechten.

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Samba wil niet
« Reactie #2 Gepost op: 2018/02/25, 11:06:27 »
Heb je geen Windows in je netwerk dan kan je beter NFS gebruiken ipv Samba. Deze laatste is bedoeld voor gebruik in een gemengde Unix/Windows omgeving.

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #3 Gepost op: 2018/02/25, 12:09:33 »
Met de encryptie heeft dit niks te maken.

Firewall tijdelijk uitzetten kan helpen.

Twee vraagjes.
Staat de firewall dan standaard aan? Ik dacht van niet?
En heeft de firewall/router hier wel mee van doen? Ik heb het over andere gebruikers in dezelfde pc.

Heb je geen Windows in je netwerk dan kan je beter NFS gebruiken ipv Samba. Deze laatste is bedoeld voor gebruik in een gemengde Unix/Windows omgeving.

Maar het vreemde is dat ik het op twee andere pc's wel gewoon zo gedaan heb en het ook gewoon werkt.
En nu ineens niet, terwijl ik het gewoon zoals ik altijd doe gedaan heb.
- I ♥ Linux -

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #4 Gepost op: 2018/02/25, 16:20:18 »
Heb je alle gebruikers toegevoegd aan samba?
Open bij users/gebruikers, daar vind je ergens wat de gebruiker mag, maar daar staat ook samba bij.
Dus de gebruiker hier aanvinken zodat deze ook samba mag doen.

user en groups - Managed groups - sambashare
hier dus je gebruikers aanvinken, voor elke gebruiker apart instellen.
« Laatst bewerkt op: 2018/02/25, 16:22:52 door jan11000 »

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #5 Gepost op: 2018/02/25, 18:23:22 »
Heb je alle gebruikers toegevoegd aan samba?
Open bij users/gebruikers, daar vind je ergens wat de gebruiker mag, maar daar staat ook samba bij.

Bedoel je bij "Gebruikers" waar je ze aan maakt? Daar kan ik alleen instellen administrator/gebruiker en het wachtwoord.
Als ik in bash "samba" zoek vind ik alleen samba.service maar ik weet niet of ik dat zomaar aan kan klikken.
Ik heb daar eerdere keren ook nog nooit in hoeven stellen.
- I ♥ Linux -

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #6 Gepost op: 2018/02/25, 18:44:24 »
Wat overigens ook vreemd is. Die gebruiker kan wel op de gedeelde map van een andere externe pc in het netwerk.  :| Dus deelprobleem ... niets anders gedaan dan anders.  ???

Firewall tijdelijk uitzetten kan helpen.

Meteen ook even nagekeken (bedankt voor het attentiepunt).
INactief, dus staat niet aan.
« Laatst bewerkt op: 2018/02/25, 18:47:45 door partyrabbit »
- I ♥ Linux -

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #7 Gepost op: 2018/02/25, 19:38:20 »
Bij een gebruiker kun je toch meer instellen, je kunt vinkjes zetten, bij welke groepen hij hoort, en bij sambashare moet een vink gezet worden, dus kijk goed.
Zelf gebruik ik xubutu, maar dit is toch hetzelfde.

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #8 Gepost op: 2018/02/25, 19:56:46 »
Sorry maar op drie ubuntu 16 pc's, een lubuntu 17, en nog meer eerdere versies (U12 o.a.) ben ik die instellingen echt nog nooit tegen gekomen, en ik heb dat ook nog nooit eerder ingesteld (waar het toch gewoon werkt). En gebruikers is toch vaak een van de eerste dingen die ik aan maak.
Kijk ik verkeerd?

En ook vreemd dan.
Ook in de gedeelde mappen op die andere pc waar deze gebruiker wel in kan heb ik niets veranderd of ingesteld, en toch is dat gewoon toegankelijk.
« Laatst bewerkt op: 2018/02/25, 19:59:29 door partyrabbit »
- I ♥ Linux -

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #9 Gepost op: 2018/02/25, 20:11:20 »
Hier is de mijne,

Bij rode pijl kan ij een vink zetten, om de user bij de sambashare toe te voegen.


Anders zoek hoe je via terminal de user kunt toevoegen aan de samba.


Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #10 Gepost op: 2018/02/25, 20:49:25 »
Dat is het verschil tussen Ubuntu en Xubuntu. Je kunt deze uitgebreidere gebruikersinstellingen applicatie in Ubuntu 16.04 er zelf bij installeren.
sudo apt install gnome-system-tools [Enter]

Dan start je ‘m via het terminalvenster.
users-admin [Enter]
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Xubuntu 18.04.1
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & testversie Xubuntu 19.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline DeliciouSSnoW

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #11 Gepost op: 2018/02/25, 23:54:57 »
Ik ben er ook al eens mee aan het stoeien geweest maar het lijkt er op dat samba is aangepast en sinds dat is gebeurd"ik vermoed ergens in 16.04 versie werkt het hier ook niet meer" er is ook een deel van de samba installatie nu virtueel en word dus niet geïnstalleerd. weet niet of het daar wat mee te maken kan hebben.

Mvg Delicioussnow

Offline youpie123

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #12 Gepost op: 2018/02/26, 01:11:17 »
Ik moet zeggen dat samba wat makkelijker is geregeld in Ubuntu Mate (en dus ook in Mint Mate)

Zie post 2 in https://ubuntu-mate.community/t/sharing-folders-on-windows-network/2644

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #13 Gepost op: 2018/02/26, 05:28:55 »
Samba werkt gewoon, ook in ubuntu 16.04.

Offline youpie123

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #14 Gepost op: 2018/02/26, 15:42:26 »
Samba werkt ja, niet gewoon. Anders waren er niet zoveel probleemtopics over  :)

Offline emvedeesje

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #15 Gepost op: 2018/02/26, 18:13:40 »
Er is een bug: https://bugs.launchpad.net/ubuntu/+source/libuser/+bug/1387274

Kort gezegd: controleer of dit bestand bestaat: /etc/libuser.conf
Zo niet, geef volgend commando:

sudo touch /etc/libuser.conf
Wie weet...

groeten van Michael
Mint Cinnamon fan  Firejail Chromium HPlip  digikam.appimage Freefilesync Puddletag virtualbox gmail
Desktop HP ProDesk 400G3 64bit I5 16gb multiboot: SSD Mint 18.3 Cinnamon + HD Ubuntu 16.04.4 + HD W10 /// Laptop HP ProBook 6570b 64bit I5 4gb SSD multiboot Mint 18.3 Cinnamon + W10
TESTBAK Desktop HP-Compaq 8000 64bit 4gb

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #16 Gepost op: 2018/02/27, 13:04:58 »
Ik ga de tips van jolo en emvedeesje nog opvolgen (staat nu uit).

Bug?
Toch blijf ik het erg vreemd vinden. Dit is de derde pc die ik exact hetzelfde installeer met dezelfde dvd en exact hetzelfde instel, maar het is de eerste die dit heeft.  :| Dan zou je toch verwachten dat ze het alle drie hebben?
- I ♥ Linux -

Offline youpie123

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #17 Gepost op: 2018/03/06, 16:14:40 »
Ik heb ondertussen ook problemen ondervonden. Oude shares werken perfect maar de nieuwe shares die ik aanmaak zijn onbereikbaar  :'(

Er zijn wel een hoop updates geweest de laatste week waar o.a. samba ook tussen zat. Ik hoop dat het snel opgelost is....

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #18 Gepost op: 2018/03/06, 16:43:52 »
Ik heb ondertussen ook problemen ondervonden.

Shit voor jou, maar voor mij wel een prettige bevestiging dat ik het niet zelf verkeerd doe. Ik vond het al zo vreemd dat hetzelfde een ander resultaat gaf.

Voorlopig maar even terughoudend zijn in grote veranderingen dan.

Oude shares werken perfect maar de nieuwe shares die ik aanmaak zijn onbereikbaar  :'(
Er zijn wel een hoop updates geweest de laatste week waar o.a. samba ook tussen zat. Ik hoop dat het snel opgelost is....

Daar dacht ik ook aan. Die updates van dat smb lek.  :(
Laten we dan maar hopen dat het weg-geupdate wordt, of dat er meer duidelijkheid komt how2...
Maar daar moet ik op wachten want ik zal daar geen rol in gaan spelen verwacht ik.
- I ♥ Linux -

Offline youpie123

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #19 Gepost op: 2018/03/06, 17:11:06 »
Het beste zou zijn wat Nero al terecht opmerkte, met NFS gaan werken maar daar moet ik nog een beetje op studeren.

Als iemand een goede, werkende en betrouwbare handleiding daarvoor weet hou ik me aanbevolen!!  :rolleyes:

Offline partyrabbit

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #20 Gepost op: 2018/03/06, 17:45:52 »
Ja moet ik me misschien ook maar eens in gaan verdiepen.

Wat ik me ook afvraag. Is Samba ook wel nodig? Dat is toch voor koppelingen binnen win-workgroups?
Maar hier is alles linux. Kan linux zelf dan niet met shares werken?

Kun je bv niet een map aanmaken in //home en deze 755 chmodden of zo?
Misschien zelfs met een .htpass er in of zo iets soortgelijks?
Iemand??
« Laatst bewerkt op: 2018/03/06, 17:48:25 door partyrabbit »
- I ♥ Linux -

Offline youpie123

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #21 Gepost op: 2018/03/06, 18:15:12 »
Wat ik me ook afvraag. Is Samba ook wel nodig? Dat is toch voor koppelingen binnen win-workgroups?
Maar hier is alles linux. Kan linux zelf dan niet met shares werken?
Dat is precies wat Nero zei. We hebben allebei geen Windows draaien dus is de linux oplossing NFS. Maar je moet wel even weten hoe het werkt  ;)

edit: Het ziet er eenvoudig uit... https://help.ubuntu.com/lts/serverguide/network-file-system.html
« Laatst bewerkt op: 2018/03/06, 18:20:18 door youpie123 »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #22 Gepost op: 2018/03/07, 11:35:05 »
Handleiding samba:

Hoe samba instellen,(zoals ik het doe).

Indien je al met instellingen gespeelt hebt, verwijder alles(tav samba) en reboot,
om zo schoon te beginnen.

Samba installeren,in "software center" zoeken op
samba(SMB/CIFS file, print, and login server for Unix).

Indien je meerdere users gebruikt, dus bijv 3 users die verschillend zijn,
op 3 verschillende pc's.
Dan op elke pc alle users als extra users aanmaken(later als alles werkt kun je de
extra users de rechten beperken, zodat ze minder kunnen, dit hoeft niet maar mag).
Dus je hebt dan de gewone user(die met installatie tot stand is gekomen) en nog 2 extra users.

Dan samba starten,(system-samba in xubuntu).
De map maken die je wilt gaan delen, zorg dat je gebruiker daar rechten voor heeft, dan pas de map gaan delen.
De share maken,
server instellen, zoals group naam,
security(niks veranderen),
samba users instellen(eigenschappen van je samba map, in de samba programma),
aanvinken die toegang krijgen(nu weet je ook waarom je meerdere users moet
ingeven, want dan zie je alle users, ook die van de andere pc).
Je kan ook extra users ingeven, maar dat heb ik nog niet gebruikt.

-Ook bij ubuntu, bij users kijken of de user ook bij de groep sambashare zit, dus aanvinken.

Nu zou het moeten werken, wel even rebooten.
Vaker moet je langer wachten totdat er verbinding komt, dus denk niet te snel dat het verkeerd is.!!!!!



Dit is normaal niet nodig!
Je kan nog in je host file de namen van de pc's ingeven,
dit zijn ipnummers met de naam van de pc, zodat deze beter
te vinden is op het netwerk, hoeft niet, maar als het niet goed werkt,
het vinden van de pc's dus.(bij pc's met vaste ip nummers is dit ook beter).
File naam is
hosts
Voorbeeld:
127.0.0.1 localhost  (dit is standaard)
127.0.1.1 jan        (dit is de pc waar samba op staat)
10.16.9.9        ba2        (dit is een andere pc op het netwerk)
10.16.9.99       download   (dit is een andere pc op het netwerk)


# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

De naam van de pc staat in de file hostname,
hier staat alleen een naam.

Indien het vinden van de pc's nog steeds slecht is,(bijv vaste ip nummers en zonder router)
probeer dan met gigolo(even installeren) de andere pc's te vinden,
vaak gaat het dan heel vlug om de pc's te vinden.

Veiligheid,

Nooit iedereen toegang geven, dit omdat als er een fout in een beveiliging/programma/router zit, dan kan iedereen in je files kijken.
Dus altijd een wachtwoord en user erop zetten.

In de samba config file kun je nog,
netwerk interface vastzetten, indien je 2 netwerkkaarten hebt,
zodat samba alleen over bepaalde netwerkkaart gaat.

Hetzelfde geld voor ip nummers, dit kun je ook vastzetten.
10.0.0.0/8 eth0
dit betekend netwerkkaart eth0, alleen hier gaat samba over werken.
en de ip range 10.0.0.0/8 gaat samba werken.

En je kunt nog met de firewall ip adressen en samba blokkeren of open zetten.

Testen netwerk,
40 Gb aan geparde files maken en dit in een ruk kopieren.
dan aan de andere kant parren, dan zie je of alles ook aankomt.
(in windows heb ik een keer gezien dat 1 op de 10 files beschadigd
waren met kopieren, lag aan de firewall, en geen foutmelding).
Bij geen fouten niks doen.
Bij fouten, dan dit gaan wijzigen in samba config(kan soms helpen)
# Most people will find that this option gives better performance.
# See smb.conf(5) and /usr/share/doc/samba-doc/htmldocs/Samba3-HOWTO/speed.html
# for details
# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY
socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
Grootte van deze 2 files wijzigen en weer testen.(klein is vaak beter maar ook langzamer).
Kan natuurlijk ook driver zijn, of netwerkkabels.
Zelf heb ik meerdere keren problemen ondervonden, en door te testen merk je opeens
dat niet alles zomaar werkt.
Na het kopieren ook met ifconfig kijken in de terminal,
daar kun je ook problemen/fouten zien.
--------------------------------------------------------------------------------------------------
Indien het nog niet werkt kun je dit nog proberen,
(bij werkte het opeens niet meer(eerste dus wel), oorzaak onbekend, toen dit erbij gezet en het werkte)
Volgend wijzigen in je samba config file(/etc/samba.smb.conf),
Dit erbij zetten,
name resolve order = bcast host

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
workgroup = workgroup
        name resolve order = bcast host

------------------------------------------------------------------------------------------------------------

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #23 Gepost op: 2018/03/07, 13:06:18 »
Een andere handige linuxoplossing is sshfs. Hierbij wordt een bestandssysteem van de server aangekoppeld over ssh. Van zodra je via ssh kan inloggen, kan je ook het bestandssysteem aan de overkant aankoppelen. Geschikt ook als veilige oplossing over het internet. Moet het niet over internet, dan is NFS zeker geschikt (en wellicht meest performant). Lang geleden dat ik nog zoiets gedaan heb, maar sshfs was zeer gemakkelijk op te zetten.

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: Samba wil niet
« Reactie #24 Gepost op: 2018/03/07, 13:34:40 »
Het beste zou zijn wat Nero al terecht opmerkte, met NFS gaan werken maar daar moet ik nog een beetje op studeren.

Als iemand een goede, werkende en betrouwbare handleiding daarvoor weet hou ik me aanbevolen!!  :rolleyes:
Onze wiki: https://wiki.ubuntu-nl.org/community/NFS
Een andere handige linuxoplossing is sshfs.
Zie ook onze wiki: https://wiki.ubuntu-nl.org/community/SSHFS

(overigens kan zowel NFS als SSHFS ook werken met Windows ;))
Klik links bovenin op Documentatie