Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: tweede harde schijf.  (gelezen 4043 keer)

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Gepost op: 2007/05/11, 14:25:32 »
Heb hier een pc met twee harde schijven. Er stond voordien op 1 ervan Windows, en op de tweede bestanden.

Heb de bestanden van die tweede schijf extern geplaats, en op de eerste ubuntu geinstalleerd.
Jammer genoeg ben ik voor de installatie vergeten die tweede schijf te formateren naar Fat32. (bedoeling is om de bestanden die er stonden daar terug te plaatsen.( Eventueel de homedirectory ook naar daar te verhuizen, al zou ik niet weten hoe)

Die NTFS geformateerde schijf, kan ik wel zien, maar niet mounten, en lezen.  Heb geprobeerd met gparted. De schijf aangeduid en voor formateren gekozen. Maar dat programma lijkt niks uit te voeren met die HDH2

Hoe doe ik dit het snelst en gemakkelijkst.

Als dat formateren naar Fat 32 gelukt is zou ik graag mijn home naar die directory verhuizen ook, maar hoe.

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #1 Gepost op: 2007/05/11, 17:48:06 »
Tot hier toe, hier geen reaktie, ..   Ik ben intussen een stukje verder geraakt.
Als ik nu ga kijken, via lokaties, zie ik dat die schijf intussen toch FAT32 geformateerd staat.
Ga ik via lokaties, deze computer naar die schijf, en klik er op, krijg ik een venster met de melding dat dit volume niet kan gemount worden.
Ik heb hier een /hda    (drie partities er op)
En een /hdb  ( niet gepartitioneerd en FAT32 geformateerd.

Voor ik dus mijn documenten van de externe harde schijf, kan op die hdb zetten moet ik die dus eerst mounten, en liefst wel zodanig dat die bij iedere nieuwe opstart van de pc in de toekomst automatisch gemount wordt.

Kan iemand me hierbij helpen?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
tweede harde schijf.
« Reactie #2 Gepost op: 2007/05/11, 19:35:45 »
Je moet wel de file /etc/fstab aanpassen, anders weet Linux niet dat je hem geformatteerd hebt :lol:
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #3 Gepost op: 2007/05/11, 19:53:16 »
En hoe doe je dat?

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #4 Gepost op: 2007/05/12, 15:03:04 »
Heb vandaag nog wat opzoekingswerk gedaan..   fstab aangepast...
sudo gedit /etc/fstab

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

/dev/hdb       /media/hdb      vfat   user        0       0

schijf lijkt dus aangekoppeld nadat ik nog sudo mount -a uitvoerde.  Geen foutmelding.

Effe getest om een document te saven op die schijf.. lukt niet...  save as, browse folders, ben naar computer - filesystem- media - hdb gegaan en kreeg een foutmelding dat het niet mogelijk was om het document daar op te slaan.

Ik veronderstel een probleem met permissies..  ( ben effe naar properties gaan kijken, en daar stond read aangevinkt en write niet.) Hoe verander ik dat.

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #5 Gepost op: 2007/05/12, 15:44:09 »
Met chmod.

Hoe precies weet ik niet maar ik denk in de trant van
chmod +x naamvandeschijf.

Wacht maar wel op andere die het allicht beter weten.

CaptainCookie

  • Gast
tweede harde schijf.
« Reactie #6 Gepost op: 2007/05/12, 16:20:01 »
Met +x maak je hem uitvoerbaar, dacht ik :P

Het is eerder iets van chmod 666 of 777 (weet de preciese getallen even niet meer)

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #7 Gepost op: 2007/05/12, 17:04:42 »
Beetje verder nu. De schijf wordt tijdens het opstarten automatisch gemount.
Eigenaar is root dewelke kan lezen en schrijven. Ik heb nu als root de bestanden naar die schijf gekopieerd.

Als gewone gebruiker kan ik nog steeds geen bestanden naar die schijf schrijven of kopieren.

Eigelijk is het nu de bedoeling om de hele home directory telkens bij het afsluiten of 1 keer per week ook naar hdb te backuppen / synchroniseren.

In het geval er dan iets  mis gaat zou ik dan heel sinpel op de eerste hard schijf ubuntu laten herinstallerenm terwijl alle documenten en instellingen op hdb staan en ik die dan erna kan overwetten naar de home van de nieuwe installatie.

Hoe kan ik dit het beste realiseren

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #8 Gepost op: 2007/05/12, 17:15:39 »
Citaat van: mhweb
Eigenaar is root dewelke kan lezen en schrijven. Ik heb nu als root de bestanden naar die schijf gekopieerd.

Als gewone gebruiker kan ik nog steeds geen bestanden naar die schijf schrijven of kopieren.
chown schiet me nu te binnen, van eigenaar wisselen, misschien dat je daar iets mee kan.

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #9 Gepost op: 2007/05/12, 17:31:28 »
heb ik geprobeerd toen ik als root de eigenschappen van dat bestand nakeek en wou dat doen toen ik schrijven niet kon aanvinken voor alle gebruikers en groepen

koos

  • Gast
tweede harde schijf.
« Reactie #10 Gepost op: 2007/05/12, 17:55:31 »
even voor de duidelijkheid, je hebt geen windows meer? tenminste dit begrijp ik uit je verhaal.
mocht dit zo zijn, heb je geen fat32 nodig. fat32 is meer iets voor windows, echter als je een dualboot wilt, dus windows en linux op 1 computer kan je het beste 1 partitie fat32 maken omdat die door windows en linux te lezen en beschrijven is.
echter je home op een fat32 te plaatsen lijkt me niet verstandig, dat zou ik lekker op een ext3 partitie doen.

in ieder geval moet je dit in je fstab schrijven om je fat32 partitie te kunnen lezen en schrijven.

/dev/hdb       /media/hdb     vfat    defaults,utf8,umask=007,gid=46 0       1

Offline Duckie

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #11 Gepost op: 2007/05/12, 18:16:47 »
chown kun je gebruiken om een b.v. een map van eigenaar te laten veranderen.
sudo chown -R gebruikersnaam /naam/van/de/map

Voor jou is dat dus b.v. "sudo chown -R mhweb /media/hdb"
____________________________________________

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #12 Gepost op: 2007/05/12, 19:59:18 »
hehe, heb intussen aan de tweede schijf wijzigingen aangebracht.  ( die was helemaal Fat32, en hier en daar las ik dat het probleem wel eens aan de Fat32 zou kunnen liggen.
Heb dus de schijf opnieuw gepartitioneerd.   Een deel als ext3  en een (kleiner)deel als Fat32

johannes@johannes-desktop:~$ sudo fdisk -l

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        9446    75874963+  83  Linux
/dev/hda2            9447        9729     2273197+   5  Extended
/dev/hda5            9447        9729     2273166   82  Linux swap / Solaris

Disk /dev/hdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1        5140    41287018+  83  Linux
/dev/hdb2            5141        9729    36861142+   b  W95 FAT32
johannes@johannes-desktop:~$


daarna de twee delen toegevoegd aan fstab, die ziet er nu zo uit:

fstab.

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

/dev/hdb1       /media/hdb1      ext3   users,auto
 0       0
/dev/hdb2       /media/hdb2      vfat   users,auto
 0       0


daarnaa proberen mounten, en daar loopt het nu fout:

ohannes@johannes-desktop:~$ sudo mount /dev/hdb1/media/hdb1
mount: can't find /dev/hdb1/media/hdb1 in /etc/fstab or /etc/mtab
johannes@johannes-desktop:~$ sudo mount /dev/hdb2/media/hdb2
mount: can't find /dev/hdb2/media/hdb2 in /etc/fstab or /etc/mtab
johannes@johannes-desktop:~$


HIer staat dus als ik het goed begrijp, dat hdb1 en hdb2 niet in fstab zitten, maar bij wat ik in fstab kon lezen staan die er wel.

Wie weet hier raad

Offline Duckie

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #13 Gepost op: 2007/05/12, 20:03:48 »
Ten eerste vergeet je volgens mij een spatie. Dus mount /dev/hdb1 /media/hdb1.
Ten tweede moet je dacht ik ook aangeven hoe je hem wilt mouten. Dus sudo mount -t ext3 /dev/hdb1 /media/hdb1
Ten derde kun je misschien beter gewoon sudo mount -a invoeren nadat je je fstab hebt aangepast.
____________________________________________

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #14 Gepost op: 2007/05/12, 20:10:18 »
johannes@johannes-desktop:~$ sudo mount -a
Password:
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

mount: mount point 0 does not exist
mount: mount point 0 does not exist
johannes@johannes-desktop:~$


Ik vrees dat er een foutje zit in mijn fstab?

Offline Duckie

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #15 Gepost op: 2007/05/12, 20:14:02 »
Citaat van: mhweb
johannes@johannes-desktop:~$ sudo mount -a
Password:
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

mount: mount point 0 does not exist
mount: mount point 0 does not exist
johannes@johannes-desktop:~$


Ik vrees dat er een foutje zit in mijn fstab?
Denk het ook. Probeer deze eens:
/dev/hdb1       /media/hdb1      ext3   defaults,rw    0  0
____________________________________________

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #16 Gepost op: 2007/05/12, 20:22:31 »
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

/dev/hdb1       /media/hdb1      ext3   defaults,rw    0  0
/dev/hdb2       /media/hdb2      vfat   defaults,rw    0  0



johannes@johannes-desktop:~$ sudo mount -a
Password:
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

mount: mount point 0 does not exist
mount: mount point 0 does not exist
johannes@johannes-desktop:~$
johannes@johannes-desktop:~$ sodu nautilius
bash: sodu: command not found
johannes@johannes-desktop:~$ sudo gedit /etc/fstab
johannes@johannes-desktop:~$  sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


nog niet dus,  maar ik heb voordien een reaktie hier over het hoofd gezien. ik heb eigelijk geen Fat32 nodig, dus ga eerst die weg doen, en de andere vergroten, zodat ik dan alleen nog die ext3 heb

Offline Duckie

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #17 Gepost op: 2007/05/12, 20:35:40 »
Bestaan de mappen "/media/hdb1" en "media/hdb2" wel?
____________________________________________

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #18 Gepost op: 2007/05/12, 21:05:33 »
Ja die bestaan..  de map hdb overigens ook.  

Ik heb nu die twee partieties gaan bewerken tot 1   ext3    (hdb) en ziet er nu uit als volgt:

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        9446    75874963+  83  Linux
/dev/hda2            9447        9729     2273197+   5  Extended
/dev/hda5            9447        9729     2273166   82  Linux swap / Solaris

Disk /dev/hdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1        9729    78148161   83  Linux

johannes@johannes-desktop:~$ sudo mount -a
mount: /dev/hdb already mounted or /media/hdb busy
johannes@johannes-desktop:~$


wat is er dan nu weer?   ( heb al eens afgesloten en opnieuw opgestart, maar helpt niet, nog hetzelfde)

even ter informatie nog mijn nieuwe fstab:

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0

/dev/hdb       /media/hdb      ext3   user        0       0

Offline Duckie

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #19 Gepost op: 2007/05/12, 22:12:35 »
Dit is een gokje, maar doe eens sudo umount -a en kijk eens of je daar foutmeldingen op krijgt.
____________________________________________

Offline mhweb

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #20 Gepost op: 2007/05/14, 09:33:26 »
ohannes@johannes-desktop:~$ sudo mount -a
mount: /dev/hdb already mounted or /media/hdb busy
johannes@johannes-desktop:~$


IK ben daarna via gtparted nog eens naar die partitie gaan kijken, en ik zag daat niet staan dat die ext3 zou zijn, maar kon het partitioneren ook niet opnieuw doen.
Toen ben ik uit mijn stab die regel gaan verwijderen, terug opgestart daarna en dan weer via gtparted gaan kijken. Er stond nog steeds niet die ext3.  Dit keer kon ik het formateren wel terug realiseren.  Daarna de regel terug toegevoegd bij estab , en de computer afgsloten, en terug opgestart. Daar stond nu mijn schijf op het bureablad, en was teven lees en beschrijvbaar voor alle gebruikers.

Probleem dus opgelost.  Daarna alleen nog een programma om te synchroniseren geladen vanuit toepassingen installeren verwijderen en de te synchroniseren mappen  opgegeven.

Offline Schuit

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #21 Gepost op: 2007/05/15, 12:16:49 »
Beste lezer,
Ik ben een volledig leek met Linux. Wil Feisty in dual boot met WXP SP2 draaien, waarbij een tweede harde schijf vrij is voor Feisty. In de Wiki lees ik dat je Ubuntu op NTFS kan draaien. Mijn Windows draait daar ook op. Is het toch nodig dat de tweede harde schijf eerst geformatteerd wordt, of doet Feisty dat Automatisch. ben in bezit van Ubuntu 7.04 verkregen per post via Shipit. Mijn systeem heeft een AMD Sempron 2500+, kloksnelheid 1,75, 1Gb. De tweede harde schijf is 120 Gb groot. Moet gparted vooraf nog partitioneren? Ben benieuwd naar uw antwoord.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #22 Gepost op: 2007/05/15, 14:41:18 »
Ubuntu kan echt niet op NTFS draaien, hoor. Wat die nodig heeft is EXT3.

Je hoeft niet vooraf te partitioneren, als je dat niet wilt. Bij de installatie van Ubuntu kun je op een bepaald moment kiezen uit drie installatie-opties. Als je de middelste kiest, dan wordt alles automatisch voor je geregeld en hou je gewoon je Windows erbij, als opstartmogelijkheid.

Groet, Pjotr.

Offline Schuit

  • Lid
  • Steunpunt: Nee
tweede harde schijf.
« Reactie #23 Gepost op: 2007/05/15, 18:57:03 »
Dank je wel Pjotr.
Groet, Ronald