Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: nieuwe hdd 4TB maakt foutjes  (gelezen 195 keer)

Offline summer of 69

  • Lid
  • Steunpunt: Nee
nieuwe hdd 4TB maakt foutjes
« Gepost op: 2018/01/24, 14:20:54 »
Hallo,
Nieuwe hdd van 4TB in systeem geïnstalleerd die moet dienen als data opslag. Vooraleer ze te plaatsen ingedeeld met een usb stick met gparted. Een GPT label en een nieuwe partitie in ext4. Bij het configureren in /etc/fstab kwam ik fouten tegen. Ik heb volgens deze instructies gehandeld :

https://sites.google.com/site/computertip/reserve-9#TOC-Hoe-koppel-ik-een-partitie-permanent-aan-
maar bij het commando sudo e2label /dev/sda1 [naam] en sudo tune2fs -m 1 /dev/sda1 kreeg ik een foutmelding : bestandssysteem is alleen-lezen en iets over een "bestandssysteem-superblok. De schijf werkte maar afsluiten wilde het systeem niet. Ook haperde de hdd bv. bij het afspelen van video-bestanden.
Vermits er nog niets belangrijk op de schijf stond heb ik via het systeem zelf gparted gebruikt om opnieuw een GPT tabel tabel en een partitie ext4 te maken. Vervolgens heb ik  In /etc/fstab  een oudere regel gebruikt : /dev/sda1 /media/guy/koppelpunt ext4 defaults 0 0
Volgens mij is het opgelost maar ik ben niet zeker. Doe ik de indeling in partitie verkeerd ? In gparted kun je ook een partitienaam en label vermelden. Ik denk niet dat ik dat ooit gebruikt heb en ik ben al bezig met linux sinds 2006 :) Indien graag meer info, laat gerust weten. Graag advies
« Laatst bewerkt op: 2018/01/24, 14:27:08 door summer of 69 »
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: nieuwe hdd 4TB maakt foutjes
« Reactie #1 Gepost op: 2018/01/24, 15:03:17 »
Volgens mij is het opgelost maar ik ben niet zeker. Doe ik de indeling in partitie verkeerd ? In gparted kun je ook een partitienaam en label vermelden. Ik denk niet dat ik dat ooit gebruikt heb en ik ben al bezig met linux sinds 2006 :) Indien graag meer info, laat gerust weten. Graag advies
Wat is nog het probleem dan? Voor een ext4 partitie lijkt mij "defaults" de beste aanpak. Ik weet niet of je zomaar de opties kan overnemen van een partitie die via udev was aangekoppeld. Ik vermoed dat dat de oorzaak was van de problemen.

Misschien eisen de commando's e2label en tune2fs wel dat de partitie niet aangekoppeld is. Ontkoppel eens (sudo umount /dev/sda1) en probeer opnieuw. Een label geven heeft evenwel geen belang als je de schijf via fstab aankoppeld. Is enkel handig als je via klikken achteraf aankoppelt, omdat het label dan gebruikt wordt als naam voor de partitie.

Ik zou de laatste instelling veranderen van 0 naar 2: dan wordt ook die partitie automatisch tijdens elke opstart gecontroleerd (in tweede prioriteit, dus pas nadat je systeempartitie werd gecontroleerd).

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: nieuwe hdd 4TB maakt foutjes
« Reactie #2 Gepost op: 2018/01/24, 15:41:20 »
Citaat
Voor een ext4 partitie lijkt mij "defaults" de beste aanpak. Ik weet niet of je zomaar de opties kan overnemen van een partitie die via udev was aangekoppeld. Ik vermoed dat dat de oorzaak was van de problemen.


Dacht ik ook. die "defaults" optie heb ik in het verleden altijd gebruikt, zonder problemen. Die udev opties heb ik overgenomen van Pjotr's instructies en blijkbaar zat hier de fout.  En eerst heb ik opnieuw ingedeeld via gparted en de "defaults" optie gebruikt in "/etc/fstab" Nu werkt blijkbaar alles normaal. ook benaderbaar door samba mits enkele kleine aanpassingen in "/etc/samba/smb.conf"
Nog bedankt, ik was niet zeker, en o ja, ik zal die laatste instelling veranderen van 0 naar 2  ;)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk