Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NAS verbindt niet meer automatisch [OPGELOST]  (gelezen 595 keer)

Offline ercmrj

  • Lid
  • Steunpunt: Nee
NAS verbindt niet meer automatisch [OPGELOST]
« Gepost op: 2018/01/12, 19:39:10 »
Mijn NAS wordt van de ene op de andere keer niet meer automatisch aangekoppeld.

Deze regel staat in mijn fstab: //***.***.***.***/home /media/NAS cifs username=******,password=********,rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0

Niets aan verandert zover ik weet.

Ik kan wel verbinding maken via de verkenner met "Met de server verbinden" als ik dan de username en password invul maakt hij gewoon verbinding met de NAS

« Laatst bewerkt op: 2018/01/15, 18:19:27 door ercmrj »

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: NAS verbindt niet meer automatisch
« Reactie #1 Gepost op: 2018/01/12, 19:41:20 »
Al eens geprobeerd om opnieuw op te starten voor zowel de nas als de pc.
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 18.04/Xubuntu 18.04; RPI: Raspbian Jessie; Asus 1005PE: Linux Lite 3.8; W10
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline ercmrj

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #2 Gepost op: 2018/01/13, 18:21:51 »
NAS had ik nog niet opnieuw opgestart, net gedaan maar helpt ook niet.

Zou er iets mis zijn met de rechten?

 Hij geeft als foutmelding "only root can mount"

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #3 Gepost op: 2018/01/13, 19:51:59 »
Rechten van nas map op je pc, hier de rechten van je gebruiker aan toekennen.
Reboot en proberen.
Test ook als de nas al wakker is, of juist als deze slaapt

En rechten van nas controleren.


Offline ercmrj

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #4 Gepost op: 2018/01/14, 13:02:15 »
Denk niet dat het aan de NAS ligt, heb net een 2e laptop geleend met ubuntu en deze regel:

 //***.***.***.***/home /media/NAS cifs username=******,password=********,rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0

uit de fstab van de ene pc in de andere gecopieerd en de andere ziet de NAS wel na het opstarten. Ook heb ik een raspberry met ubuntu daar staat ook alles zo ingesteld en die ziet de NAS ook meteen.
« Laatst bewerkt op: 2018/01/15, 18:18:42 door ercmrj »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #5 Gepost op: 2018/01/14, 13:12:07 »
Lukt het inloggen wel met het voldende commando:
sudo mount /media/NAS
Indien wel, dan is je configuratie in orde, maar dan zal je waarschijnlijk de eigenlijke aankoppeling moeten vertragen. Mogelijk is tijdens het uitvoeren van fstab het systeem nog niet klaar om netwerkconnecties aan te koppelen. Indien niet, dan zal er aan de instellingen in /etc/fstab moeten gesleuteld worden.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: NAS verbindt niet meer automatisch
« Reactie #6 Gepost op: 2018/01/14, 13:43:16 »
Bij Ubuntu 17.10 kreeg ik ook problemen met het aankoppelen van mijn NAS en mij heeft dit geholpen https://askubuntu.com/questions/958920/unable-to-mount-network-share-after-update/964565#964565 (antwoord 2)
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 18.04/Xubuntu 18.04; RPI: Raspbian Jessie; Asus 1005PE: Linux Lite 3.8; W10
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline ercmrj

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #7 Gepost op: 2018/01/14, 17:07:15 »
Met: sudo mount /media/NAS

kan ik ook niet inloggen

Volgen de link die maasnet stuurde moet ik "vers=1.0" toevoegen aan fstab maar of ik het ervoor zet of erachter het werkt allemaal niet

zo:
//***.***.***.***/home /media/NAS cifs username=****,password=****,rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0,vers=1.0

of:
vers=1.0
//***.***.***.***/home /media/NAS cifs username=****,password=****,rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0

of:
//***.***.***.***/home /media/NAS cifs username=****,password=****,rw,noperm,iocharset=utf8,dir_mode=0777,file_mode=0777 0 0
vers=1.0
« Laatst bewerkt op: 2018/01/15, 18:18:19 door ercmrj »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #8 Gepost op: 2018/01/14, 17:14:16 »
Met: sudo mount /media/NAS

kan ik ook niet inloggen
Post hier de eventuele foutmeldingen. Hoe meer we weten, hoe beter.

Het lijkt me eerder dat je "vers=2.1" moet proberen als optie. Standaard probeert de kernel versie 1, maar moderne Windows versies staan zulke verbindingen niet toe.

Offline ercmrj

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #9 Gepost op: 2018/01/14, 17:51:36 »
"vers=2.1"  werkt ook niet

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: NAS verbindt niet meer automatisch
« Reactie #10 Gepost op: 2018/01/14, 17:58:36 »
Zo ziet mijn fstab eruit:

//xxx.xxx.xxx.xx/music /media/music cifs credentials=/home/maasnet/.smbcredentials,iocharset=utf8,vers=1.0,gid=1000,uid=1000,file_mode=0777,dir_mode=0777  0  0   
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 18.04/Xubuntu 18.04; RPI: Raspbian Jessie; Asus 1005PE: Linux Lite 3.8; W10
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #11 Gepost op: 2018/01/14, 21:14:24 »
Firewall, zet deze eens uit, om te testen of het hier aan ligt.

Langer wachten na reboot kan ook helpen.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #12 Gepost op: 2018/01/15, 12:40:58 »
Waarom post je de foutmelding van het commando "sudo mount /media/NAS" niet? Of denk je dat die informatie helemaal niet zal kunnen helpen om de oorzaak van het probleem te achterhalen?

Trouwens, het bericht lijkt ook te suggereren dat er een fout is in /etc/fstab (parse error)
« Laatst bewerkt op: 2018/01/15, 12:44:49 door vanadium »

Offline ercmrj

  • Lid
  • Steunpunt: Nee
Re: NAS verbindt niet meer automatisch
« Reactie #13 Gepost op: 2018/01/15, 18:17:04 »
//***.***.***.***/home /media/NAS cifs username=*****,password=******,rw,noperm,iocharset=utf8,vers=1.0,dir_mode=0777,file_mode=0777 0 0

Daar moet die vers=1.0 staan dan zie ik de NAS weer.

Super bedankt allemaal