Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: installeren Virtualbox in Ubuntu lukt niet  (gelezen 346 keer)

Offline plek

  • Lid
  • Steunpunt: Nee
installeren Virtualbox in Ubuntu lukt niet
« Gepost op: 2017/12/28, 14:43:16 »
Zojuist heb ik Ubuntu 14.04 opnieuw geïnstalleerd. Toen ik probeerde Virtualbox 5.1 te installeren, kwam de volgend foutmelding: "afhankelijkheid is niet vervulbaar:  libdevmapper1.02.1 (>=2:1.02.97)". Geen flauw idee wat dit betekent. Heeft iemand een oplossing voor mij? Alvast dank.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #1 Gepost op: 2017/12/28, 14:46:40 »
Zojuist heb ik Ubuntu 14.04 opnieuw geïnstalleerd. Toen ik probeerde Virtualbox 5.1 te installeren, kwam de volgend foutmelding: "afhankelijkheid is niet vervulbaar:  libdevmapper1.02.1 (>=2:1.02.97)". Geen flauw idee wat dit betekent. Heeft iemand een oplossing voor mij? Alvast dank.

Dat betekent dat je libdevmapper1.02.1 via synaptic moet gaan installeren.
Dit pakket ontbreekt dus.
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 18.04/Xubuntu 18.04; RPI: Raspbian Jessie; Asus 1005PE: Linux Lite 3.8; W10
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline plek

  • Lid
  • Steunpunt: Nee
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #2 Gepost op: 2017/12/28, 15:23:30 »
Dank je maasnet. Bestandje libdevmapper1.02.1  was wel geïnstalleerd. De versie daarvan is 1.02.77. Dat lijkt erg op het laatste deel in de foutmelding (>=2:1.02.97), dus het lag misschien aan de versie van Virtualbox die ik probeerde te installeren, dat was nl 5.1.  Dus heb ik versie 5.0 gedownload, en die zonder problemen kunnen installeren. Nogmaals dank voor je reactie.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #3 Gepost op: 2017/12/28, 20:34:19 »
Dus heb ik versie 5.0 gedownload, en die zonder problemen kunnen installeren.
Alleen wordt Virtualbox 5.0 niet meer ondersteund met updates https://www.virtualbox.org/wiki/Changelog-5.0
Waarschijnlijk kun je dan beter Virtualbox 5.2.x installeren.   
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline plek

  • Lid
  • Steunpunt: Nee
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #4 Gepost op: 2017/12/29, 18:00:31 »
Citaat
Alleen wordt Virtualbox 5.0 niet meer ondersteund met updates https://www.virtualbox.org/wiki/Changelog-5.0
Waarschijnlijk kun je dan beter Virtualbox 5.2.x installeren.
Jolo, ik weet dat Vbox 5.0 niet meer ondersteund wordt. Maar gezien de foutmelding bij de mislukte installatie van Vbox 5.1 en de geslaagde installatie van Vbox 5.0, was de versie van libdevmapper in Ubuntu kennelijk te laag voor Vbox 5.1. Voor mijn gevoel gaat de nog hogere Vbox 5.2 dan zéker niet lukken. Maar dat moet ik nog wel testen.

Online rico70

  • Lid
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #5 Gepost op: 2017/12/29, 18:59:28 »
Ik heb VB 5.2.4 in Mint 18.3
libdevmapper 1.02.110
Installeerde zonder foutmeldingen

Offline plek

  • Lid
  • Steunpunt: Nee
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #6 Gepost op: 2017/12/30, 16:53:11 »
Citaat
Ik heb VB 5.2.4 in Mint 18.3. libdevmapper 1.02.110. Installeerde zonder foutmeldingen
Dank rico70. Kan ik libdevmapper 1.02.110 ergens vinden en zonder problemen in Ubuntu 14.04 opnemen?

Online rico70

  • Lid
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #7 Gepost op: 2017/12/30, 16:57:08 »
dat kan op https://packages.ubuntu.com
https://packages.ubuntu.com/search?keywords=libdevmapper&suite=default&section=all&arch=any&searchon=names
Je hebt wel kans dat je tegen dependency hell aanloopt, ligt eraan waar dit pakket van afhankelijk is

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: installeren Virtualbox in Ubuntu lukt niet
« Reactie #8 Gepost op: 2017/12/30, 21:31:00 »
In principe zou virtualbox-5.2_5.2.4-119785~Ubuntu~trusty_amd64.deb gewoon geïnstalleerd moeten kunnen worden in Ubuntu 14.04.5. Als ik de afhankelijkheden check via terminalvenstercommando dpkg -I virtualbox-5.2_5.2.4-119785~Ubuntu~trusty_amd64.deb[Enter]

toont deze onder andere bij de afhankelijkheden libdevmapper1.02.1 die gewoon wordt meegeleverd met Ubuntu 14.04.5 volgens het manifest bestand. Als ik met de rechter muisknop klik op die virtualbox-5.2 deb bestand en Gdebi selecteer, dan toont deze dat aan alle afhankelijkheden word voldaan.
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM