Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geen lpt poort  (gelezen 147 keer)

Offline jhelmond

  • Lid
geen lpt poort
« Gepost op: 2017/11/06, 19:48:15 »
bij het, na een update ,opnieuw installeren van een hp deskjet 720c krijg ik geen parallele poort te zien, alleen een seriele poort.
draai nu lubuntu 16 met alle updates. voorheen deed de printer het wel.
hplip is ook aanwezig.
wie kan mij helpen ?

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: geen lpt poort
« Reactie #1 Gepost op: 2017/11/06, 20:07:12 »
JHelmond,

Ik mag dan wel geen Lununtu hebben, maar is het bestand
/etc/modules-load.d/cups-filters.conf  wel aanwezig.
Deze zorgt ervoor dat de parallele-poort modulen worden geladen.
Zit in het pakket: cups-filters
Maw, heb je niet per ongelijk cups verwijderd.
MvG,
MauRice
Registered Linux user: 473556

Offline jhelmond

  • Lid
Re: geen lpt poort
« Reactie #2 Gepost op: 2017/11/07, 19:26:13 »
Dit kan ik vinden
is dit goed?
of waar zit  /etc/modules-load.d/cups-filters.conf

jhelmond@jhelmond-MS-7012:~$ lpstat -r
scheduler is running
jhelmond@jhelmond-MS-7012:~$

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: geen lpt poort
« Reactie #3 Gepost op: 2017/11/08, 20:37:28 »
JHelmond,

Wat er precies is gebeurt bij het update is van deze kant moeilijk te zien.
Iets moet er gedeïnstalleren zijn.

Als ik bekijk op mijn desktop....
Ik heb geen fysieke paralle-poort laat staan een HP Deskjet 720C.
Toch kan deze printer toevoegen op /dev/lp0 (lpt pport).
De /dev/lp0 bestaat ook.

Kijks eens of op systeem /dev/lp0 aanwezig is.
En met enkele terminal opdrachten of je meer info krijgt hier om trend:

dmesg | grep lp

groups <uw-gebruikers-naam>

In beide uitkomsten zal je lp er tussen moet staan.

PS
De enigste printer die bijmij actief is, is een virtuele 'cups-pdf'.
Addrukken stuur ik door naar een aparte 'Print Server', daar hangt een USB printer aan.
 
MvG,
MauRice
Registered Linux user: 473556

Offline jhelmond

  • Lid
Re: geen lpt poort
« Reactie #4 Gepost op: 2017/11/10, 16:36:47 »
bijde opdrachten geeft het volgende.
geen antwoord op 2e opdracht.
waar vind ik  systeem /dev/lp0 ?

jhelmond@jhelmond-MS-7012:~$ dmesg | grep lp
[    0.000000] On node 0 totalpages: 524174
[    0.004021] Calibrating delay loop (skipped), value calculated using timer frequency.. 5985.09 BogoMIPS (lpj=11970180)
[    8.283212] lp: driver loaded but no devices found
[    8.675858] lp0: using parport0 (interrupt-driven).
[   18.166331] audit: type=1400 audit(1510326370.219:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=486 comm="apparmor_parser"
[   18.310732] audit: type=1400 audit(1510326370.363:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/evince//sanitized_helper" pid=494 comm="apparmor_parser"
[   18.310736] audit: type=1400 audit(1510326370.363:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/evince-previewer//sanitized_helper" pid=494 comm="apparmor_parser"
[   25.189701] 8139too 0000:02:03.0 enp2s3: link up, 100Mbps, full-duplex, lpa 0x41E1
[  441.690357] nf_conntrack: default automatic helper assignment has been turned off for security reasons and CT-based  firewall rule not found. Use the iptables CT target to attach helpers instead.
jhelmond@jhelmond-MS-7012:~$ groups <jhelmond>
bash: syntaxfout nabij onverwacht symbool 'newline'
jhelmond@jhelmond-MS-7012:~$

Jan

Offline jhelmond

  • Lid
Re: geen lpt poort
« Reactie #5 Gepost op: 2017/11/10, 17:18:42 »
Het blijkt dat pnm2ppa niet geinstalleerd was.
printer werkt nu weer.
zover bedankt
jan