Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Not Found The requested URL was not found on this server. Apache/2.4.7 (Ubuntu)  (gelezen 3727 keer)

Offline tomatito

  • Lid
  • Steunpunt: Nee
Ik wil mijn website verhuizen van een live server naar localhost.

Ik gebruik daar deze tutorial voor: http://www.wpbeginner.com/wp-tutorials/how-to-move-wordpress-from-local-server-to-live-site/comment-page-5/

(deze werkwijze werkt gewoon ook al is de volgorde omgekeerd).

Mijn site is een one-pager met 1 andere pagina (blog). Alles werkt naar behoren maar als ik op de link (blog) klik dan krijg ik deze melding:
Not Found

The requested URL /backup1/blog/ was not found on this server.
Apache/2.4.7 (Ubuntu) Server at localhost Port 80

Weet iemand wat dit betekend en hoe ik dit kan oplossen?


Ubuntu 18.04

Intel Skylake i3 6100, 8 GB DDR4, nVidia Geforce GTX 750 ti (2GB)

Offline Paul Matthijsse

  • Lid
  • Steunpunt: Ja
Hallo, de live-versie van je Wordpress-site kent een zekere mapstructuur. Als je dat verhuist naar je eigen pc, neem je niet die mapstructuur mee. Die moet je dus lokaal aanmaken.

Is de exportfunctie van Wordpress niet handiger? Dashboard, Admin, Tools, Export?

Of je 'zuigt' je live-site leeg met het wget-commando:
$ wget -r <naamvanjesite>
Die -r staat voor recursief.

Dat levert in je thuismap een map op met de naam <naamvanjesite>.wordpress.com

Offline tomatito

  • Lid
  • Steunpunt: Nee
Citaat
Hallo, de live-versie van je Wordpress-site kent een zekere mapstructuur. Als je dat verhuist naar je eigen pc, neem je niet die mapstructuur mee. Die moet je dus lokaal aanmaken.
Ik weet niet of we over hetzelfde praten. Bedoel jij misschien  de gratis blog versie van Wordpress? Dus gratis hosting op een subdomein van Wordpress.

Mijn Wordpress site zit gewoon bij Yourhosting.

Citaat
Die moet je dus lokaal aanmaken
Weet ik en gedaan  ;)

Ik heb uiteindelijk maar een verhuis plugin geinstalleerd (Duplicator) maar daar gaat exact hetzelfde fout. Dus ik vermoed dat mijn manier van verhuizen klopt maar dat er iets niet goed is met Apache.
Ubuntu 18.04

Intel Skylake i3 6100, 8 GB DDR4, nVidia Geforce GTX 750 ti (2GB)

swake

  • Gast
Waarom maak jij geen backup van je WP site en MySQL database ? Is toch het meest eenvoudige om een verhuis uit te voeren .

Offline tomatito

  • Lid
  • Steunpunt: Nee
Alle pagina's werken inmiddels.

sudo gedit /etc/apache2/apache2.conf

Citaat
<Directory />
   Options FollowSymLinks
   AllowOverride None
   Require all denied
</Directory>

<Directory /usr/share>
   AllowOverride None
   Require all granted
</Directory>

<Directory /var/www/>
   Options Indexes FollowSymLinks
   AllowOverride None
   Require all granted
</Directory>

#<Directory /srv/>
#   Options Indexes FollowSymLinks
#   AllowOverride None
#   Require all granted
#</Directory>

Overal waar None staat heb ik vervangen met All

Daarna: sudo /etc/init.d/apache2 restart
Alleen nu heb ik weer geen toegang tot admin  ???. Ik zoek verder  :P



« Laatst bewerkt op: 2017/10/22, 08:39:46 door tomatito »
Ubuntu 18.04

Intel Skylake i3 6100, 8 GB DDR4, nVidia Geforce GTX 750 ti (2GB)

Offline tomatito

  • Lid
  • Steunpunt: Nee
Begrijpen doe ik het niet maar de oplossing was ook om een .htaccess bestandje verwijderen uit admin. Had ik toegevoegd om te zorgen dat ik alleen toegang heb tot admin op basis van ip-adres.
Ubuntu 18.04

Intel Skylake i3 6100, 8 GB DDR4, nVidia Geforce GTX 750 ti (2GB)