Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: update VirtualBox 5.1  (gelezen 378 keer)

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
update VirtualBox 5.1
« Gepost op: 2017/09/22, 21:34:00 »
Gisteren startte ik VirtualBox op en kreeg een melding dat er een nieuwe versie beschikbaar was. Ik downloadde zoals gewoonlijk de file (virtualbox-5.1_5.1.28-117968-Ubuntu-xenial_amd64.deb) en ging via 'Synaptic pakketbeheer' mijn versie 5.1.26 markeren voor verwijdering. Tot daar alles okee.
Maar toen ik het gedownloade bestand wou installeren in Ubuntu Software kreeg ik slechts een heel kort streepje in plaats van het gebruikelijke dat wel een tijdje loopt.
En toen ik VirtualBox wilde opstarten kon ik die niet meer vinden. Ik ga er dus van uit dat VirtualBox niet geïnstalleerd is.
Ik heb dit drie maal geprobeerd - ook het gedownloade bestand verwijderd en opnieuw gedownload, maar steeds hetzelfde verschijnsel !
Omdat ik absoluut een programma moest uitvoeren dat enkel onder Windows draait heb ik dan via Ubuntu Software de aangeboden VirtualBox (5.0.40) geïnstalleerd.
Die draait wel Windows XP en Windows 7, maar mijn virtuele Windows 10 krijg ik niet aan de praat !
Ik heb nu twee vragen:
- Hoe krijg ik VB 5.1.28 opnieuw geïnstalleerd ?
- Is er een nadeel om bij 5.0.40 te blijven ? en hoe krijg ik dan Win 10 opnieuw levend (ik krijg enkel een zwart scherm met de melding 'AUTOMATISCH HERSTEL WORDT VOOBEREID' maar die gaat geen meter verder!) ?
Alle hulp wordt zeer gewaardeerd !

NB: ik draait Ubuntu 16.04 LTS op een AKOYA i5

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #1 Gepost op: 2017/09/23, 07:37:05 »
Pjotr gaat zo te zien uit van de VirtualBox uit de Ubuntu pakketbronnen. Check eventueel https://www.virtualbox.org/wiki/Changelog

Je zou die VirtualBox deb pakket eventueel kunnen installeren via applicatie GDebi. Je klikt dan in de bestandsbeheerder met de rechter muisknop op het VirtualBox deb pakket, zodat het contextmenu verschijnt. Klik op "Openen met" en "GDebi pakketinstalleerder" Als er bij "Status" geen rode teksten staan vermeldt, dan zou je 'm kunnen installeren. Zie onderstaande afbeelding van GDebi. Vergeet verder niet de VirtualBox Extension Pack te installeren/upgraden. Dit is onder andere vereist voor de USB 2.0 en USB 3.0 ondersteuning.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #2 Gepost op: 2017/09/23, 09:15:21 »
Die versie 5.1.28 had je ook gewoon "over" versie 5.1.26 moeten installeren en die niet eerst verwijderen.
mvg,  Peter
Desktop: xubuntu 16.04.3 / xubuntu-minimal 16.04.3
Laptop: xubuntu-minimum 16.04.3
"No windows in the house but somehow there's more light..."

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #3 Gepost op: 2017/09/23, 10:46:14 »
Die versie 5.1.28 had je ook gewoon "over" versie 5.1.26 moeten installeren en die niet eerst verwijderen.
Ik gebruik VirtualBox reeds enkele jaren en was altijd in de overtuiging dat ik eerst het oude pakket moest verwijderen (niet helemaal, maar wel 'gedeeltelijk') vooraleer ik de nieuwe versie installeer ...?

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #4 Gepost op: 2017/09/23, 11:00:49 »

Je zou die VirtualBox deb pakket eventueel kunnen installeren via applicatie GDebi. Je klikt dan in de bestandsbeheerder met de rechter muisknop op het VirtualBox deb pakket, zodat het contextmenu verschijnt. Klik op "Openen met" en "GDebi pakketinstalleerder" Als er bij "Status" geen rode teksten staan vermeldt, dan zou je 'm kunnen installeren.
Bedankt voor de tip !
Heb het zojuist geprobeerd - eerst gdebi geïnstalleerd - maar ik krijg de volgende foutmelding:
Fout: Maakt het bestaande pakket 'virtualbox' stuk door conflict : virtualbox-5.1 ()
Zal ik eerst de geïnstalleerde versie 5.0.40 verwijderen ? Ben ik dan alle instellingen kwijt ...?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #5 Gepost op: 2017/09/23, 12:57:13 »
In dit geval zal die oude VirtualBox inderdaad verwijderd moeten worden. Dat doe je via terminalvenstercommando sudo apt-get remove virtualbox [Enter]

Daarmee blijven de VirtualBox instellingen bewaard. Zie https://www.howtoinstall.co/en/ubuntu/xenial/virtualbox?action=remove
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #6 Gepost op: 2017/09/23, 21:28:39 »
In dit geval zal die oude VirtualBox inderdaad verwijderd moeten worden. Dat doe je via terminalvenstercommando sudo apt-get remove virtualbox [Enter]
... en daarna zou ik de versie installeren die bij je systeem hoort met
sudo apt install virtualbox(en dus niet met download/gdebi/SoftwareCenter)

De foutmelding die van Windows 10 komt, kan niet door "een andere versie" van VirtualBox gecorrigeerd worden volgens mij. Als een Windows-systeem een reparatie wil starten, dan komt dat door een "dirty-bit". Dat wil zeggen dat het systeem de laatste keer niet succesvol gestart kon worden waardoor een Windows-interne reparatie nodig is.
Als je met VirtualBox werkt en de nieuwe versie heeft andere instellingen voor USB/modules/hardware, dan kan Windows dat zien al een gewijzigde hardware-situatie en wil misschien een nieuwe aanmelding bij Microsoft om illegale kopieën van het OS  te voorkomen.
Citaat
Omdat ik absoluut een programma moest uitvoeren dat enkel onder Windows draait heb ik dan via Ubuntu Software de aangeboden VirtualBox (5.0.40) geïnstalleerd.
In dit geval zou ik kiezen voor 1 Windowsversie en niet proberen om dat "noodzakelijke programma" in 3 verschillende versies van Windows te gebruiken.
btw: Voor mij is het ook de vraag of het binnen de licenties van Microsoft toegestaan is om 3 besturingssystemen op dezelfde pc te installeren. XP is al enige tijd eol.
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #7 Gepost op: 2017/09/24, 00:21:06 »
Citaat
In dit geval zou ik kiezen voor 1 Windowsversie en niet proberen om dat "noodzakelijke programma" in 3 verschillende versies van Windows te gebruiken.
btw: Voor mij is het ook de vraag of het binnen de licenties van Microsoft toegestaan is om 3 besturingssystemen op dezelfde pc te installeren. XP is al enige tijd eol.
De reden dat ik nog steeds Windows XP wil draaien is dat ik nog een oude Access gebruik met een database die al 20 jaar oud is en niet onder de nieuwere Windows draait. Win 10 gebruik ik dan weer voor Faststone en BaseCamp (Garmin). Win 7 kan er eigenlijk wel af.

Offline rico70

  • Lid
Re: update VirtualBox 5.1
« Reactie #8 Gepost op: 2017/09/24, 07:44:54 »
De reden dat ik nog steeds Windows XP wil draaien is dat ik nog een oude Access gebruik met een database die al 20 jaar oud is en niet onder de nieuwere Windows draait. Win 10 gebruik ik dan weer voor Faststone en BaseCamp (Garmin). Win 7 kan er eigenlijk wel af.
Kan die database niet geexporteerd worden zodat tie in een nieuwere acces gebruikt kan worden?

Persoonlijk zou ik win7 houden en win10 eraf gooien, ben je gelijk een hoop spyware kwijt.
Basecamp draait prima onder win7, en voor FastStone zou XnviewMP kunnen gebruiken onder Linux
https://en.wikipedia.org/wiki/FastStone_Image_Viewer

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #9 Gepost op: 2017/09/24, 12:38:46 »
Ik kan me nog aan ons drama op kantoor herinneren toen we van Access97 naar Access2000 gingen. We konden onze database opnieuw gaan bouwen. Volgens mij was destijds ook een probleem met de compatibiliteit van de oudere formaten aan de orde bij de overstap van Access2003 naar Access2007.
Mijn conclusie was toen de overstap naar Open(later Libre)Office. Daar heb ik nog geen problemen met de compatibiliteit gezien als ik oudere documenten/tabellen ging gebruiken. Alle "krasjes" van een conversie van mijn documenten, kon ik in een nieuwe versie verhelpen zonder raketgeleerde te moeten zijn.
Kan die database niet geexporteerd worden zodat tie in een nieuwere acces gebruikt kan worden?
Mijn advies: probeer een conversie van je oude Access-database naar LibreOffice Calc. Je kan 3 tabbladen maken: 1 de datatabel, 2 voor een grafische weergave, 3 voor een presentatie met filters. Daar kom je een heel end mee. Als je daar te weinig mogelijkheden in ziet, probeer LibreOffice Base. Calc is voldoende voor eenvoudige databases, Base is vergelijkbaar met Access (maar iets minder uitgebreid).
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #10 Gepost op: 2017/09/24, 12:51:46 »
In dit geval zal die oude VirtualBox inderdaad verwijderd moeten worden. Dat doe je via terminalvenstercommando sudo apt-get remove virtualbox [Enter]
... en daarna zou ik de versie installeren die bij je systeem hoort met
sudo apt install virtualbox(en dus niet met download/gdebi/SoftwareCenter)
[/quote]
Ik heb dit uitgevoerd, maar begrijp niet wat hier de bedoeling van is ...? Eerst wordt VB verwijderd en daarna wordt dezelfde versie opnieuw geïnstalleerd; ik moest enkel nog het extensionpack opnieuw downloaden en installeren.

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #11 Gepost op: 2017/09/24, 12:55:32 »
Persoonlijk zou ik win7 houden en win10 eraf gooien, ben je gelijk een hoop spyware kwijt.
Basecamp draait prima onder win7, en voor FastStone zou XnviewMP kunnen gebruiken onder Linux
https://en.wikipedia.org/wiki/FastStone_Image_Viewer
Ik vind Win 7 ook interessanter, maar ik geef ook computerlessen en bijna iedereen heeft tegenwoordig Win10 op z'n pc staan.
Bedankt voor de tip over XnvieuwMp; die zal ik eens uitproberen; maar ook daar weer: ik geef les over Faststone, dus moet ik die wel kunnen gebruiken.

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #12 Gepost op: 2017/09/24, 12:57:37 »
Kan die database niet geexporteerd worden zodat tie in een nieuwere acces gebruikt kan worden?
Misschien wel, maar dan moet je wel een nieuwere Acces hebben ... en die heb ik niet en een nieuwe kopen lijkt me wel héél duur.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #13 Gepost op: 2017/09/24, 14:40:21 »
Ik heb dit uitgevoerd, maar begrijp niet wat hier de bedoeling van is ...? Eerst wordt VB verwijderd en daarna wordt dezelfde versie opnieuw geïnstalleerd; ik moest enkel nog het extensionpack opnieuw downloaden en installeren.
In Ubuntu wordt anders gewerkt dan in Windows. Het is alleen in uitzonderlijke gevallen zinvol of veilig om buiten de gebruikelijke bronnen van Ubuntu programma's te downloaden en te installeren. De normale manier is via het Software Center (via de terminal met "apt install" of via Synaptic kan ook). Als op de normale manier software wordt geïnstalleerd, dan wordt deze software ook standaard meegenomen bij het automatische aanbieden van actualisaties. Er worden namelijk alle (hulp)programma's in1 keer gecontroleerd of er actualisaties of veiligheidsupdates zijn. Meer informatie staat daar.
Deze veilige manier van werken, waarin alleen software uit Ubuntubronnen wordt gebruikt, kan voorkomen dat er software erbij komt die alleen handmatig wordt geactualiseerd (dat zijn je meldingen "er is een nieuwe versie van VirtualBox"). Er is hier geen garantie bij "losse installaties" dat vanwege de onderlinge afhankelijkheden de software naar behoren werkt.

Ook de virtualbox-guest-additions-iso kan gewoon vanuit Software Center geinstalleerd worden. Heb je dat zo gedaan of via een aparte download van een website?
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #14 Gepost op: 2017/09/24, 20:06:55 »
Ik heb dit uitgevoerd, maar begrijp niet wat hier de bedoeling van is ...? Eerst wordt VB verwijderd en daarna wordt dezelfde versie opnieuw geïnstalleerd; ik moest enkel nog het extensionpack opnieuw downloaden en installeren.
In Ubuntu wordt anders gewerkt dan in Windows. Het is alleen in uitzonderlijke gevallen zinvol of veilig om buiten de gebruikelijke bronnen van Ubuntu programma's te downloaden en te installeren. De normale manier is via het Software Center (via de terminal met "apt install" of via Synaptic kan ook). Als op de normale manier software wordt geïnstalleerd, dan wordt deze software ook standaard meegenomen bij het automatische aanbieden van actualisaties. Er worden namelijk alle (hulp)programma's in1 keer gecontroleerd of er actualisaties of veiligheidsupdates zijn. Meer informatie staat daar.
Deze veilige manier van werken, waarin alleen software uit Ubuntubronnen wordt gebruikt, kan voorkomen dat er software erbij komt die alleen handmatig wordt geactualiseerd (dat zijn je meldingen "er is een nieuwe versie van VirtualBox"). Er is hier geen garantie bij "losse installaties" dat vanwege de onderlinge afhankelijkheden de software naar behoren werkt.

Ook de virtualbox-guest-additions-iso kan gewoon vanuit Software Center geinstalleerd worden. Heb je dat zo gedaan of via een aparte download van een website?
Ik begrijp je redenering wel, maar ik begrijp niet welke zin het heeft om VB 5.0.40 via de terminal er af te smijten om dan via de terminal dezelfde versie er weer op te zetten ...?
Ik had de VB 5.1.26 er voorheen reeds afgehaald en vervangen door 5.0.40 (via Software Center) omdat ik de update versie 5.1.28 niet geïnstalleerd kreeg via de gedownloade .deb-file en ook niet de vorige .deb-file 5.1.26.
Dat het veiliger en comfortabeler is om enkel de Ubuntubronnen te gebruiken neem ik aan, maar waarom worden die veilige bronnen niet aangepast aan de nieuwere versie 5.1 ? Trouwens op de site van VirtualBox staat dat 5.0 niet meer wordt ondersteund.

Offline rico70

  • Lid
Re: update VirtualBox 5.1
« Reactie #15 Gepost op: 2017/09/24, 20:25:16 »
Op de site van Oracle Virtualbox staan de repos voor diverse Linux distributies. Als je de repo voor Ubuntu toevoegd aan je sources list krijg je steeds de nieuwe versie

Offline shadoogie2960

  • Lid
  • Steunpunt: Nee
Re: update VirtualBox 5.1
« Reactie #16 Gepost op: 2017/09/26, 21:53:34 »
Ik begrijp het niet maar na een herinstallatie van virtualbox 5.1.28 via de terminal werkt alles opnieuw zoals het hoort !
Gevonden op 'superuser.com':
-------------------------------------------------------------------
Add the following line to your /etc/apt/sources.list:

deb http://download.virtualbox.org/virtualbox/debian yakkety contrib
According to your distribution, replace 'yakkety' by 'xenial', 'vivid', 'utopic', 'trusty', 'raring', 'quantal', 'precise', 'lucid', 'jessie', 'wheezy', or 'squeeze'. ... The Oracle public key for apt-secure can be downloaded...and register[ed]:

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
...snip...

To install VirtualBox, do

sudo apt-get update
sudo apt-get install virtualbox-5.1
...snip...
--------------------------------------------------------------------------
Ik moest nog wel in Ubuntu Software de versie 5.0 verwijderen en in de terminal ingeven:
sudo /sbin/vboxconfig
en alles werkt nu ! Oef ! :laugh: