Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: glade en libglade  (gelezen 530 keer)

Offline simthadim

  • Lid
  • Steunpunt: Nee
glade en libglade
« Gepost op: 2017/09/15, 21:54:45 »
Voor een simulatiepakket voor de TU Delft wil ik een GUI maken. Het framework (DUECA) gebruikt hiervoor libglade maar helaas lukt het mij niet om met glade bestanden in te lezen die gemaakt zijn voor libglage. Bestanden die gemaakt zijn voor GtkBuilder werken prima, maar die kan ik helaas niet inladen. Bij de "Opslaan als" optie kan ik wel selecteren om het op te slaan als libglade bestand, maar uiteindelijk is dit het toch niet.

Ik gebruik zelf Ubuntu 16.04, en Glade 3.18.x uit de Ubuntu repository.  Weet iemand waar dit aan kan liggen?

Achtergrond
Het grote verschil tussen libglade en GTK builder zit 'm in dat de  eerste een xml file (*.glade)  met een   <glade-interface> object maakt, en de ander een <interface> object (en toegang geeft tot meerdere widgets). 

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Re: glade en libglade
« Reactie #1 Gepost op: 2017/09/15, 22:18:31 »
Libglade is een heel oud formaat, het was ook een aparte library voor alles naar GtkBuilder werd omgezet en in de standaard GTK installatie zat. Libglade is enkel voor GTK2.

Nu, het probleem met Glade zelf. Er is een verschil tussen Glade voor GTK2 en GTK3. In Ubuntu 14.04 zaten beide pakketten in de repositories.
  Glade <= 3.8 voor GTK2: glade-gtk2
  Glade >= 3.10 voor GTK3: glade

Blijkbaar is die eerste niet meer beschikbaar, dus zelf compileren is waarschijnlijk de makkelijkste optie. Hier vind ge de broncode: http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/
Met een beetje geluk kunt ge ook gewoon het pakket uit Ubuntu 14.04 los installeren: https://packages.ubuntu.com/trusty/glade-gtk2