Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: fouten bij het updaten  (gelezen 327 keer)

Offline Plotinus

  • Lid
  • Steunpunt: Nee
fouten bij het updaten
« Gepost op: 2017/08/27, 10:50:21 »
L.S.

In Debian krijg ik bij het updaten de volgende foutmelding (in het rood geplaatst):

root@PC-***:/home/***# apt-get -y update && sudo apt-get -y upgrade && sudo apt-get -y autoremove
Geraakt:1 http://files2.eid.belgium.be/debian stretch InRelease
Geraakt:2 http://download.virtualbox.org/virtualbox/debian stretch InRelease                                                                                 
Genegeerd:3 http://deb.debian.org/debian stretch InRelease                                                                                                   
Geraakt:4 http://files.eid.belgium.be/debian stretch InRelease                                               
Geraakt:5 http://deb.debian.org/debian stretch Release                             
Geraakt:6 http://security.debian.org/debian-security stretch/updates InRelease     
Genegeerd:8 http://ftp.be.debian.org/debian stretch InRelease
Geraakt:9 http://ftp.be.debian.org/debian stretch-updates InRelease
Geraakt:10 http://ftp.be.debian.org/debian stretch Release
Pakketlijsten worden ingelezen... Klaar                 
N: Opvragen van het in de configuratie vermeld bestand 'main/binary-386/Packages' overgeslagen, vermits pakketbron 'http://files2.eid.belgium.be/debian stretch InRelease' de architectuur '386' niet ondersteunt
N: Opvragen van het in de configuratie vermeld bestand 'contrib/binary-386/Packages' overgeslagen, vermits pakketbron 'http://download.virtualbox.org/virtualbox/debian stretch InRelease' de architectuur '386' niet ondersteunt
N: Opvragen van het in de configuratie vermeld bestand 'main/binary-386/Packages' overgeslagen, vermits pakketbron 'http://files.eid.belgium.be/debian stretch InRelease' de architectuur '386' niet ondersteunt
N: Opvragen van het in de configuratie vermeld bestand 'non-free/binary-386/Packages' overgeslagen, vermits pakketbron 'http://deb.debian.org/debian stretch InRelease' de architectuur '386' niet ondersteunt
N: Opvragen van het in de configuratie vermeld bestand 'main/binary-386/Packages' overgeslagen, vermits pakketbron 'http://security.debian.org/debian-security stretch/updates InRelease' de architectuur '386' niet ondersteunt
N: Opvragen van het in de configuratie vermeld bestand 'main/binary-386/Packages' overgeslagen, vermits pakketbron 'http://ftp.be.debian.org/debian stretch-updates InRelease' de architectuur '386' niet ondersteunt
N: Opvragen van het in de configuratie vermeld bestand 'main/binary-386/Packages' overgeslagen, vermits pakketbron 'http://ftp.be.debian.org/debian stretch InRelease' de architectuur '386' niet ondersteunt

Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
Opwaardering wordt doorgerekend... Klaar
0 opgewaardeerd, 0 nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
0 opgewaardeerd, 0 nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.

Weet iemand hoe ik dat eruit kan krijgen? Het gaat natuurlijk om een of ander tekstbestandje maar welke en hoe daar te geraken?

gegroet,
mrt
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #1 Gepost op: 2017/08/27, 11:17:28 »
Ik veronderstel dat dit de ppa van de eid reader is.
Schakel deze eens uit en probeer het nog eens.
Dan weet je wat meer.
Succes!
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #2 Gepost op: 2017/08/27, 11:37:41 »
Nee, helaas, dat heeft er niets mee te maken: Dezelfde foutmeldingen behalve voor de eid reader.

Ik denk dat het te maken moet hebben met een vroegere poging programma's draaiende te krijgen die geschreven zijn voor de 386-architectuur
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #3 Gepost op: 2017/08/27, 14:02:21 »
Kijk eens in het bestand
/etc/apt/sourceslist
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #4 Gepost op: 2017/08/27, 14:16:57 »
Ik zie geen gekke dingen:
#

# deb cdrom:[Debian GNU/Linux 9.0.0 _Stretch_ - Official amd64 NETINST 20170617-13:06]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.0.0 _Stretch_ - Official amd64 NETINST 20170617-13:06]/ stretch main

deb http://ftp.be.debian.org/debian/ stretch main
deb-src http://ftp.be.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.be.debian.org/debian/ stretch-updates main
deb-src http://ftp.be.debian.org/debian/ stretch-updates main
deb http://download.virtualbox.org/virtualbox/debian stretch contrib
# deb-src http://download.virtualbox.org/virtualbox/debian stretch contrib
deb http://deb.debian.org/debian/ stretch non-free
# deb-src http://deb.debian.org/debian/ stretch non-free
# deb-src http://deb.debian.org/debian/ stretch non-free
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #5 Gepost op: 2017/08/27, 14:23:37 »
En in /etc/apt/sourceslist.d ?
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #6 Gepost op: 2017/08/27, 15:32:48 »
Dat is een mapje met de volgende inhoud; zie bijlage

Spotify en Stack trouwens niet aan de praat gekregen onder de laatste Debian-versie
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline rico70

  • Lid
Re: fouten bij het updaten
« Reactie #7 Gepost op: 2017/08/27, 15:49:29 »
Stack gaat ook niet meer werken in Debian 9, heeft geen prio bij TransIP. Als je toch Stack wilt blijven gebruiken zal je het via de webinterface of webdav moeten doen.

Heb je toevallig een 64 bit systeem en is de eid eigenlijk 32bit? In dat geval moet je multiarch installeren.

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #8 Gepost op: 2017/08/27, 18:57:45 »
Als ik 'Arch-test' doe op mijn 64 bits machine, dan levert dat het volgende op:
Citaat
root@PC-***:/home/***# arch-test
amd64
i386

Dus volgens mij zijn beide architecturen op het systeem aanwezig. Ik heb de software voor eid verwijderd, maar ik blijf de zelfde foutmeldingen krijgen behalve waarin verwezen wordt naar eid.
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline HM63

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #9 Gepost op: 2017/08/28, 10:16:35 »
probeer dit eens:

sudo dpkg --add-architecture i386

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #10 Gepost op: 2017/08/30, 16:28:40 »
helaas geen effect; verandering. Misschien is het eenvoudigste de 386 architectuur gewoon te verwijderen(?) Maar hoe doe ik dat?
« Laatst bewerkt op: 2017/08/30, 16:47:45 door Plotinus »
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.

Offline Plotinus

  • Lid
  • Steunpunt: Nee
Re: fouten bij het updaten
« Reactie #11 Gepost op: 2017/08/30, 17:02:09 »
Opgelost door de 386 architectuur te verwijderen; hier gevonden:https://superuser.com/questions/714391/how-do-i-remove-all-i386-architecture-packages-from-my-debian-installation

De fout zat er hier in dat ik blijkbaar een 386-architectuur heb proberen te installeren, terwijl het een i386-architectuur moest zijn (386 bestaat niet)
Ach! Waren alle Menschen wijs, en wilden daarbij wel! De Aard waar haar een Paradijs, Nu isse meest een Hel.