Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Pakket op bepaalde versie blocken  (gelezen 142 keer)

Offline woteb

  • Lid
  • Steunpunt: Nee
Pakket op bepaalde versie blocken
« Gepost op: 2017/08/18, 16:57:15 »
Op mijn werk heb ik te maken met een Windows omgeving. Om mijn Debian GNU/Linux desktop en laptop daarmee te verbinden heb ik CIFS nodig. Nu wil het geval dat bij de dist-upgrade van Jessie (8) naar Stretch (9) er een versie van CIFS wordt geïnstalleerd die niet communiceert met het netwerk. Op een desktop heb ik nog Jessie staan en die werkt wel.

Nu heb ik met apt-get remove cifs-utils && apt-get install -t jessie cifs-utils de zaak weer recht kunnen zetten.
Alleen, bij de apt-get upgrade wil Debian natuurlijk de versie van Stretch weer installeren die natuurlijk niet werkt.

Met deze instellingen in /etc/apt/preferences
Citaat
Package:*
Pin: release a=stretch
Pin-Priority: 900

Package:*
Pin: release a=stretch-backports
Pin-Priority: 300

Package:gftp
Pin: release a=jessie
Pin-Priority: 100

Package:cifs-utils
Pin: version 2.6.4-1
Pin-Priority: 999
wil ik dat dus voorkomen, maar dat wordt niet geaccepteerd. Met Synaptic lukt het mij wel, maar ik werk liever via de commandline.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Pakket op bepaalde versie blocken
« Reactie #1 Gepost op: 2017/08/18, 17:31:10 »
apt-mark hold?
Citaat
Apt
Starting with Ubuntu 12.04, use Apt to hold one or more packages:
sudo apt-mark hold libxfont1 …
Replace 'libxfont1' with the package(s) you wish to hold.

https://help.ubuntu.com/community/PinningHowto
Xubuntu 18.04

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Pakket op bepaalde versie blocken
« Reactie #2 Gepost op: 2017/08/18, 18:35:51 »
YESSSSSSS....... Dat werkt prima. Bedankt voor de tip.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Testing/Unstable