Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Feisty fawn start erg traag op  (gelezen 2802 keer)

Dancel

  • Gast
Feisty fawn start erg traag op
« Gepost op: 2007/05/08, 23:12:30 »
Wellicht dat hier al iets over vermeld staat op dit forum, dan mijn excuses voor de herhaling.

Ik heb inmiddels ook de overstap gemaakt naar Ubuntu, maar nu valt mij op dat het heel erg lang duurd voordat Ubuntu helemaal is opgestart.

Eerst krijg ik het het dos-achtige startup venstertje, waarna ik een 'Error allocating mem resources' bericht krijg, Vervolgens start hij door naar het opstartvenster met de oranje statusbalk, en hier begint het echte probleem.

Het balkje loopt op tot het midden, waar het vervolgens anderhalve minuut blijft haken, en vervolgens doorstart.

Wat zou dit probleem kunnen veroorzaken?

Alvast bedankt

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #1 Gepost op: 2007/05/09, 06:55:18 »
kijk eens in dit topic voor het traag starten:
http://forum.ubuntu-nl.org/topic/9174

Als je dualboot met windows hebt, dan start hij ook traag, want hij moet elke keer de schijven chekken.

Over de foutmelding kan ik weinig vinden op internet, misschien help het om een keer alle pci-kaartjes en usb-apparten uit je PC te halen en opnieuw op te starten
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Dancel

  • Gast
Feisty fawn start erg traag op
« Reactie #2 Gepost op: 2007/05/09, 12:05:25 »
Ik heb idd dualboot. Het verhaal van PCI kaarten gaat voor mij niet op, want ik heb een laptop. Nadat ik m'n USB muisje dr uit getrokken heb (het enige USB apparaat), heb ik nog steeds die vastloper halverwege dat Oranje statusbalkje, naar anderhalve minuut start ie dan wel gewoon door.

Ik heb voor een tijdje terug Dapper ook getest, maar daar had ik dit probleem niet bij. Starte juist lekker vlot op.

Volgens mij kan het ook niet aan mn specs liggen:

Amilo Pi 1556 MN 30706,
Intel Core Duo T2300 1.66GHz,
120GB SATA,
1024 MB DDR2 533MHz,
NVidia GeForce Go 7600 256MB

Kan het wellicht ook worden veroorzaakt door een corrupte partitie?

Thnxs

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #3 Gepost op: 2007/05/09, 12:23:21 »
het zou kunnen liggen aan de herkenning/het herkennen van netwerkverbindingen/networkmanager. er is dan wel een oplossing voor dacht ik. je gebruikt feisty toch? ik dacht dat het oorspronkelijk een feisty-beta probleem was.
ik ga even zoeken op het forum.

Offline woteb

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #4 Gepost op: 2007/05/09, 12:25:52 »
Citaat van: Dancel
Ik heb idd dualboot. Het verhaal van PCI kaarten gaat voor mij niet op, want ik heb een laptop. Nadat ik m'n USB muisje dr uit getrokken heb (het enige USB apparaat), heb ik nog steeds die vastloper halverwege dat Oranje statusbalkje, naar anderhalve minuut start ie dan wel gewoon door.

Ik heb voor een tijdje terug Dapper ook getest, maar daar had ik dit probleem niet bij. Starte juist lekker vlot op.

Volgens mij kan het ook niet aan mn specs liggen:

Amilo Pi 1556 MN 30706,
Intel Core Duo T2300 1.66GHz,
120GB SATA,
1024 MB DDR2 533MHz,
NVidia GeForce Go 7600 256MB

Kan het wellicht ook worden veroorzaakt door een corrupte partitie?

Thnxs
Kijk eens even in je fstab (/etc/fstab). Dit kun je doen door in een terminal het volgende commando te geven:

sudo gedit /etc/fstab

Als je daar van die UUID(met-een-heleboel-getallen) ziet, dan kan dat de boosdoener zijn.

Er bestaat al een draadje voor een trage Feisty en wel hier: http://forum.ubuntu-nl.org/topic/10183

Daar zie je ook hoe je die fstab an kunt passen, misschien dat het helpt?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Feisty fawn start erg traag op
« Reactie #5 Gepost op: 2007/05/09, 13:02:01 »
Lees ook eens https://wiki.ubuntu.com/NlFstab

Succes,
Ron
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Dancel

  • Gast
Feisty fawn start erg traag op
« Reactie #6 Gepost op: 2007/05/09, 18:24:51 »
Citaat van: leoquant
het zou kunnen liggen aan de herkenning/het herkennen van netwerkverbindingen/networkmanager. er is dan wel een oplossing voor dacht ik. je gebruikt feisty toch? ik dacht dat het oorspronkelijk een feisty-beta probleem was.
ik ga even zoeken op het forum.
Ja ik gebruikt Feisty, gewoon de laatste versie. Ik zal vanavond gelijk even jullie suggesties na gaan, en jullie laten weten hoe het er dan voor staat.

Dancel

  • Gast
Feisty fawn start erg traag op
« Reactie #7 Gepost op: 2007/05/09, 19:40:44 »
Citaat van: woteb
Citaat van: Dancel
Ik heb idd dualboot. Het verhaal van PCI kaarten gaat voor mij niet op, want ik heb een laptop. Nadat ik m'n USB muisje dr uit getrokken heb (het enige USB apparaat), heb ik nog steeds die vastloper halverwege dat Oranje statusbalkje, naar anderhalve minuut start ie dan wel gewoon door.

Ik heb voor een tijdje terug Dapper ook getest, maar daar had ik dit probleem niet bij. Starte juist lekker vlot op.

Volgens mij kan het ook niet aan mn specs liggen:

Amilo Pi 1556 MN 30706,
Intel Core Duo T2300 1.66GHz,
120GB SATA,
1024 MB DDR2 533MHz,
NVidia GeForce Go 7600 256MB

Kan het wellicht ook worden veroorzaakt door een corrupte partitie?

Thnxs
Kijk eens even in je fstab (/etc/fstab). Dit kun je doen door in een terminal het volgende commando te geven:

sudo gedit /etc/fstab

Als je daar van die UUID(met-een-heleboel-getallen) ziet, dan kan dat de boosdoener zijn.

Er bestaat al een draadje voor een trage Feisty en wel hier: http://forum.ubuntu-nl.org/topic/10183

Daar zie je ook hoe je die fstab an kunt passen, misschien dat het helpt?
Als ik fstab doe, dan krijg ik de volgende melding:

# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
# /dev/sda2
UUID=8ccc074f-4016-4473-b78b-7f700ec5ade8 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda5
UUID=1103b5a7-2648-4b2f-8b92-060de59f0f92 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0

Voor mij als linux Newbie, zegt me deze melding niet zo heel erg veel. Zij jij (jullie) hier iets geks aan?

Alvast bedankt

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #8 Gepost op: 2007/05/09, 19:52:05 »
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/sda2 /               ext3    defaults,errors=remount-ro 0       1
/dev/sda5 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0

Dus gewoon de UUID=.... verwijderen en het # voor /dev/... weghalen, dan zou hij het moeten doen, maak wel eerst een backup

sudo cp /etc/fstab /etc/fstab_backup
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #9 Gepost op: 2007/05/09, 19:52:39 »
draadje woteb:
Citaat
Ik had dit soort geintjes laatst ook. Toen ik in een terminal 'top' draaide zag ik tot mijn verbazing dat er geen Swap partitie was. Nu blijkt dat in de fstab van Feisty ongeveer het volgende staat:

# /dev/hda3
UUID=353a37f4-0b17-422a-a630-4b82e3f984cb none            swap    sw              0       0

Dat heb ik veranderd in:

/dev/hda3 none            swap    sw              0       0

En voilá.... de swappartitie was er weer.

Zo heb ik de indruk dat met de originele fstab kennelijk de swappartitie af en toe onzichtbaar is, en daardoor raakt het geheugen helemaal dol. Waarom dit in Feisty is gedaan is mij een raadsel, maar probeer eens je fstab te veranderen zoals ik dat heb gedaan (zoals bij de oudere Ubuntu versies het geval was), misschien dat dit ook bij jullie helpt.
misschien heb je er wat aan. verder zou ik even wachten op het commentaar van woteb en/of ron. die hebben dit meer aan de hand gehad! ;)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #10 Gepost op: 2007/05/09, 19:53:20 »
@ronnie
sorry......

Dancel

  • Gast
Feisty fawn start erg traag op
« Reactie #11 Gepost op: 2007/05/09, 20:31:45 »
Citaat van: Ronnie
# /etc/fstab: static file system information.
#
#            
proc            /proc           proc    defaults        0       0
/dev/sda2 /               ext3    defaults,errors=remount-ro 0       1
/dev/sda5 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0

Dus gewoon de UUID=.... verwijderen en het # voor /dev/... weghalen, dan zou hij het moeten doen, maak wel eerst een backup

sudo cp /etc/fstab /etc/fstab_backup
Zucht............... heb die UUID troep eruit gehaald, opgeslagen, pc herstart, en nog steeds het zelfde probleem.
Hmmmm..... Zijn er nog eventuele andere oorzaken waaraan het zou kunnen liggen?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #12 Gepost op: 2007/05/09, 20:35:58 »
draadje pjotr123 betreft de beta van feisty:
Citaat
Er is een manier om de vertraging bij het opstarten van Feisty bèta, te verhelpen. Namelijk door een flink aantal regels in /etc/network/interfaces uit te commentariëren.
Als volgt (voorbeeld van mijn interfaces bestand):
Code:

auto lo
iface lo inet loopback

# auto eth0
# iface eth0 inet dhcp

# auto eth1
# iface eth1 inet dhcp

# auto eth2
# iface eth2 inet dhcp

# auto ath0
# iface ath0 inet dhcp

# auto wlan0
# iface wlan0 inet dhcp

Het uitcommentariëren van die regels heeft geen enkel nadelig effect, omdat Network Manager de netwerkkaarten sowieso al kan vinden. Let op: "lo" niet uitcommentariëren!

Werkt bij mij weer als een speer nu, een aanrader!


-toevoeging-
Het probleem waar het bovenstaande een oplossing voor biedt, bestaat waarschijnlijk niet meer, sinds een update van Feisty bèta van gisteravond (10-4).  Als je geen opstartvertraging hebt, pas mijn oplossing dan niet toe.

Offline woteb

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #13 Gepost op: 2007/05/09, 21:30:34 »
Citaat van: leoquant
draadje woteb:
Citaat
Ik had dit soort geintjes laatst ook. Toen ik in een terminal 'top' draaide zag ik tot mijn verbazing dat er geen Swap partitie was. Nu blijkt dat in de fstab van Feisty ongeveer het volgende staat:

# /dev/hda3
UUID=353a37f4-0b17-422a-a630-4b82e3f984cb none            swap    sw              0       0

Dat heb ik veranderd in:

/dev/hda3 none            swap    sw              0       0

En voilá.... de swappartitie was er weer.

Zo heb ik de indruk dat met de originele fstab kennelijk de swappartitie af en toe onzichtbaar is, en daardoor raakt het geheugen helemaal dol. Waarom dit in Feisty is gedaan is mij een raadsel, maar probeer eens je fstab te veranderen zoals ik dat heb gedaan (zoals bij de oudere Ubuntu versies het geval was), misschien dat dit ook bij jullie helpt.
misschien heb je er wat aan. verder zou ik even wachten op het commentaar van woteb en/of ron. die hebben dit meer aan de hand gehad! ;)
Ik had op een gegeven moment geen swappartitie meer (dankzij die UUID zaken) en middels het weghalen van die zaken wel. En zonder swappartitie werkt Ubuntu wel heel erg log.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Dancel

  • Gast
Feisty fawn start erg traag op
« Reactie #14 Gepost op: 2007/05/09, 21:35:41 »
Citaat van: leoquant
draadje pjotr123 betreft de beta van feisty:
Citaat
Er is een manier om de vertraging bij het opstarten van Feisty bèta, te verhelpen. Namelijk door een flink aantal regels in /etc/network/interfaces uit te commentariëren.
Als volgt (voorbeeld van mijn interfaces bestand):
Code:

auto lo
iface lo inet loopback

# auto eth0
# iface eth0 inet dhcp

# auto eth1
# iface eth1 inet dhcp

# auto eth2
# iface eth2 inet dhcp

# auto ath0
# iface ath0 inet dhcp

# auto wlan0
# iface wlan0 inet dhcp

Het uitcommentariëren van die regels heeft geen enkel nadelig effect, omdat Network Manager de netwerkkaarten sowieso al kan vinden. Let op: "lo" niet uitcommentariëren!

Werkt bij mij weer als een speer nu, een aanrader!


-toevoeging-
Het probleem waar het bovenstaande een oplossing voor biedt, bestaat waarschijnlijk niet meer, sinds een update van Feisty bèta van gisteravond (10-4).  Als je geen opstartvertraging hebt, pas mijn oplossing dan niet toe.
WIEEEEEJJJJJ........... Probleem opgelost :-D
Hij loopt nu als een trein!

Bedankt voor al jullie advies!

Offline woteb

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #15 Gepost op: 2007/05/09, 22:34:18 »
Als ik dit zo lees dan denk ik dat jouw systeem op een IP adres zat te wachten, dus aan het zoeken was naar een DHCP server. Dat kan een echte server zijn, maar ook broadband routers of accesspoints kunnen die adressen leveren. Wat ook een probleem kan zijn dat jij twee van dergelijke apparaten hebt die dan beiden proberen als DHCP server te werken.

Kun je jouw originele /etc/network/interfaces eens posten?
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)

Dancel

  • Gast
Feisty fawn start erg traag op
« Reactie #16 Gepost op: 2007/05/09, 22:53:03 »
Citaat van: woteb
Als ik dit zo lees dan denk ik dat jouw systeem op een IP adres zat te wachten, dus aan het zoeken was naar een DHCP server. Dat kan een echte server zijn, maar ook broadband routers of accesspoints kunnen die adressen leveren. Wat ook een probleem kan zijn dat jij twee van dergelijke apparaten hebt die dan beiden proberen als DHCP server te werken.

Kun je jouw originele /etc/network/interfaces eens posten?
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp



Eigenlijk precies zoals dat vb dat hierboven werd genoemd. Vreemd dat ie nu ineens wel doorstart. Dacht dat het een beta-bug was, die al was verholpen door een update.

Maar goed...... Hij loopt weer!! dus mij hoor je niet klagen

Offline woteb

  • Lid
  • Steunpunt: Nee
Feisty fawn start erg traag op
« Reactie #17 Gepost op: 2007/05/09, 23:19:12 »
Dit is die van mij:

===============================
auto lo
iface lo inet loopback

iface eth0 inet dhcp

auto eth0

iface wlan0 inet dhcp
wireless-essid WLAN
wireless-key 1234567890

auto wlan0
===============================

Je ziet dat dit zowel eth0 als wlan0 (met essid + wep-key) opstart. Ik neem aan dat jij niet zoveel interfaces hebt, gebruik alleen die je echt nodig hebt. Als je draadloos gebruikt, dan ook wlan, anders alleen eth0. De rest kun je dan zelfs verwijderen.
In jouw geval was jouw systeem met al die (niet bestaande) interfaces aan het vragen om een IP adres. Vandaar dat het zo lang duurde.
Laptop, HP 550, Dual Core 1 GB RAM/2 Ghz:: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie) Fluxbox / IceWM / XFCE4 / Openbox / LXDE.
3 Werkstations + 1 laptop: Debian 5.0 Testing (Squeeze)  (lite-blokkendoos editie Gnome/XFCE/IceWM)
Server: Debian 5.0 Stable (Lenny)