Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Fout bij installeren eid lezer.  (gelezen 515 keer)

Offline polrussel

  • Lid
  • Steunpunt: Nee
Fout bij installeren eid lezer.
« Gepost op: 2017/08/05, 17:03:55 »

Ik probeer al de hele dag voor de eerste keer mijn eid lezer in firefox aan de praat te krijgen. Ik heb de meest recente topic's hieromtrent reeds gelezen en uitgeprobeerd maar ik stoot keer op keer op deze foutmelding. Ik ben min of meer een leek.

"De volgende pakketten hebben niet-voldane vereisten:
 eid-viewer : Vereisten: libproxy1v5 (>= 0.4.14) maar 0.4.11-5ubuntu1 zal geïnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast."

Wat kan ik doen om deze melding weg te krijgen  en mijn eid lezer in firefox aan de praat te krijgen.
Reeds bij voorbaat bedankt.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #1 Gepost op: 2017/08/05, 17:11:01 »
Probeer eens dit te doen via de terminal (ctrl+alt+t)

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade -f
sudo apt-get autoremove
sudo apt-get clean

of

sudo dpkg --configure -a
« Laatst bewerkt op: 2017/08/05, 17:12:57 door maasnet »
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 16.04/Xubuntu 16.04/Ubuntu 17.10; RPI: Raspbian Jessie; Asus 1005PE: Q4OS; Linux Lite 3.4; W10
***Steunpunt Ede***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #2 Gepost op: 2017/08/05, 17:19:10 »
Ok gedaan wat je hebt beschreven, moet ik nu de installatie van de eid lezer opnieuw doen.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #3 Gepost op: 2017/08/05, 17:21:38 »
Probeer maar.

Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 16.04/Xubuntu 16.04/Ubuntu 17.10; RPI: Raspbian Jessie; Asus 1005PE: Q4OS; Linux Lite 3.4; W10
***Steunpunt Ede***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #4 Gepost op: 2017/08/05, 17:26:44 »
Anders kan je ook nog proberen Synaptic te installeren of wellicht heb je dat al gedaan.

In het tweede tabblad (bewerken) heb je een optie staan gebroken pakketten repareren dat kan je ook nog proberen.

Heb je dit ook gezien https://forum.ubuntu-nl.org/index.php?topic=96915.0 ?
« Laatst bewerkt op: 2017/08/05, 17:32:08 door maasnet »
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 16.04/Xubuntu 16.04/Ubuntu 17.10; RPI: Raspbian Jessie; Asus 1005PE: Q4OS; Linux Lite 3.4; W10
***Steunpunt Ede***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #5 Gepost op: 2017/08/05, 17:38:04 »
Bij "probeer maar", neen werkt niet. Ben terug gaan kijken in het terminalvenster en krijg dan terug dezelfde fout.
https://forum.ubuntu-nl.org/index.php?topic=96915.0 dit topic had ik gelezen en volledig uitgevoerd.
Synaptic is bij mij geinstalleerd en gebruik ik ook en had reeds "gebroken pakketten repareren" geprobeerd.
« Laatst bewerkt op: 2017/08/05, 17:41:16 door polrussel »

Offline swake

  • Lid
    • Webstek van Swake
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #6 Gepost op: 2017/08/05, 20:27:21 »
Gaat het om de Belgische eID lezer ?

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #7 Gepost op: 2017/08/05, 20:42:58 »
Ja, het is een vasco 905

Offline swake

  • Lid
    • Webstek van Swake
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #8 Gepost op: 2017/08/05, 20:50:39 »
Download het installatiebestand en voer het dan uit .

https://eid.belgium.be/nl/linux-eid-software-installatie

Open daarna een terminalvenster en voer opdrachten uit .

sudo apt update
sudo apt install eid-mw eid-viewer

De Add-on voor Firefox kun je via hier installeren .
https://addons.mozilla.org/en-US/firefox/search/?q=eID&appver=54.0&platform=linux

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #9 Gepost op: 2017/08/05, 21:00:12 »
Swake,

Bedankt voor de hulp.
Echter al deze stappen al enkele malen uitgevoerd maar telkens bij het commando "sudo apt install eid-mw eid-viewer" krijg ik te lezen
"De volgende pakketten hebben niet-voldane vereisten:
 eid-viewer : Vereisten: libproxy1v5 (>= 0.4.14) maar 0.4.11-5ubuntu1 zal geïnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast."
Ik heb vervolgens bij Synaptic pakketbeheer de "libproxy1v5" hersteld en ook nog eens opnieuw geïnstalleerd.

Offline swake

  • Lid
    • Webstek van Swake
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #10 Gepost op: 2017/08/05, 21:12:57 »
De site van de overheid is momenteel off line . Heb je daar het .deb bestand gedownload
eid-archive_2017.4_all.deb ?

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #11 Gepost op: 2017/08/05, 21:48:51 »
Ja vanmiddag

Offline swake

  • Lid
    • Webstek van Swake
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #12 Gepost op: 2017/08/05, 23:02:52 »
Als je het volgende commando invoert in de terminal, wat geeft dat voor resultaat
sudo apt-get check

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #13 Gepost op: 2017/08/06, 07:06:21 »
sudo apt-get check geeft als resultaat
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
Daarna nog eens geprobeerd met "sudo apt install eid-mw eid-viewer" en dit geeft dan
"Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen
dat u om een onmogelijke situatie gevraagd heeft, of, indien u
de distributie 'unstable' gebruikt, dat sommige benodigde pakketten nog gemaakt moeten worden of uit 'Incoming' verwijderd werden.
De volgende informatie kan misschien helpen de situatie op te lossen:

De volgende pakketten hebben niet-voldane vereisten:
 eid-viewer : Vereisten: libproxy1v5 (>= 0.4.14) maar 0.4.11-5ubuntu1 zal geïnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast."

Misschien kan ik best de volledige installatie verwijderen en terug blanco opnieuw beginnen.
« Laatst bewerkt op: 2017/08/06, 07:54:53 door polrussel »

Offline swake

  • Lid
    • Webstek van Swake
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #14 Gepost op: 2017/08/06, 10:40:03 »
Citaat
Misschien kan ik best de volledige installatie verwijderen en terug blanco opnieuw beginnen.

Een slecht idee is dat niet . Download dan ook eens opnieuw het .deb bestand .

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #15 Gepost op: 2017/08/06, 11:13:54 »
Gewoon verwijderen lukt wel maar is dan ook alles weg. Moet ik in het terminalvenster ook nog iets in geven zodat werkelijk alle bestanden verdwenen of verwijderd zijn.
Ik heb dus blijkbaar een probleem in synaptic pakketbeheer. Het pakket "eid-viewer" was niet geïnstalleerd, wanneer ik dit wil markeren voor installatie komt er een verbodsteken en de tekst die je ook ziet in het terminalvenster namelijk "Vereisten: libeidviewer0 maar het zal niet worden geïnstalleerd
  Vereisten:libproxy1v5 (>=0.4.14) maar 0.4.11-5ubuntu1 wordt geïnstalleerd
Pakket kan dus niet hersteld worden, verwijderd worden of wat dan ook. Dus nu zit ik vast, suggesties welkom.
« Laatst bewerkt op: 2017/08/06, 14:38:33 door polrussel »

Offline swake

  • Lid
    • Webstek van Swake
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #16 Gepost op: 2017/08/06, 23:53:23 »
Citaat
Moet ik in het terminalvenster ook nog iets in geven zodat werkelijk alle bestanden verdwenen of verwijderd zijn.

Met deze opdracht zal het pakket en bijhorende configuratiebestanden verwijdert worden .

sudo apt-get purge eid-archive

Ik veronderstel dat je het .deb bestand gedownload hebt naar je map downloads . Probeer eens deze manier .
Type in de terminal
sudo dpkg -i Downloads/eid-archive_2017.4_all.deb
sudo apt update
sudo apt install eid-mw eid-viewer
De Add-on voor Firefox kun je via hier installeren .
https://addons.mozilla.org/en-US/firefox/search/?q=eID&appver=54.0&platform=linux


Ik weet niet welke distro je juist gebruikt maar in Linux Mint vind ik de eID kaartlezer terug onder Toepassingen >> Hulpmiddelen .
« Laatst bewerkt op: 2017/08/06, 23:58:32 door swake »

Offline spievensterke

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #17 Gepost op: 2017/08/07, 13:28:19 »
@ polrussel,

ga als volgt te werk:
Open de terminal:

sudo dpkg -i Downloads/eid-archive_2017.2_all.deb      ---> of:       sudo dpkg -i Downloads/eid-archive_2017.4_all.deb
sudo apt update
sudo apt install eid-mw eid-viewer

Selecteer, kopiëer en plak de bovenstaande regels, regel per regel, in de terminal --- daarna terminal sluiten.
Sluit computer af.

Plug de eid-viewer in.

Herstart de computer.

Open synapticpakketbeheer:  herladen > alle opwaarderingen markeren > en je ziet eid-archive_2017.2_all.deb in de lijst staan , ervoor zal een blokje staan met een pijl die naar boven wijst = je moet deze dus nog opwaarderen (= naar:  eid-archive_2017.4_all.deb) --> je kan ook proberen om deze eid-archive_2017.4_all.deb ook in de terminal te gebruiken -- dan zal je niet meer moeten opwaarderen ??? __>**dit wilde in eerste instantie niet lukken bij mij ---> proberen maar..., ook eid-mw en eid-viewer zie je staan met een groen blokje ervoor = geïnstalleerd;
 --> voer dit opwaarderen uit en sluit dan synapticpakketbeheer.

Herstart de computer opnieuw op met de kaartlezer ingeplugd.

Open de eid viewer en voer uw ID-kaart in -- controleer de pincode (ID) door die in te voeren. Klik op valideren certificaten.
----->  Afb.:1,2,3

Sluit de viewer maar laat uw ID-kaart zitten.

Open Firefox: ga naar >  Voorkeuren > Geavanceerd > Certificaten > Certificaten bekijken en zoek in de lijst naar:

- Belgiium Root CA2 --> klik op vertrouwen bewerken en zet de drie vinkjes > klik op OK.
- Citizen CA --> klik op vertrouwen bewerken en zet de drie vinkjes > klik op OK.   ----> Afb.5,6
Bij (Firefox) extenties, ziet je dat eIDBelgium enable staat = OK. (daar moet je niks mee doen) ---> Afb.:4

Nu kan je naar de website van de Federale Overheid (België) --> je moet wel nog een veiligheidsvraag doorworstelen en pincode ingeven.

Succes.
Daarnet, heb ik bovenstaande getest en het werkt, bij mij - onder Ubuntu 16.04.2 LTS -64bit-, perfect.

Groet,
spievensterke.
















« Laatst bewerkt op: 2017/08/07, 14:31:42 door spievensterke »
Testlaptop Toshiba Satellite L500-1C7 - Ubuntu Maté 16.04.2 LTS -64bit- in dualboot met LinuxMint Maté 18.1 -64bit-   Hdd 250GB  Intel Mobile Video /
AcerOne10  ( Hybride, 2 in 1 ) met Ubuntu 16.04.3 LTS -64bit- 32bit Uefi.

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #18 Gepost op: 2017/08/07, 19:38:38 »
@swake

bij het commando: sudo apt-get purge eid-archive geeft dit onderstaande als resultaat.



Wanneer ik in synaptic het pakket eid-viewer selecteer en markeer voor installatie (dat is het enige dat je kan aanduiden) dan krijg je dit en zit ik wederom vast.



Er zit blijkbaar toch iets fout want ik kan de eid-viewer dus ook niet verwijderen, niet in synaptic en ook niet via het terminalvenster.

@spievensterke
Alvast bedankt voor je hulp maar ook via uw weg lukt het me niet.

Offline spievensterke

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #19 Gepost op: 2017/08/07, 20:58:18 »
@ polrussel,

Jou Ubuntu-installatie is vervuild en ik denk dat die niet meer te redden is.
Uitvoeren van een volledig nieuwe installatie is de weg van de 'korte pijn'...

- Voer een volledig nieuwe installatie van Ubuntu 16.04.2 LTS 64-bit uit. Gebruik de gehele Hdd en laat alles over aan de installatiehelper.
- Vergeet niet om de extra's mee te installeren, aan het begin van de installatieprocedure.

- Dan de volledige updates te doen via updatebeheer.
- Het systeem te herstarten.
- Download dan de software voor de eid --> eid-archive_2017.2_all.deb van de website:  https://eid.belgium.be/nl  *download voor Linux*

**  De stappen om de kaartlezer aan de praat te krijgen:
---> stap voor stap uitvoeren zoals ik die heb beschreven en geen andere software downloaden ( = absoluut niet nodig!) of installeren.

Dit zou dan wel goed en werkend moeten zijn. Bericht ons.

Groet,
spievensterke.

« Laatst bewerkt op: 2017/08/07, 21:04:49 door spievensterke »
Testlaptop Toshiba Satellite L500-1C7 - Ubuntu Maté 16.04.2 LTS -64bit- in dualboot met LinuxMint Maté 18.1 -64bit-   Hdd 250GB  Intel Mobile Video /
AcerOne10  ( Hybride, 2 in 1 ) met Ubuntu 16.04.3 LTS -64bit- 32bit Uefi.

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #20 Gepost op: 2017/08/08, 13:50:43 »
Jou Ubuntu-installatie is vervuild en ik denk dat die niet meer te redden is.
Eerst wat beter informeren voor je zo'n advies geeft!

Niet kunnen vergrendelen is zo goed als altijd het gevolg van een ander programma wat de software bronnen in gebruik heeft. Staat synaptic open? Is er een update gaande? Dan krijg je ook dit resultaat.

De afhankelijkheden kunnen zo goed als altijd met wat zoeken worden opgelost.

Offline spievensterke

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #21 Gepost op: 2017/08/08, 14:05:57 »
@ Nero,

ik denk dat TPS polrussel toch beter een volledig nieuwe Ubuntu-installatie uitvoert. De tijd dat hij nu aan zijn probleem kwijt is kan beter besteed worden aan een herinstallatie, maar dan goed.

Ik beweer daarbij niet, dat polrussel er, als beginneling, niets zou uit leren, integendeel...

Groet,
spievensterke.
« Laatst bewerkt op: 2017/08/08, 14:07:55 door spievensterke »
Testlaptop Toshiba Satellite L500-1C7 - Ubuntu Maté 16.04.2 LTS -64bit- in dualboot met LinuxMint Maté 18.1 -64bit-   Hdd 250GB  Intel Mobile Video /
AcerOne10  ( Hybride, 2 in 1 ) met Ubuntu 16.04.3 LTS -64bit- 32bit Uefi.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: Fout bij installeren eid lezer.
« Reactie #22 Gepost op: 2017/08/08, 14:13:34 »
@ Nero,

ik denk dat TPS polrussel toch beter een volledig nieuwe Ubuntu-installatie uitvoert. De tijd dat hij nu aan zijn probleem kwijt is kan beter besteed worden aan een herinstallatie, maar dan goed.

Ik beweer daarbij niet, dat polrussel er, als beginneling, niets zou uit leren, integendeel...

Groet,
spievensterke.
Met daarbij wel het risico dat hij weer op hetzelfde punt (lees: afhankelijkheden)  belandt.
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu 16.04/Xubuntu 16.04/Ubuntu 17.10; RPI: Raspbian Jessie; Asus 1005PE: Q4OS; Linux Lite 3.4; W10
***Steunpunt Ede***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline spievensterke

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #23 Gepost op: 2017/08/08, 14:35:30 »
@ maasnet,

jij schrijft:

Citaat
Met daarbij wel het risico dat hij weer op hetzelfde punt (lees: afhankelijkheden)  belandt.

Ik heb dit, gisteren, volledig zelf nieuw geïnstalleerd (Ubuntu 16.04.2 LTS-64bit-) met de eid software, zoals ik beschreven heb.
Dit heb ik dan volledig getest/uitgeprobeerd vóór ik hierover ook maar enig woord geschreven had.
Ik heb géén afhankelijkheden moeten installeren .... ??? dat is ook niet meer nodig. Ik stel dit vast, blijkbaar is er in de software een en ander verbetert zodat dit nu beter werkt...

[ Bij de distro PCLinuxOS is het zelfs niet meer nodig om de eid-software te downloaden -- bij het installeren van eid-mw en eid-viewer ( via de synaptic) worden alle benodigde afhankelijkheden erin mee genomen, de eid-middlewaere wordt direct in Firefox gezet -- je moet het wel nog installeren, maar dat heeft 2sec. nodig, en dat is het. Het werkt perfect. ]

Dit is mijn persoonlijke mening, conclusie en de realiteit van wat ik vast stel (de dingen liegen niet).

Terug naar het probleem...

Groet,
spievensterke.
« Laatst bewerkt op: 2017/08/08, 15:17:08 door spievensterke »
Testlaptop Toshiba Satellite L500-1C7 - Ubuntu Maté 16.04.2 LTS -64bit- in dualboot met LinuxMint Maté 18.1 -64bit-   Hdd 250GB  Intel Mobile Video /
AcerOne10  ( Hybride, 2 in 1 ) met Ubuntu 16.04.3 LTS -64bit- 32bit Uefi.

Offline polrussel

  • Lid
  • Steunpunt: Nee
Re: Fout bij installeren eid lezer.
« Reactie #24 Gepost op: 2017/08/09, 16:53:44 »
Ondertussen druk bezig geweest met een zo volledig mogelijke back-up te maken en daarna ubuntu 16.04 terug te installeren van nul. Veel bijgeleerd en het is me gelukt. Daarna de EID lezer en nodige software geïnstalleerd volgens het schema van spievensterke en wederom alles gelukt. Dus nu is alles terug in orde en we zijn zeer tevreden.
Aan iedereen die meegedacht en hulpvaardig is geweest met de nodige suggesties een zeer gemeende dankuwel  :laugh:.
Topic mag, wat mij betreft, gesloten worden.