Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Intel problemen met kernel 4.9  (gelezen 791 keer)

Offline h2o

  • Lid
  • Steunpunt: Nee
Intel problemen met kernel 4.9
« Gepost op: 2017/07/12, 09:15:50 »
Sinds kort ben ik bezig met de upgrade van Debian Jessie naar Stretch. Als ik de Live-DVD start en uitprobeer dan gaat alles keurig netjes. Start vlot op en alles werkt vloeiend.
Wanneer ik het installeer op de testlaptop dan gaat de installatie ook probleemloos.
En dan....

Het opstarten gaat ineens heel traag. Het lijkt wel of het systeem ergens op wacht en opeens in een fractie van een seconde een soort kerneldump waarna het opstarten verder gaat. Na ongeveer twee minuten kan ik gaan inloggen. En ook dat duurt veel te lang in vergelijking met Jessie en de Live-DVD. Ook nu moet ik ongeveer twee minuten wachten.

Ik heb Grub aangepast en quiet enz. weggehaald zodat ik het opstartproces kan volgen, maar alles lijkt prima te verlopen, behalve dat het scherm wel vier keer zo'n 10 seconden op zwart gaat en dan weer verder boot.

Ik ben erachter gekomen dat dit kennelijk te maken heeft met mijn Intel kaart van het type i915.
Booten met de parameter i915.enable_rc6=0 haalt niets uit en als ik boot met i915.modeset=0 dan start het systeem op in vesa mode.

Het maakt niet uit of ik een dist-upgrade doe of een verse installatie.

Als ik op dezelfde laptops met MX-16 draai met kernel 4.7.8 dan gaat dat prima.
Iemand enig idee hoe ik normaal met kernel 4.9 kan werken?
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #1 Gepost op: 2017/07/12, 10:26:27 »
Als het een dualboot installatie is controleer dan het UUID van de swap partitie.
sudo blkidControleer of dit UUID overeenkomt met het UUID van de swap partitie in:  /etc/fstab
Als dat niet zo is moet je dat aanpassen onder root.
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #2 Gepost op: 2017/07/12, 10:48:21 »
Bedankt voor het meedenken
Het is geen dualboot en ik gebruik standaard labels waaronder swap
Citaat
# swap was on /dev/sda3 during installation
LABEL=swap none            swap    sw              0       0
Jij doelt kennelijk op de fout dat Swap niet kan worden benaderd. Dat is het dus niet.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #3 Gepost op: 2017/07/12, 16:09:56 »
Hier wat meer gegevens:
Citaat
inxi -G
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: X.org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           tty size: 80x24 Advanced Data: N/A for root

Citaat
CScreen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
LVDS-1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800      59.91*+
   1024x768      60.04    60.00 
   960x720       60.00 
   928x696       60.05 
   896x672       60.01 
   960x600       60.00 
   960x540       59.99 
   800x600       60.00    60.32    56.25 
   840x525       60.01    59.88 
   800x512       60.17 
   700x525       59.98 
   640x512       60.02 
   720x450       59.89 
   640x480       60.00    59.94 
   680x384       59.80    59.96 
   576x432       60.06 
   512x384       60.00 
   400x300       60.32    56.34 
   320x240       60.05 
VGA-1 disconnected (normal left inverted right x axis y axis)
SVIDEO-1 disconnected (normal left inverted right x axis y axis)
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #4 Gepost op: 2017/07/12, 21:09:45 »
Probeer eens de:
 sudo apt-get install xserver-xorg-video-intelEn dan opnieuw opstarten.
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #5 Gepost op: 2017/07/13, 18:36:24 »
Probeer eens de:
 sudo apt-get install xserver-xorg-video-intelEn dan opnieuw opstarten.
Heb ik gedaan, het resultaat blijft hetzelfde. Ik heb nog even gebuurt bij de Arch-familie en er Antergos op gezet. Daar hebben ze kernel 4.11 en ondervind ik het probleem net.
Ook MX-16(Debian Jessie gebaseerd) met kernel 4.7 doet niet moeilijk.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #6 Gepost op: 2017/07/13, 21:23:49 »
Tja, dan is het mss even wachten tot een kernel update.
Sorry dat ik je niet verder kan helpen.
Succes verder!
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #7 Gepost op: 2017/07/14, 16:01:03 »
@h20,
Hier heb ik misschien een oplossing voor jouw probleem, met een aanpassing in het grub bestand:
https://bbs.archlinux.org/viewtopic.php?id=218581&p=3
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #8 Gepost op: 2017/07/14, 19:13:27 »
Bedankt Pederoco, ik zal er naar gaan kijken als ik weer thuis ben. Vandaag op vakantie naar Drenthe en alleen goed werkend spul meegenomen. Overigens ook een HP550 wat in jouw link staat, maar dan met een drievoudig systeem (Debian Jessie, LMDE-2 en MX-16).
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #9 Gepost op: 2017/07/14, 20:16:54 »
Fijne vakantie dan maar!
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #10 Gepost op: 2017/07/22, 22:23:07 »
Goed nieuws. Na heel wat heen en weer configureren en testen werkt nu het volgende:
Citaat
GRUB_CMDLINE_LINUX_DEFAULT="video=SVIDEO-1:d noacpi"
Op dit moment start mijn werklaptop (HP 6710b) met een test harde schijf probleemloos op.

Wordt vervolgd...
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline h2o

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #11 Gepost op: 2017/07/26, 10:23:29 »
Ik heb intussen heel wat test-installaties uitgevoerd (op meerdere 'probleem' laptops) en de toevoeging video=SVIDEO-1:d noacpi werkt prima. Alles start nu normaal op zoals ik gewend ben.

Probleem opgelost!! Bedankt voor het meedenken en de link.
Laptops + werkstations: Debian Stable + backports, server Debian Stable.
Test-laptop: Debian Tesing/Unstable

Offline pederoco

  • Lid
  • Steunpunt: Nee
Re: Intel problemen met kernel 4.9
« Reactie #12 Gepost op: 2017/07/26, 10:56:28 »
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."