Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon  (gelezen 202 keer)

Offline wowo

  • Lid
  • Steunpunt: Nee
In Ubuntu 14.04 werkte alles goed maar nu ik met mijn hoofdsysteem eindelijk overgeschakeld ben naar Ubuntu 16.04 loop ik tegen het volgende probleem aan:
Als ik een koptelefoon in plug dan blijft er ook geluid komen uit mijn luidspreker. De luidspreker wordt niet automatisch gedempt.
Wat hopelijk relevante info:
lsmod | grep snd
snd_hda_codec_hdmi     45056  1
snd_hda_codec_realtek    86016  1
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          36864  3
snd_hda_codec         135168  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           86016  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               110592  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    86016  17 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd
locate snd-hda-intel
/lib/modules/4.8.0-36-generic/kernel/sound/pci/hda/snd-hda-intel.ko
/lib/modules/4.8.0-54-generic/kernel/sound/pci/hda/snd-hda-intel.ko
lspci -vvnn -s 00:1b
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
Subsystem: Gigabyte Technology Co., Ltd 7 Series/C210 Series Chipset Family High Definition Audio Controller [1458:a002]
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 31
Region 0: Memory at f7e10000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
cat /proc/asound/pcm
00-00: ALC887-VD Analog : ALC887-VD Analog : playback 1 : capture 1
00-01: ALC887-VD Digital : ALC887-VD Digital : playback 1
00-02: ALC887-VD Alt Analog : ALC887-VD Alt Analog : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1
dmesg | grep -i audio
[    1.996550] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[    1.996552] snd_hda_codec_realtek hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    1.996553] snd_hda_codec_realtek hdaudioC0D2:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    1.996554] snd_hda_codec_realtek hdaudioC0D2:    mono: mono_out=0x0
[    1.996555] snd_hda_codec_realtek hdaudioC0D2:    dig-out=0x11/0x0
[    1.996556] snd_hda_codec_realtek hdaudioC0D2:    inputs:
[    1.996558] snd_hda_codec_realtek hdaudioC0D2:      Rear Mic=0x18
[    1.996559] snd_hda_codec_realtek hdaudioC0D2:      Front Mic=0x19
[    1.996560] snd_hda_codec_realtek hdaudioC0D2:      Line=0x1a
[    1.996561] snd_hda_codec_realtek hdaudioC0D2:      CD=0x1c
[    2.014384] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Op het internet heb ik wel al verscheidene geluidsproblemen gezien met Ubuntu 16.04 maar ik heb zelf nog geen oplossing kunnen vinden (ps ik kan natuurlijk wel handmatig de speakerboxen uitzetten maar het moet toch eigenlijk gewoon automatisch kunnen)
Desktop Ubuntu 16.04 LTS

Offline peer

  • Lid
  • Steunpunt: Nee
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #1 Gepost op: 2017/06/15, 11:24:51 »
is dit geen hardwareprobleem??

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #2 Gepost op: 2017/06/15, 13:24:06 »
Is waarschijnlijk een probleem met de drivers en die hebben weer te maken met hardware.
Ooit heb ik ook een probleem gehad met geluid en toen moest ik iets in een conf bestand van de driver softwarematig aanpassen.
Als de moderator vindt dat dit onder een ander kopje valt vind ik dat ook prima, maar het probleem zou ik toch graag opgelost hebben. ;)
Desktop Ubuntu 16.04 LTS

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #3 Gepost op: 2017/06/15, 19:24:38 »
Hoi wowo,

Deze geluidskaart heeft heel veel varianten. Dat in een nieuwe release dan wat mis gaat heb ik vaker gezien. Heb je nog ergens 14.04 draaien waarbij je het kan afkijken? Of een live sessie starten? Ik ziet nu op de tablet. De plek waar je dit neerzet is apart bij Ubuntu.

Groet,

Just
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #4 Gepost op: 2017/06/15, 20:18:16 »
Jammer genoeg (maar ook wel gelukkig) ben ik nu met al mijn computers overgestapt naar Ubuntu 16.04.
Ik ga proberen als ik er tijd voor heb om te kijken of het met een virtuele (ik maak gebruik van Virtalbox Oracle) ubuntu 14.04 wel lukt. Nee heb je, ja kan je altijd krijgen.
Desktop Ubuntu 16.04 LTS

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #5 Gepost op: 2017/06/15, 21:00:37 »
Hoi wowo,

Het bestand wat je moet aanpassen is /etc/.modprobe.d/alsa-base.conf.

Probeer als laatste regel daar eens:

options snd_hda_intel model=auto position_fix=3
Ben benieuwd.

groet,

Just
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #6 Gepost op: 2017/06/15, 21:28:44 »
Ik heb de regel:
options snd_hda_intel model=auto position_fix=3Toegevoegd als laatste regel maar dat had geen enkel effect.
Het alsa-base.conf ziet er bij mij nu als volgt uit:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd_hda_intel model=auto position_fix=3
Desktop Ubuntu 16.04 LTS

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #7 Gepost op: 2017/06/15, 21:39:08 »
Hoi wowo,

Ik wist waarnaar ik zoeken moest, maar geen van de gevonden oplossingen leek me echt specifiek raak. Probeer eventueel nog eens

options snd_hda_intel model=generic
Dat lijkt me net zo weinig kans maken, maar ik kwam hem wel meer tegen en met een successtory erbij.

groet,

Just
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #8 Gepost op: 2017/06/15, 22:07:17 »
Dat zal ik zo proberen.
Ik heb het probleem niet helemaal goed omschreven merk ik nu.
Als ik naar geluidsinstellingen ga bij Ubuntu zie je bij mij het volgende staan (zie afbeelding).
Op dat moment komt er geluid uit mijn speakers.
Wanneer vervolgens mijn koptelefoon in deze desktop in plug, blijft het geluid uit de speakers komen terwijl er geen geluid komt uit de koptelefoon.
Wanneer ik vervolgens bij de geluidsinstellingen op "Analoge koptelefoon" klik, komt er zowel geluid uit mijn koptelefoon als uit mijn speakers. Rara.
Desktop Ubuntu 16.04 LTS

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #9 Gepost op: 2017/06/15, 22:21:10 »
Hoi wowo,

Dat had ik zo wel goed begrepen. In de beschreven situatie met je schermprint, als je dan bij je koptelefoon kijkt, dan zou daar "unplugged"moeten staan. Als je hem dan erin prikt moet de situatie meteen veranderen. Dat doet jij dan naar ik aanneem niet?

groet,

Just
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #10 Gepost op: 2017/06/15, 22:25:34 »
Eureka! Met de regel:
options snd_hda_intel model=genericGaat alles goed.
Nu zien de afbeeldingen bij geluidsinstellingen er wat anders uit.
Zonder de fix stond er bij Geluid afspelen via altijd:
HDMI / Displayport Intern geluid
Digital Output (S/PDIF) intern geluid
Analoge koptelefoon intern geluid
Line Out intern geluid

Na de fix:
Wanneer ik alleen de speakers aan heb en geen koptelefoon in geplugged:
HDMI / Displayport Intern geluid
Digital Output (S/PDIF) intern geluid
Line Out intern geluid

Wanneer ik vervolgens de koptelefoon in plug, schakelen de speakers uit en zie ik:
HDMI / Displayport Intern geluid
Digital Output (S/PDIF) intern geluid
Analoge koptelefoon intern geluid

Volgens mij moet het ook zo werken.
Desktop Ubuntu 16.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #11 Gepost op: 2017/06/15, 23:02:40 »
@just Nogmaals bedankt voor je snelle hulp.
Desktop Ubuntu 16.04 LTS

Offline jvecht

  • Lid
    • Just Vecht
  • Steunpunt: Ja
Re: Speakergeluid niet automatisch uitgeschakeld bij in pluggen koptelefoon
« Reactie #12 Gepost op: 2017/06/15, 23:10:00 »
Hoi wowo,

Toch wel dat generic  :) .

Graag gedaan hoor. Het is dat ik dit gebeuren al eens uitgebreid heb mogen ervaren. Ik wist in welke hoek het moest zitten. De rest was zoeken en wat geluk.

Fijn dat je er nu uit bent!

groet,

Just
GIMP bundel 2017  25 cursussen met geweldig mooi oefenmateriaal. Lekker lezen of er wat van opsteken!
  Boekje "Werken met Xubuntu" 4000+ downloads!
     Het Helpmij Magazine November 2017