Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu Gnome Network Manager and USB WIFI devices [SOLVED]  (gelezen 569 keer)

Offline Geert Jalink

  • Lid
  • Steunpunt: Nee
Ubuntu Gnome Network Manager and USB WIFI devices [SOLVED]
« Gepost op: 2017/04/13, 22:37:30 »
This message is in 2 languages, first in English. It is on a clean installation that needs a network connection by using a USB Wifi Card for Ubuntu Zesty Zapus 17.04 or Ubuntu Gnome Zesty Zapus since I think Kubuntu has an entirely different network manager. Many people seem to unfortunately have this problem since today Ubuntu 17.04 was just released people might find a possible solution described here.

user@dv9700-gnome:~$ uname -a
Linux dv9700-gnome 4.10.0-19-generic #21-Ubuntu SMP Thu Apr 6 17:04:57 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

user@dv9700-gnome:~$ lsusb
Bus 002 Device 003: ID 064e:a110 Suyin Corp. HP Webcam
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 1ea7:0066 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 148f:2770 Ralink Technology, Corp. RT2770 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 0a5c:2101 Broadcom Corp. BCM2045 Bluetooth
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
user@dv9700-gnome:~$

user@dv9700-gnome:~$ lsmod|grep usb
rt2800usb              28672  0
rt2x00usb              20480  1 rt2800usb
rt2800lib              94208  1 rt2800usb
rt2x00lib              53248  3 rt2800lib,rt2800usb,rt2x00usb
mac80211              782336  3 rt2800lib,rt2x00lib,rt2x00usb
btusb                  45056  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
bluetooth             557056  31 btrtl,btintel,bnep,btbcm,rfcomm,btusb
usbhid                 53248  0
hid                   114688  2 hid_generic,usbhid
I have a Ralink RT2770 Chipset with rt2800usb as a driver. However on Ubuntu 17.04 in my case Ubuntu Gnome 17.04 and maybe other people with Ubuntu Unity 17.04 have the same problem that USB Wifi devices do not connect properly to a Router over Wifi with the built in Network Manager.

You might first think it is a problem in kernel 4.10 that came shipped with Ubuntu 17.04, however I tried a release candidate kernel 4.11rc6 and it still did not work.

Now you might wonder how simple could it be to solve this problem?

Well it is as simple as written below, but it took me hours to find out. The only thing you have to do is in the very tiny code below and reboot your computer and it should work. However I noticed PCI Wifi cards usually do not need it, but USB Wifi cards probably do. What I believe the problem is, is that somehow USB Wifi Cards become in PROMISCUOUS mode, a term well known which means rapidly changing channels and scan on a channel, and that must be disabled.

##### in /etc/NetworkManager/NetworkManager.conf #####
##### Ubuntu (Gnome 17.04) add code below save and reboot #####

[device]
wifi.scan-rand-mac-address=0


End of message in English
---------------------------------------------------------

In het Nederlands, na de installatie moet je met je terminal gaan naar de map
/etc/NetworkManager/
Daar in die map moet je met sudo NetworkManger.conf aanpassen
cd /etc/NetworkManager
sudo cp NetworkManager.conf NetworkManager.conf.backup
sudo gedit NetworkManager.conf

##### in /etc/NetworkManager/NetworkManager.conf #####
##### Ubuntu (Gnome 17.04) add code below save and reboot #####

[device]
wifi.scan-rand-mac-address=0
Daarna zou de promiscuiteit van de USB Wifi Adapter opgelost moeten zijn, het probleem lijkt te zijn dat de USB Wifi adapter razendsnel van kanaal wisselt en zich niet focust op 1 kanaal.

Voor mij werkt het op 2.4 GHz en 5 GHz verbindingen. Ik heb dus een Wifi Adapter nodig om gesloten stuurprogramma's te installeren op een laptop, daarna werkt ironisch genoeg de ingebouwde gesloten broncode Wifi kaart die op de PCI bus zit wel. Voor PCI Wifi heb ik deze code nog niet nodig gehad. Echter USB Wifi kaartjes werkten niet zonder deze kleine aanvulling, slechts 2 regels code in het juiste bestand en het was opgelost, maar het was uren om uit te zoeken. Ik hoop dat iemand er wat aan heeft.

Tot de tijd dat Ubuntu 17.10 uitkomt is het ook voor mijzelf handig als ik dit bericht terug vind want ik neem aan dat in die toekomstige versie dit subtiel probleem is opgelost. Immers het heeft altijd gewerkt in het verleden.
« Laatst bewerkt op: 2017/04/13, 22:48:22 door Geert Jalink »
motion@home:~$ sudo apt-get install steam

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Re: Ubuntu Gnome Network Manager and USB WIFI devices [SOLVED]
« Reactie #1 Gepost op: 2017/04/30, 17:01:40 »
Dit mag wel weer even onder de aandacht worden gebracht. Ik zou willen dat ik dit eerder had gelezen want dat zou me wat tijd hebben bespaard ;) Bedankt alsnog voor de tip. Heb zelfs een andere wifi dongle geprobeerd maar zelfde resultaat. Was inderdaad een kwestie van één regel twee regeltjes toevoegen aan  /etc/NetworkManager/NetworkManager.conf maar kom er maar eens op.
« Laatst bewerkt op: 2017/04/30, 19:59:48 door erik1984 »

Offline Geert Jalink

  • Lid
  • Steunpunt: Nee
Re: Ubuntu Gnome Network Manager and USB WIFI devices [SOLVED]
« Reactie #2 Gepost op: 2017/05/13, 00:51:14 »
Ik ben doordat ik dit probleem ervaarde achter nog veel meer zaken gekomen. Ik had altijd problemen dat een verbinding wel werkte, maar ik vermoede dat het met Powersafe mode te maken had. Echter wist ik toen niet hoe ik Powersafe mode altijd uit kon schakelen. Met sudo iwconfig wlan0 power off kon ik wel tijdelijk steeds Powersafe uitzetten. En dan werkte de verbinding zeker op 5 GigaHerz heel stabiel. Maar als ik de laptop in standby zette was helaas Powersafe mode weer ingeschakeld.

Het geheim van al mijn Wifi problemen bleek al die tijd allemaal in juist ja /etc/NetworkManager directory te zitten. Er is namelijk nog een configuratie bestandje iets verderop.

in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf moest ik een kleine aanpassing doen om standaard Powersafe mode uit te zetten voor een stabiele verbinding. Het is niet via de grafische userinterface in te stellen.

To turn off power management, go to /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and you will see

[connection]
wifi.powersave = 3
Change the 3 to a 2 and reboot.

Then run iwconfig and if it worked you should see Power Management:off.

Uitvoer na iedere reboot of bij uit standby/suspend-to-ram, maakt me blij, eindelijk erachter gekomen waarom ik ooit slechte verbinding had.
user@HP-Pavilion-dv9700:~$ iwconfig
wlan0  IEEE 802.11  ESSID:"Puppie" 
          Mode:Managed  Frequency:5.2 GHz  Access Point: 12:34:56:78:90:AB 
          Bit Rate=108 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=51/70  Signal level=-59 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:112   Missed beacon:0

Kijk, ik haal nu strak 70 MegaBit met uploaden over meerdere verdiepingen op 5 GigaHerz, maar belangrijker geen stotteringen meer, geen problemen meer bij uit standby/suspend, dus eigenlijk hoef ik alleen nog te rebooten als ik een update heb geinstalleerd die een reboot vereist, en dat is eindelijk wanneer ik het wil. Zoals je ziet in de uitvoer van 'iwconfig', staat er: 'Power Management:off' wat vergelijkbaar is met 'Maximale Prestaties' voor Draadloos Netwerk bij energie beheer in Microsoft Windows.

Veel tweaks zitten er op wifi gebied dus in die directory, maar je moet maar net precies weten welke waarde. Deze tweak schrijf ik bij dit topic, omdat ik na iedere installatie deze tweak zeker weer opnieuw ga doen, het voorkomt zoveel problemen, altijd het vermoeden gehad dat iets simpels de oplossing was, en het was gewoon een 3 in een 2 veranderen. Ooh en ik weet niet waarom, maar ik haal precies 50 MegaBit down, maar ik moet dan wel zeggen dat ik met speedtest(dot)net test. Intern netwerk is beter om maximale snelheid te testen. Maar het verschil is gewoon door die 3 een 2 te maken dat ik zolang ik wil de laptop in suspend/standby kan zetten, en dankzij groot, eindelijk niet meer steeds hoef te rebooten want zelfs connectie problemen setup na een standby zijn verleden tijd.

Verder vermoed ik dat iedere distributie allemaal dezelfde /etc/NetworkManager configuratie bestanden gebruikt, maar dan default na een verse installatie net iets verschillend geconfigureerd. Eigenlijk zou er een zeer mooi Wifi Tweak programma moeten komen en alles wat het hoeft te doen is in die directory kleine dingen aanpassen in configuratiebestanden, wat eigenlijk heel makkelijk is om te programmeren, of te scripten. Maar ik heb geen tijd daarvoor aangezien ik maar 2 handelingen hoef te doen om eindelijk perfect Wifi te hebben ga ik geen compleet programma maken, dat dan op iedere distributie getest zou moeten worden enz. Hoop wel dat in de toekomst alle distributies juist deze geavanceerde opties die er al zijn maar dan met de hand grafisch als optie aanbieden.

Edit1: Mijn MAC Adres weggehaald.
« Laatst bewerkt op: 2017/05/13, 00:53:47 door Geert Jalink »
motion@home:~$ sudo apt-get install steam